HLS-ECAT02WIN APIリファレンス: HLS-ECAT02WIN APIリファレンス

HLS-ECAT02WIN APIリファレンス v 1.0.1
HLS-ECAT02WIN APIリファレンス

HLS-ECAT02WINのAPIリファレンスドキュメントです。
インストールやソフトウェアの記述等は添付のマニュアルをご覧ください

Info

著者
Hivertec
日付
2021/11/11
version
1.0.1
更新履歴
Version 1.0.1
◆2021/05/25 新規作成
◆2021/11/11 型式変更に伴う標記見直し
以上
著作権所有
Hivertec Inc. All Rights reserved.
  • 本ソフトウェアの一部又は全てを無断で複写複製（コピー）することは、 著作権侵害にあたりますので、これを禁止します。
  • 本製品の使用に起因する侵害または特許権その他権利の侵害に関しては 当社は一切その責任を負いません。
構築: doxygen 1.9.1


HLS-ECAT02WIN APIリファレンス: hmecw0_macro.h ファイル

マクロ定義
hmecw0_macro.h ファイル

マクロ定義

#define | RESULT_FUNCTION_RESET 0x0021
#define | RESULT_FUNCTION_HOME 0x0022
#define | RESULT_FUNCTION_STOP 0x0023
#define | RESULT_FUNCTION_ABSOLUTE 0x0024
#define | RESULT_FUNCTION_RELATIVE 0x0025
#define | RESULT_FUNCTION_ADDITIVE 0x0026
#define | RESULT_FUNCTION_VELOCITY 0x0027
#define | RESULT_FUNCTION_GROUP_RESET 0x0031
#define | RESULT_FUNCTION_GROUP_HOME 0x0032
#define | RESULT_FUNCTION_GROUP_STOP 0x0033
#define | RESULT_FUNCTION_LINEAR_ABSOLUTE 0x0034
#define | RESULT_FUNCTION_LINEAR_RELATIVE 0x0035
#define | RESULT_FUNCTION_LINEAR_VELOCITY 0x0036
#define | RESULT_FUNCTION_MOVE_PATH 0x0045
#define | RESULT_STATUS_DONE_WAIT 0x0001
#define | RESULT_STATUS_BUSY_WAIT 0x0002
#define | RESULT_STATUS_ABORTED_WAIT 0x0003
#define | RESULT_STATUS_ERROR_WAIT 0x0004
#define | RESULT_STATUS_DONE 0x0081
#define | RESULT_STATUS_BUSY 0x0082
#define | RESULT_STATUS_ABORTED 0x0083
#define | RESULT_STATUS_ERROR 0x0084
#define | RET_SUCCESS 0x000000
#define | RET_ILL_SLAVE 0x000002
#define | RET_ILL_AXIS 0x000003
#define | RET_ILL_GR 0x000004
#define | RET_SLV_REG_ERR 0x000006
#define | RET_AXIS_REG_ERR 0x000007
#define | RET_ILL_PARAMETER 0x000008
#define | RET_INACTIVE_INTIME 0x00000B
#define | RET_ACTIVE_OTHER_FUNCTION 0x00000C
#define | RET_MAX_CONTROL_AXIS 0x00000D
#define | RET_AXIS_REGISTERED 0x00000E
#define | RET_OTHER_ERR 0x000010
#define | RET_INACTIVE_WIN_DLL 0x00001B
#define | RET_SOFTWARE_NOT_SUPPORT 0x00001F
#define | RET_WAITING_CANCELED 0x000020
#define | RET_WAITING_NOT_EXIST 0x000021
#define | RET_S_OFFLINE 0x000031
#define | RET_S_ECATSTATE_ERR 0x000032
#define | RET_INVALID_OPERATION_MODE 0x000101
#define | RET_INVALID_PLCOPEN_STATE 0x000102
#define | RET_FOLLOWING_ERR 0x000103
#define | RET_INVALID_VARIABLE 0x000104
#define | RET_ALAM 0x000105
#define | RET_ILL_NOT 0x000106
#define | RET_ILL_POT 0x000107
#define | RET_AXIS_ERR 0x000108
#define | RET_INVALID_DIRECTION 0x000109
#define | RET_NS_SERVO 0x00010A
#define | RET_RATIO_ERR 0x00010D
#define | RET_LAST_ERR 0x000110
#define | RET_POWER_FAIL 0x000201
#define | RET_SET_OVERRIDE_FAIL 0x00020C
#define | RET_RESET_FAIL 0x00020F
#define | RET_HOMING_ERR 0x000221
#define | RET_HOMING_MODE_ERR 0x000222
#define | RET_READ_SDO_ERR 0x000223
#define | RET_WRITE_SDO_ERR 0x000224
#define | RET_ER_INVALID_BUFFER_MODE 0x000225
#define | RET_RSI_HANDLER_ERR 0x000230
#define | RET_TCH_PRB_PRM_ERR 0x000301
#define | RET_TRG_PRM_ERR 0x000302
#define | RET_PRB_ID_DUP_ERR 0x000303
#define | RET_FUNC_TOUCH_PRB_ERR 0x000304
#define | RET_FUNC_ABORT_TRIG_ERR 0x000305
#define | RET_PRB_NOT_ACTIVE 0x000306
#define | RET_PRB_FUNC_PDO_PRM_ERR 0x000307
#define | RET_ABORT_TRIG_RUNNING_ERR 0x000308
#define | RET_BUFFER_MODE_INVALID 0x000310
#define | RET_GRP_ILL_PLCOPEN_STATE 0x000402
#define | RET_GROUP_ILL_PRM 0x000403
#define | RET_GRP_ILL_DIRECTION 0x000404
#define | RET_GRP_EXIST 0x000405
#define | RET_GRP_FULL 0x000406
#define | RET_GROUP_NO_AXIS 0x000407
#define | RET_GRP_RESET_FAILED 0x000408
#define | RET_GRP_ADD_AXIS_FAILED 0x000409
#define | RET_GRP_AXIS_EXIST 0x00040A
#define | RET_GRP_AXIS_NOT_EXIST 0x00040B
#define | RET_GRP_OTHER_AXIS_EXIST 0x00040C
#define | RET_GRP_SLV_ILL_CONDITION 0x00040D
#define | RET_GRP_AXIS_ILL_CONDITION 0x00040E
#define | RET_GRP_ILL_FOLLOWING 0x000410
#define | RET_ILL_PATH_DATA_SIZE 0x000420
#define | RET_PATH_DATA_MAX 0x000421
#define | RET_ILL_LINE 0x000422
#define | RET_GRP_PATH_POSITION_ERR 0x000423
#define | RET_GRP_PATH_VELOCITY_ERR 0x000424
#define | RET_GRP_PATH_ACCELERATION_ERR 0x000425
#define | RET_GRP_PATH_DECELERATION_ERR 0x000426
#define | RET_GRP_PATH_JERK_ERR 0x000427
#define | RET_GRP_PATH_BUFFER_MODE_ERR 0x000428
#define | RET_GRP_PATH_MOTION_CMD_ERR 0x000429
#define | RET_GRP_PATH_FILE_ERR 0x00042A
#define | RET_GRP_MVPATH_EXECUTED_ERR 0x00042F
#define | RET_GRP_AXIS_ILL_PRM 0x000430
#define | RET_GRP_ARRAY0_ILL_PRM 0x000460
#define | RET_GRP_ARRAY0_ILL_PLCOPEN_STATE 0x0004A0
#define | RET_GRP_ARRAY0_ILL_DIRECTION 0x0004E0
#define | RET_GRP_ARRAY0_ILL_FOLLOWING 0x000520
#define | RET_GRP_ARRAY0_ILL_NOT 0x000560
#define | RET_GRP_ARRAY0_ILL_POT 0x0005A0
#define | RET_GRP_ARRAY0_ALAM 0x0005E0
#define | RET_GRP_ARRAY0_RATIO_ERR 0x000620
#define | RET_PDO_OBJECT_NOT_EXIST 0x000801
#define | RET_DIAGNOSIS_MESSAGE_ERR 0x000811
#define | RET_MK_MEM_ERR 0x000820
#define | RET_OUT_OF_INTIME_MEM 0x000830
#define | RET_FAILED_FILE_OPEN 0x000831
#define | RET_FAILED_FILE_PROC 0x000832
#define | RET_BUFFER_FULL 0x000901
#define | RET_EHAPI_PARAM 0x00E001
#define | RET_EHAPI_CHANNEL 0x00E002
#define | RET_EHAPI_CATEGORY 0x00E003
#define | RET_EHAPI_SIZE 0x00E004
#define | RET_EHAPI_MAX_OPEN 0x00E005
#define | RET_EHAPI_MAX_QUE 0x00E006
#define | RET_EHAPI_REQ_ERROR 0x00E007
#define | RET_EHAPI_NOT_FOUND 0x00E008
#define | RET_EHAPI_IS_DEAD 0x00E009
#define | RET_EHAPI_STATE_I 0x00E00A
#define | RET_EHAPI_STATE_P 0x00E00B
#define | RET_EHAPI_STATE_S 0x00E00C
#define | RET_EHAPI_STATE_O 0x00E00D
#define | RET_EHAPI_NOITEM 0x00E00E
#define | RET_EHAPI_TIMEOUT 0x00E00F
#define | RET_EHAPI_STATE_UNKNOWN 0x00E010
#define | RET_EHAPI_SLAVE_IS_ZERO 0x00E011
#define | RET_EHAPI_WORKING 0x00E020
#define | RET_EHAPI_OPEN 0x00E021
#define | RET_EHAPI_CLOSE 0x00E022
#define | RET_EHAPI_TXBUFF 0x00E023
#define | RET_EHAPI_TXDATA 0x00E024
#define | RET_EHAPI_RECV 0x00E025
#define | RET_EHAPI_SEND 0x00E026
#define | RET_EHAPI_OPENED 0x00E027
#define | RET_EHAPI_CLOSED 0x00E028
#define | RET_EHAPI_CMDERR 0x00E029
#define | RET_EHAPI_SYSERR 0x00E030
#define | RET_EHAPI_OBJECT 0x00E033
#define | RET_EHAPI_READONLY 0x00E034
#define | RET_EHAPI_ALIAS_CONFLICT 0x00E035
#define | RET_EHAPI_SLAVE_COUNT 0x00E036
#define | RET_EHAPI_READ_EEPROM 0x00E037
#define | RET_EHAPI_WRITE_EEPROM 0x00E038
#define | RET_EHAPI_READ_REGISTER 0x00E039
#define | RET_EHAPI_WRITE_REGISTER 0x00E040
#define | RET_EHAPI_CATALOG 0x00E041
#define | RET_EHAPI_OFFLINE 0x00E042
#define | RET_EHAPI_NIC_DRIVER 0x00E043
#define | RET_EHAPI_ENIFILE 0x00E044
#define | RET_EHAPI_CONFLICT 0x00E045
#define | RET_EHAPI_EXIST 0x00E046
#define | RET_EHAPI_INDEX 0x00E047
#define | RET_EHAPI_SUBINDEX 0x00E048
#define | RET_EHAPI_LENGTH 0x00E049
#define | RET_EHAPI_LIMIT 0x00E04A
#define | RET_EHAPI_WRITEONLY 0x00E04B
#define | RET_EHAPI_NO_RESPONSE 0x00E04C
#define | RET_EHAPI_NOT_REGISTERED 0x00E04D
#define | RET_EHAPI_NOT_HOTCONNECT 0x00E04E
#define | RET_EHAPI_REF_CATALOG 0x00E050
#define | RET_EHAPI_STARTARG_LOWER 0x00E0FD
#define | RET_EHAPI_STARTARG_HIGHER 0x00E0FE
#define | RET_EHAPI_STARTARG_ABNORMAL 0x00E0FF
#define | RET_EHAPI_WAIT_CANCEL 0x00E100
#define | RET_EHAPI_FIND_SLAVE 0x00E106
#define | RET_EHAPI_NOT_READY 0x00E107
#define | RET_EHAPI_REG_EVENT 0x00E108
#define | RET_EHAPI_WAIT_EVENT 0x00E109
#define | RET_EHAPI_CREATE_EVENT 0x00E10A
#define | RET_EHAPI_INVALID_EVENT 0x00E10B
#define | RET_EHAPI_RT_MEM 0x00EF11
#define | RET_EHAPI_RT_VMEM 0x00EF1B
#define | RET_EHAPI_INVALID_LOCATION 0x00EF20
#define | RET_EHAPI_STOPNODE 0x00EF21
#define | RET_EHAPI_MEMORY 0x00E810
#define | RET_EHAPI_EDITION 0x00E840
#define | RET_EHAPI_LICENSE 0x00E850

マクロ定義詳解

◆ RESULT_FUNCTION_RESET

#define RESULT_FUNCTION_RESET 0x0021

MC_ReadFunctionResultで取得した「完了したAPI」: MC_Reset

◆ RESULT_FUNCTION_HOME

#define RESULT_FUNCTION_HOME 0x0022

MC_ReadFunctionResultで取得した「完了したAPI」: MC_Home

◆ RESULT_FUNCTION_STOP

#define RESULT_FUNCTION_STOP 0x0023

MC_ReadFunctionResultで取得した「完了したAPI」: MC_Stop

◆ RESULT_FUNCTION_ABSOLUTE

#define RESULT_FUNCTION_ABSOLUTE 0x0024

MC_ReadFunctionResultで取得した「完了したAPI」: MC_MoveAbsolute

◆ RESULT_FUNCTION_RELATIVE

#define RESULT_FUNCTION_RELATIVE 0x0025

MC_ReadFunctionResultで取得した「完了したAPI」: MC_MoveRelative

◆ RESULT_FUNCTION_ADDITIVE

#define RESULT_FUNCTION_ADDITIVE 0x0026

MC_ReadFunctionResultで取得した「完了したAPI」: MC_MoveAdditive

◆ RESULT_FUNCTION_VELOCITY

#define RESULT_FUNCTION_VELOCITY 0x0027

MC_ReadFunctionResultで取得した「完了したAPI」: MC_MoveVelocity

◆ RESULT_FUNCTION_GROUP_RESET

#define RESULT_FUNCTION_GROUP_RESET 0x0031

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_GroupReset

◆ RESULT_FUNCTION_GROUP_HOME

#define RESULT_FUNCTION_GROUP_HOME 0x0032

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_GroupHome

◆ RESULT_FUNCTION_GROUP_STOP

#define RESULT_FUNCTION_GROUP_STOP 0x0033

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_GroupStop

◆ RESULT_FUNCTION_LINEAR_ABSOLUTE

#define RESULT_FUNCTION_LINEAR_ABSOLUTE 0x0034

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_MoveLinearAbsolute

◆ RESULT_FUNCTION_LINEAR_RELATIVE

#define RESULT_FUNCTION_LINEAR_RELATIVE 0x0035

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_MoveLinearRelative

◆ RESULT_FUNCTION_LINEAR_VELOCITY

#define RESULT_FUNCTION_LINEAR_VELOCITY 0x0036

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_MoveLinearVelocity

◆ RESULT_FUNCTION_MOVE_PATH

#define RESULT_FUNCTION_MOVE_PATH 0x0045

MC_GroupReadFunctionResultで取得した「完了したAPI」: MC_MovePath

◆ RESULT_STATUS_DONE_WAIT

#define RESULT_STATUS_DONE_WAIT 0x0001

MC_AXIS_MOVE構造体メンバbDisableWaitMotionIntの値がFALSEの時,MC_ReadFunctionResultで取得した「完了APIのステータス」: Done
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がFALSEの時,MC_GroupReadFunctionResultで取得した「完了APIのステータス」: Done

◆ RESULT_STATUS_BUSY_WAIT

#define RESULT_STATUS_BUSY_WAIT 0x0002

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がFALSEの時,MC_ReadFunctionResultで取得した「完了APIのステータス」: Busy
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がFALSEの時,MC_GroupReadFunctionResultで取得した「完了APIのステータス」: Busy

◆ RESULT_STATUS_ABORTED_WAIT

#define RESULT_STATUS_ABORTED_WAIT 0x0003

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がFALSEの時, MC_ReadFunctionResultで取得した「完了APIのステータス」: CommandAborted
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がFALSEの時, MC_GroupReadFunctionResultで取得した「完了APIのステータス」: CommandAborted

◆ RESULT_STATUS_ERROR_WAIT

#define RESULT_STATUS_ERROR_WAIT 0x0004

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がFALSEの時, MC_ReadFunctionResultで取得した「完了APIのステータス」: Error
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がFALSEの時, MC_GroupReadFunctionResultで取得した「完了APIのステータス」: Error

◆ RESULT_STATUS_DONE

#define RESULT_STATUS_DONE 0x0081

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がTRUEの時,MC_ReadFunctionResultで取得した「完了APIのステータス」: Done
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_GroupReadFunctionResultで取得した「完了APIのステータス」: Done

◆ RESULT_STATUS_BUSY

#define RESULT_STATUS_BUSY 0x0082

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_ReadFunctionResultで取得した「完了APIのステータス」: Busy
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_GroupReadFunctionResultで取得した「完了APIのステータス」: Busy

◆ RESULT_STATUS_ABORTED

#define RESULT_STATUS_ABORTED 0x0083

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_ReadFunctionResultで取得した「完了APIのステータス」: CommandAborted
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_GroupReadFunctionResultで取得した「完了APIのステータス」: CommandAborted

◆ RESULT_STATUS_ERROR

#define RESULT_STATUS_ERROR 0x0084

MC_AXIS_MOVE 構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_ReadFunctionResultで取得した「完了APIのステータス」: Error
MC_GROUP_MOVE構造体メンバbDisableWaitMotionIntの値がTRUEの時, MC_GroupReadFunctionResultで取得した「完了APIのステータス」: Error

◆ RET_SUCCESS

#define RET_SUCCESS 0x000000

エラーコード "エラー無し"

◆ RET_ILL_SLAVE

#define RET_ILL_SLAVE 0x000002

エラーコード "スレーブのノード番号が不正"

◆ RET_ILL_AXIS

#define RET_ILL_AXIS 0x000003

エラーコード "軸番号が不正"

◆ RET_ILL_GR

#define RET_ILL_GR 0x000004

エラーコード "グループ番号が不正"

◆ RET_SLV_REG_ERR

#define RET_SLV_REG_ERR 0x000006

エラーコード "スレーブ異常"

◆ RET_AXIS_REG_ERR

#define RET_AXIS_REG_ERR 0x000007

エラーコード "軸異常"

◆ RET_ILL_PARAMETER

#define RET_ILL_PARAMETER 0x000008

エラーコード "不正なパラメータを指定"

◆ RET_INACTIVE_INTIME

#define RET_INACTIVE_INTIME 0x00000B

エラーコード "INtimeが未起動"

◆ RET_ACTIVE_OTHER_FUNCTION

#define RET_ACTIVE_OTHER_FUNCTION 0x00000C

エラーコード "他の関数が起動中"

◆ RET_MAX_CONTROL_AXIS

#define RET_MAX_CONTROL_AXIS 0x00000D

エラーコード "制御軸登録数が最大"

◆ RET_AXIS_REGISTERED

#define RET_AXIS_REGISTERED 0x00000E

エラーコード "スレーブが登録済み"

◆ RET_OTHER_ERR

#define RET_OTHER_ERR 0x000010

エラーコード "その他のエラー"

◆ RET_INACTIVE_WIN_DLL

#define RET_INACTIVE_WIN_DLL 0x00001B

エラーコード "DLLの読み込みが未完了"

◆ RET_SOFTWARE_NOT_SUPPORT

#define RET_SOFTWARE_NOT_SUPPORT 0x00001F

エラーコード "サポートしていない機能"

◆ RET_WAITING_CANCELED

#define RET_WAITING_CANCELED 0x000020

エラーコード "割り込み待機がキャンセル"

◆ RET_WAITING_NOT_EXIST

#define RET_WAITING_NOT_EXIST 0x000021

エラーコード "割り込み待機中の関数が存在しない"

◆ RET_S_OFFLINE

#define RET_S_OFFLINE 0x000031

エラーコード "スレーブ応答エラー"

◆ RET_S_ECATSTATE_ERR

#define RET_S_ECATSTATE_ERR 0x000032

エラーコード "Operationalでない"

◆ RET_INVALID_OPERATION_MODE

#define RET_INVALID_OPERATION_MODE 0x000101

エラーコード "制御モードが異常"

◆ RET_INVALID_PLCOPEN_STATE

#define RET_INVALID_PLCOPEN_STATE 0x000102

エラーコード "軸の状態が異常"

◆ RET_FOLLOWING_ERR

#define RET_FOLLOWING_ERR 0x000103

エラーコード "位置偏差過大エラー"

◆ RET_INVALID_VARIABLE

#define RET_INVALID_VARIABLE 0x000104

エラーコード "範囲外の値"

◆ RET_ALAM

#define RET_ALAM 0x000105

エラーコード "サーボアラーム"

◆ RET_ILL_NOT

#define RET_ILL_NOT 0x000106

エラーコード "-ELSを検出"

◆ RET_ILL_POT

#define RET_ILL_POT 0x000107

エラーコード "+ELSを検出"

◆ RET_AXIS_ERR

#define RET_AXIS_ERR 0x000108

エラーコード "軸のエラーを検出"

◆ RET_INVALID_DIRECTION

#define RET_INVALID_DIRECTION 0x000109

エラーコード "動作方向の指定が不正"

◆ RET_NS_SERVO

#define RET_NS_SERVO 0x00010A

エラーコード "サポート外のスレーブ"

◆ RET_RATIO_ERR

#define RET_RATIO_ERR 0x00010D

エラーコード "電子ギア設定エラー"

◆ RET_LAST_ERR

#define RET_LAST_ERR 0x000110

エラーコード "INtime実行エラー"

◆ RET_POWER_FAIL

#define RET_POWER_FAIL 0x000201

エラーコード "サーボオンに失敗しました"

  • ソフトウェアで定めた時間内にサーボオンができない

◆ RET_SET_OVERRIDE_FAIL

#define RET_SET_OVERRIDE_FAIL 0x00020C

エラーコード "オーバーライド失敗"

◆ RET_RESET_FAIL

#define RET_RESET_FAIL 0x00020F

エラーコード "サーボアラームのリセットに失敗"

◆ RET_HOMING_ERR

#define RET_HOMING_ERR 0x000221

エラーコード "目標位置に到達前にエラーが発生"

◆ RET_HOMING_MODE_ERR

#define RET_HOMING_MODE_ERR 0x000222

エラーコード "不正な原点復帰動作モード"

◆ RET_READ_SDO_ERR

#define RET_READ_SDO_ERR 0x000223

エラーコード "MC_ReadSDOのエラー"

◆ RET_WRITE_SDO_ERR

#define RET_WRITE_SDO_ERR 0x000224

エラーコード "MC_WriteSDOのエラー"

◆ RET_ER_INVALID_BUFFER_MODE

#define RET_ER_INVALID_BUFFER_MODE 0x000225

エラーコード "バッファモードの設定異常"

◆ RET_RSI_HANDLER_ERR

#define RET_RSI_HANDLER_ERR 0x000230

エラーコード "RSI-ECAT-masterの通信異常"

◆ RET_TCH_PRB_PRM_ERR

#define RET_TCH_PRB_PRM_ERR 0x000301

エラーコード "パラメータ異常: MC_TOUCH_PROBE_IN"

◆ RET_TRG_PRM_ERR

#define RET_TRG_PRM_ERR 0x000302

エラーコード "パラメータ異常: MC_TRIGGER_REF"

◆ RET_PRB_ID_DUP_ERR

#define RET_PRB_ID_DUP_ERR 0x000303

エラーコード "実行中のプローブIDに実行命令が発行"

◆ RET_FUNC_TOUCH_PRB_ERR

#define RET_FUNC_TOUCH_PRB_ERR 0x000304

エラーコード "関数の実行に失敗: MC_TouchProbe"

◆ RET_FUNC_ABORT_TRIG_ERR

#define RET_FUNC_ABORT_TRIG_ERR 0x000305

エラーコード "関数の実行に失敗: MC_AbortTrigger"

◆ RET_PRB_NOT_ACTIVE

#define RET_PRB_NOT_ACTIVE 0x000306

エラーコード "プローブが未定義または未動作"

◆ RET_PRB_FUNC_PDO_PRM_ERR

#define RET_PRB_FUNC_PDO_PRM_ERR 0x000307

エラーコード "PDOマッピングされていない: Index-SubIndex 60B8-0"

◆ RET_ABORT_TRIG_RUNNING_ERR

#define RET_ABORT_TRIG_RUNNING_ERR 0x000308

エラーコード "関数が実行中: MC_AbortTrigger"

◆ RET_BUFFER_MODE_INVALID

#define RET_BUFFER_MODE_INVALID 0x000310

エラーコード "不正なバッファモード"

◆ RET_GRP_ILL_PLCOPEN_STATE

#define RET_GRP_ILL_PLCOPEN_STATE 0x000402

エラーコード "軸グループの状態が異常"

◆ RET_GROUP_ILL_PRM

#define RET_GROUP_ILL_PRM 0x000403

エラーコード "軸グループのパラメータが異常"

◆ RET_GRP_ILL_DIRECTION

#define RET_GRP_ILL_DIRECTION 0x000404

エラーコード "軸グループの動作方向が異常"

◆ RET_GRP_EXIST

#define RET_GRP_EXIST 0x000405

エラーコード "軸グループが重複"

◆ RET_GRP_FULL

#define RET_GRP_FULL 0x000406

エラーコード "軸グループの軸が最大数"

◆ RET_GROUP_NO_AXIS

#define RET_GROUP_NO_AXIS 0x000407

エラーコード "軸グループに軸が存在しない"

◆ RET_GRP_RESET_FAILED

#define RET_GRP_RESET_FAILED 0x000408

エラーコード "軸グループのリセットに失敗"

◆ RET_GRP_ADD_AXIS_FAILED

#define RET_GRP_ADD_AXIS_FAILED 0x000409

エラーコード "軸グループへの軸の追加に失敗"

◆ RET_GRP_AXIS_EXIST

#define RET_GRP_AXIS_EXIST 0x00040A

エラーコード "軸グループに軸が重複"

◆ RET_GRP_AXIS_NOT_EXIST

#define RET_GRP_AXIS_NOT_EXIST 0x00040B

エラーコード "軸グループに存在しない"

◆ RET_GRP_OTHER_AXIS_EXIST

#define RET_GRP_OTHER_AXIS_EXIST 0x00040C

エラーコード "配列番号に軸が登録済み"

◆ RET_GRP_SLV_ILL_CONDITION

#define RET_GRP_SLV_ILL_CONDITION 0x00040D

エラーコード "未登録のスレーブを指定"

◆ RET_GRP_AXIS_ILL_CONDITION

#define RET_GRP_AXIS_ILL_CONDITION 0x00040E

エラーコード "未登録の軸を指定"

◆ RET_GRP_ILL_FOLLOWING

#define RET_GRP_ILL_FOLLOWING 0x000410

エラーコード "ガントリ軸の位置偏差エラー"

◆ RET_ILL_PATH_DATA_SIZE

#define RET_ILL_PATH_DATA_SIZE 0x000420

エラーコード "データ数の指定が不正"

◆ RET_PATH_DATA_MAX

#define RET_PATH_DATA_MAX 0x000421

エラーコード "パスデータ数が最大"

◆ RET_ILL_LINE

#define RET_ILL_LINE 0x000422

エラーコード "パスデータのパラメータ不正"

◆ RET_GRP_PATH_POSITION_ERR

#define RET_GRP_PATH_POSITION_ERR 0x000423

エラーコード "パスデータのパラメータエラー: 位置"

◆ RET_GRP_PATH_VELOCITY_ERR

#define RET_GRP_PATH_VELOCITY_ERR 0x000424

エラーコード "パスデータのパラメータエラー: 速度"

◆ RET_GRP_PATH_ACCELERATION_ERR

#define RET_GRP_PATH_ACCELERATION_ERR 0x000425

エラーコード "パスデータのパラメータエラー: 加速度"

◆ RET_GRP_PATH_DECELERATION_ERR

#define RET_GRP_PATH_DECELERATION_ERR 0x000426

エラーコード "パスデータのパラメータエラー: 減速度"

◆ RET_GRP_PATH_JERK_ERR

#define RET_GRP_PATH_JERK_ERR 0x000427

エラーコード "パスデータのパラメータエラー: ジャーク"

◆ RET_GRP_PATH_BUFFER_MODE_ERR

#define RET_GRP_PATH_BUFFER_MODE_ERR 0x000428

エラーコード "パスデータのパラメータエラー: バッファモード"

◆ RET_GRP_PATH_MOTION_CMD_ERR

#define RET_GRP_PATH_MOTION_CMD_ERR 0x000429

エラーコード "パスデータのパラメータエラー: モーションコマンド"

◆ RET_GRP_PATH_FILE_ERR

#define RET_GRP_PATH_FILE_ERR 0x00042A

エラーコード "パスデータのファイル読み込みエラー"

◆ RET_GRP_MVPATH_EXECUTED_ERR

#define RET_GRP_MVPATH_EXECUTED_ERR 0x00042F

エラーコード "関数実行中: MC_MovePath"

◆ RET_GRP_AXIS_ILL_PRM

#define RET_GRP_AXIS_ILL_PRM 0x000430

エラーコード "軸グループの軸の設定パラメータが異常．"

◆ RET_GRP_ARRAY0_ILL_PRM

#define RET_GRP_ARRAY0_ILL_PRM 0x000460

エラーコード "軸グループに追加済みの軸のエラー: パラメータ"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x000460 / 01: 0x000461 / 02: 0x000462 / 03: 0x000463 / 04: 0x000464
05: 0x000465 / 06: 0x000466 / 07: 0x000467 / 08: 0x000468 / 09: 0x000469
10: 0x00046A / 11: 0x00046B / 12: 0x00046C / 13: 0x00046D / 14: 0x00046E
15: 0x00046F / 16: 0x000470 / 17: 0x000471 / 18: 0x000472 / 19: 0x000473
20: 0x000474 / 21: 0x000475 / 22: 0x000476 / 23: 0x000477 / 24: 0x000478
25: 0x000479 / 26: 0x00047A / 27: 0x00047B / 28: 0x00047C / 29: 0x00047D
30: 0x00047E / 31: 0x00047F

◆ RET_GRP_ARRAY0_ILL_PLCOPEN_STATE

#define RET_GRP_ARRAY0_ILL_PLCOPEN_STATE 0x0004A0

エラーコード "軸グループに追加済みの軸のエラー: 状態"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x0004A0 / 01: 0x0004A1 / 02: 0x0004A2 / 03: 0x0004A3 / 04: 0x0004A4
05: 0x0004A5 / 06: 0x0004A6 / 07: 0x0004A7 / 08: 0x0004A8 / 09: 0x0004A9
10: 0x0004AA / 11: 0x0004AB / 12: 0x0004AC / 13: 0x0004AD / 14: 0x0004AE
15: 0x0004AF / 16: 0x0004B0 / 17: 0x0004B1 / 18: 0x0004B2 / 19: 0x0004B3
20: 0x0004B4 / 21: 0x0004B5 / 22: 0x0004B6 / 23: 0x0004B7 / 24: 0x0004B8
25: 0x0004B9 / 26: 0x0004BA / 27: 0x0004BB / 28: 0x0004BC / 29: 0x0004BD
30: 0x0004BE / 31: 0x0004BF

◆ RET_GRP_ARRAY0_ILL_DIRECTION

#define RET_GRP_ARRAY0_ILL_DIRECTION 0x0004E0

エラーコード "軸グループに追加済みの軸のエラー: 動作方向"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x0004E0 / 01: 0x0004E1 / 02: 0x0004E2 / 03: 0x0004E3 / 04: 0x0004E4
05: 0x0004E5 / 06: 0x0004E6 / 07: 0x0004E7 / 08: 0x0004E8 / 09: 0x0004E9
10: 0x0004EA / 11: 0x0004EB / 12: 0x0004EC / 13: 0x0004ED / 14: 0x0004EE
15: 0x0004EF / 16: 0x0004F0 / 17: 0x0004F1 / 18: 0x0004F2 / 19: 0x0004F3
20: 0x0004F4 / 21: 0x0004F5 / 22: 0x0004F6 / 23: 0x0004F7 / 24: 0x0004F8
25: 0x0004F9 / 26: 0x0004FA / 27: 0x0004FB / 28: 0x0004FC / 29: 0x0004FD
30: 0x0004FE / 31: 0x0004FF

◆ RET_GRP_ARRAY0_ILL_FOLLOWING

#define RET_GRP_ARRAY0_ILL_FOLLOWING 0x000520

エラーコード "軸グループに追加済みの軸のエラー: 位置偏差エラー"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x000520 / 01: 0x000521 / 02: 0x000522 / 03: 0x000523 / 04: 0x000524
05: 0x000525 / 06: 0x000526 / 07: 0x000527 / 08: 0x000528 / 09: 0x000529
10: 0x00052A / 11: 0x00052B / 12: 0x00052C / 13: 0x00052D / 14: 0x00052E
15: 0x00052F / 16: 0x000530 / 17: 0x000531 / 18: 0x000532 / 19: 0x000533
20: 0x000534 / 21: 0x000535 / 22: 0x000536 / 23: 0x000537 / 24: 0x000538
25: 0x000539 / 26: 0x00053A / 27: 0x00053B / 28: 0x00053C / 29: 0x00053D
30: 0x00053E / 31: 0x00053F

◆ RET_GRP_ARRAY0_ILL_NOT

#define RET_GRP_ARRAY0_ILL_NOT 0x000560

エラーコード "軸グループに追加済みの軸のエラー: -ELS"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x000560 / 01: 0x000561 / 02: 0x000562 / 03: 0x000563 / 04: 0x000564
05: 0x000565 / 06: 0x000566 / 07: 0x000567 / 08: 0x000568 / 09: 0x000569
10: 0x00056A / 11: 0x00056B / 12: 0x00056C / 13: 0x00056D / 14: 0x00056E
15: 0x00056F / 16: 0x000570 / 17: 0x000571 / 18: 0x000572 / 19: 0x000573
20: 0x000574 / 21: 0x000575 / 22: 0x000576 / 23: 0x000577 / 24: 0x000578
25: 0x000579 / 26: 0x00057A / 27: 0x00057B / 28: 0x00057C / 29: 0x00057D
30: 0x00057E / 31: 0x00057F

◆ RET_GRP_ARRAY0_ILL_POT

#define RET_GRP_ARRAY0_ILL_POT 0x0005A0

エラーコード "軸グループに追加済みの軸のエラー: +ELS"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x0005A0 / 01: 0x0005A1 / 02: 0x0005A2 / 03: 0x0005A3 / 04: 0x0005A4
05: 0x0005A5 / 06: 0x0005A6 / 07: 0x0005A7 / 08: 0x0005A8 / 09: 0x0005A9
10: 0x0005AA / 11: 0x0005AB / 12: 0x0005AC / 13: 0x0005AD / 14: 0x0005AE
15: 0x0005AF / 16: 0x0005B0 / 17: 0x0005B1 / 18: 0x0005B2 / 19: 0x0005B3
20: 0x0005B4 / 21: 0x0005B5 / 22: 0x0005B6 / 23: 0x0005B7 / 24: 0x0005B8
25: 0x0005B9 / 26: 0x0005BA / 27: 0x0005BB / 28: 0x0005BC / 29: 0x0005BD
30: 0x0005BE / 31: 0x0005BF

◆ RET_GRP_ARRAY0_ALAM

#define RET_GRP_ARRAY0_ALAM 0x0005E0

エラーコード "軸グループに追加済みの軸のエラー: サーボアラーム"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x0005E0 / 01: 0x0005E1 / 02: 0x0005E2 / 03: 0x0005E3 / 04: 0x0005E4
05: 0x0005E5 / 06: 0x0005E6 / 07: 0x0005E7 / 08: 0x0005E8 / 09: 0x0005E9
10: 0x0005EA / 11: 0x0005EB / 12: 0x0005EC / 13: 0x0005ED / 14: 0x0005EE
15: 0x0005EF / 16: 0x0005F0 / 17: 0x0005F1 / 18: 0x0005F2 / 19: 0x0005F3
20: 0x0005F4 / 21: 0x0005F5 / 22: 0x0005F6 / 23: 0x0005F7 / 24: 0x0005F8
25: 0x0005F9 / 26: 0x0005FA / 27: 0x0005FB / 28: 0x0005FC / 29: 0x0005FD
30: 0x0005FE / 31: 0x0005FF

◆ RET_GRP_ARRAY0_RATIO_ERR

#define RET_GRP_ARRAY0_RATIO_ERR 0x000620

エラーコード "軸グループの電子ギアの設定エラー"
ARRAY[X] : 配列番号0 - 31
エラー番号
00: 0x000620 / 01: 0x000621 / 02: 0x000622 / 03: 0x000623 / 04: 0x000624
05: 0x000625 / 06: 0x000626 / 07: 0x000627 / 08: 0x000628 / 09: 0x000629
10: 0x00062A / 11: 0x00062B / 12: 0x00062C / 13: 0x00062D / 14: 0x00062E
15: 0x00062F / 16: 0x000630 / 17: 0x000631 / 18: 0x000632 / 19: 0x000633
20: 0x000634 / 21: 0x000635 / 22: 0x000636 / 23: 0x000637 / 24: 0x000638
25: 0x000639 / 26: 0x00063A / 27: 0x00063B / 28: 0x00063C / 29: 0x00063D
30: 0x00063E / 31: 0x00063F

◆ RET_PDO_OBJECT_NOT_EXIST

#define RET_PDO_OBJECT_NOT_EXIST 0x000801

エラーコード "PDOオブジェクトが存在しない"

◆ RET_DIAGNOSIS_MESSAGE_ERR

#define RET_DIAGNOSIS_MESSAGE_ERR 0x000811

エラーコード "ダイアグノーシス情報取得に失敗"

◆ RET_MK_MEM_ERR

#define RET_MK_MEM_ERR 0x000820

エラーコード "INtimeメモリ容量不足: パスデータ"

◆ RET_OUT_OF_INTIME_MEM

#define RET_OUT_OF_INTIME_MEM 0x000830

エラーコード "INtimeメモリ容量不足: ログ出力"

◆ RET_FAILED_FILE_OPEN

#define RET_FAILED_FILE_OPEN 0x000831

エラーコード "ファイル作成に失敗"

◆ RET_FAILED_FILE_PROC

#define RET_FAILED_FILE_PROC 0x000832

エラーコード "ファイル出力に失敗"

◆ RET_BUFFER_FULL

#define RET_BUFFER_FULL 0x000901

エラーコード "バッファモードのバッファが最大"

◆ RET_EHAPI_PARAM

#define RET_EHAPI_PARAM 0x00E001

エラーコード "パラメータに問題あり"

◆ RET_EHAPI_CHANNEL

#define RET_EHAPI_CHANNEL 0x00E002

エラーコード "範囲外のチャンネルが指定"

◆ RET_EHAPI_CATEGORY

#define RET_EHAPI_CATEGORY 0x00E003

エラーコード "範囲外のカテゴリ"

◆ RET_EHAPI_SIZE

#define RET_EHAPI_SIZE 0x00E004

エラーコード "データサイズが不正"

◆ RET_EHAPI_MAX_OPEN

#define RET_EHAPI_MAX_OPEN 0x00E005

エラーコード "最大API対話数が範囲外"

◆ RET_EHAPI_MAX_QUE

#define RET_EHAPI_MAX_QUE 0x00E006

エラーコード "最大API要求数が範囲外"

◆ RET_EHAPI_REQ_ERROR

#define RET_EHAPI_REQ_ERROR 0x00E007

エラーコード "API要求に失敗"

◆ RET_EHAPI_NOT_FOUND

#define RET_EHAPI_NOT_FOUND 0x00E008

エラーコード "EcatHandlerが見つからない"

◆ RET_EHAPI_IS_DEAD

#define RET_EHAPI_IS_DEAD 0x00E009

エラーコード "EcatHandlerが応答しない"

◆ RET_EHAPI_STATE_I

#define RET_EHAPI_STATE_I 0x00E00A

エラーコード "マスタステート: Init"

◆ RET_EHAPI_STATE_P

#define RET_EHAPI_STATE_P 0x00E00B

エラーコード "マスタステート: Pre-Operational"

◆ RET_EHAPI_STATE_S

#define RET_EHAPI_STATE_S 0x00E00C

エラーコード "マスタステート: Safe-Operational"

◆ RET_EHAPI_STATE_O

#define RET_EHAPI_STATE_O 0x00E00D

エラーコード "マスタステートがOperationalでは実行不可"

◆ RET_EHAPI_NOITEM

#define RET_EHAPI_NOITEM 0x00E00E

エラーコード "指定チャンネルのスレーブに設定項目がない"

◆ RET_EHAPI_TIMEOUT

#define RET_EHAPI_TIMEOUT 0x00E00F

エラーコード "API要求のタイムアウト"

◆ RET_EHAPI_STATE_UNKNOWN

#define RET_EHAPI_STATE_UNKNOWN 0x00E010

エラーコード "マスタステートの取得に失敗"

◆ RET_EHAPI_SLAVE_IS_ZERO

#define RET_EHAPI_SLAVE_IS_ZERO 0x00E011

エラーコード "ENIに定義されたスレーブがない"

◆ RET_EHAPI_WORKING

#define RET_EHAPI_WORKING 0x00E020

エラーコード "再コール不可"

◆ RET_EHAPI_OPEN

#define RET_EHAPI_OPEN 0x00E021

エラーコード "オープンに失敗"

◆ RET_EHAPI_CLOSE

#define RET_EHAPI_CLOSE 0x00E022

エラーコード "クローズに失敗"

◆ RET_EHAPI_TXBUFF

#define RET_EHAPI_TXBUFF 0x00E023

エラーコード "送信バッファが最大"

◆ RET_EHAPI_TXDATA

#define RET_EHAPI_TXDATA 0x00E024

エラーコード "送信データが存在しない"

◆ RET_EHAPI_RECV

#define RET_EHAPI_RECV 0x00E025

エラーコード "受信に失敗"

◆ RET_EHAPI_SEND

#define RET_EHAPI_SEND 0x00E026

エラーコード "送信に失敗"

◆ RET_EHAPI_OPENED

#define RET_EHAPI_OPENED 0x00E027

エラーコード "オープン済み"

◆ RET_EHAPI_CLOSED

#define RET_EHAPI_CLOSED 0x00E028

エラーコード "クローズ済み"

◆ RET_EHAPI_CMDERR

#define RET_EHAPI_CMDERR 0x00E029

エラーコード "スレーブへ発行したコマンドが不正"

◆ RET_EHAPI_SYSERR

#define RET_EHAPI_SYSERR 0x00E030

エラーコード "スレーブシステムエラー"

◆ RET_EHAPI_OBJECT

#define RET_EHAPI_OBJECT 0x00E033

エラーコード "INtimeオブジェクトの生成に失敗"

◆ RET_EHAPI_READONLY

#define RET_EHAPI_READONLY 0x00E034

エラーコード "対象の項目は読み取り専用"

◆ RET_EHAPI_ALIAS_CONFLICT

#define RET_EHAPI_ALIAS_CONFLICT 0x00E035

エラーコード "エイリアスが競合"

◆ RET_EHAPI_SLAVE_COUNT

#define RET_EHAPI_SLAVE_COUNT 0x00E036

エラーコード "スレーブの総数取得に失敗"

◆ RET_EHAPI_READ_EEPROM

#define RET_EHAPI_READ_EEPROM 0x00E037

エラーコード "スレーブのEEPROMの読み取り失敗"

◆ RET_EHAPI_WRITE_EEPROM

#define RET_EHAPI_WRITE_EEPROM 0x00E038

エラーコード "スレーブのEEPROMへ書き込み失敗"

◆ RET_EHAPI_READ_REGISTER

#define RET_EHAPI_READ_REGISTER 0x00E039

エラーコード "スレーブのレジスタメモリの読み取り失敗"

◆ RET_EHAPI_WRITE_REGISTER

#define RET_EHAPI_WRITE_REGISTER 0x00E040

エラーコード "スレーブのレジスタメモリの書き込み失敗"

◆ RET_EHAPI_CATALOG

#define RET_EHAPI_CATALOG 0x00E041

エラーコード "スレーブのカタログに失敗"

◆ RET_EHAPI_OFFLINE

#define RET_EHAPI_OFFLINE 0x00E042

エラーコード "スレーブがオフライン"

◆ RET_EHAPI_NIC_DRIVER

#define RET_EHAPI_NIC_DRIVER 0x00E043

エラーコード "ネットワークドライバが不適合"

◆ RET_EHAPI_ENIFILE

#define RET_EHAPI_ENIFILE 0x00E044

エラーコード "ENIファイルのロード失敗"

◆ RET_EHAPI_CONFLICT

#define RET_EHAPI_CONFLICT 0x00E045

エラーコード "複数のスレッドから呼び出し"

◆ RET_EHAPI_EXIST

#define RET_EHAPI_EXIST 0x00E046

エラーコード "オブジェクトディクショナリが存在しない"

◆ RET_EHAPI_INDEX

#define RET_EHAPI_INDEX 0x00E047

エラーコード "オブジェクトディクショナリに指定のインデックスが存在しない"

◆ RET_EHAPI_SUBINDEX

#define RET_EHAPI_SUBINDEX 0x00E048

エラーコード "オブジェクトディクショナリの指定のインデックスにサブインデックスが存在しない"

◆ RET_EHAPI_LENGTH

#define RET_EHAPI_LENGTH 0x00E049

エラーコード "変数サイズが不正"

◆ RET_EHAPI_LIMIT

#define RET_EHAPI_LIMIT 0x00E04A

エラーコード "値が範囲外"

◆ RET_EHAPI_WRITEONLY

#define RET_EHAPI_WRITEONLY 0x00E04B

エラーコード "書き込み専用"

◆ RET_EHAPI_NO_RESPONSE

#define RET_EHAPI_NO_RESPONSE 0x00E04C

エラーコード "スレーブから応答なし"

◆ RET_EHAPI_NOT_REGISTERED

#define RET_EHAPI_NOT_REGISTERED 0x00E04D

エラーコード "スレッドハンドルが未登録"

◆ RET_EHAPI_NOT_HOTCONNECT

#define RET_EHAPI_NOT_HOTCONNECT 0x00E04E

エラーコード "ENIファイルにホットコネクト機能が未定義"

◆ RET_EHAPI_REF_CATALOG

#define RET_EHAPI_REF_CATALOG 0x00E050

エラーコード "ノード間通信用オブジェクトのカタログに失敗"

◆ RET_EHAPI_STARTARG_LOWER

#define RET_EHAPI_STARTARG_LOWER 0x00E0FD

エラーコード "起動パラメータの下限範囲外"

◆ RET_EHAPI_STARTARG_HIGHER

#define RET_EHAPI_STARTARG_HIGHER 0x00E0FE

エラーコード "起動パラメータの上限範囲外"

◆ RET_EHAPI_STARTARG_ABNORMAL

#define RET_EHAPI_STARTARG_ABNORMAL 0x00E0FF

エラーコード "起動パラメータが不正"

◆ RET_EHAPI_WAIT_CANCEL

#define RET_EHAPI_WAIT_CANCEL 0x00E100

エラーコード "EhWaitForCyclic/EhWaitForCyclicExが中断"

◆ RET_EHAPI_FIND_SLAVE

#define RET_EHAPI_FIND_SLAVE 0x00E106

エラーコード "スレーブの検出に失敗"

◆ RET_EHAPI_NOT_READY

#define RET_EHAPI_NOT_READY 0x00E107

エラーコード "準備中にイベント参照不可"

◆ RET_EHAPI_REG_EVENT

#define RET_EHAPI_REG_EVENT 0x00E108

エラーコード "イベントの登録に失敗"

◆ RET_EHAPI_WAIT_EVENT

#define RET_EHAPI_WAIT_EVENT 0x00E109

エラーコード "イベント待機に失敗"

◆ RET_EHAPI_CREATE_EVENT

#define RET_EHAPI_CREATE_EVENT 0x00E10A

エラーコード "イベント作成に失敗"

◆ RET_EHAPI_INVALID_EVENT

#define RET_EHAPI_INVALID_EVENT 0x00E10B

エラーコード "イベントは無効"

◆ RET_EHAPI_RT_MEM

#define RET_EHAPI_RT_MEM 0x00EF11

エラーコード "INtimeメモリが不足"

◆ RET_EHAPI_RT_VMEM

#define RET_EHAPI_RT_VMEM 0x00EF1B

エラーコード "仮想セグメントサイズが不足"

◆ RET_EHAPI_INVALID_LOCATION

#define RET_EHAPI_INVALID_LOCATION 0x00EF20

エラーコード "INtimeノード名が存在しない"

◆ RET_EHAPI_STOPNODE

#define RET_EHAPI_STOPNODE 0x00EF21

エラーコード "INtimeノードのINtimeカーネルが停止"

◆ RET_EHAPI_MEMORY

#define RET_EHAPI_MEMORY 0x00E810

エラーコード "内部メモリ確保に失敗"

◆ RET_EHAPI_EDITION

#define RET_EHAPI_EDITION 0x00E840

エラーコード "利用できない機能"

◆ RET_EHAPI_LICENSE

#define RET_EHAPI_LICENSE 0x00E850

エラーコード "ライセンスが未適用"


HLS-ECAT02WIN APIリファレンス: hmecw0_macro.h ソースファイル

hmecw0_macro.h
[詳解]
1 //==========================================
2 // HLS-ECAT02xx/Win
3 // File Name : hmecw0_macro.h
4 // Last update : 2021/05/26
5 //
6 // Copyright(C) 2015-2021　Hivertec,Inc.
7 // All Rights Reserved.
8 //==========================================
9
10
14 #define RESULT_FUNCTION_RESET 0x0021
18 #define RESULT_FUNCTION_HOME 0x0022
22 #define RESULT_FUNCTION_STOP 0x0023
26 #define RESULT_FUNCTION_ABSOLUTE 0x0024
30 #define RESULT_FUNCTION_RELATIVE 0x0025
34 #define RESULT_FUNCTION_ADDITIVE 0x0026
38 #define RESULT_FUNCTION_VELOCITY 0x0027
42 #define RESULT_FUNCTION_GROUP_RESET 0x0031
46 #define RESULT_FUNCTION_GROUP_HOME 0x0032
50 #define RESULT_FUNCTION_GROUP_STOP 0x0033
54 #define RESULT_FUNCTION_LINEAR_ABSOLUTE 0x0034
58 #define RESULT_FUNCTION_LINEAR_RELATIVE 0x0035
62 #define RESULT_FUNCTION_LINEAR_VELOCITY 0x0036
63
67 #define RESULT_FUNCTION_MOVE_PATH 0x0045
72 #define RESULT_STATUS_DONE_WAIT 0x0001
77 #define RESULT_STATUS_BUSY_WAIT 0x0002
82 #define RESULT_STATUS_ABORTED_WAIT 0x0003
87 #define RESULT_STATUS_ERROR_WAIT 0x0004
92 #define RESULT_STATUS_DONE 0x0081
97 #define RESULT_STATUS_BUSY 0x0082
102 #define RESULT_STATUS_ABORTED 0x0083
107 #define RESULT_STATUS_ERROR 0x0084
108
112 #define RET_SUCCESS 0x000000
116 #define RET_ILL_SLAVE 0x000002 //
120 #define RET_ILL_AXIS 0x000003 //
124 #define RET_ILL_GR 0x000004 //
128 #define RET_SLV_REG_ERR 0x000006 //
132 #define RET_AXIS_REG_ERR 0x000007 //
136 #define RET_ILL_PARAMETER 0x000008 //
140 #define RET_INACTIVE_INTIME 0x00000B //
144 #define RET_ACTIVE_OTHER_FUNCTION 0x00000C //
148 #define RET_MAX_CONTROL_AXIS 0x00000D //
152 #define RET_AXIS_REGISTERED 0x00000E //
156 #define RET_OTHER_ERR 0x000010 //
160 #define RET_INACTIVE_WIN_DLL 0x00001B //
164 #define RET_SOFTWARE_NOT_SUPPORT 0x00001F //
168 #define RET_WAITING_CANCELED 0x000020 //
172 #define RET_WAITING_NOT_EXIST 0x000021 //
176 #define RET_S_OFFLINE 0x000031 //
180 #define RET_S_ECATSTATE_ERR 0x000032 //
184 #define RET_INVALID_OPERATION_MODE 0x000101 // ．
188 #define RET_INVALID_PLCOPEN_STATE 0x000102 //
192 #define RET_FOLLOWING_ERR 0x000103 //
196 #define RET_INVALID_VARIABLE 0x000104 //
200 #define RET_ALAM 0x000105 //
204 #define RET_ILL_NOT 0x000106 //
208 #define RET_ILL_POT 0x000107 //
212 #define RET_AXIS_ERR 0x000108 //
216 #define RET_INVALID_DIRECTION 0x000109 //
220 #define RET_NS_SERVO 0x00010A //
224 #define RET_RATIO_ERR 0x00010D //
228 #define RET_LAST_ERR 0x000110 //
233 #define RET_POWER_FAIL 0x000201 //
237 #define RET_SET_OVERRIDE_FAIL 0x00020C //
241 #define RET_RESET_FAIL 0x00020F //
245 #define RET_HOMING_ERR 0x000221 //
249 #define RET_HOMING_MODE_ERR 0x000222 //
253 #define RET_READ_SDO_ERR 0x000223 //
257 #define RET_WRITE_SDO_ERR 0x000224 //
261 #define RET_ER_INVALID_BUFFER_MODE 0x000225 //
265 #define RET_RSI_HANDLER_ERR 0x000230 //
269 #define RET_TCH_PRB_PRM_ERR 0x000301 //
273 #define RET_TRG_PRM_ERR 0x000302 //
277 #define RET_PRB_ID_DUP_ERR 0x000303 //
281 #define RET_FUNC_TOUCH_PRB_ERR 0x000304 //
285 #define RET_FUNC_ABORT_TRIG_ERR 0x000305 //
289 #define RET_PRB_NOT_ACTIVE 0x000306 //
293 #define RET_PRB_FUNC_PDO_PRM_ERR 0x000307 //
297 #define RET_ABORT_TRIG_RUNNING_ERR 0x000308 //
301 #define RET_BUFFER_MODE_INVALID 0x000310 //
305 #define RET_GRP_ILL_PLCOPEN_STATE 0x000402 //
309 #define RET_GROUP_ILL_PRM 0x000403 //
313 #define RET_GRP_ILL_DIRECTION 0x000404 //
317 #define RET_GRP_EXIST 0x000405 //
321 #define RET_GRP_FULL 0x000406 //
325 #define RET_GROUP_NO_AXIS 0x000407 //
329 #define RET_GRP_RESET_FAILED 0x000408 //
333 #define RET_GRP_ADD_AXIS_FAILED 0x000409 //
337 #define RET_GRP_AXIS_EXIST 0x00040A //
341 #define RET_GRP_AXIS_NOT_EXIST 0x00040B //
345 #define RET_GRP_OTHER_AXIS_EXIST 0x00040C //
349 #define RET_GRP_SLV_ILL_CONDITION 0x00040D //
353 #define RET_GRP_AXIS_ILL_CONDITION 0x00040E //
357 #define RET_GRP_ILL_FOLLOWING 0x000410 //
361 #define RET_ILL_PATH_DATA_SIZE 0x000420 //
365 #define RET_PATH_DATA_MAX 0x000421 //
369 #define RET_ILL_LINE 0x000422 //
373 #define RET_GRP_PATH_POSITION_ERR 0x000423 //
377 #define RET_GRP_PATH_VELOCITY_ERR 0x000424 //
381 #define RET_GRP_PATH_ACCELERATION_ERR 0x000425 //
385 #define RET_GRP_PATH_DECELERATION_ERR 0x000426 //
389 #define RET_GRP_PATH_JERK_ERR 0x000427 //
393 #define RET_GRP_PATH_BUFFER_MODE_ERR 0x000428 //
397 #define RET_GRP_PATH_MOTION_CMD_ERR 0x000429 //
401 #define RET_GRP_PATH_FILE_ERR 0x00042A //
405 #define RET_GRP_MVPATH_EXECUTED_ERR 0x00042F //
409 #define RET_GRP_AXIS_ILL_PRM 0x000430 //
422 #define RET_GRP_ARRAY0_ILL_PRM 0x000460 // 軸グループ(配列番号0)に追加済みの軸のパラメータ異常です
435 #define RET_GRP_ARRAY0_ILL_PLCOPEN_STATE 0x0004A0 // 軸グループ(配列番号0)に追加済みの軸の状態が異常です．状態とは，PLCOpenで定義された状態です．
448 #define RET_GRP_ARRAY0_ILL_DIRECTION 0x0004E0 //
461 #define RET_GRP_ARRAY0_ILL_FOLLOWING 0x000520 // 軸グループ(配列番号0)に追加済みの軸の位置偏差エラーです．
474 #define RET_GRP_ARRAY0_ILL_NOT 0x000560 // 軸グループ(配列番号0)に追加済みの軸の負方向駆動禁止入力エラーです．
487 #define RET_GRP_ARRAY0_ILL_POT 0x0005A0 // 軸グループ(配列番号0)に追加済みの軸の正方向駆動禁止入力エラーです．
500 #define RET_GRP_ARRAY0_ALAM 0x0005E0 // 軸グループ(配列番号0)に追加済みの軸にサーボアラームが発生しています．
513 #define RET_GRP_ARRAY0_RATIO_ERR 0x000620 // 軸グループの電子ギアの設定に関係するエラー(配列番号0)
517 #define RET_PDO_OBJECT_NOT_EXIST 0x000801 //
521 #define RET_DIAGNOSIS_MESSAGE_ERR 0x000811 //
525 #define RET_MK_MEM_ERR 0x000820 //
529 #define RET_OUT_OF_INTIME_MEM 0x000830 //
533 #define RET_FAILED_FILE_OPEN 0x000831 //
537 #define RET_FAILED_FILE_PROC 0x000832 //
541 #define RET_BUFFER_FULL 0x000901 //
545 #define RET_EHAPI_PARAM 0x00E001 //
549 #define RET_EHAPI_CHANNEL 0x00E002 //
553 #define RET_EHAPI_CATEGORY 0x00E003 //
557 #define RET_EHAPI_SIZE 0x00E004 //
561 #define RET_EHAPI_MAX_OPEN 0x00E005 //
565 #define RET_EHAPI_MAX_QUE 0x00E006 //
569 #define RET_EHAPI_REQ_ERROR 0x00E007 //
573 #define RET_EHAPI_NOT_FOUND 0x00E008 //
577 #define RET_EHAPI_IS_DEAD 0x00E009 //
581 #define RET_EHAPI_STATE_I 0x00E00A //
585 #define RET_EHAPI_STATE_P 0x00E00B //
589 #define RET_EHAPI_STATE_S 0x00E00C //
593 #define RET_EHAPI_STATE_O 0x00E00D //
597 #define RET_EHAPI_NOITEM 0x00E00E //
601 #define RET_EHAPI_TIMEOUT 0x00E00F //
605 #define RET_EHAPI_STATE_UNKNOWN 0x00E010 //
609 #define RET_EHAPI_SLAVE_IS_ZERO 0x00E011 //
613 #define RET_EHAPI_WORKING 0x00E020 //
617 #define RET_EHAPI_OPEN 0x00E021 //
621 #define RET_EHAPI_CLOSE 0x00E022 //
625 #define RET_EHAPI_TXBUFF 0x00E023 //
629 #define RET_EHAPI_TXDATA 0x00E024 //
633 #define RET_EHAPI_RECV 0x00E025 //
637 #define RET_EHAPI_SEND 0x00E026
641 #define RET_EHAPI_OPENED 0x00E027 //
645 #define RET_EHAPI_CLOSED 0x00E028 //
649 #define RET_EHAPI_CMDERR 0x00E029 //
653 #define RET_EHAPI_SYSERR 0x00E030 //
657 #define RET_EHAPI_OBJECT 0x00E033 //
661 #define RET_EHAPI_READONLY 0x00E034 //
665 #define RET_EHAPI_ALIAS_CONFLICT 0x00E035 //
669 #define RET_EHAPI_SLAVE_COUNT 0x00E036 //
673 #define RET_EHAPI_READ_EEPROM 0x00E037 //
677 #define RET_EHAPI_WRITE_EEPROM 0x00E038 //
681 #define RET_EHAPI_READ_REGISTER 0x00E039 //
685 #define RET_EHAPI_WRITE_REGISTER 0x00E040 //
689 #define RET_EHAPI_CATALOG 0x00E041 //
693 #define RET_EHAPI_OFFLINE 0x00E042 //
697 #define RET_EHAPI_NIC_DRIVER 0x00E043 //
701 #define RET_EHAPI_ENIFILE 0x00E044 //
705 #define RET_EHAPI_CONFLICT 0x00E045 //
709 #define RET_EHAPI_EXIST 0x00E046 //
713 #define RET_EHAPI_INDEX 0x00E047 //
717 #define RET_EHAPI_SUBINDEX 0x00E048 //
721 #define RET_EHAPI_LENGTH 0x00E049 //
725 #define RET_EHAPI_LIMIT 0x00E04A // .
729 #define RET_EHAPI_WRITEONLY 0x00E04B // .
733 #define RET_EHAPI_NO_RESPONSE 0x00E04C // .
737 #define RET_EHAPI_NOT_REGISTERED 0x00E04D // .
741 #define RET_EHAPI_NOT_HOTCONNECT 0x00E04E //
745 #define RET_EHAPI_REF_CATALOG 0x00E050 //
749 #define RET_EHAPI_STARTARG_LOWER 0x00E0FD //
753 #define RET_EHAPI_STARTARG_HIGHER 0x00E0FE //
757 #define RET_EHAPI_STARTARG_ABNORMAL 0x00E0FF //
761 #define RET_EHAPI_WAIT_CANCEL 0x00E100 //
765 #define RET_EHAPI_FIND_SLAVE 0x00E106 //
769 #define RET_EHAPI_NOT_READY 0x00E107 //
773 #define RET_EHAPI_REG_EVENT 0x00E108 //
777 #define RET_EHAPI_WAIT_EVENT 0x00E109 //
781 #define RET_EHAPI_CREATE_EVENT 0x00E10A //
785 #define RET_EHAPI_INVALID_EVENT 0x00E10B //
789 #define RET_EHAPI_RT_MEM 0x00EF11 //
793 #define RET_EHAPI_RT_VMEM 0x00EF1B //
797 #define RET_EHAPI_INVALID_LOCATION 0x00EF20 //
801 #define RET_EHAPI_STOPNODE 0x00EF21 //
805 #define RET_EHAPI_MEMORY 0x00E810 //
809 #define RET_EHAPI_EDITION 0x00E840 //
813 #define RET_EHAPI_LICENSE 0x00E850 //
814
815 /* @} */


HLS-ECAT02WIN APIリファレンス: hmecw0_struct.h ファイル

データ構造
hmecw0_struct.h ファイル

データ構造

struct | MC_AXIS_REF
軸情報を格納する構造体 [詳解]
struct | MC_AXIS_FACTOR
[Struct] MC_AXIS_SETTING [詳解]
struct | MC_AXIS_MOVE
[Struct] MC_AXIS_SETTING [詳解]
struct | MC_AXIS_DRIVE
[Struct] MC_AXIS_SETTING [詳解]
struct | MC_AXIS_MACHINE
[Struct] MC_AXIS_SETTING [詳解]
struct | MC_AXIS_SETTING
[Out] MC_GetAxisSetting [詳解]
struct | MC_POWER_IN
[Out] MC_GetAxisSetting, MC_SetAxisSetting [詳解]
struct | MC_POWER_OUT
[Out] MC_GetAxisSetting, MC_SetAxisSetting [詳解]
struct | MC_STATUS
[Out] MC_ReadStatus [詳解]
struct | MC_AXIS_ERROR
[Out] MC_ReadAxisError [詳解]
struct | MC_ACTUAL_POSITION
[In] MC_SetPosition [詳解]
struct | MC_ACTUAL_VELOCITY
[Out] MC_ReadActualVelocity [詳解]
struct | MC_AXIS_INFO
[Out] MC_ReadAxisInfo [詳解]
struct | MC_MOTION_STATE
[Out] MC_ReadMotionState [詳解]
struct | MC_SET_OVERRIDE_IN
[In] MC_SetOverride [詳解]
struct | MC_TRIGGER_REF
[Struct] MC_TOUCH_PROBE_IN [詳解]
struct | MC_TOUCH_PROBE_IN
[In] MC_TouchProbe [詳解]
struct | MC_TOUCH_PROBE_OUT
[In] MC_TouchProbe [詳解]
struct | MC_RESET_OUT
[Out] MC_Reset [詳解]
struct | MC_HOME_IN
[In] MC_Home [詳解]
struct | MC_HOME_OUT
[Out] MC_Home [詳解]
struct | MC_STOP_IN
[In] MC_Stop [詳解]
struct | MC_STOP_OUT
[Out] MC_Stop [詳解]
struct | MC_MOVE_ABSOLUTE_IN
[In] MC_MoveAbsolute [詳解]
struct | MC_MOVE_ABSOLUTE_OUT
[Out] MC_MoveAbsolute [詳解]
struct | MC_MOVE_RELATIVE_IN
[In] MC_MoveRelative [詳解]
struct | MC_MOVE_RELATIVE_OUT
[Out] MC_MoveRelative [詳解]
struct | MC_MOVE_ADDITIVE_IN
[In] MC_MoveAdditive [詳解]
struct | MC_MOVE_ADDITIVE_OUT
[Out] MC_MoveAdditive [詳解]
struct | MC_MOVE_VELOCITY_IN
[In] MC_MoveVelocitiy [詳解]
struct | MC_MOVE_VELOCITY_OUT
[Out] MC_MoveVelocitiy [詳解]
struct | MC_MOVE_FUNCTION_RESULT
[Out] MC_ReadFunctionResult [詳解]
struct | MC_BUFFER_FUNC
[Struct] MC_READ_BUFFER_OUT [詳解]
struct | MC_READ_BUFFER_OUT
[Out] MC_ReadBuffer [詳解]
struct | MC_LATCH_COUNT_RESULT
[Out] MC_ReadLatchCountResult [詳解]
struct | MC_PROBE_STATUS
[Out] MC_ReadProbeStatus [詳解]
struct | MC_LATCH_COUNT_REF
[In] MC_ReadLatchCountResult [詳解]
struct | EC_MASTER_INFO
[In] EC_GetMasterInfom, EC_OpenMaster [詳解]
struct | EC_GET_SLAVE_INFO_IN
[In] EC_GetSlaveInfo [詳解]
struct | EC_SLAVE_INFO
[In] EC_GetSlaveInfo [詳解]
struct | EC_DIAGNOSIS_MESSAGE_FLAGS
[In] EC_SetDiagnosisMessageFlags [詳解]
struct | EC_DIAGNOSIS_PARAMETER
[Struct] EC_GET_DIAGNOSIS_MESSAGE_OUT [詳解]
struct | EC_GET_DIAGNOSIS_MESSAGE_OUT
[Out] EC_GetDiagnosisMessage [詳解]
struct | EC_DELAY_TIMER
[In] MC_SetDelayTimer [詳解]
struct | EC_VERSION
[Out] EC_ReadVersion [詳解]
struct | MC_AXES_GROUP_REF
[Handle] Group関数全般ハンドル [詳解]
struct | MC_GROUP_ADD_AXIS
[In] MC_AddAxisToGroup [詳解]
struct | MC_GROUP_REMOVE_AXIS
[In] MC_RemoveAxisFromGroup [詳解]
struct | MC_GROUP_READ_CONFIG_IN
[In] MC_GroupReadConfiguration [詳解]
struct | MC_GROUP_READ_CONFIG_OUT
[Out] MC_GroupReadConfiguration [詳解]
struct | MC_GROUP_MOVE
[Struct] MC_GROUP_SETTING [詳解]
struct | MC_GROUP_SETTING
[In] MC_SetGroupSetting [詳解]
struct | MC_GROUP_SET_POSITION
[In] MC_GroupSetPosition [詳解]
struct | MC_GROUP_READ_ACT_POS_IN
[In] MC_GroupReadActualPosition [詳解]
struct | MC_GROUP_READ_ACT_POS_OUT
[In] MC_GroupReadActualPosition [詳解]
struct | MC_GROUP_READ_ACT_VEL_IN
[In] MC_GroupReadActualVelocity [詳解]
struct | MC_GROUP_READ_ACT_VEL_OUT
[Out] MC_GroupReadActualVelocity [詳解]
struct | MC_GROUP_READ_STATUS
[Out] MC_GroupReadStatus [詳解]
struct | MC_GROUP_READ_ERROR
[Out] MC_GroupReadError [詳解]
struct | MC_GROUP_RESET_OUT
[Out] MC_GroupReset [詳解]
struct | MC_PATH_DATA_REF
[Struct] MC_GROUP_READ_PATH_DATA_OUT [詳解]
struct | MC_MOVE_PATH_IN
[In] MC_MovePath [詳解]
struct | MC_MOVE_PATH_OUT
[Out] MC_MovePath [詳解]
struct | MC_GROUP_READ_PATH_DATA_OUT
[Out] MC_GroupReadPathData [詳解]
struct | MC_GROUP_SET_OVERRIDE_IN
[Out] MC_GroupReadPathData [詳解]
struct | MC_GROUP_MOVE_FUNCTION_RESULT
[Out] MC_GroupReadFunctionResult [詳解]
struct | MC_GROUP_HOME_IN
[In] MC_GroupHome [詳解]
struct | MC_GROUP_HOME_OUT
[Out] MC_GroupHome [詳解]
struct | MC_GROUP_STOP_IN
[In] MC_GroupStop [詳解]
struct | MC_GROUP_STOP_OUT
[Out] MC_GroupStop [詳解]
struct | MC_MOVE_LINEAR_ABS_IN
[In] MC_MoveLinearAbsolute [詳解]
struct | MC_MOVE_LINEAR_ABS_OUT
[Out] MC_MoveLinearAbsolute [詳解]
struct | MC_MOVE_LINEAR_REL_IN
[In] MC_MoveLinearRelative [詳解]
struct | MC_MOVE_LINEAR_REL_OUT
[In] MC_MoveLinearRelative [詳解]
struct | MC_GROUP_BUFFER_FUNC
[Struct] MC_GROUP_READ_BUFFER_OUT [詳解]
struct | MC_GROUP_READ_BUFFER_OUT
[Out] MC_GroupReadBuffer [詳解]
struct | MC_MOVE_LINEAR_VEL_IN
[In] MC_MoveLinearVelocity [詳解]
struct | MC_MOVE_LINEAR_VEL_OUT
[Out] MC_MoveLinearVelocity [詳解]
struct | READ_STATUS
[Struct] MC_AXES_READ_STATUS [詳解]
struct | MC_AXES_READ_STATUS
[Out] MC_GroupAxesReadStatus [詳解]
struct | READ_MOTION_STATE
[Struct] MC_AXES_READ_MOTION_STATE [詳解]
struct | MC_AXES_READ_MOTION_STATE
[Out] MC_GroupAxesReadMotionState [詳解]
struct | READ_AXIS_INFO
[Struct] MC_AXES_READ_INFO [詳解]
struct | MC_AXES_READ_INFO
[Out] MC_GroupAxesReadInfo [詳解]
struct | READ_ERROR
[Struct] MC_AXES_READ_ERROR [詳解]
struct | MC_AXES_READ_ERROR
[Out] MC_GroupAxesReadError [詳解]
struct | EC_LOGPOS_STATUS
[In] EC_ReadLogPositionStatus [詳解]
struct | EC_SAVE_LOGPOS
[In] EC_SaveLogPosition [詳解]
struct | EC_START_LOGPOS
[In] EC_StartLogPosition [詳解]


HLS-ECAT02WIN APIリファレンス: hmecw0_struct.h ソースファイル

hmecw0_struct.h
[詳解]
1 //==========================================
2 // HLS-ECAT02xx/Win
3 // File Name : hmecw0_struct.h
4 // Last update : 2021/05/26
5 //
6 // Copyright(C) 2015-2021　Hivertec,Inc.
7 // All Rights Reserved.
8 //==========================================
9
13 typedef struct {
14 BYTE bSlaveNo;
15 WORD wAxisNo;
16 }MC_AXIS_REF;
20 typedef struct {
21 WORD wAxisType;
22 WORD wActuatorType;
23 WORD wMotorType;
24 WORD wEncType;
25 WORD wCountMode;
26 double fMaxCount;
27 double fMinCount;
28 }MC_AXIS_FACTOR;
29
33 typedef struct {
34
35 BOOL bDisableWaitMotionInt;
36 DWORD dwInposWidth;
37 BYTE bInposMode;
48 long lEncPulse;
49 WORD wIncPerMM;
50 DWORD dwPullPR;
51 DWORD dwDisPR;
52 WORD wPreviousDirection;
53 double fFLvelocity;
54 double fMaxSLS;
55 double fMinSLS;
56 double fPosDeviation;
57 double fPosDevAlarm;
58 }MC_AXIS_MOVE;
59
63 typedef struct {
64 BOOL bFollowingError;
65 BOOL bInposEnable;
66 BOOL bInposInput;
67 }MC_AXIS_DRIVE;
68
72 typedef struct {
73 BOOL bPosiElsEnable;
74 BOOL bNegaElsEnable;
75 BOOL bElsInput;
76 WORD wElsStop;
77 } MC_AXIS_MACHINE;
78
83 typedef struct {
84 MC_AXIS_FACTOR AxisFactor;
85 MC_AXIS_MOVE AxisMove;
86 MC_AXIS_DRIVE AxisDrive;
87 MC_AXIS_MACHINE AxisMachine;
88 }MC_AXIS_SETTING;
89
93 typedef struct {
94 BOOL bEnable;
95 BOOL bEnablePositive;
96 BOOL bEnableNegative;
97 }MC_POWER_IN;
98
102 typedef struct {
103 BOOL bStatus;
104 BOOL bError;
105 WORD wErrorID;
106 }MC_POWER_OUT;
107
111 typedef struct {
112 WORD wStatus;
113 }MC_STATUS;
114
118 typedef struct {
119 WORD wErrorID;
120 }MC_AXIS_ERROR;
121
126 typedef struct {
127 double fPosition;
128 }MC_ACTUAL_POSITION;
129
133 typedef struct {
134 double fVelocity;
135 }MC_ACTUAL_VELOCITY;
136
140 typedef struct {
141 DWORD dwAxisInfo;
142 }MC_AXIS_INFO;
143
147 typedef struct {
148 WORD wMotionState;
149 }MC_MOTION_STATE;
150
154 typedef struct {
155 double fVelFactor;
156 double fAccFactor;
157 double fJerkFactor;
158 }MC_SET_OVERRIDE_IN;
159
164 typedef struct {
165 WORD wProbeID;
166 BOOL bEdge;
167 BYTE byTriggerMode;
168 BYTE byInputSelect;
169 BYTE byEncoderID;
170 BYTE byTriggerVariable;
171 BYTE byProbeState;
172 }MC_TRIGGER_REF;
173
177 typedef struct {
178 MC_TRIGGER_REF TriggerInput;
179 BOOL bWindowOnly;
180 double fFirstPosition;
181 double fLastPosition;
182 WORD wPositionSelect;
183 WORD wStopMotionSelect;
184 }MC_TOUCH_PROBE_IN;
185
189 typedef struct {
190 WORD wStatus;
191 WORD wErrorID;
192 }MC_TOUCH_PROBE_OUT;
193
197 typedef struct {
198 WORD wStatus;
199 WORD wErrorID;
200 }MC_RESET_OUT;
201
205 typedef struct {
206 BOOL bEncoder;
207 BYTE byHomingMethod;
208 double fSpeed1;
209 double fSpeed2;
210 double fPosition;
211 double fVelocity;
212 double fAcceleration;
213 double fDeceleration;
214 double fJerk;
215 WORD wHomePosiInpType;
216 WORD wHomePosiDir;
217 WORD wHomePosiInpDir;
218 double fHomeMaskDis;
219 double fHomePosiOffset;
220 DWORD dwHomePushWait;
221 WORD wBufferMode;
222 BOOL bSyncMotion;
223 }MC_HOME_IN;
224
228 typedef struct {
229 WORD wStatus;
230 WORD wErrorID;
231 }MC_HOME_OUT;
232
236 typedef struct {
237 double fDeceleration;
238 double fJerk;
239 }MC_STOP_IN;
240
244 typedef struct {
245 WORD wStatus;
246 WORD wErrorID;
247 }MC_STOP_OUT;
248
252 typedef struct {
253 double fPosition;
254 double fVelocity;
255 double fAcceleration;
256 double fDeceleration;
257 double fJerk;
258 WORD wDirection;
259 WORD wBufferMode;
260 }MC_MOVE_ABSOLUTE_IN;
261
265 typedef struct {
266 WORD wStatus;
267 WORD wErrorID;
268 }MC_MOVE_ABSOLUTE_OUT;
269
273 typedef struct {
274 double fDistance;
275 double fVelocity;
276 double fAcceleration;
277 double fDeceleration;
278 double fJerk;
279 WORD wBufferMode;
280 }MC_MOVE_RELATIVE_IN;
281
285 typedef struct {
286 WORD wStatus;
287 WORD wErrorID;
288 }MC_MOVE_RELATIVE_OUT;
289
293 typedef struct {
294 double fDistance;
295 double fVelocity;
296 double fAcceleration;
297 double fDeceleration;
298 double fJerk;
299 WORD wBufferMode;
300 }MC_MOVE_ADDITIVE_IN;
301
305 typedef struct {
306 WORD wStatus;
307 WORD wErrorID;
308 }MC_MOVE_ADDITIVE_OUT;
309
313 typedef struct {
314 double fVelocity;
315 double fAcceleration;
316 double fDeceleration;
317 double fJerk;
318 WORD wDirection;
319 WORD wBufferMode;
320 }MC_MOVE_VELOCITY_IN;
321
325 typedef struct {
326 WORD wStatus;
327 WORD wErrorID;
328 }MC_MOVE_VELOCITY_OUT;
329
333 typedef struct {
334 WORD wFunction;
335 WORD wStatus;
336 WORD wErrorID;
337 }MC_MOVE_FUNCTION_RESULT;
338
343 typedef struct {
344 BYTE bFuncID;
345 double fPosition;
346 double fDistance;
347 double fVelocity;
348 double fAcceleration;
349 double fDeceleration;
350 double fJerk;
351 }MC_BUFFER_FUNC;
352
356 typedef struct {
357 BYTE bBufferNum;
358 WORD wErrorID;
359 MC_BUFFER_FUNC BufferFunction[4];
360 }MC_READ_BUFFER_OUT;
361
365 typedef struct {
366 BYTE byLatchCountRef;
367 BOOL bProbe1Stored;
368 WORD wProbe1Status;
369 WORD wProbe1ErrorID;
370 double fProbe1RecPosition;
371 BOOL bProbe2Stored;
372 WORD wProbe2Status;
373 WORD wProbe2ErrorID;
374 double fProbe2RecPosition;
375 }MC_LATCH_COUNT_RESULT;
376
380 typedef struct
381 {
382 WORD woProbe1Status;
383 WORD woProbe1ErrorID;
384 WORD woProbe2Status;
385 WORD woProbe2ErrorID;
386 }MC_PROBE_STATUS;
387
391 typedef struct
392 {
393 BYTE byLatchCountRef;
394 }MC_LATCH_COUNT_REF;
395
399 typedef struct {
400 char cMasterName[12];
401 DWORD dwCyclicTime;
402 BYTE bBasePrioriy;
403 char cInterfaceDriver[16];
404 char cRedundancyDriver[16];
405 WORD wSlaveCountXml;
406 WORD wSlaveCountOnline;
407 DWORD dwPdoInSize;
408 DWORD dwPdoOutSize;
409 DWORD hMasterHandle;
410 }EC_MASTER_INFO;
411
415 typedef struct {
416 DWORD dwInstance;
417 DWORD dwVendorID;
418 DWORD dwProductCode;
419 }EC_GET_SLAVE_INFO_IN;
420
424 typedef struct {
425 BYTE bSlaveNo;
426 BYTE bAxisNo;
427 WORD wSlaveStatus;
428 //[説明] 対象スレーブのステータス状態を格納します．
429 //[範囲] 0-65535
430 WORD wAlias;
431 WORD wSlaveType;
432 DWORD dwInstance;
433 DWORD dwVendorID;
434 DWORD dwProductCode;
435 DWORD dwRevisionNo;
436 DWORD dwSerialNo;
437 DWORD dwPhysicalAddr;
438 DWORD dwAutoIncAddr;
439 DWORD dwStatusBit;
440 DWORD dwViosInBaseOffset;
441 DWORD dwViosInSize;
442 DWORD dwViosOutBaseOffset;
443 DWORD dwViosOutSize;
444 DWORD dwDCEnable;
445 }EC_SLAVE_INFO;
446
451 typedef struct {
452 BOOL bEnableEmergensy;
453 BOOL bDisableInfMes;
454 BOOL bDisableWarnMes;
455 BOOL bDisableErrMes;
456 BOOL bModeSelect;
457 }EC_DIAGNOSIS_MESSAGE_FLAGS;
458
463 typedef struct {
464 WORD wFlags;
465 BOOL bBoolParameter;
466 char cInt8Parameter;
467 short sInt16Parameter;
468 long lInt32Parameter;
469 BYTE bUnsigned8Parameter;
470 WORD wUnsigned16Parameter;
471 DWORD dwUnsigned32Parameter;
472 BYTE bByteArrayParameter[64];
473 char cStrParameter[64];
474 }EC_DIAGNOSIS_PARAMETER;
475
479 typedef struct {
480 BYTE bType;
481 WORD wTextID;
482 DWORD dwTimeStampL;
483 DWORD dwTimeStampH;
484 BYTE bParameterNum;
485 EC_DIAGNOSIS_PARAMETER Parameter[64];
486 }EC_GET_DIAGNOSIS_MESSAGE_OUT;
487
492 typedef struct {
493 long lMvAbsDelay;
494 long lMvAddDelay;
495 long lMvRelDelay;
496 long lMvHmDelay;
497 long lMvVelDelay;
498 }EC_DELAY_TIMER;
499
503 typedef struct {
504 WORD wAxisNum;
505 BYTE bVersion[16];
506 }EC_VERSION;
507
509 // MC Group Function
511
515 typedef struct {
516 BYTE byGroupID;
517 BYTE bySyncAxis;
518 MC_AXIS_REF stAxis[32];
519
520 }MC_AXES_GROUP_REF;
521
525 typedef struct {
526 BYTE bySeqNo;
527 }MC_GROUP_ADD_AXIS;
528
532 typedef struct {
533 BYTE bySeqNo;
534 }MC_GROUP_REMOVE_AXIS;
535
539 typedef struct {
540 BYTE bySeqNo;
541 }MC_GROUP_READ_CONFIG_IN;
542
546 typedef struct {
547 MC_AXIS_REF stAxis;
548 }MC_GROUP_READ_CONFIG_OUT;
549
553 typedef struct {
554 BOOL bDisableWaitMotionInt;
555 BYTE byMasterSeqNo;
556 BYTE bySlaveSeqNo;
557 BOOL bDeviationStopEnable;
558 BYTE byDeviationStopMode;
559 double fPosDeviation;
560 double fDeviationDec;
561 double fDeviationJerk;
562 }MC_GROUP_MOVE;
563
568 typedef struct {
569 MC_GROUP_MOVE GroupMove;
570 }MC_GROUP_SETTING;
571
575 typedef struct {
576 double fPosition[32];
577 BOOL bPositionInp;
578 BYTE byCoordSys;
579 WORD wBufferMode;
580 }MC_GROUP_SET_POSITION;
581
585 typedef struct {
586 BYTE byCoordSys;
587 }MC_GROUP_READ_ACT_POS_IN;
588
592 typedef struct {
593 double fPosition[32];
594 }MC_GROUP_READ_ACT_POS_OUT;
595
599 typedef struct {
600 BYTE byCoordSys;
601 }MC_GROUP_READ_ACT_VEL_IN;
602
606 typedef struct {
607 double fPathVelocity;
608 double fVelocity[32];
609 }MC_GROUP_READ_ACT_VEL_OUT;
610
614 typedef struct {
615 WORD wPLCOpenStatus;
616 WORD wMotionStatus;
617 }MC_GROUP_READ_STATUS;
618
622 typedef struct {
623 WORD wErrorID;
624 }MC_GROUP_READ_ERROR;
625
629 typedef struct {
630 WORD wStatus;
631 WORD wErrorID;
632 }MC_GROUP_RESET_OUT;
633
638 typedef struct {
639 double fPosition[32];
640 double fVelocity;
641 double fAcceleration;
642 double fDeceleration;
643 double fJerk;
644 WORD wBufferMode;
645 BYTE byTransitionMode;
646 BYTE byMtnCmd;
647 double fVelFactor;
648 double fCornerDistance;
649 double fMaxCornerDeviation;
650 }MC_PATH_DATA_REF;
651
655 typedef struct {
656 BYTE byInpMode;
657 DWORD dwSize;
658 BYTE byCoordSystem; // (予約)
659 WORD wBufferMode;
660 BYTE byTransitionMode;
661 double fVelFactor;
662 double fCornerDistance;
663 double fMaxCornerDeviation;
664 double fTransitionParam[1];
665 char* pName;
666 }MC_MOVE_PATH_IN;
667
671 typedef struct {
672 WORD wStatus;
673 DWORD dwSize;
674 WORD wErrorID;
675 DWORD dwErrLine;
676 }MC_MOVE_PATH_OUT;
677
681 typedef struct {
682 DWORD dwSize;
683 DWORD dwRun;
684 MC_PATH_DATA_REF PathRef;
685 }MC_GROUP_READ_PATH_DATA_OUT;
686
690 typedef struct {
691 double fVelFactor;
692 double fAccFactor;
693 double fJerkFactor;
694 }MC_GROUP_SET_OVERRIDE_IN;
695
699 typedef struct {
700 WORD wFunction;
701 WORD wStatus;
702 WORD wErrorID;
703 }MC_GROUP_MOVE_FUNCTION_RESULT;
704
708 typedef struct {
709 double fPosition[32];
710 double fVelocity;
711 double fAcceleration;
712 double fDeceleration;
713 double fJerk;
714 WORD wBufferMode;
715 }MC_GROUP_HOME_IN;
716
720 typedef struct {
721 WORD wStatus;
722 WORD wErrorID;
723 }MC_GROUP_HOME_OUT;
724
728 typedef struct {
729 double fDeceleration;
730 double fJerk;
731 WORD wBufferMode;
732 }MC_GROUP_STOP_IN;
733
737 typedef struct {
738 WORD wStatus;
739 WORD wErrorID;
740 }MC_GROUP_STOP_OUT;
741
745 typedef struct {
746 double fPosition[32];
747 double fVelocity;
748 double fAcceleration;
749 double fDeceleration;
750 double fJerk;
751 WORD wBufferMode;
752 }MC_MOVE_LINEAR_ABS_IN;
753
757 typedef struct {
758 WORD wStatus;
759 WORD wErrorID;
760 }MC_MOVE_LINEAR_ABS_OUT;
761
765 typedef struct {
766 double fDistance[32];
767 double fVelocity;
768 double fAcceleration;
769 double fDeceleration;
770 double fJerk;
771 WORD wBufferMode;
772 }MC_MOVE_LINEAR_REL_IN;
773
777 typedef struct {
778 WORD wStatus;
779 WORD wErrorID;
780 }MC_MOVE_LINEAR_REL_OUT;
781
786 typedef struct {
787 WORD wBufferMode;
788 BYTE bFuncID;
789 double fPosition[32];
790 double fDistance[32];
791 double fVelocity;
792 double fAcceleration;
793 double fDeceleration;
794 double fJerk;
795 }MC_GROUP_BUFFER_FUNC;
796
800 typedef struct {
801 BYTE bBufferNum;
802 WORD wErrorID;
803 MC_GROUP_BUFFER_FUNC BufferFunction[4];
804 }MC_GROUP_READ_BUFFER_OUT;
805
809 typedef struct
810 {
811 BOOL bJogAxis[32];
812 double fVelocity;
813 double fAcceleration;
814 double fDeceleration;
815 double fJerk;
816 WORD wDirection;
817 WORD wBufferMode;
818 BYTE byMode;
819 BYTE byBase;
820 double fJogVelocity[32];
821 }MC_MOVE_LINEAR_VEL_IN;
822
826 typedef struct {
827 WORD wStatus;
828 WORD wErrorID;
829 } MC_MOVE_LINEAR_VEL_OUT;
830
835 typedef struct
836 {
837 WORD wStatus;
838 }READ_STATUS;
839
843 typedef struct
844 {
845 WORD wPLCOpenStatus;
846 WORD wMotionStatus;
847 READ_STATUS Status[32];
848 }MC_AXES_READ_STATUS;
849
854 typedef struct
855 {
856 WORD wMotionState;
857 }READ_MOTION_STATE;
858
862 typedef struct
863 {
864 WORD wPLCOpenStatus;
865 WORD wMotionStatus;
866 READ_MOTION_STATE MotionState[32];
867 }MC_AXES_READ_MOTION_STATE;
868
873 typedef struct
874 {
875 DWORD dwAxisInfo;
876 }READ_AXIS_INFO;
877
881 typedef struct
882 {
883 READ_AXIS_INFO AxisInfo[32];
884 }MC_AXES_READ_INFO;
885
890 typedef struct
891 {
892 WORD wErrorID;
893 }READ_ERROR;
894
898 typedef struct
899 {
900 WORD wErrorID;
901 READ_ERROR AxisError[32];
902 }MC_AXES_READ_ERROR;
903
907 typedef struct
908 {
909 WORD wStatus;
910 double fMaxTime;
911 double fActTime;
912 }EC_LOGPOS_STATUS;
913
917 typedef struct
918 {
919 BYTE byFormat;
920 char* pName;
921 char* pPath;
922 }EC_SAVE_LOGPOS;
923
927 typedef struct
928 {
929 double fTime;
937 }EC_START_LOGPOS;
938
939 /* @} */
EC_DELAY_TIMER
[In] MC_SetDelayTimer
Definition: hmecw0_struct.h:492
EC_DELAY_TIMER::lMvHmDelay
long lMvHmDelay
DelayTime: MC_Home [単位] ms [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:496
EC_DELAY_TIMER::lMvVelDelay
long lMvVelDelay
DelayTime: MC_MoveVelocity [単位] ms [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:497
EC_DELAY_TIMER::lMvAbsDelay
long lMvAbsDelay
DelayTime: MC_MoveAbsolute [単位] ms [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:493
EC_DELAY_TIMER::lMvAddDelay
long lMvAddDelay
DelayTime: MC_MoveAdditive [単位] ms [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:494
EC_DELAY_TIMER::lMvRelDelay
long lMvRelDelay
DelayTime: MC_MoveRelative [単位] ms [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:495
EC_DIAGNOSIS_MESSAGE_FLAGS
[In] EC_SetDiagnosisMessageFlags
Definition: hmecw0_struct.h:451
EC_DIAGNOSIS_MESSAGE_FLAGS::bDisableWarnMes
BOOL bDisableWarnMes
WarningMessage無効 [値] FALSE： WarningMessageをDiagnosis messageに保存します TRUE: WarningMessageをDiagnosis ...
Definition: hmecw0_struct.h:454
EC_DIAGNOSIS_MESSAGE_FLAGS::bModeSelect
BOOL bModeSelect
OverWrite/Acknowlededモード選択 [値] FALSE: OverWrite: 未承認データが存在していてもリングバッファに上書きします TRUE: Acknowleded: リ...
Definition: hmecw0_struct.h:456
EC_DIAGNOSIS_MESSAGE_FLAGS::bEnableEmergensy
BOOL bEnableEmergensy
診断メッセージをエマージェンシメッセージとして通知するか [値] FALSE:無効，TRUE:有効
Definition: hmecw0_struct.h:452
EC_DIAGNOSIS_MESSAGE_FLAGS::bDisableErrMes
BOOL bDisableErrMes
ErrorMEssage無効 [値] FALSE: ErrorMessageをDiagnosis messageに保存します TRUE: ErrorMessageをDiagnosis messag...
Definition: hmecw0_struct.h:455
EC_DIAGNOSIS_MESSAGE_FLAGS::bDisableInfMes
BOOL bDisableInfMes
InfoMessage無効 [値] FALSE: InfoMessageをDiagnosis messageに保存します TRUE: InfoMessageをDiagnosis messageに保...
Definition: hmecw0_struct.h:453
EC_DIAGNOSIS_PARAMETER
[Struct] EC_GET_DIAGNOSIS_MESSAGE_OUT
Definition: hmecw0_struct.h:463
EC_DIAGNOSIS_PARAMETER::lInt32Parameter
long lInt32Parameter
診断メッセージのINTEGER32データ
Definition: hmecw0_struct.h:468
EC_DIAGNOSIS_PARAMETER::cInt8Parameter
char cInt8Parameter
診断メッセージのINTEGER8データ
Definition: hmecw0_struct.h:466
EC_DIAGNOSIS_PARAMETER::bUnsigned8Parameter
BYTE bUnsigned8Parameter
診断メッセージのUNSIGNED8データ
Definition: hmecw0_struct.h:469
EC_DIAGNOSIS_PARAMETER::dwUnsigned32Parameter
DWORD dwUnsigned32Parameter
診断メッセージのUNSIGNED32データ
Definition: hmecw0_struct.h:471
EC_DIAGNOSIS_PARAMETER::wFlags
WORD wFlags
診断メッセージのパラメータタイプ [値] <bit12-15=0> 1: BOOL 2: INTEGER8 3: INTEGER16 4: INTEGER32 5: UNSIGNED8 ...
Definition: hmecw0_struct.h:464
EC_DIAGNOSIS_PARAMETER::wUnsigned16Parameter
WORD wUnsigned16Parameter
診断メッセージのUNSIGNED16データ．
Definition: hmecw0_struct.h:470
EC_DIAGNOSIS_PARAMETER::bBoolParameter
BOOL bBoolParameter
診断メッセージのBOOLデータ
Definition: hmecw0_struct.h:465
EC_DIAGNOSIS_PARAMETER::sInt16Parameter
short sInt16Parameter
診断メッセージのINTEGER16データ．
Definition: hmecw0_struct.h:467
EC_GET_DIAGNOSIS_MESSAGE_OUT
[Out] EC_GetDiagnosisMessage
Definition: hmecw0_struct.h:479
EC_GET_DIAGNOSIS_MESSAGE_OUT::dwTimeStampL
DWORD dwTimeStampL
診断メッセージのタイムスタンプ下位データ [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:482
EC_GET_DIAGNOSIS_MESSAGE_OUT::wTextID
WORD wTextID
診断メッセージのテキストID [範囲] 0 - 65535
Definition: hmecw0_struct.h:481
EC_GET_DIAGNOSIS_MESSAGE_OUT::bType
BYTE bType
診断メッセージのデータタイプ [値] 0: InfoMessage 1: WarningMessage 2: ErrorMessage
Definition: hmecw0_struct.h:480
EC_GET_DIAGNOSIS_MESSAGE_OUT::bParameterNum
BYTE bParameterNum
診断メッセージのパラメータ数 [範囲] 0 - 255
Definition: hmecw0_struct.h:484
EC_GET_DIAGNOSIS_MESSAGE_OUT::dwTimeStampH
DWORD dwTimeStampH
診断メッセージのタイムスタンプ上位データ [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:483
EC_GET_SLAVE_INFO_IN
[In] EC_GetSlaveInfo
Definition: hmecw0_struct.h:415
EC_GET_SLAVE_INFO_IN::dwProductCode
DWORD dwProductCode
プロダクトコード [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:418
EC_GET_SLAVE_INFO_IN::dwVendorID
DWORD dwVendorID
ベンダーID [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:417
EC_GET_SLAVE_INFO_IN::dwInstance
DWORD dwInstance
インスタンス番号 [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:416
EC_LOGPOS_STATUS
[In] EC_ReadLogPositionStatus
Definition: hmecw0_struct.h:908
EC_LOGPOS_STATUS::fMaxTime
double fMaxTime
ログ記録最大時間 [単位] ms [範囲] 0 - 84000
Definition: hmecw0_struct.h:910
EC_LOGPOS_STATUS::wStatus
WORD wStatus
ログの記録状態 [範囲] 0: ログが存在しない 1: ログの記録中 2: ログの記録停止中
Definition: hmecw0_struct.h:909
EC_LOGPOS_STATUS::fActTime
double fActTime
記録したログの時間 [単位] ms [範囲] 0 - 84000
Definition: hmecw0_struct.h:911
EC_MASTER_INFO
[In] EC_GetMasterInfom, EC_OpenMaster
Definition: hmecw0_struct.h:399
EC_MASTER_INFO::hMasterHandle
DWORD hMasterHandle
マスターハンドル
Definition: hmecw0_struct.h:409
EC_MASTER_INFO::dwPdoInSize
DWORD dwPdoInSize
PDO_IN全体のサイズ
Definition: hmecw0_struct.h:407
EC_MASTER_INFO::wSlaveCountOnline
WORD wSlaveCountOnline
接続しているスレーブ数
Definition: hmecw0_struct.h:406
EC_MASTER_INFO::dwPdoOutSize
DWORD dwPdoOutSize
PDO_OUT全体のサイズ
Definition: hmecw0_struct.h:408
EC_MASTER_INFO::dwCyclicTime
DWORD dwCyclicTime
サイクリックタイム [単位] μs
Definition: hmecw0_struct.h:401
EC_MASTER_INFO::wSlaveCountXml
WORD wSlaveCountXml
コンフィグレーション(XML)定義上のスレーブ数
Definition: hmecw0_struct.h:405
EC_MASTER_INFO::bBasePrioriy
BYTE bBasePrioriy
EcatHandlerスレッドベースプライオリティ
Definition: hmecw0_struct.h:402
EC_SAVE_LOGPOS
[In] EC_SaveLogPosition
Definition: hmecw0_struct.h:918
EC_SAVE_LOGPOS::pName
char * pName
ファイル名. [未設定(NULL)の場合] ファイル名 "hvt時_分_秒"
Definition: hmecw0_struct.h:920
EC_SAVE_LOGPOS::pPath
char * pPath
ファイルを保存するパス. [未設定(NULL)の場合] exeを実行したパスにファイルが保存されます.
Definition: hmecw0_struct.h:921
EC_SAVE_LOGPOS::byFormat
BYTE byFormat
保存するファイル形式 [範囲] 1以外: txt 1: csv
Definition: hmecw0_struct.h:919
EC_SLAVE_INFO
[In] EC_GetSlaveInfo
Definition: hmecw0_struct.h:424
EC_SLAVE_INFO::bAxisNo
BYTE bAxisNo
軸ノード番号 [範囲] 0 - 255
Definition: hmecw0_struct.h:426
EC_SLAVE_INFO::dwProductCode
DWORD dwProductCode
プロダクトコード [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:434
EC_SLAVE_INFO::wAlias
WORD wAlias
エイリアス番号 [範囲] 0 - 65535
Definition: hmecw0_struct.h:430
EC_SLAVE_INFO::dwViosInBaseOffset
DWORD dwViosInBaseOffset
VIOS IN ベースオフセット [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:440
EC_SLAVE_INFO::dwPhysicalAddr
DWORD dwPhysicalAddr
フィジカルアドレス [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:437
EC_SLAVE_INFO::dwViosOutBaseOffset
DWORD dwViosOutBaseOffset
VIOS OUT ベースオフセット [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:442
EC_SLAVE_INFO::wSlaveType
WORD wSlaveType
スレーブタイプ [範囲] 0 - 65535
Definition: hmecw0_struct.h:431
EC_SLAVE_INFO::dwVendorID
DWORD dwVendorID
ベンダーID [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:433
EC_SLAVE_INFO::dwInstance
DWORD dwInstance
インスタンス番号 [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:432
EC_SLAVE_INFO::dwSerialNo
DWORD dwSerialNo
シリアルナンバー [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:436
EC_SLAVE_INFO::dwAutoIncAddr
DWORD dwAutoIncAddr
自動インクリメントアドレス [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:438
EC_SLAVE_INFO::wSlaveStatus
WORD wSlaveStatus
(予約)
Definition: hmecw0_struct.h:427
EC_SLAVE_INFO::dwViosInSize
DWORD dwViosInSize
VIOS IN サイズ[byte] [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:441
EC_SLAVE_INFO::dwStatusBit
DWORD dwStatusBit
スレーブステータスビット [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:439
EC_SLAVE_INFO::dwRevisionNo
DWORD dwRevisionNo
リビジョンナンバー [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:435
EC_SLAVE_INFO::dwViosOutSize
DWORD dwViosOutSize
VIOS OUT サイズ[byte] [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:443
EC_SLAVE_INFO::bSlaveNo
BYTE bSlaveNo
スレーブノード番号 [範囲] 0 - 255
Definition: hmecw0_struct.h:425
EC_SLAVE_INFO::dwDCEnable
DWORD dwDCEnable
DC設定 [値] 0: 無効 0以外: 有効
Definition: hmecw0_struct.h:444
EC_START_LOGPOS
[In] EC_StartLogPosition
Definition: hmecw0_struct.h:928
EC_START_LOGPOS::fTime
double fTime
Definition: hmecw0_struct.h:929
EC_VERSION
[Out] EC_ReadVersion
Definition: hmecw0_struct.h:503
EC_VERSION::wAxisNum
WORD wAxisNum
契約軸数
Definition: hmecw0_struct.h:504
MC_ACTUAL_POSITION
[In] MC_SetPosition
Definition: hmecw0_struct.h:126
MC_ACTUAL_POSITION::fPosition
double fPosition
現在位置 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:127
MC_ACTUAL_VELOCITY
[Out] MC_ReadActualVelocity
Definition: hmecw0_struct.h:133
MC_ACTUAL_VELOCITY::fVelocity
double fVelocity
現在速度 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:134
MC_AXES_GROUP_REF
[Handle] Group関数全般ハンドル
Definition: hmecw0_struct.h:515
MC_AXES_GROUP_REF::byGroupID
BYTE byGroupID
軸グループの識別番号 [範囲] 1 - 32
Definition: hmecw0_struct.h:516
MC_AXES_GROUP_REF::bySyncAxis
BYTE bySyncAxis
軸グループの軸数 [範囲] 0 - 32
Definition: hmecw0_struct.h:517
MC_AXES_READ_ERROR
[Out] MC_GroupAxesReadError
Definition: hmecw0_struct.h:899
MC_AXES_READ_ERROR::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF..
Definition: hmecw0_struct.h:900
MC_AXES_READ_INFO
[Out] MC_GroupAxesReadInfo
Definition: hmecw0_struct.h:882
MC_AXES_READ_MOTION_STATE
[Out] MC_GroupAxesReadMotionState
Definition: hmecw0_struct.h:863
MC_AXES_READ_MOTION_STATE::wPLCOpenStatus
WORD wPLCOpenStatus
軸グループ状態遷移ステータス [範囲] 0x02: GroupMoving 0x04: GroupHoming 0x08: GroupErrorStop 0x10: GroupStandby ...
Definition: hmecw0_struct.h:864
MC_AXES_READ_MOTION_STATE::wMotionStatus
WORD wMotionStatus
軸グループの動作状態 [値] bit1: 定速中 bit2: 加速中 bit3: 減速中
Definition: hmecw0_struct.h:865
MC_AXES_READ_STATUS
[Out] MC_GroupAxesReadStatus
Definition: hmecw0_struct.h:844
MC_AXES_READ_STATUS::wPLCOpenStatus
WORD wPLCOpenStatus
軸グループ状態遷移ステータス [値] 0x02: GroupMoving 0x04: GroupHoming 0x08: GroupErrorStop 0x10: GroupStandby ...
Definition: hmecw0_struct.h:845
MC_AXES_READ_STATUS::wMotionStatus
WORD wMotionStatus
軸グループの動作状態．
Definition: hmecw0_struct.h:846
MC_AXIS_DRIVE
[Struct] MC_AXIS_SETTING
Definition: hmecw0_struct.h:63
MC_AXIS_DRIVE::bInposEnable
BOOL bInposEnable
(予約)
Definition: hmecw0_struct.h:65
MC_AXIS_DRIVE::bFollowingError
BOOL bFollowingError
位置偏差エラー検出時動作 [値] FALSE: 継続，TRUE: 即時停止．
Definition: hmecw0_struct.h:64
MC_AXIS_DRIVE::bInposInput
BOOL bInposInput
(予約)
Definition: hmecw0_struct.h:66
MC_AXIS_ERROR
[Out] MC_ReadAxisError
Definition: hmecw0_struct.h:118
MC_AXIS_ERROR::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:119
MC_AXIS_FACTOR
[Struct] MC_AXIS_SETTING
Definition: hmecw0_struct.h:20
MC_AXIS_FACTOR::wCountMode
WORD wCountMode
(予約)
Definition: hmecw0_struct.h:25
MC_AXIS_FACTOR::wMotorType
WORD wMotorType
(予約)
Definition: hmecw0_struct.h:23
MC_AXIS_FACTOR::fMinCount
double fMinCount
(予約)
Definition: hmecw0_struct.h:27
MC_AXIS_FACTOR::wAxisType
WORD wAxisType
(予約)
Definition: hmecw0_struct.h:21
MC_AXIS_FACTOR::wActuatorType
WORD wActuatorType
(予約)
Definition: hmecw0_struct.h:22
MC_AXIS_FACTOR::wEncType
WORD wEncType
(予約)
Definition: hmecw0_struct.h:24
MC_AXIS_FACTOR::fMaxCount
double fMaxCount
(予約)
Definition: hmecw0_struct.h:26
MC_AXIS_INFO
[Out] MC_ReadAxisInfo
Definition: hmecw0_struct.h:140
MC_AXIS_INFO::dwAxisInfo
DWORD dwAxisInfo
軸情報 bit0: 軸のエラー有無 [値] 0: 無, 1: 有 bit1: 原点入力信号 [値] 0: OFF, 1: ON bit2: +ELS [値] 0: OFF,...
Definition: hmecw0_struct.h:141
MC_AXIS_MACHINE
[Struct] MC_AXIS_SETTING
Definition: hmecw0_struct.h:72
MC_AXIS_MACHINE::bPosiElsEnable
BOOL bPosiElsEnable
(予約)
Definition: hmecw0_struct.h:73
MC_AXIS_MACHINE::bNegaElsEnable
BOOL bNegaElsEnable
(予約)
Definition: hmecw0_struct.h:74
MC_AXIS_MACHINE::wElsStop
WORD wElsStop
(予約)
Definition: hmecw0_struct.h:76
MC_AXIS_MACHINE::bElsInput
BOOL bElsInput
(予約)
Definition: hmecw0_struct.h:75
MC_AXIS_MOVE
[Struct] MC_AXIS_SETTING
Definition: hmecw0_struct.h:33
MC_AXIS_MOVE::dwPullPR
DWORD dwPullPR
電子ギア設定時の分子 [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:50
MC_AXIS_MOVE::bInposMode
BYTE bInposMode
Definition: hmecw0_struct.h:37
MC_AXIS_MOVE::wPreviousDirection
WORD wPreviousDirection
(予約)
Definition: hmecw0_struct.h:52
MC_AXIS_MOVE::fPosDeviation
double fPosDeviation
(予約)
Definition: hmecw0_struct.h:56
MC_AXIS_MOVE::fPosDevAlarm
double fPosDevAlarm
(予約)
Definition: hmecw0_struct.h:57
MC_AXIS_MOVE::wIncPerMM
WORD wIncPerMM
(予約)
Definition: hmecw0_struct.h:49
MC_AXIS_MOVE::lEncPulse
long lEncPulse
(予約)
Definition: hmecw0_struct.h:48
MC_AXIS_MOVE::fMinSLS
double fMinSLS
(予約)
Definition: hmecw0_struct.h:55
MC_AXIS_MOVE::bDisableWaitMotionInt
BOOL bDisableWaitMotionInt
MC_WaitNextInterruptのイベント取得待機の無効設定 [値] FALSE: イベント取得待機します． [値] TRUE: イベント取得待機しません．このとき、MC_MOVE_FUNC...
Definition: hmecw0_struct.h:35
MC_AXIS_MOVE::dwInposWidth
DWORD dwInposWidth
位置決め完了幅 [単位] pulse [範囲] 0 - 4294967295
Definition: hmecw0_struct.h:36
MC_AXIS_MOVE::dwDisPR
DWORD dwDisPR
電子ギア設定時の分母 [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:51
MC_AXIS_MOVE::fFLvelocity
double fFLvelocity
FL速度 [単位] pps [範囲] 0-2147483647
Definition: hmecw0_struct.h:53
MC_AXIS_MOVE::fMaxSLS
double fMaxSLS
(予約)
Definition: hmecw0_struct.h:54
MC_AXIS_REF
軸情報を格納する構造体
Definition: hmecw0_struct.h:13
MC_AXIS_REF::wAxisNo
WORD wAxisNo
軸番号 [範囲] 0 - 65535
Definition: hmecw0_struct.h:15
MC_AXIS_REF::bSlaveNo
BYTE bSlaveNo
スレーブのノード番号 [範囲] 0 - 255
Definition: hmecw0_struct.h:14
MC_AXIS_SETTING
[Out] MC_GetAxisSetting
Definition: hmecw0_struct.h:83
MC_AXIS_SETTING::AxisFactor
MC_AXIS_FACTOR AxisFactor
軸要素パラメータ
Definition: hmecw0_struct.h:84
MC_AXIS_SETTING::AxisDrive
MC_AXIS_DRIVE AxisDrive
サーボIFパラメータ
Definition: hmecw0_struct.h:86
MC_AXIS_SETTING::AxisMachine
MC_AXIS_MACHINE AxisMachine
マシンIFパラメータ
Definition: hmecw0_struct.h:87
MC_AXIS_SETTING::AxisMove
MC_AXIS_MOVE AxisMove
軸動作パラメータ
Definition: hmecw0_struct.h:85
MC_BUFFER_FUNC
[Struct] MC_READ_BUFFER_OUT
Definition: hmecw0_struct.h:343
MC_BUFFER_FUNC::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:348
MC_BUFFER_FUNC::fVelocity
double fVelocity
最高速度 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:347
MC_BUFFER_FUNC::fPosition
double fPosition
目標位置(MC_MoveAbsolute) [単位] pulse
Definition: hmecw0_struct.h:345
MC_BUFFER_FUNC::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:350
MC_BUFFER_FUNC::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:349
MC_BUFFER_FUNC::bFuncID
BYTE bFuncID
バッファ待機中のAPI識別コード [値] 0x66： MC_MoveRelative 0x65： MC_MoveAbsolute
Definition: hmecw0_struct.h:344
MC_BUFFER_FUNC::fDistance
double fDistance
移動量(MC_MoveRelative) [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:346
MC_GROUP_ADD_AXIS
[In] MC_AddAxisToGroup
Definition: hmecw0_struct.h:525
MC_GROUP_ADD_AXIS::bySeqNo
BYTE bySeqNo
軸追加先の配列番号 [範囲] 0 - 31．
Definition: hmecw0_struct.h:526
MC_GROUP_BUFFER_FUNC
[Struct] MC_GROUP_READ_BUFFER_OUT
Definition: hmecw0_struct.h:786
MC_GROUP_BUFFER_FUNC::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:792
MC_GROUP_BUFFER_FUNC::fVelocity
double fVelocity
速度 [単位] pps [範囲] 1 - 2147483647
Definition: hmecw0_struct.h:791
MC_GROUP_BUFFER_FUNC::wBufferMode
WORD wBufferMode
動作モード [値] 0:Aborting 1:Buffered 2:BlendingLow 3:BlendingPrevious 4:BlendingNext 5:BlendingHigh
Definition: hmecw0_struct.h:787
MC_GROUP_BUFFER_FUNC::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:794
MC_GROUP_BUFFER_FUNC::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:793
MC_GROUP_BUFFER_FUNC::bFuncID
BYTE bFuncID
バッファ待機中の関数の識別コード [値] 0x24：MC_MoveLinearAbsolute 0x25：MC_MoveLinearRelative
Definition: hmecw0_struct.h:788
MC_GROUP_HOME_IN
[In] MC_GroupHome
Definition: hmecw0_struct.h:708
MC_GROUP_HOME_IN::fAcceleration
double fAcceleration
原点復帰加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:711
MC_GROUP_HOME_IN::fVelocity
double fVelocity
原点復帰速度 [単位] pps [範囲] 1 - 2147483647
Definition: hmecw0_struct.h:710
MC_GROUP_HOME_IN::wBufferMode
WORD wBufferMode
(予約)
Definition: hmecw0_struct.h:714
MC_GROUP_HOME_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:713
MC_GROUP_HOME_IN::fDeceleration
double fDeceleration
原点復帰減速度 [単位] pps^2 [範囲] 0-2,251,799,813,685,250
Definition: hmecw0_struct.h:712
MC_GROUP_HOME_OUT
[Out] MC_GroupHome
Definition: hmecw0_struct.h:720
MC_GROUP_HOME_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:721
MC_GROUP_HOME_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:722
MC_GROUP_MOVE_FUNCTION_RESULT
[Out] MC_GroupReadFunctionResult
Definition: hmecw0_struct.h:699
MC_GROUP_MOVE_FUNCTION_RESULT::wStatus
WORD wStatus
ステータス [値] [MC_GROUP_MOVE.bDisableWaitMotionInt = FALSE] 0x01: Done 0x02: Busy 0x03: CommandAbort...
Definition: hmecw0_struct.h:701
MC_GROUP_MOVE_FUNCTION_RESULT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:702
MC_GROUP_MOVE_FUNCTION_RESULT::wFunction
WORD wFunction
動作完了した関数コード [値] 0x0031： MC_GroupReset 0x0032： MC_GroupHome 0x0033： MC_GroupStop 0x0034： MC_MoveL...
Definition: hmecw0_struct.h:700
MC_GROUP_MOVE
[Struct] MC_GROUP_SETTING
Definition: hmecw0_struct.h:553
MC_GROUP_MOVE::fDeviationJerk
double fDeviationJerk
(予約)
Definition: hmecw0_struct.h:561
MC_GROUP_MOVE::byMasterSeqNo
BYTE byMasterSeqNo
ガントリ制御時のマスター軸 [範囲] 0 - 31 (ガントリ制御を行わない場合は常に0)
Definition: hmecw0_struct.h:555
MC_GROUP_MOVE::fPosDeviation
double fPosDeviation
ガントリ制御時の位置偏差の許容値 [単位] pulse [範囲] 0 - 4294967295 (0: 無効)
Definition: hmecw0_struct.h:559
MC_GROUP_MOVE::byDeviationStopMode
BYTE byDeviationStopMode
ガントリ制御時の位置偏差エラー発生時の停止方法 [値] 0:即時停止
Definition: hmecw0_struct.h:558
MC_GROUP_MOVE::bDeviationStopEnable
BOOL bDeviationStopEnable
ガントリ制御時の位置偏差エラー発生時の停止有効/無効 [値] FALSE:無効，TRUE：有効
Definition: hmecw0_struct.h:557
MC_GROUP_MOVE::bDisableWaitMotionInt
BOOL bDisableWaitMotionInt
イベント取得待機のキャンセル無効設定 FALSE: 無効(イベント取得待機します) TRUE: 有効(イベント取得待機しません)
Definition: hmecw0_struct.h:554
MC_GROUP_MOVE::bySlaveSeqNo
BYTE bySlaveSeqNo
ガントリ制御時のスレーブ軸 [範囲] 0 - 31 (ガントリ制御を行わない場合は常に0)
Definition: hmecw0_struct.h:556
MC_GROUP_MOVE::fDeviationDec
double fDeviationDec
(予約)
Definition: hmecw0_struct.h:560
MC_GROUP_READ_ACT_POS_IN
[In] MC_GroupReadActualPosition
Definition: hmecw0_struct.h:585
MC_GROUP_READ_ACT_POS_IN::byCoordSys
BYTE byCoordSys
(予約)
Definition: hmecw0_struct.h:586
MC_GROUP_READ_ACT_POS_OUT
[In] MC_GroupReadActualPosition
Definition: hmecw0_struct.h:592
MC_GROUP_READ_ACT_VEL_IN
[In] MC_GroupReadActualVelocity
Definition: hmecw0_struct.h:599
MC_GROUP_READ_ACT_VEL_IN::byCoordSys
BYTE byCoordSys
(予約)
Definition: hmecw0_struct.h:600
MC_GROUP_READ_ACT_VEL_OUT
[Out] MC_GroupReadActualVelocity
Definition: hmecw0_struct.h:606
MC_GROUP_READ_ACT_VEL_OUT::fPathVelocity
double fPathVelocity
移動方向の現在速度 [単位] pps [範囲] -2147483648 - 2147483647
Definition: hmecw0_struct.h:607
MC_GROUP_READ_BUFFER_OUT
[Out] MC_GroupReadBuffer
Definition: hmecw0_struct.h:800
MC_GROUP_READ_BUFFER_OUT::bBufferNum
BYTE bBufferNum
バッファ待機中のAPI個数 [範囲] 0-1
Definition: hmecw0_struct.h:801
MC_GROUP_READ_BUFFER_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:802
MC_GROUP_READ_CONFIG_IN
[In] MC_GroupReadConfiguration
Definition: hmecw0_struct.h:539
MC_GROUP_READ_CONFIG_IN::bySeqNo
BYTE bySeqNo
軸グループ内の読込む軸配列番号
Definition: hmecw0_struct.h:540
MC_GROUP_READ_CONFIG_OUT
[Out] MC_GroupReadConfiguration
Definition: hmecw0_struct.h:546
MC_GROUP_READ_CONFIG_OUT::stAxis
MC_AXIS_REF stAxis
軸の情報
Definition: hmecw0_struct.h:547
MC_GROUP_READ_ERROR
[Out] MC_GroupReadError
Definition: hmecw0_struct.h:622
MC_GROUP_READ_ERROR::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:623
MC_GROUP_READ_PATH_DATA_OUT
[Out] MC_GroupReadPathData
Definition: hmecw0_struct.h:681
MC_GROUP_READ_PATH_DATA_OUT::PathRef
MC_PATH_DATA_REF PathRef
パスデータを格納する構造体
Definition: hmecw0_struct.h:684
MC_GROUP_READ_PATH_DATA_OUT::dwSize
DWORD dwSize
パスデータ数 [範囲] 0-10000
Definition: hmecw0_struct.h:682
MC_GROUP_READ_PATH_DATA_OUT::dwRun
DWORD dwRun
実行中のパスデータ番号 [範囲] 0-10000
Definition: hmecw0_struct.h:683
MC_GROUP_READ_STATUS
[Out] MC_GroupReadStatus
Definition: hmecw0_struct.h:614
MC_GROUP_READ_STATUS::wPLCOpenStatus
WORD wPLCOpenStatus
軸グループのステータス. [値] 0x02： GroupMoving 0x04： GroupHoming 0x08： GroupErrorStop 0x10： GroupStandby 0x...
Definition: hmecw0_struct.h:615
MC_GROUP_READ_STATUS::wMotionStatus
WORD wMotionStatus
軸グループの動作状態． [値] bit1: 定速中 bit2: 加速中 bit3: 減速中
Definition: hmecw0_struct.h:616
MC_GROUP_REMOVE_AXIS
[In] MC_RemoveAxisFromGroup
Definition: hmecw0_struct.h:532
MC_GROUP_REMOVE_AXIS::bySeqNo
BYTE bySeqNo
軸グループ内の削除する軸配列番号
Definition: hmecw0_struct.h:533
MC_GROUP_RESET_OUT
[Out] MC_GroupReset
Definition: hmecw0_struct.h:629
MC_GROUP_RESET_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:630
MC_GROUP_RESET_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:631
MC_GROUP_SET_OVERRIDE_IN
[Out] MC_GroupReadPathData
Definition: hmecw0_struct.h:690
MC_GROUP_SET_OVERRIDE_IN::fVelFactor
double fVelFactor
速度の係数 [範囲] 0.0 - 1.0
Definition: hmecw0_struct.h:691
MC_GROUP_SET_OVERRIDE_IN::fJerkFactor
double fJerkFactor
(予約)
Definition: hmecw0_struct.h:693
MC_GROUP_SET_OVERRIDE_IN::fAccFactor
double fAccFactor
(予約)
Definition: hmecw0_struct.h:692
MC_GROUP_SET_POSITION
[In] MC_GroupSetPosition
Definition: hmecw0_struct.h:575
MC_GROUP_SET_POSITION::byCoordSys
BYTE byCoordSys
(予約)
Definition: hmecw0_struct.h:578
MC_GROUP_SET_POSITION::bPositionInp
BOOL bPositionInp
(予約)
Definition: hmecw0_struct.h:577
MC_GROUP_SET_POSITION::wBufferMode
WORD wBufferMode
(予約)
Definition: hmecw0_struct.h:579
MC_GROUP_SETTING
[In] MC_SetGroupSetting
Definition: hmecw0_struct.h:568
MC_GROUP_SETTING::GroupMove
MC_GROUP_MOVE GroupMove
軸グループの動作パラメータ
Definition: hmecw0_struct.h:569
MC_GROUP_STOP_IN
[In] MC_GroupStop
Definition: hmecw0_struct.h:728
MC_GROUP_STOP_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting
Definition: hmecw0_struct.h:731
MC_GROUP_STOP_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:730
MC_GROUP_STOP_IN::fDeceleration
double fDeceleration
原点復帰加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:729
MC_GROUP_STOP_OUT
[Out] MC_GroupStop
Definition: hmecw0_struct.h:737
MC_GROUP_STOP_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:738
MC_GROUP_STOP_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:739
MC_HOME_IN
[In] MC_Home
Definition: hmecw0_struct.h:205
MC_HOME_IN::fAcceleration
double fAcceleration
原点復帰加速度: エンコーダ [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:212
MC_HOME_IN::fSpeed2
double fSpeed2
原点入力サーチ速度: CiA402による原点復帰 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:209
MC_HOME_IN::fSpeed1
double fSpeed1
原点近傍入力サーチ速度: CiA402による原点復帰 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:208
MC_HOME_IN::fVelocity
double fVelocity
原点復帰速度: エンコーダ [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:211
MC_HOME_IN::fPosition
double fPosition
原点位置: エンコーダ [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:210
MC_HOME_IN::byHomingMethod
BYTE byHomingMethod
CiA402による原点復帰方法 [範囲] 0 - 65535
Definition: hmecw0_struct.h:207
MC_HOME_IN::bSyncMotion
BOOL bSyncMotion
(予約)
Definition: hmecw0_struct.h:222
MC_HOME_IN::wBufferMode
WORD wBufferMode
(予約)
Definition: hmecw0_struct.h:221
MC_HOME_IN::fJerk
double fJerk
ジャーク: エンコーダ [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:214
MC_HOME_IN::wHomePosiDir
WORD wHomePosiDir
(予約)
Definition: hmecw0_struct.h:216
MC_HOME_IN::wHomePosiInpDir
WORD wHomePosiInpDir
(予約)
Definition: hmecw0_struct.h:217
MC_HOME_IN::dwHomePushWait
DWORD dwHomePushWait
(予約)
Definition: hmecw0_struct.h:220
MC_HOME_IN::wHomePosiInpType
WORD wHomePosiInpType
(予約)
Definition: hmecw0_struct.h:215
MC_HOME_IN::fHomePosiOffset
double fHomePosiOffset
(予約)
Definition: hmecw0_struct.h:219
MC_HOME_IN::fDeceleration
double fDeceleration
原点復帰減速度: エンコーダ [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:213
MC_HOME_IN::fHomeMaskDis
double fHomeMaskDis
(予約)
Definition: hmecw0_struct.h:218
MC_HOME_IN::bEncoder
BOOL bEncoder
エンコーダ [値] FALSE: CiA402による原点復帰方式, TRUE: エンコーダによる原点復帰方式
Definition: hmecw0_struct.h:206
MC_HOME_OUT
[Out] MC_Home
Definition: hmecw0_struct.h:228
MC_HOME_OUT::wStatus
WORD wStatus
ステータス [値] 0x02: Busy 0x04: Error
Definition: hmecw0_struct.h:229
MC_HOME_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:230
MC_LATCH_COUNT_REF
[In] MC_ReadLatchCountResult
Definition: hmecw0_struct.h:392
MC_LATCH_COUNT_REF::byLatchCountRef
BYTE byLatchCountRef
ラッチ位置を取得するプローブID [値] 1: Probe1 2: Probe2 3: Probe1，Probe2
Definition: hmecw0_struct.h:393
MC_LATCH_COUNT_RESULT
[Out] MC_ReadLatchCountResult
Definition: hmecw0_struct.h:365
MC_LATCH_COUNT_RESULT::wProbe1Status
WORD wProbe1Status
Probe1のステータス [範囲] 0x01: Done 0x02: Busy 0x03: CommandAborted 0x04: Error
Definition: hmecw0_struct.h:368
MC_LATCH_COUNT_RESULT::wProbe1ErrorID
WORD wProbe1ErrorID
Probe1のエラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:369
MC_LATCH_COUNT_RESULT::byLatchCountRef
BYTE byLatchCountRef
ラッチ位置を取得するプローブID [値] 1: Probe1 2: Probe2 3: Probe1，Probe2
Definition: hmecw0_struct.h:366
MC_LATCH_COUNT_RESULT::fProbe2RecPosition
double fProbe2RecPosition
Probe2のラッチ位置 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:374
MC_LATCH_COUNT_RESULT::wProbe2Status
WORD wProbe2Status
Probe2のステータス [値] 0x01: Done 0x02: Busy 0x03: CommandAborted 0x04: Error
Definition: hmecw0_struct.h:372
MC_LATCH_COUNT_RESULT::fProbe1RecPosition
double fProbe1RecPosition
Probe1のラッチ位置 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:370
MC_LATCH_COUNT_RESULT::wProbe2ErrorID
WORD wProbe2ErrorID
Probe2のエラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:373
MC_LATCH_COUNT_RESULT::bProbe1Stored
BOOL bProbe1Stored
Probe1のラッチ位置保存状態 [値] FALSE: 非保存 TRUE: 保存
Definition: hmecw0_struct.h:367
MC_LATCH_COUNT_RESULT::bProbe2Stored
BOOL bProbe2Stored
Probe2のラッチ位置保存状態 [値] FALSE: 非保存 TRUE: 保存
Definition: hmecw0_struct.h:371
MC_MOTION_STATE
[Out] MC_ReadMotionState
Definition: hmecw0_struct.h:147
MC_MOTION_STATE::wMotionState
WORD wMotionState
モーションステータス bit1: 定速中 bit2: 加速中 bit3: 減速中 bit4: ＋方向動作中 bit5: ?方向動作中
Definition: hmecw0_struct.h:148
MC_MOVE_ABSOLUTE_IN
[In] MC_MoveAbsolute
Definition: hmecw0_struct.h:252
MC_MOVE_ABSOLUTE_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:255
MC_MOVE_ABSOLUTE_IN::wDirection
WORD wDirection
(予約)
Definition: hmecw0_struct.h:258
MC_MOVE_ABSOLUTE_IN::fVelocity
double fVelocity
最高速度 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:254
MC_MOVE_ABSOLUTE_IN::fPosition
double fPosition
目標位置 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:253
MC_MOVE_ABSOLUTE_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting 1: Buffered 2: BlendingLow 3: BlendingPrevious 4: BlendingNext 5: Blendi...
Definition: hmecw0_struct.h:259
MC_MOVE_ABSOLUTE_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:257
MC_MOVE_ABSOLUTE_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:256
MC_MOVE_ABSOLUTE_OUT
[Out] MC_MoveAbsolute
Definition: hmecw0_struct.h:265
MC_MOVE_ABSOLUTE_OUT::wStatus
WORD wStatus
ステータス [値] 0x02: Busy 0x04: Error
Definition: hmecw0_struct.h:266
MC_MOVE_ABSOLUTE_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:267
MC_MOVE_ADDITIVE_IN
[In] MC_MoveAdditive
Definition: hmecw0_struct.h:293
MC_MOVE_ADDITIVE_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:296
MC_MOVE_ADDITIVE_IN::fVelocity
double fVelocity
最高速度 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:295
MC_MOVE_ADDITIVE_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting
Definition: hmecw0_struct.h:299
MC_MOVE_ADDITIVE_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0-2,251,799,813,685,250
Definition: hmecw0_struct.h:298
MC_MOVE_ADDITIVE_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:297
MC_MOVE_ADDITIVE_IN::fDistance
double fDistance
移動距離 [単位] pulse [範囲] -2147483647-2147483648
Definition: hmecw0_struct.h:294
MC_MOVE_ADDITIVE_OUT
[Out] MC_MoveAdditive
Definition: hmecw0_struct.h:305
MC_MOVE_ADDITIVE_OUT::wStatus
WORD wStatus
ステータス [値] 0x02: Busy 0x04: Error
Definition: hmecw0_struct.h:306
MC_MOVE_ADDITIVE_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:307
MC_MOVE_FUNCTION_RESULT
[Out] MC_ReadFunctionResult
Definition: hmecw0_struct.h:333
MC_MOVE_FUNCTION_RESULT::wStatus
WORD wStatus
完了したAPIステータス [値] [MC_AXIS_MOVE.bDisableWaitMotionInt = FALSE] 0x01: Done 0x02: Busy 0x03: Comman...
Definition: hmecw0_struct.h:335
MC_MOVE_FUNCTION_RESULT::wErrorID
WORD wErrorID
完了したAPIエラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:336
MC_MOVE_FUNCTION_RESULT::wFunction
WORD wFunction
完了したAPI [値] 0x21： MC_Reset 0x22： MC_Home 0x23： MC_Stop 0x24： MC_MoveAbsolute 0x25： MC_MoveRelat...
Definition: hmecw0_struct.h:334
MC_MOVE_LINEAR_ABS_IN
[In] MC_MoveLinearAbsolute
Definition: hmecw0_struct.h:745
MC_MOVE_LINEAR_ABS_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:748
MC_MOVE_LINEAR_ABS_IN::fVelocity
double fVelocity
速度 [単位] pps [範囲] 1 - 2147483647
Definition: hmecw0_struct.h:747
MC_MOVE_LINEAR_ABS_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0:Aborting 1:Buffered 2:BlendingLow 3:BlendingPrevious 4:BlendingNext 5:BlendingHigh
Definition: hmecw0_struct.h:751
MC_MOVE_LINEAR_ABS_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:750
MC_MOVE_LINEAR_ABS_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:749
MC_MOVE_LINEAR_ABS_OUT
[Out] MC_MoveLinearAbsolute
Definition: hmecw0_struct.h:757
MC_MOVE_LINEAR_ABS_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:758
MC_MOVE_LINEAR_ABS_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:759
MC_MOVE_LINEAR_REL_IN
[In] MC_MoveLinearRelative
Definition: hmecw0_struct.h:765
MC_MOVE_LINEAR_REL_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:768
MC_MOVE_LINEAR_REL_IN::fVelocity
double fVelocity
速度 [単位] pps [範囲] 1 - 2147483647
Definition: hmecw0_struct.h:767
MC_MOVE_LINEAR_REL_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting 1: Buffered 2: BlendingLow 3: BlendingPrevious 4: BlendingNext 5: Blendi...
Definition: hmecw0_struct.h:771
MC_MOVE_LINEAR_REL_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:770
MC_MOVE_LINEAR_REL_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:769
MC_MOVE_LINEAR_REL_OUT
[In] MC_MoveLinearRelative
Definition: hmecw0_struct.h:777
MC_MOVE_LINEAR_REL_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:778
MC_MOVE_LINEAR_REL_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:779
MC_MOVE_LINEAR_VEL_IN
[In] MC_MoveLinearVelocity
Definition: hmecw0_struct.h:810
MC_MOVE_LINEAR_VEL_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:813
MC_MOVE_LINEAR_VEL_IN::wDirection
WORD wDirection
回転方向 [範囲] 0:負方向, 1:正方向
Definition: hmecw0_struct.h:816
MC_MOVE_LINEAR_VEL_IN::fVelocity
double fVelocity
速度 [単位] pps [範囲] 1 - 2147483647
Definition: hmecw0_struct.h:812
MC_MOVE_LINEAR_VEL_IN::byBase
BYTE byBase
[byMode = 1時に設定] 加速度"fAcceleration",減速度"fDeceleration",ジャーク"fJerk"を適用する軸設定 [範囲] 0 - 31
Definition: hmecw0_struct.h:819
MC_MOVE_LINEAR_VEL_IN::wBufferMode
WORD wBufferMode
(予約)
Definition: hmecw0_struct.h:817
MC_MOVE_LINEAR_VEL_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:815
MC_MOVE_LINEAR_VEL_IN::byMode
BYTE byMode
速度の設定モード [値] 1以外: 全軸で fVelocity の値を使用します。 1:各軸で fJogVelosity[32] の値を使用します。
Definition: hmecw0_struct.h:818
MC_MOVE_LINEAR_VEL_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:814
MC_MOVE_LINEAR_VEL_OUT
[Out] MC_MoveLinearVelocity
Definition: hmecw0_struct.h:826
MC_MOVE_LINEAR_VEL_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:827
MC_MOVE_LINEAR_VEL_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:828
MC_MOVE_PATH_IN
[In] MC_MovePath
Definition: hmecw0_struct.h:655
MC_MOVE_PATH_IN::pName
char * pName
ファイルのパス (txt, csv, xml) [例] pName = “C：\PathData.csv”
Definition: hmecw0_struct.h:665
MC_MOVE_PATH_IN::fVelFactor
double fVelFactor
(予約)
Definition: hmecw0_struct.h:661
MC_MOVE_PATH_IN::fMaxCornerDeviation
double fMaxCornerDeviation
(予約)
Definition: hmecw0_struct.h:663
MC_MOVE_PATH_IN::fCornerDistance
double fCornerDistance
(予約)
Definition: hmecw0_struct.h:662
MC_MOVE_PATH_IN::dwSize
DWORD dwSize
パスデータ数 [範囲] 0 - 10000
Definition: hmecw0_struct.h:657
MC_MOVE_PATH_IN::byTransitionMode
BYTE byTransitionMode
(予約)
Definition: hmecw0_struct.h:660
MC_MOVE_PATH_IN::wBufferMode
WORD wBufferMode
(予約)
Definition: hmecw0_struct.h:659
MC_MOVE_PATH_IN::byInpMode
BYTE byInpMode
パスデータ生成モード [値] 0: MC_PATH_DATA_REFで設定 1: txt,csvファイルで設定
Definition: hmecw0_struct.h:656
MC_MOVE_PATH_IN::byCoordSystem
BYTE byCoordSystem
Definition: hmecw0_struct.h:658
MC_MOVE_PATH_OUT
[Out] MC_MovePath
Definition: hmecw0_struct.h:671
MC_MOVE_PATH_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:672
MC_MOVE_PATH_OUT::dwErrLine
DWORD dwErrLine
エラーが発生したパスデータ番号 [範囲] 0 - 10000
Definition: hmecw0_struct.h:675
MC_MOVE_PATH_OUT::dwSize
DWORD dwSize
パスデータ数 [範囲] 0-10000
Definition: hmecw0_struct.h:673
MC_MOVE_PATH_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:674
MC_MOVE_RELATIVE_IN
[In] MC_MoveRelative
Definition: hmecw0_struct.h:273
MC_MOVE_RELATIVE_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:276
MC_MOVE_RELATIVE_IN::fVelocity
double fVelocity
最高速度 [単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:275
MC_MOVE_RELATIVE_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting 1: Buffered 2: BlendingLow 3: BlendingPrevious 4: BlendingNext 5: Blendi...
Definition: hmecw0_struct.h:279
MC_MOVE_RELATIVE_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:278
MC_MOVE_RELATIVE_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:277
MC_MOVE_RELATIVE_IN::fDistance
double fDistance
移動距離 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:274
MC_MOVE_RELATIVE_OUT
[Out] MC_MoveRelative
Definition: hmecw0_struct.h:285
MC_MOVE_RELATIVE_OUT::wStatus
WORD wStatus
ステータス [値] 0x02: Busy 0x04: Error
Definition: hmecw0_struct.h:286
MC_MOVE_RELATIVE_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:287
MC_MOVE_VELOCITY_IN
[In] MC_MoveVelocitiy
Definition: hmecw0_struct.h:313
MC_MOVE_VELOCITY_IN::fAcceleration
double fAcceleration
加速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:315
MC_MOVE_VELOCITY_IN::wDirection
WORD wDirection
回転方向 [値] 0: mcNegativeDirection(負方向) 1: mcPositiveDirection(正方向)
Definition: hmecw0_struct.h:318
MC_MOVE_VELOCITY_IN::fVelocity
double fVelocity
最高速度 単位] pps [範囲] 0 - 2147483647
Definition: hmecw0_struct.h:314
MC_MOVE_VELOCITY_IN::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting，1: Buffered
Definition: hmecw0_struct.h:319
MC_MOVE_VELOCITY_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:317
MC_MOVE_VELOCITY_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:316
MC_MOVE_VELOCITY_OUT
[Out] MC_MoveVelocitiy
Definition: hmecw0_struct.h:325
MC_MOVE_VELOCITY_OUT::wStatus
WORD wStatus
ステータス [値] 0x02: Busy 0x04: Error
Definition: hmecw0_struct.h:326
MC_MOVE_VELOCITY_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:327
MC_PATH_DATA_REF
[Struct] MC_GROUP_READ_PATH_DATA_OUT
Definition: hmecw0_struct.h:638
MC_PATH_DATA_REF::fAcceleration
double fAcceleration
Acceleration [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:641
MC_PATH_DATA_REF::fVelFactor
double fVelFactor
(予約)
Definition: hmecw0_struct.h:647
MC_PATH_DATA_REF::fVelocity
double fVelocity
Velocity [単位] pps [範囲] 1 - 2147483647
Definition: hmecw0_struct.h:640
MC_PATH_DATA_REF::byMtnCmd
BYTE byMtnCmd
パスの動作設定 [値] 0： 相対位置決め動作 1： 絶対位置決め動作 2： 原点復帰による位置決め動作
Definition: hmecw0_struct.h:646
MC_PATH_DATA_REF::fMaxCornerDeviation
double fMaxCornerDeviation
(予約)
Definition: hmecw0_struct.h:649
MC_PATH_DATA_REF::fCornerDistance
double fCornerDistance
(予約)
Definition: hmecw0_struct.h:648
MC_PATH_DATA_REF::byTransitionMode
BYTE byTransitionMode
(予約)
Definition: hmecw0_struct.h:645
MC_PATH_DATA_REF::wBufferMode
WORD wBufferMode
動作モード [値] 0: Aborting 1: Buffered 2: BlendingLow 3: BlendingPrevious 4: BlendingNext 5: Blendi...
Definition: hmecw0_struct.h:644
MC_PATH_DATA_REF::fJerk
double fJerk
Jerk 単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:643
MC_PATH_DATA_REF::fDeceleration
double fDeceleration
Deceleration [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:642
MC_POWER_IN
[Out] MC_GetAxisSetting, MC_SetAxisSetting
Definition: hmecw0_struct.h:93
MC_POWER_IN::bEnable
BOOL bEnable
電源制御 [値] FALSE: サーボOFF，TRUE: サーボON．
Definition: hmecw0_struct.h:94
MC_POWER_IN::bEnableNegative
BOOL bEnableNegative
負方向運転有効設定 [値] FALSE: 無効，TRUE: 有効
Definition: hmecw0_struct.h:96
MC_POWER_IN::bEnablePositive
BOOL bEnablePositive
正方向運転有効設定 [値] FALSE: 無効，TRUE: 有効
Definition: hmecw0_struct.h:95
MC_POWER_OUT
[Out] MC_GetAxisSetting, MC_SetAxisSetting
Definition: hmecw0_struct.h:102
MC_POWER_OUT::bError
BOOL bError
エラー [値] FALSE: 正常，TRUE: エラー
Definition: hmecw0_struct.h:104
MC_POWER_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:105
MC_POWER_OUT::bStatus
BOOL bStatus
サーボ状態 [値] FALSE: サーボOFF，TRUE: サーボON
Definition: hmecw0_struct.h:103
MC_PROBE_STATUS
[Out] MC_ReadProbeStatus
Definition: hmecw0_struct.h:381
MC_PROBE_STATUS::woProbe1ErrorID
WORD woProbe1ErrorID
Probe1のエラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:383
MC_PROBE_STATUS::woProbe2Status
WORD woProbe2Status
Probe2のステータス [値] 0x01: Done 0x02: Busy 0x03: CommandAborted 0x04: Error
Definition: hmecw0_struct.h:384
MC_PROBE_STATUS::woProbe2ErrorID
WORD woProbe2ErrorID
Probe2のエラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:385
MC_PROBE_STATUS::woProbe1Status
WORD woProbe1Status
Probe1のステータス [値] 0x01: Done 0x02: Busy 0x03: CommandAborted 0x04: Error
Definition: hmecw0_struct.h:382
MC_READ_BUFFER_OUT
[Out] MC_ReadBuffer
Definition: hmecw0_struct.h:356
MC_READ_BUFFER_OUT::bBufferNum
BYTE bBufferNum
バッファ待機中の関数の個数 [範囲] 0 - 1
Definition: hmecw0_struct.h:357
MC_READ_BUFFER_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:358
MC_RESET_OUT
[Out] MC_Reset
Definition: hmecw0_struct.h:197
MC_RESET_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:198
MC_RESET_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:199
MC_SET_OVERRIDE_IN
[In] MC_SetOverride
Definition: hmecw0_struct.h:154
MC_SET_OVERRIDE_IN::fVelFactor
double fVelFactor
速度の係数 [範囲] 0.0 - 1.0
Definition: hmecw0_struct.h:155
MC_SET_OVERRIDE_IN::fJerkFactor
double fJerkFactor
(予約)
Definition: hmecw0_struct.h:157
MC_SET_OVERRIDE_IN::fAccFactor
double fAccFactor
(予約)
Definition: hmecw0_struct.h:156
MC_STATUS
[Out] MC_ReadStatus
Definition: hmecw0_struct.h:111
MC_STATUS::wStatus
WORD wStatus
状態遷移のステータス [範囲] 0x00: 未定義 0x02: ErrorStop 0x04: Disabled 0x08: Stopping 0x10: Homing 0x20: Sta...
Definition: hmecw0_struct.h:112
MC_STOP_IN
[In] MC_Stop
Definition: hmecw0_struct.h:236
MC_STOP_IN::fJerk
double fJerk
ジャーク [単位] pps^3 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:238
MC_STOP_IN::fDeceleration
double fDeceleration
減速度 [単位] pps^2 [範囲] 0 - 2,251,799,813,685,250
Definition: hmecw0_struct.h:237
MC_STOP_OUT
[Out] MC_Stop
Definition: hmecw0_struct.h:244
MC_STOP_OUT::wStatus
WORD wStatus
ステータス [値] 0x02: Busy 0x04: Error
Definition: hmecw0_struct.h:245
MC_STOP_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:246
MC_TOUCH_PROBE_IN
[In] MC_TouchProbe
Definition: hmecw0_struct.h:177
MC_TOUCH_PROBE_IN::wPositionSelect
WORD wPositionSelect
(予約)
Definition: hmecw0_struct.h:182
MC_TOUCH_PROBE_IN::bWindowOnly
BOOL bWindowOnly
モニタリング範囲設定 [値] FALSE:無効，TRUE:有効
Definition: hmecw0_struct.h:179
MC_TOUCH_PROBE_IN::TriggerInput
MC_TRIGGER_REF TriggerInput
タッチプローブ要素
Definition: hmecw0_struct.h:178
MC_TOUCH_PROBE_IN::fFirstPosition
double fFirstPosition
モニタリング範囲開始位置 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:180
MC_TOUCH_PROBE_IN::fLastPosition
double fLastPosition
モニタリング範囲終了位置 [単位] pulse [範囲] -2147483647 - 2147483648
Definition: hmecw0_struct.h:181
MC_TOUCH_PROBE_IN::wStopMotionSelect
WORD wStopMotionSelect
(予約)
Definition: hmecw0_struct.h:183
MC_TOUCH_PROBE_OUT
[In] MC_TouchProbe
Definition: hmecw0_struct.h:189
MC_TOUCH_PROBE_OUT::wStatus
WORD wStatus
ステータス [値] 0x02:Busy 0x04:Error
Definition: hmecw0_struct.h:190
MC_TOUCH_PROBE_OUT::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF
Definition: hmecw0_struct.h:191
MC_TRIGGER_REF
[Struct] MC_TOUCH_PROBE_IN
Definition: hmecw0_struct.h:164
MC_TRIGGER_REF::wProbeID
WORD wProbeID
プローブID [値] 1: プローブ 1，2: プローブ2
Definition: hmecw0_struct.h:165
MC_TRIGGER_REF::byTriggerMode
BYTE byTriggerMode
(予約)
Definition: hmecw0_struct.h:167
MC_TRIGGER_REF::byEncoderID
BYTE byEncoderID
(予約)
Definition: hmecw0_struct.h:169
MC_TRIGGER_REF::byTriggerVariable
BYTE byTriggerVariable
(予約)
Definition: hmecw0_struct.h:170
MC_TRIGGER_REF::bEdge
BOOL bEdge
値を1に設定してください [値] 1:立ち上がりエッジを使用
Definition: hmecw0_struct.h:166
MC_TRIGGER_REF::byProbeState
BYTE byProbeState
(予約)
Definition: hmecw0_struct.h:171
MC_TRIGGER_REF::byInputSelect
BYTE byInputSelect
トリガの選択 ご使用のサーボドライバをご確認下さい．
Definition: hmecw0_struct.h:168
READ_AXIS_INFO
[Struct] MC_AXES_READ_INFO
Definition: hmecw0_struct.h:874
READ_AXIS_INFO::dwAxisInfo
DWORD dwAxisInfo
軸情報 bit1: 原点入力信号 [値] 0: OFF, 1: ON bit2: +ELS [値] 0: OFF, 1: ON bit3: -ELS [値] 0:OFF,...
Definition: hmecw0_struct.h:875
READ_ERROR
[Struct] MC_AXES_READ_ERROR
Definition: hmecw0_struct.h:891
READ_ERROR::wErrorID
WORD wErrorID
エラーID [範囲] 0-0xFFFF.
Definition: hmecw0_struct.h:892
READ_MOTION_STATE
[Struct] MC_AXES_READ_MOTION_STATE
Definition: hmecw0_struct.h:855
READ_MOTION_STATE::wMotionState
WORD wMotionState
モーションステータス [値] bit1: 定速中 bit2: 加速中 bit3: 減速中 bit4: +方向動作中 bit5: -方向動作中
Definition: hmecw0_struct.h:856
READ_STATUS
[Struct] MC_AXES_READ_STATUS
Definition: hmecw0_struct.h:836
READ_STATUS::wStatus
WORD wStatus
状態遷移ステータス [値] 0x02: ErrorStop 0x04: Disabled 0x08: Stopping 0x10: Homing 0x20: StandStill 0x40...
Definition: hmecw0_struct.h:837


HLS-ECAT02WIN APIリファレンス: hmecw0_func.h ファイル

hmecw0_func.h ファイル

関数

モーション制御用API
DWORD | MC_Power (DWORD, MC_AXIS_REF *, MC_POWER_IN *, MC_POWER_OUT *, WORD)
電源制御 [詳解]
DWORD | MC_ReadStatus (DWORD, MC_AXIS_REF *, MC_STATUS *, WORD)
状態遷移のステータス読み込み [詳解]
DWORD | MC_ResetAxisSetting (DWORD, MC_AXIS_REF *, WORD)
軸設定の初期化 [詳解]
DWORD | MC_GetAxisSetting (DWORD, MC_AXIS_REF *, MC_AXIS_SETTING *, WORD)
軸設定の取得 [詳解]
DWORD | MC_SetAxisSetting (DWORD, MC_AXIS_REF *, MC_AXIS_SETTING *, WORD)
軸設定の設定 [詳解]
DWORD | MC_ReadAxisError (DWORD, MC_AXIS_REF *, MC_AXIS_ERROR *, WORD)
軸エラー読み込み [詳解]
DWORD | MC_ReadActualPosition (DWORD, MC_AXIS_REF *, MC_ACTUAL_POSITION *, WORD)
現在位置読み込み [詳解]
DWORD | MC_ReadActualVelocity (DWORD, MC_AXIS_REF *, MC_ACTUAL_VELOCITY *, WORD)
現在速度読み込み [詳解]
DWORD | MC_ReadAxisInfo (DWORD, MC_AXIS_REF *, MC_AXIS_INFO *, WORD)
軸情報読み込み [詳解]
DWORD | MC_ReadMotionState (DWORD, MC_AXIS_REF *, MC_MOTION_STATE *, WORD)
モーションステータス読み込み [詳解]
DWORD | MC_SetPosition (DWORD, MC_AXIS_REF *, MC_ACTUAL_POSITION *, WORD)
現在位置設定 [詳解]
DWORD | MC_SetOverride (DWORD, MC_AXIS_REF *, MC_SET_OVERRIDE_IN *, WORD)
速度のオーバーライドファクタ設定 [詳解]
DWORD | MC_TouchProbe (DWORD, MC_AXIS_REF *, MC_TOUCH_PROBE_IN *, MC_TOUCH_PROBE_OUT *, WORD)
トリガーイベントによる現在位置読み込み [詳解]
DWORD | MC_AbortTrigger (DWORD, MC_AXIS_REF *, MC_TRIGGER_REF *, WORD)
トリガーイベントによる現在位置読み込み中止 [詳解]
DWORD | MC_Reset (DWORD, MC_AXIS_REF *, MC_RESET_OUT *, WORD)
軸異常解除 [詳解]
DWORD | MC_ReadProbeStatus (DWORD, MC_AXIS_REF *, MC_PROBE_STATUS *, WORD)
タッチプローブの状態読み込み [詳解]
DWORD | MC_ReadBuffer (DWORD, MC_AXIS_REF *, MC_READ_BUFFER_OUT *, WORD)
バッファ待機中の関数の情報を読み込み [詳解]
DWORD | MC_DeleteBuffer (DWORD, MC_AXIS_REF *, WORD)
バッファ待機中の関数を削除 [詳解]
DWORD | MC_ReadLatchCountResult (DWORD, MC_AXIS_REF *, MC_LATCH_COUNT_REF *, MC_LATCH_COUNT_RESULT *, WORD)
指定したタッチプローブの状態を読み込みます [詳解]
DWORD | MC_WaitNextLatchCountInterrupt (DWORD, MC_AXIS_REF *, MC_LATCH_COUNT_REF *, DWORD, WORD)
タッチプローブの実行完了待機 [詳解]
DWORD | MC_CancelWaitLatchCountInterrupt (DWORD, MC_AXIS_REF *, WORD)
タッチプローブの実行完了待機キャンセル [詳解]
DWORD | MC_ResetLatchSts (DWORD, MC_AXIS_REF *, WORD)
ラッチ完了後の変数値を格納している内部メモリを0クリアします [詳解]
DWORD | MC_SetDelayTimer (DWORD, MC_AXIS_REF *, EC_DELAY_TIMER *, WORD)
位置決め動作の遅延時間の設定 [詳解]
DWORD | MC_ReadDelayTimer (DWORD, MC_AXIS_REF *, EC_DELAY_TIMER *, WORD)
位置決め動作の遅延時間を読み込み [詳解]
DWORD | MC_Home (DWORD, MC_AXIS_REF *, MC_HOME_IN *, MC_HOME_OUT *, WORD)
原点復帰 [詳解]
DWORD | MC_Stop (DWORD, MC_AXIS_REF *, MC_STOP_IN *, MC_STOP_OUT *, WORD)
減速停止 [詳解]
DWORD | MC_MoveAbsolute (DWORD, MC_AXIS_REF *, MC_MOVE_ABSOLUTE_IN *, MC_MOVE_ABSOLUTE_OUT *, WORD)
絶対位置決め [詳解]
DWORD | MC_MoveRelative (DWORD, MC_AXIS_REF *, MC_MOVE_RELATIVE_IN *, MC_MOVE_RELATIVE_OUT *, WORD)
相対位置決め [詳解]
DWORD | MC_MoveAdditive (DWORD, MC_AXIS_REF *, MC_MOVE_ADDITIVE_IN *, MC_MOVE_ADDITIVE_OUT *, WORD)
位置決め相対位置付加 [詳解]
DWORD | MC_MoveVelocity (DWORD, MC_AXIS_REF *, MC_MOVE_VELOCITY_IN *, MC_MOVE_VELOCITY_OUT *, WORD)
指定速度連続送り [詳解]
DWORD | MC_WaitNextInterrupt (DWORD, MC_AXIS_REF *, DWORD, WORD)
動作指令の実行結果を通知する割り込みが発生するまで待機します。 [詳解]
DWORD | MC_ReadFunctionResult (DWORD, MC_AXIS_REF *, MC_MOVE_FUNCTION_RESULT *, WORD)
動作指令の出力変数読出し [詳解]
DWORD | MC_CancelWaitInterrupt (DWORD, MC_AXIS_REF *, WORD)
割り込み待機キャンセル [詳解]
DWORD | MC_ResetMotionSts (DWORD, MC_AXIS_REF *, WORD)
関数動作完了後の変数値を格納している内部メモリを 0 クリアします． [詳解]
DWORD | MC_SetIntSignalInfo (DWORD, MC_AXIS_REF *, DWORD, WORD)
動作指令の実行結果を通知する割り込みに関係する設定 [詳解]
DWORD | MC_GetIntSignalInfo (DWORD, MC_AXIS_REF *, DWORD *, WORD)
動作指令の実行結果を通知する割り込みに関係する設定の取得 [詳解]
DWORD | MC_SetLatchCountIntSignalInfo (DWORD, MC_AXIS_REF *, DWORD, WORD)
タッチプローブの実行結果を通知する割り込みに関係する設定 [詳解]
DWORD | MC_GetLatchCountIntSignalInfo (DWORD, MC_AXIS_REF *, DWORD *, WORD)
タッチプローブの実行結果を通知する割り込みイベントに関係する設定の取得 [詳解]
DWORD | MC_AddAxisToGroup (DWORD, MC_AXES_GROUP_REF *, MC_AXIS_REF *, MC_GROUP_ADD_AXIS *, WORD)
軸を軸グループに追加 [詳解]
DWORD | MC_RemoveAxisFromGroup (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_REMOVE_AXIS *, WORD)
指定の軸を軸グループから削除 [詳解]
DWORD | MC_UngroupAllAxes (DWORD, MC_AXES_GROUP_REF *, WORD)
全ての軸を軸グループから削除 [詳解]
DWORD | MC_GroupReadConfiguration (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_CONFIG_IN *, MC_GROUP_READ_CONFIG_OUT *, WORD)
軸グループに追加された軸の情報の読込み [詳解]
DWORD | MC_GroupEnable (DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの状態遷移のステータスをGroupStandby に変更 [詳解]
DWORD | MC_GroupDisable (DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの状態遷移のステータスを GroupDisabled に変更 [詳解]
DWORD | MC_ResetGroupSetting (DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループのパラメータの設定を初期化 [詳解]
DWORD | MC_SetGroupSetting (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SETTING *, WORD)
軸グループのパラメータの設定 [詳解]
DWORD | MC_GetGroupSetting (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SETTING *, WORD)
軸グループのパラメータの取得 [詳解]
DWORD | MC_GroupSetPosition (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SET_POSITION *, WORD)
軸グループの軸の位置を設定 [詳解]
DWORD | MC_GroupReadActualPosition (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_ACT_POS_IN *, MC_GROUP_READ_ACT_POS_OUT *, WORD)
軸グループの現在位置の読込み [詳解]
DWORD | MC_GroupReadActualVelocity (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_ACT_VEL_IN *, MC_GROUP_READ_ACT_VEL_OUT *, WORD)
軸グループの現在速度の読込み [詳解]
DWORD | MC_GroupReadStatus (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_STATUS *, WORD)
軸グループの状態遷移のステータス，モーションステータスの読込み [詳解]
DWORD | MC_GroupReadError (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_ERROR *, WORD)
軸グループのエラーの読込み [詳解]
DWORD | MC_GroupReset (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_RESET_OUT *, WORD)
軸グループのエラーをリセット [詳解]
DWORD | MC_GroupAxesReadMotionState (DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_MOTION_STATE *, WORD)
軸グループに追加された軸のモーションステータスの読込み [詳解]
DWORD | MC_GroupAxesReadStatus (DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_STATUS *, WORD)
軸グループに追加された軸のステータスの読込みます [詳解]
DWORD | MC_GroupAxesReadInfo (DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_INFO *, WORD)
軸グループに追加された軸の軸情報の読込み [詳解]
DWORD | MC_GroupAxesReadError (DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_ERROR *, WORD)
軸グループに追加された軸のエラーコードの読込み [詳解]
DWORD | MC_GroupSetOverride (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SET_OVERRIDE_IN *, WORD)
軸グループにおける速度のオーバーライドファクタ設定 [詳解]
DWORD | MC_GroupReadPathData (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_PATH_DATA_OUT *, WORD)
MC_MovePath関数により実行中のパスデータの読み込み [詳解]
DWORD | MC_GroupWaitNextInterrupt (DWORD, MC_AXES_GROUP_REF *, DWORD, WORD)
軸グループの動作指令の実行結果を通知する割り込みが発生するまで待機します。 [詳解]
DWORD | MC_GroupReadFunctionResult (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_MOVE_FUNCTION_RESULT *, WORD)
軸グループの動作指令の実行結果の読込み [詳解]
DWORD | MC_GroupCancelWaitInterrupt (DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの動作指令の実行結果を通知する割り込み待機をキャンセル [詳解]
DWORD | MC_GroupResetMotionSts (DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの動作指令の実行結果を格納している内部メモリを0クリア [詳解]
DWORD | MC_GroupHome (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_HOME_IN *, MC_GROUP_HOME_OUT *, WORD)
軸グループの原点復帰 [詳解]
DWORD | MC_GroupStop (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_STOP_IN *, MC_GROUP_STOP_OUT *, WORD)
軸グループの停止動作 [詳解]
DWORD | MC_MoveLinearAbsolute (DWORD, MC_AXES_GROUP_REF *, MC_MOVE_LINEAR_ABS_IN *, MC_MOVE_LINEAR_ABS_OUT *, WORD)
絶対移動量における直線補間動作 [詳解]
DWORD | MC_MoveLinearRelative (DWORD, MC_AXES_GROUP_REF *, MC_MOVE_LINEAR_REL_IN *, MC_MOVE_LINEAR_REL_OUT *, WORD)
相対移動量における直線補間動作 [詳解]
DWORD | MC_MoveLinearVelocity (DWORD, MC_AXES_GROUP_REF *, MC_MOVE_LINEAR_VEL_IN *, MC_MOVE_LINEAR_VEL_OUT *, WORD)
軸グループに追加された軸の連続動作 [詳解]
DWORD | MC_MovePath (DWORD, MC_AXES_GROUP_REF *, MC_PATH_DATA_REF *, MC_MOVE_PATH_IN *, MC_MOVE_PATH_OUT *, WORD)
指定のパスデータを使用して，動作の連続実行 [詳解]
DWORD | MC_GroupReadBuffer (DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_BUFFER_OUT *, WORD)
軸グループのバッファ待機中の関数の情報を読込み [詳解]
DWORD | MC_GroupDeleteBuffer (DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループのバッファ待機中の関数の削除 [詳解]
DWORD | MC_SetGroupIntSignalInfo (DWORD, MC_AXES_GROUP_REF *, DWORD, WORD)
軸グループの動作指令の実行結果を通知する割り込みに関係する設定 [詳解]
DWORD | MC_GetGroupIntSignalInfo (DWORD, MC_AXES_GROUP_REF *, DWORD *, WORD)
軸グループの動作指令の実行結果を通知する割り込みに関係する設定の取得 [詳解]
IO制御用API
DWORD | IO_inp (DWORD, BYTE, DWORD, BYTE *, WORD)
データ8ビット読込み [詳解]
DWORD | IO_inpw (DWORD, BYTE, DWORD, WORD *, WORD)
データ16ビット読込み [詳解]
DWORD | IO_inpdw (DWORD, BYTE, DWORD, DWORD *, WORD)
データ32ビット読込み [詳解]
DWORD | IO_outp (DWORD, BYTE, DWORD, BYTE, WORD)
データ8ビット書き込み [詳解]
DWORD | IO_outpw (DWORD, BYTE, DWORD, WORD, WORD)
データ16ビット書き込み [詳解]
DWORD | IO_outpdw (DWORD, BYTE, DWORD, DWORD, WORD)
データ32ビット書き込み [詳解]
DWORD | IO_Groupinp (DWORD, MC_AXES_GROUP_REF *, DWORD, BYTE[], WORD)
軸グループに追加された軸のPDOデータ8ビットの読込み [詳解]
DWORD | IO_Groupinpw (DWORD, MC_AXES_GROUP_REF *, DWORD, WORD[], WORD)
軸グループに追加された軸のPDOデータ16ビットの読込み [詳解]
DWORD | IO_Groupinpdw (DWORD, MC_AXES_GROUP_REF *, DWORD, DWORD[], WORD)
軸グループに追加された軸のPDOデータ32ビットの読込み [詳解]
DWORD | IO_Groupoutp (DWORD, MC_AXES_GROUP_REF *, DWORD, BYTE[], WORD)
軸グループに追加された軸のPDOデータ8ビットの書き込み [詳解]
DWORD | IO_Groupoutpw (DWORD, MC_AXES_GROUP_REF *, DWORD, WORD[], WORD)
軸グループに追加された軸のPDOデータ16ビットの書き込み [詳解]
DWORD | IO_Groupoutpdw (DWORD, MC_AXES_GROUP_REF *, DWORD, DWORD[], WORD)
軸グループに追加された軸のPDOデータ32ビットの書き込み [詳解]
EtherCAT通信制御用API
DWORD | EC_GetMasterInfo (EC_MASTER_INFO *, WORD)
マスタ情報取得 [詳解]
DWORD | EC_OpenMaster (DWORD *, EC_MASTER_INFO *, WORD)
マスタオープン( EtherCAT通信の開始 ) [詳解]
DWORD | EC_CloseMaster (DWORD, WORD)
マスタクローズ( EtherCAT通信の停止 ) [詳解]
DWORD | EC_GetSlaveInfo (DWORD, EC_GET_SLAVE_INFO_IN *, EC_SLAVE_INFO *, WORD)
スレーブ情報取得 [詳解]
DWORD | EC_GetDiagnosisMessage (DWORD, BYTE, EC_GET_DIAGNOSIS_MESSAGE_OUT *, WORD)
スレーブの診断メッセージ取得 [詳解]
DWORD | EC_GetDiagnosisMessageFlags (DWORD, BYTE, EC_DIAGNOSIS_MESSAGE_FLAGS *, WORD)
スレーブの診断メッセージフラグ取得 [詳解]
DWORD | EC_SetDiagnosisMessageFlags (DWORD, BYTE, EC_DIAGNOSIS_MESSAGE_FLAGS *, WORD)
スレーブの診断メッセージ設定 [詳解]
DWORD | EC_ResetDiagnosisMessage (DWORD, BYTE, WORD)
スレーブの診断メッセージクリア [詳解]
DWORD | EC_ReadVersion (EC_VERSION *, WORD)
モーション機能パックライブラリのバージョンと契約軸数取得 [詳解]
DWORD | EC_ReadSDO (DWORD, BYTE, DWORD, DWORD, BYTE, BYTE[], WORD)
SDOデータ読込み [詳解]
DWORD | EC_WriteSDO (DWORD, BYTE, DWORD, DWORD, BYTE, BYTE[], WORD)
SDOデータ書き込み [詳解]
DWORD | EC_StartLogPosition (DWORD, EC_START_LOGPOS *, WORD)
ログ(指令・現在位置)の記録を開始 [詳解]
DWORD | EC_StopLogPosition (DWORD, WORD)
ログ(指令・現在位置)の記録を停止 [詳解]
DWORD | EC_SaveLogPosition (DWORD, EC_SAVE_LOGPOS *, WORD)
ログ(指令・現在位置)をファイルに保存 [詳解]
DWORD | EC_ReadLogPositionStatus (DWORD, EC_LOGPOS_STATUS *, WORD)
ログ(指令・現在位置)の記録状態の読込み [詳解]
DWORD | EC_ClearLogPositionMemory (DWORD, WORD)
ログ(指令・現在位置)を格納するINtimeメモリ削除 [詳解]

関数詳解

◆ MC_Power()

DWORD WINAPI MC_Power | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_POWER_IN * | ,
 |  | MC_POWER_OUT * | ,
 |  | WORD |
 | ) |  |

電源制御

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_POWER_IN*) | 入力情報を格納する構造体のポインタ
(MC_POWER_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の電源を制御(On 又は Off)します

動作中の軸にサーボオフを実行した場合
1. FB動作ステータスが CommandAborted になる。
2. サーボオフになる。

実行完了時間に関して
APIを実行して終了までには一定の時間を要します。処理時間はサーボドライバに起因します。

◆ MC_ReadStatus()

DWORD WINAPI MC_ReadStatus | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_STATUS * | ,
 |  | WORD |
 | ) |  |

状態遷移のステータス読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_STATUS*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸のステートマシンのステータスを読込みます

◆ MC_ResetAxisSetting()

DWORD WINAPI MC_ResetAxisSetting | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | WORD |
 | ) |  |

軸設定の初期化

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の軸設定を初期化します

下記パラメータを初期化します。

[MC_AXIS_MOVE]
dwInposWidth
bInposMode
bDisableWaitMotionInt
dwPullPR
dwDisPR
fFLvelocity

[MC_AXIS_DRIVE]
bFollowingError

◆ MC_GetAxisSetting()

DWORD WINAPI MC_GetAxisSetting | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_AXIS_SETTING * | ,
 |  | WORD |
 | ) |  |

軸設定の取得

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_AXIS_SETTING*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の軸設定を読み込みます

下記パラメータを読み込みます。

[MC_AXIS_MOVE]
dwInposWidth
bInposMode
bDisableWaitMotionInt
dwPullPR
dwDisPR
fFLvelocity

[MC_AXIS_DRIVE]
bFollowingError

◆ MC_SetAxisSetting()

DWORD WINAPI MC_SetAxisSetting | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_AXIS_SETTING * | ,
 |  | WORD |
 | ) |  |

軸設定の設定

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_AXIS_SETTING*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の軸設定を書き込みます

下記パラメータを設定します．

[MC_AXIS_MOVE]
dwInposWidth
bInposMode
bDisableWaitMotionInt
dwPullPR
dwDisPR
fFLvelocity

[MC_AXIS_DRIVE]
bFollowingError

◆ MC_ReadAxisError()

DWORD WINAPI MC_ReadAxisError | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_AXIS_ERROR * | ,
 |  | WORD |
 | ) |  |

軸エラー読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_AXIS_ERROR*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の軸エラーを読み込みます

◆ MC_ReadActualPosition()

DWORD WINAPI MC_ReadActualPosition | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_ACTUAL_POSITION * | ,
 |  | WORD |
 | ) |  |

現在位置読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_ACTUAL_POSITION*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の現在位置を読み込みます

PDOマッピングのPosition actual valueを読み込みます

◆ MC_ReadActualVelocity()

DWORD WINAPI MC_ReadActualVelocity | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_ACTUAL_VELOCITY * | ,
 |  | WORD |
 | ) |  |

現在速度読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_ACTUAL_VELOCITY*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の現在速度を読み込みます

PDOマッピングのVelocity actual valueを読み込みます

◆ MC_ReadAxisInfo()

DWORD WINAPI MC_ReadAxisInfo | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_AXIS_INFO * | ,
 |  | WORD |
 | ) |  |

軸情報読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_AXIS_INFO*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の軸情報を読み込みます

◆ MC_ReadMotionState()

DWORD WINAPI MC_ReadMotionState | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_MOTION_STATE * | ,
 |  | WORD |
 | ) |  |

モーションステータス読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_MOTION_STATE*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸のモーションステータスを読み込みます

◆ MC_SetPosition()

DWORD WINAPI MC_SetPosition | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_ACTUAL_POSITION * | ,
 |  | WORD |
 | ) |  |

現在位置設定

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_ACTUAL_POSITION*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の現在位置を任意の値に設定します

◆ MC_SetOverride()

DWORD WINAPI MC_SetOverride | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_SET_OVERRIDE_IN * | ,
 |  | WORD |
 | ) |  |

速度のオーバーライドファクタ設定

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_SET_OVERRIDE_IN*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の速度のオーバーライドファクタを設定します

軸の速度倍率を変更します．
直線加減速動作中に速度変更した場合、直線で速度が変化します。

S字曲線動作中に速度変更場合、S字曲線で速度が変化します

オーバーライド時の速度変化
オーバーライドが実行できない場合

◆ MC_TouchProbe()

DWORD WINAPI MC_TouchProbe | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_TOUCH_PROBE_IN * | ,
 |  | MC_TOUCH_PROBE_OUT * | ,
 |  | WORD |
 | ) |  |

トリガーイベントによる現在位置読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_TOUCH_PROBE_IN*) | 入力情報を格納する構造体のポインタ
(MC_TOUCH_PROBE_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸のトリガーイベントにより現在位置をラッチします

◆ MC_AbortTrigger()

DWORD WINAPI MC_AbortTrigger | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_TRIGGER_REF * | ,
 |  | WORD |
 | ) |  |

トリガーイベントによる現在位置読み込み中止

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_TRIGGER_REF*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸のトリガーイベントにより現在位置のラッチを解除して中断します．

◆ MC_Reset()

DWORD WINAPI MC_Reset | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_RESET_OUT * | ,
 |  | WORD |
 | ) |  |

軸異常解除

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_TRIGGER_REF*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸に関するすべての内部エラーをリセットします

◆ MC_ReadProbeStatus()

DWORD WINAPI MC_ReadProbeStatus | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_PROBE_STATUS * | ,
 |  | WORD |
 | ) |  |

タッチプローブの状態読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_PROBE_STATUS*) | タッチプローブの状態を格納する構造体
(WORD) | 値: 0
戻り値
エラーコード

指定したタッチプローブの状態を読み込みます

◆ MC_ReadBuffer()

DWORD WINAPI MC_ReadBuffer | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_READ_BUFFER_OUT * | ,
 |  | WORD |
 | ) |  |

バッファ待機中の関数の情報を読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_READ_BUFFER_OUT*) | バッファ待機中の関数の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

バッファモード機能よりバッファ中の情報を読み込みます

◆ MC_DeleteBuffer()

DWORD WINAPI MC_DeleteBuffer | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | WORD |
 | ) |  |

バッファ待機中の関数を削除

引数
(DWORD) | マスタハンドル
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

バッファ待機中の関数を削除します．削除された関数は実行されません．

◆ MC_ReadLatchCountResult()

DWORD WINAPI MC_ReadLatchCountResult | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_LATCH_COUNT_REF * | ,
 |  | MC_LATCH_COUNT_RESULT * | ,
 |  | WORD |
 | ) |  |

指定したタッチプローブの状態を読み込みます

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_LATCH_COUNT_REF*) | タッチプローブ機能によるラッチの条件を格納する構造体のポインタ
(MC_LATCH_COUNT_RESULT*) | ラッチした位置を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定したタッチプローブの状態を読み込みます

MC_TouchProbeが実行完了結果を読み込む関数です．

◆ MC_WaitNextLatchCountInterrupt()

DWORD WINAPI MC_WaitNextLatchCountInterrupt | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_LATCH_COUNT_REF * | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

タッチプローブの実行完了待機

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_LATCH_COUNT_REF*) | タッチプローブ機能によるラッチの条件を格納する構造体のポインタ
(DWORD) | (予約)タイムアウト時間(ms)
(WORD) | 値: 0
戻り値
エラーコード

タッチプローブの実行完了を待機します

MC_TouchProbe完了時のステータス通知イベントを取得します

◆ MC_CancelWaitLatchCountInterrupt()

DWORD WINAPI MC_CancelWaitLatchCountInterrupt | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | WORD |
 | ) |  |

タッチプローブの実行完了待機キャンセル

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

タッチプローブの実行完了の待機状態をキャンセルします

MC_WaitNextLatchCountInterruptの待機状態をキャンセルします

◆ MC_ResetLatchSts()

DWORD WINAPI MC_ResetLatchSts | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | WORD |
 | ) |  |

ラッチ完了後の変数値を格納している内部メモリを0クリアします

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

タッチプローブの実行結果を格納している内部メモリを0クリアします

MC_LATCH_COUNT_RESULT構造体を0クリアします．

◆ MC_SetDelayTimer()

DWORD WINAPI MC_SetDelayTimer | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | EC_DELAY_TIMER * | ,
 |  | WORD |
 | ) |  |

位置決め動作の遅延時間の設定

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(EC_DELAY_TIMER*) | 遅延時間の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

位置決め動作における動作開始までの遅延時間を設定します

位置決め動作開始の遅延時間を設定します．
設定した遅延時間を経過後に動作を開始します．

◆ MC_ReadDelayTimer()

DWORD WINAPI MC_ReadDelayTimer | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | EC_DELAY_TIMER * | ,
 |  | WORD |
 | ) |  |

位置決め動作の遅延時間を読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(EC_DELAY_TIMER*) | 遅延時間の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

位置決め動作における動作開始までの遅延時間を読み込みます

設定した遅延時間を読み込みます

◆ MC_Home()

DWORD WINAPI MC_Home | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_HOME_IN * | ,
 |  | MC_HOME_OUT * | ,
 |  | WORD |
 | ) |  |

原点復帰

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_HOME_IN*) | 入力情報を格納する構造体のポインタ
(MC_HOME_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸の原点復帰を行います

[CiA402による原点復帰方式の場合]
原点近傍入力検索速度及び原点入力検索速度による原点復帰を行います

[エンコーダによる原点復帰の場合]
速度，加速度，減速度，ジャークの設定値で目標位置まで原点復帰を行います

◆ MC_Stop()

DWORD WINAPI MC_Stop | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_STOP_IN * | ,
 |  | MC_STOP_OUT * | ,
 |  | WORD |
 | ) |  |

減速停止

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_STOP_IN*) | 入力情報を格納する構造体のポインタ
(MC_STOP_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸を減速停止します

停止後に軸ステータスが StandStill に遷移します．
減速停止中は軸ステータスが Stopping に遷移します

減速停止中は指定した軸を他の動作指令で動作させることはできません

MC_Stopに設定した減速度と現在動作中APIの減速度を比較し，値が大きい方を使用して減速停止します

◆ MC_MoveAbsolute()

DWORD WINAPI MC_MoveAbsolute | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_MOVE_ABSOLUTE_IN * | ,
 |  | MC_MOVE_ABSOLUTE_OUT * | ,
 |  | WORD |
 | ) |  |

絶対位置決め

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_MOVE_ABSOLUTE_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_ABSOLUTE_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸を指定した絶対位置へ移動します

[最高速度に到達する前に目標距離に到達する場合]
加速を止め減速します．

設定値によっては減速し終わる前に移動終了する可能性があります．

[MC_SetPositionで現在位置を設定した場合]
絶対位置の基準は設定後の値になります

◆ MC_MoveRelative()

DWORD WINAPI MC_MoveRelative | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_MOVE_RELATIVE_IN * | ,
 |  | MC_MOVE_RELATIVE_OUT * | ,
 |  | WORD |
 | ) |  |

相対位置決め

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_MOVE_RELATIVE_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_RELATIVE_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸を移動します。指定した距離を移動すると停止します。

移動距離を厳守するため、最高速度に到達する前に減速開始する可能性があります。

設定値によっては減速し終わる前に終了する可能性があります。

◆ MC_MoveAdditive()

DWORD WINAPI MC_MoveAdditive | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_MOVE_ADDITIVE_IN * | ,
 |  | MC_MOVE_ADDITIVE_OUT * | ,
 |  | WORD |
 | ) |  |

位置決め相対位置付加

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_MOVE_ADDITIVE_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_ADDITIVE_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸を指定した相対距離を付加して移動します。

移動距離を厳守するため、最高速度に到達する前に減速開始する可能性があります。

設定値によっては減速し終わる前に終了する可能性があります。

◆ MC_MoveVelocity()

DWORD WINAPI MC_MoveVelocity | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_MOVE_VELOCITY_IN * | ,
 |  | MC_MOVE_VELOCITY_OUT * | ,
 |  | WORD |
 | ) |  |

指定速度連続送り

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_MOVE_VELOCITY_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_VELOCITY_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定した軸を指定した速度で連続送りします @detailes MC_SetOverrideで実行中に速度を変更できます。

◆ MC_WaitNextInterrupt()

DWORD WINAPI MC_WaitNextInterrupt | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

動作指令の実行結果を通知する割り込みが発生するまで待機します。

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(DWORD) | 待機時間
(WORD) | 値: 0
戻り値
エラーコード

下記関数の実行完了時に実行結果を通知する割り込みが発生します。
MC_Reset
MC_Stop
MC_MoveAbsolute
MC_MoveRelative
MC_MoveAdditive
MC_MoveVelocity
MC_Home

待機状態のキャンセルにはMC_CancelWaitInterruptを使用します。

◆ MC_ReadFunctionResult()

DWORD WINAPI MC_ReadFunctionResult | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_MOVE_FUNCTION_RESULT * | ,
 |  | WORD |
 | ) |  |

動作指令の出力変数読出し

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_MOVE_FUNCTION_RESULT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

完了したAPIの情報を MC_MOVE_FUNCTION_RESULT 構造体に読みだします。

下記関数の実行完了時に実行結果を読み込みます。
MC_Reset
MC_Stop
MC_MoveAbsolute
MC_MoveRelative
MC_MoveAdditive
MC_MoveVelocity
MC_Home

◆ MC_CancelWaitInterrupt()

DWORD WINAPI MC_CancelWaitInterrupt | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | WORD |
 | ) |  |

割り込み待機キャンセル

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

割り込み待機をキャンセルします

MC_WaitNextInterruptをキャンセルします．

◆ MC_ResetMotionSts()

DWORD WINAPI MC_ResetMotionSts | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | WORD |
 | ) |  |

関数動作完了後の変数値を格納している内部メモリを 0 クリアします．

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

動作の出力変数を格納している内部メモリを 0 クリアします．

MC_ MOVE_FUNCTION_RESULT構造体を 0 クリアします

◆ MC_SetIntSignalInfo()

DWORD WINAPI MC_SetIntSignalInfo | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

動作指令の実行結果を通知する割り込みに関係する設定

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(DWORD) | 設定値
(WORD) | 値: 0
戻り値
エラーコード

MC_CancelWaitInterruptによって待機中断されたときのMC_WaitNextInterruptの戻り値の設定をします

設定値 0：戻り値 0
設定値 1：戻り値 0ｘ000020

◆ MC_GetIntSignalInfo()

DWORD WINAPI MC_GetIntSignalInfo | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | DWORD * | ,
 |  | WORD |
 | ) |  |

動作指令の実行結果を通知する割り込みに関係する設定の取得

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(DWORD) | 設定値
(WORD) | 値: 0
戻り値
エラーコード

MC_SetIntSignalInfo関数を実行して設定した値を読み込みます．

◆ MC_SetLatchCountIntSignalInfo()

DWORD WINAPI MC_SetLatchCountIntSignalInfo | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

タッチプローブの実行結果を通知する割り込みに関係する設定

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(DWORD) | 設定値
(WORD) | 値: 0
戻り値
エラーコード

MC_CancelWaitLatchCountInterruptによって待機中断されたときのMC_WaitNextInterruptの戻り値の設定をします

設定値 0：戻り値 0
設定値 1：戻り値 0ｘ000020

◆ MC_GetLatchCountIntSignalInfo()

DWORD WINAPI MC_GetLatchCountIntSignalInfo | ( | DWORD | ,
 |  | MC_AXIS_REF * | ,
 |  | DWORD * | ,
 |  | WORD |
 | ) |  |

タッチプローブの実行結果を通知する割り込みイベントに関係する設定の取得

引数
(DWORD) | マスタハンドル.
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(DWORD) | 設定値
(WORD) | 値: 0
戻り値
エラーコード

MC_SetLatchCountIntSignalInfo関数を実行して設定した値の読み込みを行います．

◆ MC_AddAxisToGroup()

DWORD WINAPI MC_AddAxisToGroup | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_AXIS_REF * | ,
 |  | MC_GROUP_ADD_AXIS * | ,
 |  | WORD |
 | ) |  |

軸を軸グループに追加

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_AXIS_REF*) | 軸の情報を格納する構造体のポインタ
(MC_GROUP_ADD_AXIS*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸を軸グループに追加します

◆ MC_RemoveAxisFromGroup()

DWORD WINAPI MC_RemoveAxisFromGroup | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_REMOVE_AXIS * | ,
 |  | WORD |
 | ) |  |

指定の軸を軸グループから削除

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_REMOVE_AXIS*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定の軸を軸グループから取り除きます．

◆ MC_UngroupAllAxes()

DWORD WINAPI MC_UngroupAllAxes | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

全ての軸を軸グループから削除

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

全軸を軸グループから取り除きます．

◆ MC_GroupReadConfiguration()

DWORD WINAPI MC_GroupReadConfiguration | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_CONFIG_IN * | ,
 |  | MC_GROUP_READ_CONFIG_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループに追加された軸の情報の読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_CONFIG_IN*) | 入力情報を格納する構造体のポインタ
(MC_GROUP_READ_CONFIG_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸の情報を読み込みます．

◆ MC_GroupEnable()

DWORD WINAPI MC_GroupEnable | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

軸グループの状態遷移のステータスをGroupStandby に変更

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの状態遷移のステータスをGroupStandby に変更します．

サーボオン状態で実行してください。サーボオフの軸が存在する場合，戻り値にエラーが返却されます．

◆ MC_GroupDisable()

DWORD WINAPI MC_GroupDisable | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

軸グループの状態遷移のステータスを GroupDisabled に変更

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの状態遷移のステータスを GroupDisabled に変更します．

◆ MC_ResetGroupSetting()

DWORD WINAPI MC_ResetGroupSetting | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

軸グループのパラメータの設定を初期化

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのパラメータの設定を初期化します

MC_AXES_GROUP_REFを初期値します

◆ MC_SetGroupSetting()

DWORD WINAPI MC_SetGroupSetting | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_SETTING * | ,
 |  | WORD |
 | ) |  |

軸グループのパラメータの設定

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_SETTING*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのパラメータの設定を行います

下記パラメータを設定します．

[MC_GROUP_MOVE]
bDisableWaitMotionInt
byMasterSeqNo
bySlaveSeqNo
bDeviationStopEnable
byDeviationStopMode
fPosDeviation

◆ MC_GetGroupSetting()

DWORD WINAPI MC_GetGroupSetting | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_SETTING * | ,
 |  | WORD |
 | ) |  |

軸グループのパラメータの取得

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_SETTING*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのパラメータを取得します

下記パラメータを取得します

[MC_GROUP_MOVE]
bDisableWaitMotionInt
byMasterSeqNo
bySlaveSeqNo
bDeviationStopEnable
byDeviationStopMode
fPosDeviation

◆ MC_GroupSetPosition()

DWORD WINAPI MC_GroupSetPosition | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_SET_POSITION * | ,
 |  | WORD |
 | ) |  |

軸グループの軸の位置を設定

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_SET_POSITION*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの軸の位置を設定します

◆ MC_GroupReadActualPosition()

DWORD WINAPI MC_GroupReadActualPosition | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_ACT_POS_IN * | ,
 |  | MC_GROUP_READ_ACT_POS_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループの現在位置の読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_ACT_POS_IN*) | 入力情報を格納する構造体のポインタ
(MC_GROUP_READ_ACT_POS_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加した軸の現在位置を読み込みます

◆ MC_GroupReadActualVelocity()

DWORD WINAPI MC_GroupReadActualVelocity | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_ACT_VEL_IN * | ,
 |  | MC_GROUP_READ_ACT_VEL_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループの現在速度の読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_ACT_VEL_IN*) | 入力情報を格納する構造体のポインタ
(MC_GROUP_READ_ACT_VEL_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加した軸の現在速度を読み込みます．

◆ MC_GroupReadStatus()

DWORD WINAPI MC_GroupReadStatus | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_STATUS * | ,
 |  | WORD |
 | ) |  |

軸グループの状態遷移のステータス，モーションステータスの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_STATUS*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの状態遷移のステータス，モーションステータスを読み込みます

◆ MC_GroupReadError()

DWORD WINAPI MC_GroupReadError | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_ERROR * | ,
 |  | WORD |
 | ) |  |

軸グループのエラーの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_ERROR*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのエラーを読み込みます

◆ MC_GroupReset()

DWORD WINAPI MC_GroupReset | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_RESET_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループのエラーをリセット

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_RESET_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのエラーをリセットします

[GroupErrorStopになる前がサーボオフであった場合]
軸グループのステータスは，GroupDisabledに遷移します

◆ MC_GroupAxesReadMotionState()

DWORD WINAPI MC_GroupAxesReadMotionState | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_AXES_READ_MOTION_STATE * | ,
 |  | WORD |
 | ) |  |

軸グループに追加された軸のモーションステータスの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_AXES_READ_MOTION_STATE*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のモーションステータスを読込みます．

◆ MC_GroupAxesReadStatus()

DWORD WINAPI MC_GroupAxesReadStatus | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_AXES_READ_STATUS * | ,
 |  | WORD |
 | ) |  |

軸グループに追加された軸のステータスの読込みます

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_AXES_READ_STATUS*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のステータスを読込みます

◆ MC_GroupAxesReadInfo()

DWORD WINAPI MC_GroupAxesReadInfo | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_AXES_READ_INFO * | ,
 |  | WORD |
 | ) |  |

軸グループに追加された軸の軸情報の読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_AXES_READ_INFO*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸の軸情報を読込みます．

◆ MC_GroupAxesReadError()

DWORD WINAPI MC_GroupAxesReadError | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_AXES_READ_ERROR * | ,
 |  | WORD |
 | ) |  |

軸グループに追加された軸のエラーコードの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_AXES_READ_ERROR*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のエラーコードを読込みます

◆ MC_GroupSetOverride()

DWORD WINAPI MC_GroupSetOverride | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_SET_OVERRIDE_IN * | ,
 |  | WORD |
 | ) |  |

軸グループにおける速度のオーバーライドファクタ設定

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_SET_OVERRIDE_IN*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループにおける速度のオーバーライドファクタ設定

速度倍率の目標速度を変更します．
[直線加減速動作中に速度変更した場合]
直線で速度が変化します

S字曲線動作中に速度変更場合、S字曲線で速度が変化します．

オーバーライド時の速度変化
オーバーライドが実行できない場合

◆ MC_GroupReadPathData()

DWORD WINAPI MC_GroupReadPathData | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_PATH_DATA_OUT * | ,
 |  | WORD |
 | ) |  |

MC_MovePath関数により実行中のパスデータの読み込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_PATH_DATA_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

MC_MovePath関数により実行中のパスデータを読み込みます

◆ MC_GroupWaitNextInterrupt()

DWORD WINAPI MC_GroupWaitNextInterrupt | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

軸グループの動作指令の実行結果を通知する割り込みが発生するまで待機します。

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | 待機時間
(WORD) | 値: 0
戻り値
エラーコード

下記関数の実行完了時に実行結果を通知する割り込みが発生します。
MC_GroupReset
MC_GroupStop
MC_MoveLinearAbsolute
MC_MoveLinearRelativ
MC_MoveLinearVelocity
MC_GroupHome
MC_MovePath

待機状態のキャンセルにはMC_GroupCancelWaitInterruptを使用します。

◆ MC_GroupReadFunctionResult()

DWORD WINAPI MC_GroupReadFunctionResult | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_MOVE_FUNCTION_RESULT * | ,
 |  | WORD |
 | ) |  |

軸グループの動作指令の実行結果の読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_MOVE_FUNCTION_RESULT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

完了したグループAPIの情報を MC_GROUP_MOVE_FUNCTION_RESULT 構造体に読みだします。

下記関数の実行結果を取得します．
MC_GroupReset
MC_GroupStop
MC_MoveLinearAbsolute
MC_MoveLinearRelativ
MC_MoveLinearVelocity
MC_GroupHome
MC_MovePath

◆ MC_GroupCancelWaitInterrupt()

DWORD WINAPI MC_GroupCancelWaitInterrupt | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

軸グループの動作指令の実行結果を通知する割り込み待機をキャンセル

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの実行完了待機をキャンセルします．

MC_GroupWaitNextInterruptをキャンセルします．

◆ MC_GroupResetMotionSts()

DWORD WINAPI MC_GroupResetMotionSts | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

軸グループの動作指令の実行結果を格納している内部メモリを0クリア

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの実行結果を格納している内部メモリを 0 クリアします

MC_GROUP_MOVE_FUNCTION_RESULTを 0 クリアします．

◆ MC_GroupHome()

DWORD WINAPI MC_GroupHome | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_HOME_IN * | ,
 |  | MC_GROUP_HOME_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループの原点復帰

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_HOME_IN*) | 入力情報を格納する構造体のポインタ
(MC_GROUP_HOME_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループの原点復帰を行います

各軸のfPosition[32]に設定した位置まで原点復帰します．fVelocityは，直線補間速度です．

◆ MC_GroupStop()

DWORD WINAPI MC_GroupStop | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_STOP_IN * | ,
 |  | MC_GROUP_STOP_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループの停止動作

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_STOP_IN*) | 入力情報を格納する構造体のポインタ
(MC_GROUP_STOP_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループを停止します

◆ MC_MoveLinearAbsolute()

DWORD WINAPI MC_MoveLinearAbsolute | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_MOVE_LINEAR_ABS_IN * | ,
 |  | MC_MOVE_LINEAR_ABS_OUT * | ,
 |  | WORD |
 | ) |  |

絶対移動量における直線補間動作

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_MOVE_LINEAR_ABS_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_LINEAR_ABS_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

絶対移動量における直線補間動作を行います．

◆ MC_MoveLinearRelative()

DWORD WINAPI MC_MoveLinearRelative | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_MOVE_LINEAR_REL_IN * | ,
 |  | MC_MOVE_LINEAR_REL_OUT * | ,
 |  | WORD |
 | ) |  |

相対移動量における直線補間動作

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_MOVE_LINEAR_REL_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_LINEAR_REL_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

相対移動量における直線補間動作を行います

◆ MC_MoveLinearVelocity()

DWORD WINAPI MC_MoveLinearVelocity | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_MOVE_LINEAR_VEL_IN * | ,
 |  | MC_MOVE_LINEAR_VEL_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループに追加された軸の連続動作

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_MOVE_LINEAR_VEL_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_LINEAR_VEL_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸の連続動作を行います．

◆ MC_MovePath()

DWORD WINAPI MC_MovePath | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_PATH_DATA_REF * | ,
 |  | MC_MOVE_PATH_IN * | ,
 |  | MC_MOVE_PATH_OUT * | ,
 |  | WORD |
 | ) |  |

指定のパスデータを使用して，動作の連続実行

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_PATH_DATA_REF*) | パスデータを格納する構造体のポインタ
(MC_MOVE_PATH_IN*) | 入力情報を格納する構造体のポインタ
(MC_MOVE_PATH_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

指定のパスデータを使用して，動作の連続実行を行います

◆ MC_GroupReadBuffer()

DWORD WINAPI MC_GroupReadBuffer | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | MC_GROUP_READ_BUFFER_OUT * | ,
 |  | WORD |
 | ) |  |

軸グループのバッファ待機中の関数の情報を読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(MC_GROUP_READ_BUFFER_OUT*) | 出力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのバッファ待機中の関数の情報を読込みます

◆ MC_GroupDeleteBuffer()

DWORD WINAPI MC_GroupDeleteBuffer | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | WORD |
 | ) |  |

軸グループのバッファ待機中の関数の削除

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

軸グループのバッファ待機中の関数が存在する場合，関数が実行される前に削除します

◆ MC_SetGroupIntSignalInfo()

DWORD WINAPI MC_SetGroupIntSignalInfo | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

軸グループの動作指令の実行結果を通知する割り込みに関係する設定

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 設定値
(WORD) | 値: 0
戻り値
エラーコード

MC_GroupCancelWaitInterruptによって待機中断されたときのMC_GroupWaitNextInterruptの戻り値の設定をします

設定値 0：戻り値 0
設定値 1：戻り値 0ｘ000020

◆ MC_GetGroupIntSignalInfo()

DWORD WINAPI MC_GetGroupIntSignalInfo | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD * | ,
 |  | WORD |
 | ) |  |

軸グループの動作指令の実行結果を通知する割り込みに関係する設定の取得

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(WORD) | 設定値
(WORD) | 値: 0
戻り値
エラーコード

MC_SetGroupIntSignalInfo関数を実行して設定した値の読み込みを行います．

MC_SetGroupIntSignalInfoによる設定値を読み込みます．

◆ IO_inp()

DWORD WINAPI IO_inp | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | BYTE * | ,
 |  | WORD |
 | ) |  |

データ8ビット読込み

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号
(DWORD) | データオフセット
(BYTE*) | 読み込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのPDOデータを読込みます

◆ IO_inpw()

DWORD WINAPI IO_inpw | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | WORD * | ,
 |  | WORD |
 | ) |  |

データ16ビット読込み

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号
(DWORD) | データオフセット
(WORD*) | 読み込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのPDOデータを読込みます

◆ IO_inpdw()

DWORD WINAPI IO_inpdw | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | DWORD * | ,
 |  | WORD |
 | ) |  |

データ32ビット読込み

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号
(DWORD) | データオフセット
(DWORD*) | 読み込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのPDOデータを読込みます

◆ IO_outp()

DWORD WINAPI IO_outp | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | BYTE | ,
 |  | WORD |
 | ) |  |

データ8ビット書き込み

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号
(DWORD) | データオフセット
(BYTE) | 書き込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのPDOデータを書き込みます

◆ IO_outpw()

DWORD WINAPI IO_outpw | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | WORD | ,
 |  | WORD |
 | ) |  |

データ16ビット書き込み

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号
(DWORD) | データオフセット
(WORD) | 書き込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのPDOデータを書き込みます

◆ IO_outpdw()

DWORD WINAPI IO_outpdw | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | DWORD | ,
 |  | WORD |
 | ) |  |

データ32ビット書き込み

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号
(DWORD) | データオフセット
(DWORD) | 書き込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのPDOデータを書き込みます

◆ IO_Groupinp()

DWORD WINAPI IO_Groupinp | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | BYTE | [],
 |  | WORD |
 | ) |  |

軸グループに追加された軸のPDOデータ8ビットの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | PDOマッピングを行ったオブジェクトのオフセットアドレス
(BYTE[]) | 読込みを行うデータを格納する配列． 配列番号は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[32]と対応しています． (byData[0]，byData[1]，byData[2]，・・・は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[0]，stAxis[0]，stAxis[0]，・・・と対応しています．)
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のPDOデータ8ビットを読込みます．

第4引数の配列番号は軸グループのMC_AXES_GROUP_REFのstAxis[32]と対応しています

◆ IO_Groupinpw()

DWORD WINAPI IO_Groupinpw | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | WORD | [],
 |  | WORD |
 | ) |  |

軸グループに追加された軸のPDOデータ16ビットの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | PDOマッピングを行ったオブジェクトのオフセットアドレス
(WORD[]) | 読込みを行うデータを格納する配列． 配列番号は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[32]と対応しています． (byData[0]，byData[1]，byData[2]，・・・は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[0]，stAxis[0]，stAxis[0]，・・・と対応しています．)
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のPDOデータ16ビットを読込みます．

第4引数の配列番号は軸グループのMC_AXES_GROUP_REFのstAxis[32]と対応しています

◆ IO_Groupinpdw()

DWORD WINAPI IO_Groupinpdw | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | DWORD | [],
 |  | WORD |
 | ) |  |

軸グループに追加された軸のPDOデータ32ビットの読込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | PDOマッピングを行ったオブジェクトのオフセットアドレス
(DWORD[]) | 読込みを行うデータを格納する配列． 配列番号は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[32]と対応しています． (byData[0]，byData[1]，byData[2]，・・・は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[0]，stAxis[0]，stAxis[0]，・・・と対応しています．)
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のPDOデータ32ビットを読込みます．

第4引数の配列番号は軸グループのMC_AXES_GROUP_REFのstAxis[32]と対応しています

◆ IO_Groupoutp()

DWORD WINAPI IO_Groupoutp | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | BYTE | [],
 |  | WORD |
 | ) |  |

軸グループに追加された軸のPDOデータ8ビットの書き込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | PDOマッピングを行ったオブジェクトのオフセットアドレス
(BYTE[]) | 書込みを行うデータを格納する配列． 配列番号は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[32]と対応しています． (byData[0]，byData[1]，byData[2]，・・・は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[0]，stAxis[0]，stAxis[0]，・・・と対応しています．)
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のPDOデータ8ビットを書込みます．

第4引数の配列番号は軸グループのMC_AXES_GROUP_REFのstAxis[32]と対応しています

◆ IO_Groupoutpw()

DWORD WINAPI IO_Groupoutpw | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | WORD | [],
 |  | WORD |
 | ) |  |

軸グループに追加された軸のPDOデータ16ビットの書き込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | PDOマッピングを行ったオブジェクトのオフセットアドレス
(WORD[]) | 書込みを行うデータを格納する配列． 配列番号は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[32]と対応しています． (byData[0]，byData[1]，byData[2]，・・・は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[0]，stAxis[0]，stAxis[0]，・・・と対応しています．)
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のPDOデータ16ビットを書込みます．

第4引数の配列番号は軸グループのMC_AXES_GROUP_REFのstAxis[32]と対応しています

◆ IO_Groupoutpdw()

DWORD WINAPI IO_Groupoutpdw | ( | DWORD | ,
 |  | MC_AXES_GROUP_REF * | ,
 |  | DWORD | ,
 |  | DWORD | [],
 |  | WORD |
 | ) |  |

軸グループに追加された軸のPDOデータ32ビットの書き込み

引数
(DWORD) | マスタハンドル.
(MC_AXES_GROUP_REF*) | 軸グループの情報を格納する構造体のポインタ
(DWORD) | PDOマッピングを行ったオブジェクトのオフセットアドレス
(DWORD[]) | 書込みを行うデータを格納する配列． 配列番号は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[32]と対応しています． (byData[0]，byData[1]，byData[2]，・・・は，軸グループのMC_AXES_GROUP_REF構造体メンバstAxis[0]，stAxis[0]，stAxis[0]，・・・と対応しています．)
(WORD) | 値: 0
戻り値
エラーコード

軸グループに追加された軸のPDOデータ32ビットを書込みます．

第4引数の配列番号は軸グループのMC_AXES_GROUP_REFのstAxis[32]と対応しています

◆ EC_GetMasterInfo()

DWORD WINAPI EC_GetMasterInfo | ( | EC_MASTER_INFO * | ,
 |  | WORD |
 | ) |  |

マスタ情報取得

引数
(EC_MASTER_INFO*) | マスタ情報を格納する構造体のポインタ.
(WORD) | 値: 0
戻り値
エラーコード

マスタ情報を取得します．

◆ EC_OpenMaster()

DWORD WINAPI EC_OpenMaster | ( | DWORD * | ,
 |  | EC_MASTER_INFO * | ,
 |  | WORD |
 | ) |  |

マスタオープン( EtherCAT通信の開始 )

引数
(DWORD*) | マスタハンドル.
(EC_MASTER_INFO*) | マスタ情報を格納する構造体のポインタ.
(WORD) | 値: 0
戻り値
エラーコード

マスタをオープンします

◆ EC_CloseMaster()

DWORD WINAPI EC_CloseMaster | ( | DWORD | ,
 |  | WORD |
 | ) |  |

マスタクローズ( EtherCAT通信の停止 )

引数
(DWORD) | マスタハンドル.
(WORD) | 値: 0
戻り値
エラーコード

マスタをクローズします

◆ EC_GetSlaveInfo()

DWORD WINAPI EC_GetSlaveInfo | ( | DWORD | ,
 |  | EC_GET_SLAVE_INFO_IN * | ,
 |  | EC_SLAVE_INFO * | ,
 |  | WORD |
 | ) |  |

スレーブ情報取得

引数
(DWORD) | マスタハンドル.
(EC_GET_SLAVE_INFO_IN*) | 入力情報を格納する構造体のポインタ.
(EC_SLAVE_INFO*) | スレーブ情報を格納する構造体のポインタ.
(WORD) | 値: 0
戻り値
エラーコード

指定したマスタのスレーブ情報を取得します

スレーブ情報を取得して軸の登録を行います．
複数軸を持つドライバは軸数分実行してください．

◆ EC_GetDiagnosisMessage()

DWORD WINAPI EC_GetDiagnosisMessage | ( | DWORD | ,
 |  | BYTE | ,
 |  | EC_GET_DIAGNOSIS_MESSAGE_OUT * | ,
 |  | WORD |
 | ) |  |

スレーブの診断メッセージ取得

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号.
(EC_GET_DIAGNOSIS_MESSAGE_OUT*) | 出力情報を格納する構造体のポインタ.
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブの診断メッセージを取得します．

◆ EC_GetDiagnosisMessageFlags()

DWORD WINAPI EC_GetDiagnosisMessageFlags | ( | DWORD | ,
 |  | BYTE | ,
 |  | EC_DIAGNOSIS_MESSAGE_FLAGS * | ,
 |  | WORD |
 | ) |  |

スレーブの診断メッセージフラグ取得

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号.
(EC_DIAGNOSIS_MESSAGE_FLAGS*) | 出力情報を格納する構造体のポインタ.
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブの診断メッセージフラグを取得します．

◆ EC_SetDiagnosisMessageFlags()

DWORD WINAPI EC_SetDiagnosisMessageFlags | ( | DWORD | ,
 |  | BYTE | ,
 |  | EC_DIAGNOSIS_MESSAGE_FLAGS * | ,
 |  | WORD |
 | ) |  |

スレーブの診断メッセージ設定

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号.
(EC_DIAGNOSIS_MESSAGE_FLAGS*) | 入力情報を格納する構造体のポインタ.
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブの診断メッセージを設定します．

◆ EC_ResetDiagnosisMessage()

DWORD WINAPI EC_ResetDiagnosisMessage | ( | DWORD | ,
 |  | BYTE | ,
 |  | WORD |
 | ) |  |

スレーブの診断メッセージクリア

引数
(DWORD) | マスタハンドル.
(BYTE) | スレーブのノード番号.
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブの診断メッセージをクリアします．

◆ EC_ReadVersion()

DWORD WINAPI EC_ReadVersion | ( | EC_VERSION * | ,
 |  | WORD |
 | ) |  |

モーション機能パックライブラリのバージョンと契約軸数取得

引数
(EC_VERSION*) | 出力情報を格納する構造体
(WORD) | 値: 0
戻り値
エラーコード

モーション機能パックライブラリのバージョンと契約軸数を取得します．

◆ EC_ReadSDO()

DWORD WINAPI EC_ReadSDO | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | DWORD | ,
 |  | BYTE | ,
 |  | BYTE | [],
 |  | WORD |
 | ) |  |

SDOデータ読込み

引数
(DWORD) | マスタハンドル
(BYTE) | スレーブのノード番号
(DWORD) | インデックス
(DWORD) | サブインデックス
(BYTE) | 読み込みデータサイズ[BYTE]
(BYTE[]) | 読み込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのSDOデータを読込みます

◆ EC_WriteSDO()

DWORD WINAPI EC_WriteSDO | ( | DWORD | ,
 |  | BYTE | ,
 |  | DWORD | ,
 |  | DWORD | ,
 |  | BYTE | ,
 |  | BYTE | [],
 |  | WORD |
 | ) |  |

SDOデータ書き込み

引数
(DWORD) | マスタハンドル
(BYTE) | スレーブのノード番号
(DWORD) | インデックス
(DWORD) | サブインデックス
(BYTE) | 書き込みデータサイズ[BYTE]
(BYTE[]) | 書き込みデータ
(WORD) | 値: 0
戻り値
エラーコード

指定したスレーブのSDOデータを書き込みます

◆ EC_StartLogPosition()

DWORD WINAPI EC_StartLogPosition | ( | DWORD | ,
 |  | EC_START_LOGPOS * | ,
 |  | WORD |
 | ) |  |

ログ(指令・現在位置)の記録を開始

引数
(DWORD) | マスタハンドル
(EC_START_LOGPOS*) | 入力情報を格納する構造体のポインタ
(WORD) | 値: 0
戻り値
エラーコード

EtherCAT通信周期ごとに，ログ(指令・現在位置)の記録を開始します.
(INtimeメモリに格納します．)

RSI-ECAT-Masterのサイクル周期ごとに軸の指令・現在位置を記録します．

◆ EC_StopLogPosition()

DWORD WINAPI EC_StopLogPosition | ( | DWORD | ,
 |  | WORD |
 | ) |  |

ログ(指令・現在位置)の記録を停止

引数
(DWORD) | マスタハンドル
(WORD) | 値: 0
戻り値
エラーコード

ログ(指令・現在位置)の記録を停止します.
(INtimeメモリへの格納を停止します．)

EC_StartLogPositionのよる指令・現在位置の記録を停止します．
本APIを実行する前のサイクルまでのログがファイルへ保存されます．ただし、INtimeメモリへのログデータは削除されません

◆ EC_SaveLogPosition()

DWORD WINAPI EC_SaveLogPosition | ( | DWORD | ,
 |  | EC_SAVE_LOGPOS * | ,
 |  | WORD |
 | ) |  |

ログ(指令・現在位置)をファイルに保存

引数
(DWORD) | マスタハンドル
(EC_SAVE_LOGPOS*) | 入力情報を格納する構造体
(WORD) | 値: 0
戻り値
エラーコード

ログ(指令・現在位置)をファイルに保存します.
(INtimeメモリからファイルへ保存します．)

EC_StartLogPositionによるログデータをファイルへ保存します．

保存したファイル例 (csv形式 )

◆ EC_ReadLogPositionStatus()

DWORD WINAPI EC_ReadLogPositionStatus | ( | DWORD | ,
 |  | EC_LOGPOS_STATUS * | ,
 |  | WORD |
 | ) |  |

ログ(指令・現在位置)の記録状態の読込み

引数
(DWORD) | マスタハンドル
(EC_LOGPOS_STATUS*) | 入力情報を格納する構造体
(WORD) | 値: 0
戻り値
エラーコード

ログ(指令・現在位置)の記録状態を読込みます.
(INtimeメモリへの格納状態を読込みます．)

ログの記録状態を読み込みます．

◆ EC_ClearLogPositionMemory()

DWORD WINAPI EC_ClearLogPositionMemory | ( | DWORD | ,
 |  | WORD |
 | ) |  |

ログ(指令・現在位置)を格納するINtimeメモリ削除

引数
(DWORD) | マスタハンドル
(WORD) | 値: 0
戻り値
エラーコード

ログ(指令・現在位置)を格納するINtimeメモリを削除します

ログデータを書き込んだINtimeメモリを削除します．


HLS-ECAT02WIN APIリファレンス: hmecw0_func.h ソースファイル

hmecw0_func.h
[詳解]
1 //==========================================
2 // HLS-ECAT02xx/Win
3 // File Name : hmecw0_func.h
4 // Last update : 2021/05/26
5 //
6 // Copyright(C) 2015-2021　Hivertec,Inc.
7 // All Rights Reserved.
8 //==========================================
9 //
10 // // 多重定義を防ぐため
11
12 #ifdef __cplusplus
13 extern "C"
14 {
15 #endif
16
18 /* @{ */
31 DWORD MC_Power(DWORD, MC_AXIS_REF*, MC_POWER_IN*, MC_POWER_OUT*, WORD); // 電源制御
32
42 DWORD MC_ReadStatus(DWORD, MC_AXIS_REF*, MC_STATUS*, WORD); // ステータス読込み
43
55 DWORD MC_ResetAxisSetting(DWORD, MC_AXIS_REF*, WORD); // 軸設定の初期化
56
69 DWORD MC_GetAxisSetting(DWORD, MC_AXIS_REF*, MC_AXIS_SETTING*, WORD); // 軸設定の取得
70
83 DWORD MC_SetAxisSetting(DWORD, MC_AXIS_REF*, MC_AXIS_SETTING*, WORD); // 軸設定の設定
84
94 DWORD MC_ReadAxisError(DWORD, MC_AXIS_REF*, MC_AXIS_ERROR*, WORD); // 軸エラー読込み
95
106 DWORD MC_ReadActualPosition(DWORD, MC_AXIS_REF*, MC_ACTUAL_POSITION*, WORD); // 現在位置読込み
107
118 DWORD MC_ReadActualVelocity(DWORD, MC_AXIS_REF*, MC_ACTUAL_VELOCITY*, WORD); // 現在速度読込み
119
129 DWORD MC_ReadAxisInfo(DWORD, MC_AXIS_REF*, MC_AXIS_INFO*, WORD); // 軸情報読込み
130
140 DWORD MC_ReadMotionState(DWORD, MC_AXIS_REF*, MC_MOTION_STATE*, WORD); // モーションステータス読込み
141
151 DWORD MC_SetPosition(DWORD, MC_AXIS_REF*, MC_ACTUAL_POSITION*, WORD); // 現在位置変更
152
166 DWORD MC_SetOverride(DWORD, MC_AXIS_REF*, MC_SET_OVERRIDE_IN*, WORD); // 速度、加減速度、ジャークのオーバーライドファクタ設定
167
178 DWORD MC_TouchProbe(DWORD, MC_AXIS_REF*, MC_TOUCH_PROBE_IN*, MC_TOUCH_PROBE_OUT*, WORD); // トリガーイベントによる現在位置ラッチ
179
189 DWORD MC_AbortTrigger(DWORD, MC_AXIS_REF*, MC_TRIGGER_REF*, WORD); // トリガーイベントによる現在位置読込み中止
190
200 DWORD MC_Reset(DWORD, MC_AXIS_REF*, MC_RESET_OUT*, WORD); // 軸異常解除
201
211 DWORD MC_ReadProbeStatus(DWORD, MC_AXIS_REF*, MC_PROBE_STATUS*, WORD); // プローブステータス読み込み
212
222 DWORD MC_ReadBuffer(DWORD, MC_AXIS_REF*, MC_READ_BUFFER_OUT*, WORD); // Buffered待機中の動作情報読込み
223
232 DWORD MC_DeleteBuffer(DWORD, MC_AXIS_REF*, WORD); // Buffered待機中の関数の情報を削除
233
245 DWORD MC_ReadLatchCountResult(DWORD, MC_AXIS_REF*, MC_LATCH_COUNT_REF*, MC_LATCH_COUNT_RESULT*, WORD); // タッチプローブ機能の出力情報読出し
246
258 DWORD MC_WaitNextLatchCountInterrupt(DWORD, MC_AXIS_REF*, MC_LATCH_COUNT_REF*, DWORD, WORD); // タッチプローブ機能の割り込み待機
259
269 DWORD MC_CancelWaitLatchCountInterrupt(DWORD, MC_AXIS_REF*, WORD); // タッチプローブ機能の割り込み待機キャンセル
270
280 DWORD MC_ResetLatchSts(DWORD, MC_AXIS_REF*, WORD); // ラッチ完了後の変数値を格納している内部メモリを0クリアします
281
292 DWORD MC_SetDelayTimer(DWORD, MC_AXIS_REF*, EC_DELAY_TIMER*, WORD); // 遅延時間設定
293
304 DWORD MC_ReadDelayTimer(DWORD, MC_AXIS_REF*, EC_DELAY_TIMER*, WORD); // 遅延時間読み込み
305
318 DWORD MC_Home(DWORD, MC_AXIS_REF*, MC_HOME_IN*, MC_HOME_OUT*, WORD); // 原点復帰
319
333 DWORD MC_Stop(DWORD, MC_AXIS_REF*, MC_STOP_IN*, MC_STOP_OUT*, WORD); // 減速停止
334
348 DWORD MC_MoveAbsolute(DWORD, MC_AXIS_REF*, MC_MOVE_ABSOLUTE_IN*, MC_MOVE_ABSOLUTE_OUT*, WORD); // 現在位置移動
349
362 DWORD MC_MoveRelative(DWORD, MC_AXIS_REF*, MC_MOVE_RELATIVE_IN*, MC_MOVE_RELATIVE_OUT*, WORD); // 相対位置決め
363
376 DWORD MC_MoveAdditive(DWORD, MC_AXIS_REF*, MC_MOVE_ADDITIVE_IN*, MC_MOVE_ADDITIVE_OUT*, WORD); // 位置決め相対位置付加
377
389 DWORD MC_MoveVelocity(DWORD, MC_AXIS_REF*, MC_MOVE_VELOCITY_IN*, MC_MOVE_VELOCITY_OUT*, WORD); // 指定速度連続送り
390
401 DWORD MC_WaitNextInterrupt(DWORD, MC_AXIS_REF*, DWORD, WORD); // 動作指令の実行結果の割り込み待機
402
413 DWORD MC_ReadFunctionResult(DWORD, MC_AXIS_REF*, MC_MOVE_FUNCTION_RESULT*, WORD); // 動作関数出力情報読出し
414
424 DWORD MC_CancelWaitInterrupt(DWORD, MC_AXIS_REF*, WORD); // 割り込み待機キャンセル
425
435 DWORD MC_ResetMotionSts(DWORD, MC_AXIS_REF*, WORD); // 関数動作完了後の変数値を格納している内部メモリを0クリアします
436
447 DWORD MC_SetIntSignalInfo(DWORD, MC_AXIS_REF*, DWORD, WORD); // MC_CancelWaitInterrupt関数を実行した後, MC_ReadFunctionResult関数を実行した時の戻り値の設定
448
458 DWORD MC_GetIntSignalInfo(DWORD, MC_AXIS_REF*, DWORD*, WORD); // MC_SetIntSignalInfo関数を実行して設定した値の読み込み
459
470 DWORD MC_SetLatchCountIntSignalInfo(DWORD, MC_AXIS_REF*, DWORD, WORD); // MC_CancelWaitLatchCountInterrupt関数を実行した後, MC_ReadLatchCountResult関数を実行した時の戻り値の設定
471
481 DWORD MC_GetLatchCountIntSignalInfo(DWORD, MC_AXIS_REF*, DWORD*, WORD); // MC_SetLatchCountIntSignalInfo関数を実行して設定した値の読み込み
482
493 DWORD MC_AddAxisToGroup(DWORD, MC_AXES_GROUP_REF*, MC_AXIS_REF*, MC_GROUP_ADD_AXIS*, WORD); // 軸を軸グループに追加します．
494
504 DWORD MC_RemoveAxisFromGroup(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_REMOVE_AXIS*, WORD); // 指定の軸を軸グループから取り除きます．
505
514 DWORD MC_UngroupAllAxes(DWORD, MC_AXES_GROUP_REF*, WORD); // 全ての軸を軸グループから取り除きます．
515
526 DWORD MC_GroupReadConfiguration(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_CONFIG_IN*, MC_GROUP_READ_CONFIG_OUT*, WORD); // 軸グループに追加された軸の情報を読み込みます．
527
537 DWORD MC_GroupEnable(DWORD, MC_AXES_GROUP_REF*, WORD); // 軸グループのPLCOpenのステータスをGroupStandby に変更します．
538
547 DWORD MC_GroupDisable(DWORD, MC_AXES_GROUP_REF*, WORD); // 軸グループのPLCOpenのステータスをGroupDisabled に変更します．
548
558 DWORD MC_ResetGroupSetting(DWORD, MC_AXES_GROUP_REF*, WORD); // 軸グループのパラメータの設定を初期化します．
559
571 DWORD MC_SetGroupSetting(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_SETTING*, WORD); // 軸グループのパラメータの設定を行います．
572
584 DWORD MC_GetGroupSetting(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_SETTING*, WORD); // 軸グループのパラメータの設定を行います．
585
595 DWORD MC_GroupSetPosition(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_SET_POSITION*, WORD); // 軸グループの軸の位置を設定します．
596
607 DWORD MC_GroupReadActualPosition(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_ACT_POS_IN*, MC_GROUP_READ_ACT_POS_OUT*, WORD); // 軸グループの現在位置を読み込みます．
608
619 DWORD MC_GroupReadActualVelocity(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_ACT_VEL_IN*, MC_GROUP_READ_ACT_VEL_OUT*, WORD); // 軸グループの現在速度を読み込みます．
620
630 DWORD MC_GroupReadStatus(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_STATUS*, WORD); // 軸グループのPLCOpenにおけるステータス，モーションステータスを読み込みます．
631
641 DWORD MC_GroupReadError(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_ERROR*, WORD); // 軸グループのエラーを読み込みます．
642
653 DWORD MC_GroupReset(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_RESET_OUT*, WORD); // 軸グループのエラーをリセットします．
654
664 DWORD MC_GroupAxesReadMotionState(DWORD, MC_AXES_GROUP_REF*, MC_AXES_READ_MOTION_STATE*, WORD); // 軸グループに含まれる軸のステータスを読込みます．
665
675 DWORD MC_GroupAxesReadStatus(DWORD, MC_AXES_GROUP_REF*, MC_AXES_READ_STATUS*, WORD); // 軸グループに含まれる軸のステータス読込み
676
686 DWORD MC_GroupAxesReadInfo(DWORD, MC_AXES_GROUP_REF*, MC_AXES_READ_INFO*, WORD); // 軸グループに含まれる軸の軸情報を読込みます．
687
697 DWORD MC_GroupAxesReadError(DWORD, MC_AXES_GROUP_REF*, MC_AXES_READ_ERROR*, WORD); // 軸グループに含まれる軸のエラーコードを読込みます．
698
712 DWORD MC_GroupSetOverride(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_SET_OVERRIDE_IN*, WORD); // 軸グループのオーバーライドファクタ設定
713
723 DWORD MC_GroupReadPathData(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_PATH_DATA_OUT*, WORD); // パスデータを読み込みます.
724
735 DWORD MC_GroupWaitNextInterrupt(DWORD, MC_AXES_GROUP_REF*, DWORD, WORD); // 軸グループの動作指令の実行結果の割り込み待機
736
747 DWORD MC_GroupReadFunctionResult(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_MOVE_FUNCTION_RESULT*, WORD); // 軸グループの実行結果を読み込みます．
748
758 DWORD MC_GroupCancelWaitInterrupt(DWORD, MC_AXES_GROUP_REF*, WORD); // 軸グループの実行完了待機をキャンセル．
759
769 DWORD MC_GroupResetMotionSts(DWORD, MC_AXES_GROUP_REF*, WORD); // 軸グループの実行結果を格納している内部メモリを0クリアします
770
782 DWORD MC_GroupHome(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_HOME_IN*, MC_GROUP_HOME_OUT*, WORD); // 軸グループの原点復帰を行います．
783
794 DWORD MC_GroupStop(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_STOP_IN*, MC_GROUP_STOP_OUT*, WORD); // 軸グループを停止します．
795
806 DWORD MC_MoveLinearAbsolute(DWORD, MC_AXES_GROUP_REF*, MC_MOVE_LINEAR_ABS_IN*, MC_MOVE_LINEAR_ABS_OUT*, WORD); // 絶対移動量における直線補間動作を行います．
807
818 DWORD MC_MoveLinearRelative(DWORD, MC_AXES_GROUP_REF*, MC_MOVE_LINEAR_REL_IN*, MC_MOVE_LINEAR_REL_OUT*, WORD); // 相対移動量における直線補間動作を行います．
819
830 DWORD MC_MoveLinearVelocity(DWORD, MC_AXES_GROUP_REF*, MC_MOVE_LINEAR_VEL_IN*, MC_MOVE_LINEAR_VEL_OUT*, WORD); // 軸グループに含まれる軸の連続動作を行います．
831
843 DWORD MC_MovePath(DWORD, MC_AXES_GROUP_REF*, MC_PATH_DATA_REF*, MC_MOVE_PATH_IN*, MC_MOVE_PATH_OUT*, WORD); // パスデータを使用して連続動作を行います.
844
854 DWORD MC_GroupReadBuffer(DWORD, MC_AXES_GROUP_REF*, MC_GROUP_READ_BUFFER_OUT*, WORD); // 軸グループにおいて，Buffered待機中の動作情報読込み
855
864 DWORD MC_GroupDeleteBuffer(DWORD, MC_AXES_GROUP_REF*, WORD); // 軸グループにおいて，Buffered待機中の関数の情報を削除
865
876 DWORD MC_SetGroupIntSignalInfo(DWORD, MC_AXES_GROUP_REF*, DWORD, WORD); // MC_SetGroupIntSignalInfo関数を実行して設定した値の読み込み
877
888 DWORD MC_GetGroupIntSignalInfo(DWORD, MC_AXES_GROUP_REF*, DWORD*, WORD); // MC_GroupCancelWaitInterrupt関数を実行した後, MC_GroupReadFunctionResult関数を実行した時の戻り値の設定．
889 /* @} */
890
892 /* @{ */
903 DWORD IO_inp(DWORD, BYTE, DWORD, BYTE*, WORD); // PDOデータ8ビット読込み
904
915 DWORD IO_inpw(DWORD, BYTE, DWORD, WORD*, WORD); // PDOデータ16ビット読込み
916
927 DWORD IO_inpdw(DWORD, BYTE, DWORD, DWORD*, WORD); // PDOデータ32ビット読込み
928
939 DWORD IO_outp(DWORD, BYTE, DWORD, BYTE, WORD); // PDOデータ8ビット書込み
940
951 DWORD IO_outpw(DWORD, BYTE, DWORD, WORD, WORD); // PDOデータ16ビット書込み
952
963 DWORD IO_outpdw(DWORD, BYTE, DWORD, DWORD, WORD); // PDOデータ32ビット書込み
964
978 DWORD IO_Groupinp(DWORD, MC_AXES_GROUP_REF*, DWORD, BYTE[], WORD); // 軸グループに含まれる軸のPDOデータ8ビット読込み
979
993 DWORD IO_Groupinpw(DWORD, MC_AXES_GROUP_REF*, DWORD, WORD[], WORD); // 軸グループに含まれる軸のPDOデータ16ビット読込み
994
1008 DWORD IO_Groupinpdw(DWORD, MC_AXES_GROUP_REF*, DWORD, DWORD[], WORD); // 軸グループに含まれる軸のPDOデータ32ビット読込み
1009
1023 DWORD IO_Groupoutp(DWORD, MC_AXES_GROUP_REF*, DWORD, BYTE[], WORD); // 軸グループに含まれる軸のPDOデータ8ビット書込み
1024
1038 DWORD IO_Groupoutpw(DWORD, MC_AXES_GROUP_REF*, DWORD, WORD[], WORD); // 軸グループに含まれる軸のPDOデータ16ビット書込み
1039
1053 DWORD IO_Groupoutpdw(DWORD, MC_AXES_GROUP_REF*, DWORD, DWORD[], WORD); // 軸グループに含まれる軸のPDOデータ32ビット書込み
1054 /* @} */
1055
1057 /* @{ */
1065 DWORD EC_GetMasterInfo(EC_MASTER_INFO*, WORD); // マスター情報取得
1066
1075 DWORD EC_OpenMaster(DWORD*, EC_MASTER_INFO*, WORD); // マスターオープン
1076
1084 DWORD EC_CloseMaster(DWORD, WORD); // マスタークローズ
1085
1096 DWORD EC_GetSlaveInfo(DWORD, EC_GET_SLAVE_INFO_IN*, EC_SLAVE_INFO*, WORD); // スレーブ情報取得
1097
1107 DWORD EC_GetDiagnosisMessage(DWORD, BYTE, EC_GET_DIAGNOSIS_MESSAGE_OUT*, WORD); // スレーブの診断DiagnosisMessage取得
1108
1118 DWORD EC_GetDiagnosisMessageFlags(DWORD, BYTE, EC_DIAGNOSIS_MESSAGE_FLAGS*, WORD); // スレーブのDiagnosisMessageフラグ取得
1119
1129 DWORD EC_SetDiagnosisMessageFlags(DWORD, BYTE, EC_DIAGNOSIS_MESSAGE_FLAGS*, WORD); // スレーブのDiagnosisMessageフラグ設定
1130
1139 DWORD EC_ResetDiagnosisMessage(DWORD, BYTE, WORD); // スレーブの診断メッセージクリア
1140
1148 DWORD EC_ReadVersion(EC_VERSION*, WORD); // モーション機能パックライブラリのバージョン、契約軸数取得
1149
1162 DWORD EC_ReadSDO(DWORD, BYTE, DWORD, DWORD, BYTE, BYTE[], WORD); // SDOデータ読込み
1163
1176 DWORD EC_WriteSDO(DWORD, BYTE, DWORD, DWORD, BYTE, BYTE[], WORD); // SDOデータ書込み
1177
1187 DWORD EC_StartLogPosition(DWORD, EC_START_LOGPOS*, WORD); // EtherCAT通信周期ごとに，ログ(指令・現在位置)の記録を開始します.
1188
1197 DWORD EC_StopLogPosition(DWORD, WORD); // ログ(指令・現在位置)の記録を停止します.
1198
1209 DWORD EC_SaveLogPosition(DWORD, EC_SAVE_LOGPOS*, WORD); // ログ(指令・現在位置)をファイルに保存します.
1210
1220 DWORD EC_ReadLogPositionStatus(DWORD, EC_LOGPOS_STATUS*, WORD); // ログ(指令・現在位置)の記録状態を読込みます.
1221
1230 DWORD EC_ClearLogPositionMemory(DWORD, WORD); // ログ(指令・現在位置)を格納するINtimeメモリを削除します.
1231 /* @} */
1232
1233 #ifdef __cplusplus
1234 }
1235 #endif
1236 #endif
MC_GroupAxesReadInfo
DWORD MC_GroupAxesReadInfo(DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_INFO *, WORD)
軸グループに追加された軸の軸情報の読込み
MC_ReadAxisError
DWORD MC_ReadAxisError(DWORD, MC_AXIS_REF *, MC_AXIS_ERROR *, WORD)
軸エラー読み込み
MC_WaitNextInterrupt
DWORD MC_WaitNextInterrupt(DWORD, MC_AXIS_REF *, DWORD, WORD)
動作指令の実行結果を通知する割り込みが発生するまで待機します。
MC_Reset
DWORD MC_Reset(DWORD, MC_AXIS_REF *, MC_RESET_OUT *, WORD)
軸異常解除
EC_GetDiagnosisMessageFlags
DWORD EC_GetDiagnosisMessageFlags(DWORD, BYTE, EC_DIAGNOSIS_MESSAGE_FLAGS *, WORD)
スレーブの診断メッセージフラグ取得
MC_GroupHome
DWORD MC_GroupHome(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_HOME_IN *, MC_GROUP_HOME_OUT *, WORD)
軸グループの原点復帰
MC_GroupStop
DWORD MC_GroupStop(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_STOP_IN *, MC_GROUP_STOP_OUT *, WORD)
軸グループの停止動作
MC_GroupDeleteBuffer
DWORD MC_GroupDeleteBuffer(DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループのバッファ待機中の関数の削除
IO_outpw
DWORD IO_outpw(DWORD, BYTE, DWORD, WORD, WORD)
データ16ビット書き込み
MC_ReadMotionState
DWORD MC_ReadMotionState(DWORD, MC_AXIS_REF *, MC_MOTION_STATE *, WORD)
モーションステータス読み込み
MC_MoveAdditive
DWORD MC_MoveAdditive(DWORD, MC_AXIS_REF *, MC_MOVE_ADDITIVE_IN *, MC_MOVE_ADDITIVE_OUT *, WORD)
位置決め相対位置付加
MC_ResetMotionSts
DWORD MC_ResetMotionSts(DWORD, MC_AXIS_REF *, WORD)
関数動作完了後の変数値を格納している内部メモリを 0 クリアします．
MC_ReadAxisInfo
DWORD MC_ReadAxisInfo(DWORD, MC_AXIS_REF *, MC_AXIS_INFO *, WORD)
軸情報読み込み
EC_ResetDiagnosisMessage
DWORD EC_ResetDiagnosisMessage(DWORD, BYTE, WORD)
スレーブの診断メッセージクリア
MC_ReadLatchCountResult
DWORD MC_ReadLatchCountResult(DWORD, MC_AXIS_REF *, MC_LATCH_COUNT_REF *, MC_LATCH_COUNT_RESULT *, WORD)
指定したタッチプローブの状態を読み込みます
MC_ResetGroupSetting
DWORD MC_ResetGroupSetting(DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループのパラメータの設定を初期化
MC_SetIntSignalInfo
DWORD MC_SetIntSignalInfo(DWORD, MC_AXIS_REF *, DWORD, WORD)
動作指令の実行結果を通知する割り込みに関係する設定
MC_ResetLatchSts
DWORD MC_ResetLatchSts(DWORD, MC_AXIS_REF *, WORD)
ラッチ完了後の変数値を格納している内部メモリを0クリアします
MC_Power
DWORD MC_Power(DWORD, MC_AXIS_REF *, MC_POWER_IN *, MC_POWER_OUT *, WORD)
電源制御
MC_GroupReset
DWORD MC_GroupReset(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_RESET_OUT *, WORD)
軸グループのエラーをリセット
MC_MoveLinearVelocity
DWORD MC_MoveLinearVelocity(DWORD, MC_AXES_GROUP_REF *, MC_MOVE_LINEAR_VEL_IN *, MC_MOVE_LINEAR_VEL_OUT *, WORD)
軸グループに追加された軸の連続動作
MC_SetDelayTimer
DWORD MC_SetDelayTimer(DWORD, MC_AXIS_REF *, EC_DELAY_TIMER *, WORD)
位置決め動作の遅延時間の設定
IO_inp
DWORD IO_inp(DWORD, BYTE, DWORD, BYTE *, WORD)
データ8ビット読込み
MC_MoveLinearRelative
DWORD MC_MoveLinearRelative(DWORD, MC_AXES_GROUP_REF *, MC_MOVE_LINEAR_REL_IN *, MC_MOVE_LINEAR_REL_OUT *, WORD)
相対移動量における直線補間動作
EC_GetSlaveInfo
DWORD EC_GetSlaveInfo(DWORD, EC_GET_SLAVE_INFO_IN *, EC_SLAVE_INFO *, WORD)
スレーブ情報取得
MC_SetAxisSetting
DWORD MC_SetAxisSetting(DWORD, MC_AXIS_REF *, MC_AXIS_SETTING *, WORD)
軸設定の設定
MC_ReadActualPosition
DWORD MC_ReadActualPosition(DWORD, MC_AXIS_REF *, MC_ACTUAL_POSITION *, WORD)
現在位置読み込み
IO_Groupoutp
DWORD IO_Groupoutp(DWORD, MC_AXES_GROUP_REF *, DWORD, BYTE[], WORD)
軸グループに追加された軸のPDOデータ8ビットの書き込み
MC_GroupReadError
DWORD MC_GroupReadError(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_ERROR *, WORD)
軸グループのエラーの読込み
MC_ReadDelayTimer
DWORD MC_ReadDelayTimer(DWORD, MC_AXIS_REF *, EC_DELAY_TIMER *, WORD)
位置決め動作の遅延時間を読み込み
EC_GetDiagnosisMessage
DWORD EC_GetDiagnosisMessage(DWORD, BYTE, EC_GET_DIAGNOSIS_MESSAGE_OUT *, WORD)
スレーブの診断メッセージ取得
MC_GroupWaitNextInterrupt
DWORD MC_GroupWaitNextInterrupt(DWORD, MC_AXES_GROUP_REF *, DWORD, WORD)
軸グループの動作指令の実行結果を通知する割り込みが発生するまで待機します。
MC_GroupReadBuffer
DWORD MC_GroupReadBuffer(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_BUFFER_OUT *, WORD)
軸グループのバッファ待機中の関数の情報を読込み
EC_WriteSDO
DWORD EC_WriteSDO(DWORD, BYTE, DWORD, DWORD, BYTE, BYTE[], WORD)
SDOデータ書き込み
EC_GetMasterInfo
DWORD EC_GetMasterInfo(EC_MASTER_INFO *, WORD)
マスタ情報取得
MC_GroupReadFunctionResult
DWORD MC_GroupReadFunctionResult(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_MOVE_FUNCTION_RESULT *, WORD)
軸グループの動作指令の実行結果の読込み
MC_MoveVelocity
DWORD MC_MoveVelocity(DWORD, MC_AXIS_REF *, MC_MOVE_VELOCITY_IN *, MC_MOVE_VELOCITY_OUT *, WORD)
指定速度連続送り
EC_StartLogPosition
DWORD EC_StartLogPosition(DWORD, EC_START_LOGPOS *, WORD)
ログ(指令・現在位置)の記録を開始
MC_UngroupAllAxes
DWORD MC_UngroupAllAxes(DWORD, MC_AXES_GROUP_REF *, WORD)
全ての軸を軸グループから削除
EC_ReadSDO
DWORD EC_ReadSDO(DWORD, BYTE, DWORD, DWORD, BYTE, BYTE[], WORD)
SDOデータ読込み
IO_inpdw
DWORD IO_inpdw(DWORD, BYTE, DWORD, DWORD *, WORD)
データ32ビット読込み
IO_Groupoutpdw
DWORD IO_Groupoutpdw(DWORD, MC_AXES_GROUP_REF *, DWORD, DWORD[], WORD)
軸グループに追加された軸のPDOデータ32ビットの書き込み
MC_GroupEnable
DWORD MC_GroupEnable(DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの状態遷移のステータスをGroupStandby に変更
IO_Groupinpw
DWORD IO_Groupinpw(DWORD, MC_AXES_GROUP_REF *, DWORD, WORD[], WORD)
軸グループに追加された軸のPDOデータ16ビットの読込み
MC_SetGroupIntSignalInfo
DWORD MC_SetGroupIntSignalInfo(DWORD, MC_AXES_GROUP_REF *, DWORD, WORD)
軸グループの動作指令の実行結果を通知する割り込みに関係する設定
IO_Groupinp
DWORD IO_Groupinp(DWORD, MC_AXES_GROUP_REF *, DWORD, BYTE[], WORD)
軸グループに追加された軸のPDOデータ8ビットの読込み
MC_GetGroupIntSignalInfo
DWORD MC_GetGroupIntSignalInfo(DWORD, MC_AXES_GROUP_REF *, DWORD *, WORD)
軸グループの動作指令の実行結果を通知する割り込みに関係する設定の取得
MC_ReadActualVelocity
DWORD MC_ReadActualVelocity(DWORD, MC_AXIS_REF *, MC_ACTUAL_VELOCITY *, WORD)
現在速度読み込み
MC_GroupCancelWaitInterrupt
DWORD MC_GroupCancelWaitInterrupt(DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの動作指令の実行結果を通知する割り込み待機をキャンセル
MC_GetIntSignalInfo
DWORD MC_GetIntSignalInfo(DWORD, MC_AXIS_REF *, DWORD *, WORD)
動作指令の実行結果を通知する割り込みに関係する設定の取得
MC_GroupAxesReadStatus
DWORD MC_GroupAxesReadStatus(DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_STATUS *, WORD)
軸グループに追加された軸のステータスの読込みます
MC_GetLatchCountIntSignalInfo
DWORD MC_GetLatchCountIntSignalInfo(DWORD, MC_AXIS_REF *, DWORD *, WORD)
タッチプローブの実行結果を通知する割り込みイベントに関係する設定の取得
MC_MoveLinearAbsolute
DWORD MC_MoveLinearAbsolute(DWORD, MC_AXES_GROUP_REF *, MC_MOVE_LINEAR_ABS_IN *, MC_MOVE_LINEAR_ABS_OUT *, WORD)
絶対移動量における直線補間動作
MC_GetAxisSetting
DWORD MC_GetAxisSetting(DWORD, MC_AXIS_REF *, MC_AXIS_SETTING *, WORD)
軸設定の取得
MC_GroupDisable
DWORD MC_GroupDisable(DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの状態遷移のステータスを GroupDisabled に変更
EC_ReadVersion
DWORD EC_ReadVersion(EC_VERSION *, WORD)
モーション機能パックライブラリのバージョンと契約軸数取得
MC_SetOverride
DWORD MC_SetOverride(DWORD, MC_AXIS_REF *, MC_SET_OVERRIDE_IN *, WORD)
速度のオーバーライドファクタ設定
MC_SetLatchCountIntSignalInfo
DWORD MC_SetLatchCountIntSignalInfo(DWORD, MC_AXIS_REF *, DWORD, WORD)
タッチプローブの実行結果を通知する割り込みに関係する設定
IO_Groupinpdw
DWORD IO_Groupinpdw(DWORD, MC_AXES_GROUP_REF *, DWORD, DWORD[], WORD)
軸グループに追加された軸のPDOデータ32ビットの読込み
MC_WaitNextLatchCountInterrupt
DWORD MC_WaitNextLatchCountInterrupt(DWORD, MC_AXIS_REF *, MC_LATCH_COUNT_REF *, DWORD, WORD)
タッチプローブの実行完了待機
MC_GroupReadActualVelocity
DWORD MC_GroupReadActualVelocity(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_ACT_VEL_IN *, MC_GROUP_READ_ACT_VEL_OUT *, WORD)
軸グループの現在速度の読込み
MC_GroupReadPathData
DWORD MC_GroupReadPathData(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_PATH_DATA_OUT *, WORD)
MC_MovePath関数により実行中のパスデータの読み込み
MC_SetPosition
DWORD MC_SetPosition(DWORD, MC_AXIS_REF *, MC_ACTUAL_POSITION *, WORD)
現在位置設定
EC_StopLogPosition
DWORD EC_StopLogPosition(DWORD, WORD)
ログ(指令・現在位置)の記録を停止
MC_GroupResetMotionSts
DWORD MC_GroupResetMotionSts(DWORD, MC_AXES_GROUP_REF *, WORD)
軸グループの動作指令の実行結果を格納している内部メモリを0クリア
IO_inpw
DWORD IO_inpw(DWORD, BYTE, DWORD, WORD *, WORD)
データ16ビット読込み
MC_GroupSetPosition
DWORD MC_GroupSetPosition(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SET_POSITION *, WORD)
軸グループの軸の位置を設定
MC_MoveRelative
DWORD MC_MoveRelative(DWORD, MC_AXIS_REF *, MC_MOVE_RELATIVE_IN *, MC_MOVE_RELATIVE_OUT *, WORD)
相対位置決め
MC_CancelWaitInterrupt
DWORD MC_CancelWaitInterrupt(DWORD, MC_AXIS_REF *, WORD)
割り込み待機キャンセル
MC_Home
DWORD MC_Home(DWORD, MC_AXIS_REF *, MC_HOME_IN *, MC_HOME_OUT *, WORD)
原点復帰
MC_Stop
DWORD MC_Stop(DWORD, MC_AXIS_REF *, MC_STOP_IN *, MC_STOP_OUT *, WORD)
減速停止
MC_ReadFunctionResult
DWORD MC_ReadFunctionResult(DWORD, MC_AXIS_REF *, MC_MOVE_FUNCTION_RESULT *, WORD)
動作指令の出力変数読出し
MC_ResetAxisSetting
DWORD MC_ResetAxisSetting(DWORD, MC_AXIS_REF *, WORD)
軸設定の初期化
MC_ReadBuffer
DWORD MC_ReadBuffer(DWORD, MC_AXIS_REF *, MC_READ_BUFFER_OUT *, WORD)
バッファ待機中の関数の情報を読み込み
EC_ClearLogPositionMemory
DWORD EC_ClearLogPositionMemory(DWORD, WORD)
ログ(指令・現在位置)を格納するINtimeメモリ削除
EC_SaveLogPosition
DWORD EC_SaveLogPosition(DWORD, EC_SAVE_LOGPOS *, WORD)
ログ(指令・現在位置)をファイルに保存
MC_AbortTrigger
DWORD MC_AbortTrigger(DWORD, MC_AXIS_REF *, MC_TRIGGER_REF *, WORD)
トリガーイベントによる現在位置読み込み中止
MC_ReadProbeStatus
DWORD MC_ReadProbeStatus(DWORD, MC_AXIS_REF *, MC_PROBE_STATUS *, WORD)
タッチプローブの状態読み込み
IO_outpdw
DWORD IO_outpdw(DWORD, BYTE, DWORD, DWORD, WORD)
データ32ビット書き込み
MC_MoveAbsolute
DWORD MC_MoveAbsolute(DWORD, MC_AXIS_REF *, MC_MOVE_ABSOLUTE_IN *, MC_MOVE_ABSOLUTE_OUT *, WORD)
絶対位置決め
MC_GroupAxesReadError
DWORD MC_GroupAxesReadError(DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_ERROR *, WORD)
軸グループに追加された軸のエラーコードの読込み
EC_SetDiagnosisMessageFlags
DWORD EC_SetDiagnosisMessageFlags(DWORD, BYTE, EC_DIAGNOSIS_MESSAGE_FLAGS *, WORD)
スレーブの診断メッセージ設定
MC_MovePath
DWORD MC_MovePath(DWORD, MC_AXES_GROUP_REF *, MC_PATH_DATA_REF *, MC_MOVE_PATH_IN *, MC_MOVE_PATH_OUT *, WORD)
指定のパスデータを使用して，動作の連続実行
MC_SetGroupSetting
DWORD MC_SetGroupSetting(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SETTING *, WORD)
軸グループのパラメータの設定
MC_GroupReadStatus
DWORD MC_GroupReadStatus(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_STATUS *, WORD)
軸グループの状態遷移のステータス，モーションステータスの読込み
MC_ReadStatus
DWORD MC_ReadStatus(DWORD, MC_AXIS_REF *, MC_STATUS *, WORD)
状態遷移のステータス読み込み
IO_Groupoutpw
DWORD IO_Groupoutpw(DWORD, MC_AXES_GROUP_REF *, DWORD, WORD[], WORD)
軸グループに追加された軸のPDOデータ16ビットの書き込み
MC_GroupReadConfiguration
DWORD MC_GroupReadConfiguration(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_CONFIG_IN *, MC_GROUP_READ_CONFIG_OUT *, WORD)
軸グループに追加された軸の情報の読込み
EC_ReadLogPositionStatus
DWORD EC_ReadLogPositionStatus(DWORD, EC_LOGPOS_STATUS *, WORD)
ログ(指令・現在位置)の記録状態の読込み
MC_GroupReadActualPosition
DWORD MC_GroupReadActualPosition(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_READ_ACT_POS_IN *, MC_GROUP_READ_ACT_POS_OUT *, WORD)
軸グループの現在位置の読込み
MC_GroupAxesReadMotionState
DWORD MC_GroupAxesReadMotionState(DWORD, MC_AXES_GROUP_REF *, MC_AXES_READ_MOTION_STATE *, WORD)
軸グループに追加された軸のモーションステータスの読込み
MC_CancelWaitLatchCountInterrupt
DWORD MC_CancelWaitLatchCountInterrupt(DWORD, MC_AXIS_REF *, WORD)
タッチプローブの実行完了待機キャンセル
EC_OpenMaster
DWORD EC_OpenMaster(DWORD *, EC_MASTER_INFO *, WORD)
マスタオープン( EtherCAT通信の開始 )
EC_CloseMaster
DWORD EC_CloseMaster(DWORD, WORD)
マスタクローズ( EtherCAT通信の停止 )
MC_GroupSetOverride
DWORD MC_GroupSetOverride(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SET_OVERRIDE_IN *, WORD)
軸グループにおける速度のオーバーライドファクタ設定
IO_outp
DWORD IO_outp(DWORD, BYTE, DWORD, BYTE, WORD)
データ8ビット書き込み
MC_DeleteBuffer
DWORD MC_DeleteBuffer(DWORD, MC_AXIS_REF *, WORD)
バッファ待機中の関数を削除
MC_TouchProbe
DWORD MC_TouchProbe(DWORD, MC_AXIS_REF *, MC_TOUCH_PROBE_IN *, MC_TOUCH_PROBE_OUT *, WORD)
トリガーイベントによる現在位置読み込み
MC_AddAxisToGroup
DWORD MC_AddAxisToGroup(DWORD, MC_AXES_GROUP_REF *, MC_AXIS_REF *, MC_GROUP_ADD_AXIS *, WORD)
軸を軸グループに追加
MC_GetGroupSetting
DWORD MC_GetGroupSetting(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_SETTING *, WORD)
軸グループのパラメータの取得
MC_RemoveAxisFromGroup
DWORD MC_RemoveAxisFromGroup(DWORD, MC_AXES_GROUP_REF *, MC_GROUP_REMOVE_AXIS *, WORD)
指定の軸を軸グループから削除
EC_DELAY_TIMER
[In] MC_SetDelayTimer
Definition: hmecw0_struct.h:492
EC_DIAGNOSIS_MESSAGE_FLAGS
[In] EC_SetDiagnosisMessageFlags
Definition: hmecw0_struct.h:451
EC_GET_DIAGNOSIS_MESSAGE_OUT
[Out] EC_GetDiagnosisMessage
Definition: hmecw0_struct.h:479
EC_GET_SLAVE_INFO_IN
[In] EC_GetSlaveInfo
Definition: hmecw0_struct.h:415
EC_LOGPOS_STATUS
[In] EC_ReadLogPositionStatus
Definition: hmecw0_struct.h:908
EC_MASTER_INFO
[In] EC_GetMasterInfom, EC_OpenMaster
Definition: hmecw0_struct.h:399
EC_SAVE_LOGPOS
[In] EC_SaveLogPosition
Definition: hmecw0_struct.h:918
EC_SLAVE_INFO
[In] EC_GetSlaveInfo
Definition: hmecw0_struct.h:424
EC_START_LOGPOS
[In] EC_StartLogPosition
Definition: hmecw0_struct.h:928
EC_VERSION
[Out] EC_ReadVersion
Definition: hmecw0_struct.h:503
MC_ACTUAL_POSITION
[In] MC_SetPosition
Definition: hmecw0_struct.h:126
MC_ACTUAL_VELOCITY
[Out] MC_ReadActualVelocity
Definition: hmecw0_struct.h:133
MC_AXES_GROUP_REF
[Handle] Group関数全般ハンドル
Definition: hmecw0_struct.h:515
MC_AXES_READ_ERROR
[Out] MC_GroupAxesReadError
Definition: hmecw0_struct.h:899
MC_AXES_READ_INFO
[Out] MC_GroupAxesReadInfo
Definition: hmecw0_struct.h:882
MC_AXES_READ_MOTION_STATE
[Out] MC_GroupAxesReadMotionState
Definition: hmecw0_struct.h:863
MC_AXES_READ_STATUS
[Out] MC_GroupAxesReadStatus
Definition: hmecw0_struct.h:844
MC_AXIS_ERROR
[Out] MC_ReadAxisError
Definition: hmecw0_struct.h:118
MC_AXIS_INFO
[Out] MC_ReadAxisInfo
Definition: hmecw0_struct.h:140
MC_AXIS_REF
軸情報を格納する構造体
Definition: hmecw0_struct.h:13
MC_AXIS_SETTING
[Out] MC_GetAxisSetting
Definition: hmecw0_struct.h:83
MC_GROUP_ADD_AXIS
[In] MC_AddAxisToGroup
Definition: hmecw0_struct.h:525
MC_GROUP_HOME_IN
[In] MC_GroupHome
Definition: hmecw0_struct.h:708
MC_GROUP_HOME_OUT
[Out] MC_GroupHome
Definition: hmecw0_struct.h:720
MC_GROUP_MOVE_FUNCTION_RESULT
[Out] MC_GroupReadFunctionResult
Definition: hmecw0_struct.h:699
MC_GROUP_READ_ACT_POS_IN
[In] MC_GroupReadActualPosition
Definition: hmecw0_struct.h:585
MC_GROUP_READ_ACT_POS_OUT
[In] MC_GroupReadActualPosition
Definition: hmecw0_struct.h:592
MC_GROUP_READ_ACT_VEL_IN
[In] MC_GroupReadActualVelocity
Definition: hmecw0_struct.h:599
MC_GROUP_READ_ACT_VEL_OUT
[Out] MC_GroupReadActualVelocity
Definition: hmecw0_struct.h:606
MC_GROUP_READ_BUFFER_OUT
[Out] MC_GroupReadBuffer
Definition: hmecw0_struct.h:800
MC_GROUP_READ_CONFIG_IN
[In] MC_GroupReadConfiguration
Definition: hmecw0_struct.h:539
MC_GROUP_READ_CONFIG_OUT
[Out] MC_GroupReadConfiguration
Definition: hmecw0_struct.h:546
MC_GROUP_READ_ERROR
[Out] MC_GroupReadError
Definition: hmecw0_struct.h:622
MC_GROUP_READ_PATH_DATA_OUT
[Out] MC_GroupReadPathData
Definition: hmecw0_struct.h:681
MC_GROUP_READ_STATUS
[Out] MC_GroupReadStatus
Definition: hmecw0_struct.h:614
MC_GROUP_REMOVE_AXIS
[In] MC_RemoveAxisFromGroup
Definition: hmecw0_struct.h:532
MC_GROUP_RESET_OUT
[Out] MC_GroupReset
Definition: hmecw0_struct.h:629
MC_GROUP_SET_OVERRIDE_IN
[Out] MC_GroupReadPathData
Definition: hmecw0_struct.h:690
MC_GROUP_SET_POSITION
[In] MC_GroupSetPosition
Definition: hmecw0_struct.h:575
MC_GROUP_SETTING
[In] MC_SetGroupSetting
Definition: hmecw0_struct.h:568
MC_GROUP_STOP_IN
[In] MC_GroupStop
Definition: hmecw0_struct.h:728
MC_GROUP_STOP_OUT
[Out] MC_GroupStop
Definition: hmecw0_struct.h:737
MC_HOME_IN
[In] MC_Home
Definition: hmecw0_struct.h:205
MC_HOME_OUT
[Out] MC_Home
Definition: hmecw0_struct.h:228
MC_LATCH_COUNT_REF
[In] MC_ReadLatchCountResult
Definition: hmecw0_struct.h:392
MC_LATCH_COUNT_RESULT
[Out] MC_ReadLatchCountResult
Definition: hmecw0_struct.h:365
MC_MOTION_STATE
[Out] MC_ReadMotionState
Definition: hmecw0_struct.h:147
MC_MOVE_ABSOLUTE_IN
[In] MC_MoveAbsolute
Definition: hmecw0_struct.h:252
MC_MOVE_ABSOLUTE_OUT
[Out] MC_MoveAbsolute
Definition: hmecw0_struct.h:265
MC_MOVE_ADDITIVE_IN
[In] MC_MoveAdditive
Definition: hmecw0_struct.h:293
MC_MOVE_ADDITIVE_OUT
[Out] MC_MoveAdditive
Definition: hmecw0_struct.h:305
MC_MOVE_FUNCTION_RESULT
[Out] MC_ReadFunctionResult
Definition: hmecw0_struct.h:333
MC_MOVE_LINEAR_ABS_IN
[In] MC_MoveLinearAbsolute
Definition: hmecw0_struct.h:745
MC_MOVE_LINEAR_ABS_OUT
[Out] MC_MoveLinearAbsolute
Definition: hmecw0_struct.h:757
MC_MOVE_LINEAR_REL_IN
[In] MC_MoveLinearRelative
Definition: hmecw0_struct.h:765
MC_MOVE_LINEAR_REL_OUT
[In] MC_MoveLinearRelative
Definition: hmecw0_struct.h:777
MC_MOVE_LINEAR_VEL_IN
[In] MC_MoveLinearVelocity
Definition: hmecw0_struct.h:810
MC_MOVE_LINEAR_VEL_OUT
[Out] MC_MoveLinearVelocity
Definition: hmecw0_struct.h:826
MC_MOVE_PATH_IN
[In] MC_MovePath
Definition: hmecw0_struct.h:655
MC_MOVE_PATH_OUT
[Out] MC_MovePath
Definition: hmecw0_struct.h:671
MC_MOVE_RELATIVE_IN
[In] MC_MoveRelative
Definition: hmecw0_struct.h:273
MC_MOVE_RELATIVE_OUT
[Out] MC_MoveRelative
Definition: hmecw0_struct.h:285
MC_MOVE_VELOCITY_IN
[In] MC_MoveVelocitiy
Definition: hmecw0_struct.h:313
MC_MOVE_VELOCITY_OUT
[Out] MC_MoveVelocitiy
Definition: hmecw0_struct.h:325
MC_PATH_DATA_REF
[Struct] MC_GROUP_READ_PATH_DATA_OUT
Definition: hmecw0_struct.h:638
MC_POWER_IN
[Out] MC_GetAxisSetting, MC_SetAxisSetting
Definition: hmecw0_struct.h:93
MC_POWER_OUT
[Out] MC_GetAxisSetting, MC_SetAxisSetting
Definition: hmecw0_struct.h:102
MC_PROBE_STATUS
[Out] MC_ReadProbeStatus
Definition: hmecw0_struct.h:381
MC_READ_BUFFER_OUT
[Out] MC_ReadBuffer
Definition: hmecw0_struct.h:356
MC_RESET_OUT
[Out] MC_Reset
Definition: hmecw0_struct.h:197
MC_SET_OVERRIDE_IN
[In] MC_SetOverride
Definition: hmecw0_struct.h:154
MC_STATUS
[Out] MC_ReadStatus
Definition: hmecw0_struct.h:111
MC_STOP_IN
[In] MC_Stop
Definition: hmecw0_struct.h:236
MC_STOP_OUT
[Out] MC_Stop
Definition: hmecw0_struct.h:244
MC_TOUCH_PROBE_IN
[In] MC_TouchProbe
Definition: hmecw0_struct.h:177
MC_TOUCH_PROBE_OUT
[In] MC_TouchProbe
Definition: hmecw0_struct.h:189
MC_TRIGGER_REF
[Struct] MC_TOUCH_PROBE_IN
Definition: hmecw0_struct.h:164


HLS-ECAT02WIN APIリファレンス: データ構造

データ構造
データ構造一覧です。
C EC_DELAY_TIMER | [In] MC_SetDelayTimer
C EC_DIAGNOSIS_MESSAGE_FLAGS | [In] EC_SetDiagnosisMessageFlags
C EC_DIAGNOSIS_PARAMETER | [Struct] EC_GET_DIAGNOSIS_MESSAGE_OUT
C EC_GET_DIAGNOSIS_MESSAGE_OUT | [Out] EC_GetDiagnosisMessage
C EC_GET_SLAVE_INFO_IN | [In] EC_GetSlaveInfo
C EC_LOGPOS_STATUS | [In] EC_ReadLogPositionStatus
C EC_MASTER_INFO | [In] EC_GetMasterInfom, EC_OpenMaster
C EC_SAVE_LOGPOS | [In] EC_SaveLogPosition
C EC_SLAVE_INFO | [In] EC_GetSlaveInfo
C EC_START_LOGPOS | [In] EC_StartLogPosition
C EC_VERSION | [Out] EC_ReadVersion
C MC_ACTUAL_POSITION | [In] MC_SetPosition
C MC_ACTUAL_VELOCITY | [Out] MC_ReadActualVelocity
C MC_AXES_GROUP_REF | [Handle] Group関数全般ハンドル
C MC_AXES_READ_ERROR | [Out] MC_GroupAxesReadError
C MC_AXES_READ_INFO | [Out] MC_GroupAxesReadInfo
C MC_AXES_READ_MOTION_STATE | [Out] MC_GroupAxesReadMotionState
C MC_AXES_READ_STATUS | [Out] MC_GroupAxesReadStatus
C MC_AXIS_DRIVE | [Struct] MC_AXIS_SETTING
C MC_AXIS_ERROR | [Out] MC_ReadAxisError
C MC_AXIS_FACTOR | [Struct] MC_AXIS_SETTING
C MC_AXIS_INFO | [Out] MC_ReadAxisInfo
C MC_AXIS_MACHINE | [Struct] MC_AXIS_SETTING
C MC_AXIS_MOVE | [Struct] MC_AXIS_SETTING
C MC_AXIS_REF | 軸情報を格納する構造体
C MC_AXIS_SETTING | [Out] MC_GetAxisSetting
C MC_BUFFER_FUNC | [Struct] MC_READ_BUFFER_OUT
C MC_GROUP_ADD_AXIS | [In] MC_AddAxisToGroup
C MC_GROUP_BUFFER_FUNC | [Struct] MC_GROUP_READ_BUFFER_OUT
C MC_GROUP_HOME_IN | [In] MC_GroupHome
C MC_GROUP_HOME_OUT | [Out] MC_GroupHome
C MC_GROUP_MOVE | [Struct] MC_GROUP_SETTING
C MC_GROUP_MOVE_FUNCTION_RESULT | [Out] MC_GroupReadFunctionResult
C MC_GROUP_READ_ACT_POS_IN | [In] MC_GroupReadActualPosition
C MC_GROUP_READ_ACT_POS_OUT | [In] MC_GroupReadActualPosition
C MC_GROUP_READ_ACT_VEL_IN | [In] MC_GroupReadActualVelocity
C MC_GROUP_READ_ACT_VEL_OUT | [Out] MC_GroupReadActualVelocity
C MC_GROUP_READ_BUFFER_OUT | [Out] MC_GroupReadBuffer
C MC_GROUP_READ_CONFIG_IN | [In] MC_GroupReadConfiguration
C MC_GROUP_READ_CONFIG_OUT | [Out] MC_GroupReadConfiguration
C MC_GROUP_READ_ERROR | [Out] MC_GroupReadError
C MC_GROUP_READ_PATH_DATA_OUT | [Out] MC_GroupReadPathData
C MC_GROUP_READ_STATUS | [Out] MC_GroupReadStatus
C MC_GROUP_REMOVE_AXIS | [In] MC_RemoveAxisFromGroup
C MC_GROUP_RESET_OUT | [Out] MC_GroupReset
C MC_GROUP_SET_OVERRIDE_IN | [Out] MC_GroupReadPathData
C MC_GROUP_SET_POSITION | [In] MC_GroupSetPosition
C MC_GROUP_SETTING | [In] MC_SetGroupSetting
C MC_GROUP_STOP_IN | [In] MC_GroupStop
C MC_GROUP_STOP_OUT | [Out] MC_GroupStop
C MC_HOME_IN | [In] MC_Home
C MC_HOME_OUT | [Out] MC_Home
C MC_LATCH_COUNT_REF | [In] MC_ReadLatchCountResult
C MC_LATCH_COUNT_RESULT | [Out] MC_ReadLatchCountResult
C MC_MOTION_STATE | [Out] MC_ReadMotionState
C MC_MOVE_ABSOLUTE_IN | [In] MC_MoveAbsolute
C MC_MOVE_ABSOLUTE_OUT | [Out] MC_MoveAbsolute
C MC_MOVE_ADDITIVE_IN | [In] MC_MoveAdditive
C MC_MOVE_ADDITIVE_OUT | [Out] MC_MoveAdditive
C MC_MOVE_FUNCTION_RESULT | [Out] MC_ReadFunctionResult
C MC_MOVE_LINEAR_ABS_IN | [In] MC_MoveLinearAbsolute
C MC_MOVE_LINEAR_ABS_OUT | [Out] MC_MoveLinearAbsolute
C MC_MOVE_LINEAR_REL_IN | [In] MC_MoveLinearRelative
C MC_MOVE_LINEAR_REL_OUT | [In] MC_MoveLinearRelative
C MC_MOVE_LINEAR_VEL_IN | [In] MC_MoveLinearVelocity
C MC_MOVE_LINEAR_VEL_OUT | [Out] MC_MoveLinearVelocity
C MC_MOVE_PATH_IN | [In] MC_MovePath
C MC_MOVE_PATH_OUT | [Out] MC_MovePath
C MC_MOVE_RELATIVE_IN | [In] MC_MoveRelative
C MC_MOVE_RELATIVE_OUT | [Out] MC_MoveRelative
C MC_MOVE_VELOCITY_IN | [In] MC_MoveVelocitiy
C MC_MOVE_VELOCITY_OUT | [Out] MC_MoveVelocitiy
C MC_PATH_DATA_REF | [Struct] MC_GROUP_READ_PATH_DATA_OUT
C MC_POWER_IN | [Out] MC_GetAxisSetting, MC_SetAxisSetting
C MC_POWER_OUT | [Out] MC_GetAxisSetting, MC_SetAxisSetting
C MC_PROBE_STATUS | [Out] MC_ReadProbeStatus
C MC_READ_BUFFER_OUT | [Out] MC_ReadBuffer
C MC_RESET_OUT | [Out] MC_Reset
C MC_SET_OVERRIDE_IN | [In] MC_SetOverride
C MC_STATUS | [Out] MC_ReadStatus
C MC_STOP_IN | [In] MC_Stop
C MC_STOP_OUT | [Out] MC_Stop
C MC_TOUCH_PROBE_IN | [In] MC_TouchProbe
C MC_TOUCH_PROBE_OUT | [In] MC_TouchProbe
C MC_TRIGGER_REF | [Struct] MC_TOUCH_PROBE_IN
C READ_AXIS_INFO | [Struct] MC_AXES_READ_INFO
C READ_ERROR | [Struct] MC_AXES_READ_ERROR
C READ_MOTION_STATE | [Struct] MC_AXES_READ_MOTION_STATE
C READ_STATUS | [Struct] MC_AXES_READ_STATUS


HLS-ECAT02WIN APIリファレンス: EC_DELAY_TIMER 構造体

フィールド
EC_DELAY_TIMER 構造体

[In] MC_SetDelayTimer [詳解]

#include <hmecw0_struct.h>

フィールド

long | lMvAbsDelay
DelayTime: MC_MoveAbsolute
[単位] ms
[範囲] 0 - 2147483647 [詳解]
long | lMvAddDelay
DelayTime: MC_MoveAdditive
[単位] ms
[範囲] 0 - 2147483647 [詳解]
long | lMvRelDelay
DelayTime: MC_MoveRelative
[単位] ms
[範囲] 0 - 2147483647 [詳解]
long | lMvHmDelay
DelayTime: MC_Home
[単位] ms
[範囲] 0 - 2147483647 [詳解]
long | lMvVelDelay
DelayTime: MC_MoveVelocity
[単位] ms
[範囲] 0 - 2147483647 [詳解]

詳解

[In] MC_SetDelayTimer

[Out] MC_ReadDelayTimer

フィールド詳解

◆ lMvAbsDelay

long lMvAbsDelay

DelayTime: MC_MoveAbsolute
[単位] ms
[範囲] 0 - 2147483647

◆ lMvAddDelay

long lMvAddDelay

DelayTime: MC_MoveAdditive
[単位] ms
[範囲] 0 - 2147483647

◆ lMvRelDelay

long lMvRelDelay

DelayTime: MC_MoveRelative
[単位] ms
[範囲] 0 - 2147483647

◆ lMvHmDelay

long lMvHmDelay

DelayTime: MC_Home
[単位] ms
[範囲] 0 - 2147483647

◆ lMvVelDelay

long lMvVelDelay

DelayTime: MC_MoveVelocity
[単位] ms
[範囲] 0 - 2147483647

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_DIAGNOSIS_MESSAGE_FLAGS 構造体

フィールド
EC_DIAGNOSIS_MESSAGE_FLAGS 構造体

[In] EC_SetDiagnosisMessageFlags [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bEnableEmergensy
診断メッセージをエマージェンシメッセージとして通知するか
[値] FALSE:無効，TRUE:有効 [詳解]
BOOL | bDisableInfMes
InfoMessage無効
[値]
FALSE: InfoMessageをDiagnosis messageに保存します
TRUE: InfoMessageをDiagnosis messageに保存しません． [詳解]
BOOL | bDisableWarnMes
WarningMessage無効
[値]
FALSE： WarningMessageをDiagnosis messageに保存します
TRUE: WarningMessageをDiagnosis messageに保存しません． [詳解]
BOOL | bDisableErrMes
ErrorMEssage無効
[値]
FALSE: ErrorMessageをDiagnosis messageに保存します
TRUE: ErrorMessageをDiagnosis messageに保存しません． [詳解]
BOOL | bModeSelect
OverWrite/Acknowlededモード選択
[値]
FALSE: OverWrite: 未承認データが存在していてもリングバッファに上書きします
TRUE: Acknowleded: リングバッファがFULLになった場合，上書きせず新しいメッセージを破棄しません． [詳解]

詳解

[In] EC_SetDiagnosisMessageFlags

[Out] EC_GetDiagnosisMessageFlags

フィールド詳解

◆ bEnableEmergensy

BOOL bEnableEmergensy

診断メッセージをエマージェンシメッセージとして通知するか
[値] FALSE:無効，TRUE:有効

◆ bDisableInfMes

BOOL bDisableInfMes

InfoMessage無効
[値]
FALSE: InfoMessageをDiagnosis messageに保存します
TRUE: InfoMessageをDiagnosis messageに保存しません．

◆ bDisableWarnMes

BOOL bDisableWarnMes

WarningMessage無効
[値]
FALSE： WarningMessageをDiagnosis messageに保存します
TRUE: WarningMessageをDiagnosis messageに保存しません．

◆ bDisableErrMes

BOOL bDisableErrMes

ErrorMEssage無効
[値]
FALSE: ErrorMessageをDiagnosis messageに保存します
TRUE: ErrorMessageをDiagnosis messageに保存しません．

◆ bModeSelect

BOOL bModeSelect

OverWrite/Acknowlededモード選択
[値]
FALSE: OverWrite: 未承認データが存在していてもリングバッファに上書きします
TRUE: Acknowleded: リングバッファがFULLになった場合，上書きせず新しいメッセージを破棄しません．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_DIAGNOSIS_PARAMETER 構造体

フィールド
EC_DIAGNOSIS_PARAMETER 構造体

[Struct] EC_GET_DIAGNOSIS_MESSAGE_OUT [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wFlags
診断メッセージのパラメータタイプ
[値]
<bit12-15=0>
1: BOOL
2: INTEGER8
3: INTEGER16
4: INTEGER32
5: UNSIGNED8
6: UNSIGNED16
7: UNSIGNED32
<bit12-15=1>
BYTE配列
<bit12-15=2>
ASCII配列 [詳解]
BOOL | bBoolParameter
診断メッセージのBOOLデータ [詳解]
char | cInt8Parameter
診断メッセージのINTEGER8データ [詳解]
short | sInt16Parameter
診断メッセージのINTEGER16データ． [詳解]
long | lInt32Parameter
診断メッセージのINTEGER32データ [詳解]
BYTE | bUnsigned8Parameter
診断メッセージのUNSIGNED8データ [詳解]
WORD | wUnsigned16Parameter
診断メッセージのUNSIGNED16データ． [詳解]
DWORD | dwUnsigned32Parameter
診断メッセージのUNSIGNED32データ [詳解]
BYTE | bByteArrayParameter [64]
診断メッセージのBYTE配列データ [詳解]
char | cStrParameter [64]
診断メッセージのASCII配列データ． [詳解]

詳解

[Struct] EC_GET_DIAGNOSIS_MESSAGE_OUT

[Out] EC_GetDiagnosisMessage

フィールド詳解

◆ wFlags

WORD wFlags

診断メッセージのパラメータタイプ
[値]
<bit12-15=0>
1: BOOL
2: INTEGER8
3: INTEGER16
4: INTEGER32
5: UNSIGNED8
6: UNSIGNED16
7: UNSIGNED32
<bit12-15=1>
BYTE配列
<bit12-15=2>
ASCII配列

◆ bBoolParameter

BOOL bBoolParameter

診断メッセージのBOOLデータ

◆ cInt8Parameter

char cInt8Parameter

診断メッセージのINTEGER8データ

◆ sInt16Parameter

short sInt16Parameter

診断メッセージのINTEGER16データ．

◆ lInt32Parameter

long lInt32Parameter

診断メッセージのINTEGER32データ

◆ bUnsigned8Parameter

BYTE bUnsigned8Parameter

診断メッセージのUNSIGNED8データ

◆ wUnsigned16Parameter

WORD wUnsigned16Parameter

診断メッセージのUNSIGNED16データ．

◆ dwUnsigned32Parameter

DWORD dwUnsigned32Parameter

診断メッセージのUNSIGNED32データ

◆ bByteArrayParameter

BYTE bByteArrayParameter[64]

診断メッセージのBYTE配列データ

◆ cStrParameter

char cStrParameter[64]

診断メッセージのASCII配列データ．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_GET_DIAGNOSIS_MESSAGE_OUT 構造体

フィールド
EC_GET_DIAGNOSIS_MESSAGE_OUT 構造体

[Out] EC_GetDiagnosisMessage [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | bType
診断メッセージのデータタイプ
[値]
0: InfoMessage
1: WarningMessage
2: ErrorMessage [詳解]
WORD | wTextID
診断メッセージのテキストID
[範囲] 0 - 65535 [詳解]
DWORD | dwTimeStampL
診断メッセージのタイムスタンプ下位データ
[範囲] 0 - 4294967295 [詳解]
DWORD | dwTimeStampH
診断メッセージのタイムスタンプ上位データ
[範囲] 0 - 4294967295 [詳解]
BYTE | bParameterNum
診断メッセージのパラメータ数
[範囲] 0 - 255 [詳解]
EC_DIAGNOSIS_PARAMETER | Parameter [64]
診断メッセージのパラメータ [詳解]

詳解

[Out] EC_GetDiagnosisMessage

フィールド詳解

◆ bType

BYTE bType

診断メッセージのデータタイプ
[値]
0: InfoMessage
1: WarningMessage
2: ErrorMessage

◆ wTextID

WORD wTextID

診断メッセージのテキストID
[範囲] 0 - 65535

◆ dwTimeStampL

DWORD dwTimeStampL

診断メッセージのタイムスタンプ下位データ
[範囲] 0 - 4294967295

◆ dwTimeStampH

DWORD dwTimeStampH

診断メッセージのタイムスタンプ上位データ
[範囲] 0 - 4294967295

◆ bParameterNum

BYTE bParameterNum

診断メッセージのパラメータ数
[範囲] 0 - 255

◆ Parameter

EC_DIAGNOSIS_PARAMETER Parameter[64]

診断メッセージのパラメータ

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_GET_SLAVE_INFO_IN 構造体

フィールド
EC_GET_SLAVE_INFO_IN 構造体

[In] EC_GetSlaveInfo [詳解]

#include <hmecw0_struct.h>

フィールド

DWORD | dwInstance
インスタンス番号
[範囲] 0 - 4294967295 [詳解]
DWORD | dwVendorID
ベンダーID
[範囲] 0 - 4294967295 [詳解]
DWORD | dwProductCode
プロダクトコード
[範囲] 0 - 4294967295 [詳解]

詳解

[In] EC_GetSlaveInfo

フィールド詳解

◆ dwInstance

DWORD dwInstance

インスタンス番号
[範囲] 0 - 4294967295

◆ dwVendorID

DWORD dwVendorID

ベンダーID
[範囲] 0 - 4294967295

◆ dwProductCode

DWORD dwProductCode

プロダクトコード
[範囲] 0 - 4294967295

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_LOGPOS_STATUS 構造体

フィールド
EC_LOGPOS_STATUS 構造体

[In] EC_ReadLogPositionStatus [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ログの記録状態
[範囲]
0: ログが存在しない
1: ログの記録中
2: ログの記録停止中 [詳解]
double | fMaxTime
ログ記録最大時間
[単位] ms
[範囲] 0 - 84000 [詳解]
double | fActTime
記録したログの時間
[単位] ms
[範囲] 0 - 84000 [詳解]

詳解

[In] EC_ReadLogPositionStatus

フィールド詳解

◆ wStatus

WORD wStatus

ログの記録状態
[範囲]
0: ログが存在しない
1: ログの記録中
2: ログの記録停止中

◆ fMaxTime

double fMaxTime

ログ記録最大時間
[単位] ms
[範囲] 0 - 84000

◆ fActTime

double fActTime

記録したログの時間
[単位] ms
[範囲] 0 - 84000

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_MASTER_INFO 構造体

フィールド
EC_MASTER_INFO 構造体

[In] EC_GetMasterInfom, EC_OpenMaster [詳解]

#include <hmecw0_struct.h>

フィールド

char | cMasterName [12]
INtimeノード名 [詳解]
DWORD | dwCyclicTime
サイクリックタイム
[単位] μs [詳解]
BYTE | bBasePrioriy
EcatHandlerスレッドベースプライオリティ [詳解]
char | cInterfaceDriver [16]
使用するNICインターフェースドライバ.
二重化回線の場合は1番目のNICインターフェースドライバ [詳解]
char | cRedundancyDriver [16]
二重化回線の場合の2番目のNICインターフェースドライバ [詳解]
WORD | wSlaveCountXml
コンフィグレーション(XML)定義上のスレーブ数 [詳解]
WORD | wSlaveCountOnline
接続しているスレーブ数 [詳解]
DWORD | dwPdoInSize
PDO_IN全体のサイズ [詳解]
DWORD | dwPdoOutSize
PDO_OUT全体のサイズ [詳解]
DWORD | hMasterHandle
マスターハンドル [詳解]

詳解

[In] EC_GetMasterInfom, EC_OpenMaster

フィールド詳解

◆ cMasterName

char cMasterName[12]

INtimeノード名

◆ dwCyclicTime

DWORD dwCyclicTime

サイクリックタイム
[単位] μs

◆ bBasePrioriy

BYTE bBasePrioriy

EcatHandlerスレッドベースプライオリティ

◆ cInterfaceDriver

char cInterfaceDriver[16]

使用するNICインターフェースドライバ.
二重化回線の場合は1番目のNICインターフェースドライバ

◆ cRedundancyDriver

char cRedundancyDriver[16]

二重化回線の場合の2番目のNICインターフェースドライバ

◆ wSlaveCountXml

WORD wSlaveCountXml

コンフィグレーション(XML)定義上のスレーブ数

◆ wSlaveCountOnline

WORD wSlaveCountOnline

接続しているスレーブ数

◆ dwPdoInSize

DWORD dwPdoInSize

PDO_IN全体のサイズ

◆ dwPdoOutSize

DWORD dwPdoOutSize

PDO_OUT全体のサイズ

◆ hMasterHandle

DWORD hMasterHandle

マスターハンドル

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_SAVE_LOGPOS 構造体

フィールド
EC_SAVE_LOGPOS 構造体

[In] EC_SaveLogPosition [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | byFormat
保存するファイル形式
[範囲]
1以外: txt
1: csv [詳解]
char * | pName
ファイル名.
[未設定(NULL)の場合] ファイル名 "hvt時_分_秒" [詳解]
char * | pPath
ファイルを保存するパス. [未設定(NULL)の場合] exeを実行したパスにファイルが保存されます. [詳解]

詳解

[In] EC_SaveLogPosition

フィールド詳解

◆ byFormat

BYTE byFormat

保存するファイル形式
[範囲]
1以外: txt
1: csv

◆ pName

char* pName

ファイル名.
[未設定(NULL)の場合] ファイル名 "hvt時_分_秒"

◆ pPath

char* pPath

ファイルを保存するパス. [未設定(NULL)の場合] exeを実行したパスにファイルが保存されます.

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_SLAVE_INFO 構造体

フィールド
EC_SLAVE_INFO 構造体

[In] EC_GetSlaveInfo [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | bSlaveNo
スレーブノード番号
[範囲] 0 - 255 [詳解]
BYTE | bAxisNo
軸ノード番号
[範囲] 0 - 255 [詳解]
WORD | wSlaveStatus
(予約) [詳解]
WORD | wAlias
エイリアス番号
[範囲] 0 - 65535 [詳解]
WORD | wSlaveType
スレーブタイプ
[範囲] 0 - 65535 [詳解]
DWORD | dwInstance
インスタンス番号
[範囲] 0 - 4294967295 [詳解]
DWORD | dwVendorID
ベンダーID
[範囲] 0 - 4294967295 [詳解]
DWORD | dwProductCode
プロダクトコード
[範囲] 0 - 4294967295 [詳解]
DWORD | dwRevisionNo
リビジョンナンバー
[範囲] 0 - 4294967295 [詳解]
DWORD | dwSerialNo
シリアルナンバー
[範囲] 0 - 4294967295 [詳解]
DWORD | dwPhysicalAddr
フィジカルアドレス
[範囲] 0 - 4294967295 [詳解]
DWORD | dwAutoIncAddr
自動インクリメントアドレス
[範囲] 0 - 4294967295 [詳解]
DWORD | dwStatusBit
スレーブステータスビット
[範囲] 0 - 4294967295 [詳解]
DWORD | dwViosInBaseOffset
VIOS IN ベースオフセット
[範囲] 0 - 4294967295 [詳解]
DWORD | dwViosInSize
VIOS IN サイズ[byte]
[範囲] 0 - 4294967295 [詳解]
DWORD | dwViosOutBaseOffset
VIOS OUT ベースオフセット
[範囲] 0 - 4294967295 [詳解]
DWORD | dwViosOutSize
VIOS OUT サイズ[byte]
[範囲] 0 - 4294967295 [詳解]
DWORD | dwDCEnable
DC設定
[値] 0: 無効 0以外: 有効 [詳解]

詳解

[In] EC_GetSlaveInfo

フィールド詳解

◆ bSlaveNo

BYTE bSlaveNo

スレーブノード番号
[範囲] 0 - 255

◆ bAxisNo

BYTE bAxisNo

軸ノード番号
[範囲] 0 - 255

◆ wSlaveStatus

WORD wSlaveStatus

(予約)

◆ wAlias

WORD wAlias

エイリアス番号
[範囲] 0 - 65535

◆ wSlaveType

WORD wSlaveType

スレーブタイプ
[範囲] 0 - 65535

◆ dwInstance

DWORD dwInstance

インスタンス番号
[範囲] 0 - 4294967295

◆ dwVendorID

DWORD dwVendorID

ベンダーID
[範囲] 0 - 4294967295

◆ dwProductCode

DWORD dwProductCode

プロダクトコード
[範囲] 0 - 4294967295

◆ dwRevisionNo

DWORD dwRevisionNo

リビジョンナンバー
[範囲] 0 - 4294967295

◆ dwSerialNo

DWORD dwSerialNo

シリアルナンバー
[範囲] 0 - 4294967295

◆ dwPhysicalAddr

DWORD dwPhysicalAddr

フィジカルアドレス
[範囲] 0 - 4294967295

◆ dwAutoIncAddr

DWORD dwAutoIncAddr

自動インクリメントアドレス
[範囲] 0 - 4294967295

◆ dwStatusBit

DWORD dwStatusBit

スレーブステータスビット
[範囲] 0 - 4294967295

◆ dwViosInBaseOffset

DWORD dwViosInBaseOffset

VIOS IN ベースオフセット
[範囲] 0 - 4294967295

◆ dwViosInSize

DWORD dwViosInSize

VIOS IN サイズ[byte]
[範囲] 0 - 4294967295

◆ dwViosOutBaseOffset

DWORD dwViosOutBaseOffset

VIOS OUT ベースオフセット
[範囲] 0 - 4294967295

◆ dwViosOutSize

DWORD dwViosOutSize

VIOS OUT サイズ[byte]
[範囲] 0 - 4294967295

◆ dwDCEnable

DWORD dwDCEnable

DC設定
[値] 0: 無効 0以外: 有効

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_START_LOGPOS 構造体

フィールド
EC_START_LOGPOS 構造体

[In] EC_StartLogPosition [詳解]

#include <hmecw0_struct.h>

フィールド

double fTime

詳解

[In] EC_StartLogPosition

フィールド詳解

◆ fTime

double fTime

ログ記録時間
[単位] ms
[範囲] 0 - 84000 [備考] 値が 0 の時，1ms のログを記録します．サイクル周期の設定により，設定可能な最大の範囲が変化します．
[サイクル周期の設定が，1ms 以下の場合]
125μs(0.5ms)： 最大 10500 [ms]
250μs(0.25ms)： 最大 21000 [ms]
500μs(0.5ms)： 最大 42000 [ms]
[サイクル周期の設定が，1ms 以上の場合]
最大 84000 [ms]

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: EC_VERSION 構造体

フィールド
EC_VERSION 構造体

[Out] EC_ReadVersion [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wAxisNum
契約軸数 [詳解]
BYTE | bVersion [16]
モーション機能パックライブラリバージョン [詳解]

詳解

[Out] EC_ReadVersion

フィールド詳解

◆ wAxisNum

WORD wAxisNum

契約軸数

◆ bVersion

BYTE bVersion[16]

モーション機能パックライブラリバージョン

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_ACTUAL_POSITION 構造体

フィールド
MC_ACTUAL_POSITION 構造体

[In] MC_SetPosition [詳解]

#include <hmecw0_struct.h>

フィールド

double fPosition
現在位置
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]

詳解

[In] MC_SetPosition

[Out] MC_ReadActualPosition

フィールド詳解

◆ fPosition

double fPosition

現在位置
[単位] pulse
[範囲] -2147483647 - 2147483648

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_ACTUAL_VELOCITY 構造体

フィールド
MC_ACTUAL_VELOCITY 構造体

[Out] MC_ReadActualVelocity [詳解]

#include <hmecw0_struct.h>

フィールド

double fVelocity
現在速度
[単位] pps
[範囲] 0 - 2147483647 [詳解]

詳解

[Out] MC_ReadActualVelocity

フィールド詳解

◆ fVelocity

double fVelocity

現在速度
[単位] pps
[範囲] 0 - 2147483647

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXES_GROUP_REF 構造体

フィールド
MC_AXES_GROUP_REF 構造体

[Handle] Group関数全般ハンドル [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | byGroupID
軸グループの識別番号
[範囲] 1 - 32 [詳解]
BYTE | bySyncAxis
軸グループの軸数
[範囲] 0 - 32 [詳解]
MC_AXIS_REF | stAxis [32]
軸グループの軸情報を格納する構造体 [詳解]

詳解

[Handle] Group関数全般ハンドル

フィールド詳解

◆ byGroupID

BYTE byGroupID

軸グループの識別番号
[範囲] 1 - 32

◆ bySyncAxis

BYTE bySyncAxis

軸グループの軸数
[範囲] 0 - 32

◆ stAxis

MC_AXIS_REF stAxis[32]

軸グループの軸情報を格納する構造体

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXES_READ_ERROR 構造体

フィールド
MC_AXES_READ_ERROR 構造体

[Out] MC_GroupAxesReadError [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wErrorID
エラーID
[範囲] 0-0xFFFF.. [詳解]
READ_ERROR | AxisError [32]
軸グループに軸のエラーコードを格納する構造体 [詳解]

詳解

[Out] MC_GroupAxesReadError

フィールド詳解

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF..

◆ AxisError

READ_ERROR AxisError[32]

軸グループに軸のエラーコードを格納する構造体

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXES_READ_INFO 構造体

フィールド
MC_AXES_READ_INFO 構造体

[Out] MC_GroupAxesReadInfo [詳解]

#include <hmecw0_struct.h>

フィールド

READ_AXIS_INFO AxisInfo [32]
軸の軸情報を格納する構造体． [詳解]

詳解

[Out] MC_GroupAxesReadInfo

フィールド詳解

◆ AxisInfo

READ_AXIS_INFO AxisInfo[32]

軸の軸情報を格納する構造体．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXES_READ_MOTION_STATE 構造体

フィールド
MC_AXES_READ_MOTION_STATE 構造体

[Out] MC_GroupAxesReadMotionState [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wPLCOpenStatus
軸グループ状態遷移ステータス
[範囲]
0x02: GroupMoving
0x04: GroupHoming
0x08: GroupErrorStop
0x10: GroupStandby
0x20: GroupStopping
0x40: GroupDisabled [詳解]
WORD | wMotionStatus
軸グループの動作状態
[値]
bit1: 定速中
bit2: 加速中
bit3: 減速中 [詳解]
READ_MOTION_STATE | MotionState [32]
軸のモーションステータスを格納する構造体． [詳解]

詳解

[Out] MC_GroupAxesReadMotionState

フィールド詳解

◆ wPLCOpenStatus

WORD wPLCOpenStatus

軸グループ状態遷移ステータス
[範囲]
0x02: GroupMoving
0x04: GroupHoming
0x08: GroupErrorStop
0x10: GroupStandby
0x20: GroupStopping
0x40: GroupDisabled

◆ wMotionStatus

WORD wMotionStatus

軸グループの動作状態
[値]
bit1: 定速中
bit2: 加速中
bit3: 減速中

◆ MotionState

READ_MOTION_STATE MotionState[32]

軸のモーションステータスを格納する構造体．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXES_READ_STATUS 構造体

フィールド
MC_AXES_READ_STATUS 構造体

[Out] MC_GroupAxesReadStatus [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wPLCOpenStatus
軸グループ状態遷移ステータス
[値]
0x02: GroupMoving
0x04: GroupHoming
0x08: GroupErrorStop
0x10: GroupStandby
0x20: GroupStopping
0x40: GroupDisabled [詳解]
WORD | wMotionStatus
軸グループの動作状態． [詳解]
READ_STATUS | Status [32]
軸のPLCOpenの状態を格納する構造体． [詳解]

詳解

[Out] MC_GroupAxesReadStatus

フィールド詳解

◆ wPLCOpenStatus

WORD wPLCOpenStatus

軸グループ状態遷移ステータス
[値]
0x02: GroupMoving
0x04: GroupHoming
0x08: GroupErrorStop
0x10: GroupStandby
0x20: GroupStopping
0x40: GroupDisabled

◆ wMotionStatus

WORD wMotionStatus

軸グループの動作状態．

◆ Status

READ_STATUS Status[32]

軸のPLCOpenの状態を格納する構造体．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_DRIVE 構造体

フィールド
MC_AXIS_DRIVE 構造体

[Struct] MC_AXIS_SETTING [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bFollowingError
位置偏差エラー検出時動作
[値] FALSE: 継続，TRUE: 即時停止． [詳解]
BOOL | bInposEnable
(予約) [詳解]
BOOL | bInposInput
(予約) [詳解]

詳解

[Struct] MC_AXIS_SETTING

フィールド詳解

◆ bFollowingError

BOOL bFollowingError

位置偏差エラー検出時動作
[値] FALSE: 継続，TRUE: 即時停止．

◆ bInposEnable

BOOL bInposEnable

(予約)

◆ bInposInput

BOOL bInposInput

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_ERROR 構造体

フィールド
MC_AXIS_ERROR 構造体

[Out] MC_ReadAxisError [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_ReadAxisError

フィールド詳解

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_FACTOR 構造体

フィールド
MC_AXIS_FACTOR 構造体

[Struct] MC_AXIS_SETTING [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wAxisType
(予約) [詳解]
WORD | wActuatorType
(予約) [詳解]
WORD | wMotorType
(予約) [詳解]
WORD | wEncType
(予約) [詳解]
WORD | wCountMode
(予約) [詳解]
double | fMaxCount
(予約) [詳解]
double | fMinCount
(予約) [詳解]

詳解

[Struct] MC_AXIS_SETTING

フィールド詳解

◆ wAxisType

WORD wAxisType

(予約)

◆ wActuatorType

WORD wActuatorType

(予約)

◆ wMotorType

WORD wMotorType

(予約)

◆ wEncType

WORD wEncType

(予約)

◆ wCountMode

WORD wCountMode

(予約)

◆ fMaxCount

double fMaxCount

(予約)

◆ fMinCount

double fMinCount

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_INFO 構造体

フィールド
MC_AXIS_INFO 構造体

[Out] MC_ReadAxisInfo [詳解]

#include <hmecw0_struct.h>

フィールド

DWORD dwAxisInfo
軸情報
bit0: 軸のエラー有無 [値] 0: 無, 1: 有
bit1: 原点入力信号 [値] 0: OFF, 1: ON
bit2: +ELS [値] 0: OFF, 1: ON
bit3: -ELS [値] 0:OFF, 1:ON
bit7: スレーブを駆動する準備が完了 [値] 0: 未完了, 1: 完了
bit8: サーボ [値] 0:OFF, 1:ON
bit9: 原点復帰完了(原点復帰方式がCiA402による方式の場合) [値] 0:未確定, 1:確定
Bit10: ワーニング発生状況 [値] 0:未発生, 1:ワーニング発生 [詳解]

詳解

[Out] MC_ReadAxisInfo

フィールド詳解

◆ dwAxisInfo

DWORD dwAxisInfo

軸情報
bit0: 軸のエラー有無 [値] 0: 無, 1: 有
bit1: 原点入力信号 [値] 0: OFF, 1: ON
bit2: +ELS [値] 0: OFF, 1: ON
bit3: -ELS [値] 0:OFF, 1:ON
bit7: スレーブを駆動する準備が完了 [値] 0: 未完了, 1: 完了
bit8: サーボ [値] 0:OFF, 1:ON
bit9: 原点復帰完了(原点復帰方式がCiA402による方式の場合) [値] 0:未確定, 1:確定
Bit10: ワーニング発生状況 [値] 0:未発生, 1:ワーニング発生

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_MACHINE 構造体

フィールド
MC_AXIS_MACHINE 構造体

[Struct] MC_AXIS_SETTING [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bPosiElsEnable
(予約) [詳解]
BOOL | bNegaElsEnable
(予約) [詳解]
BOOL | bElsInput
(予約) [詳解]
WORD | wElsStop
(予約) [詳解]

詳解

[Struct] MC_AXIS_SETTING

フィールド詳解

◆ bPosiElsEnable

BOOL bPosiElsEnable

(予約)

◆ bNegaElsEnable

BOOL bNegaElsEnable

(予約)

◆ bElsInput

BOOL bElsInput

(予約)

◆ wElsStop

WORD wElsStop

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_MOVE 構造体

フィールド
MC_AXIS_MOVE 構造体

[Struct] MC_AXIS_SETTING [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bDisableWaitMotionInt
MC_WaitNextInterruptのイベント取得待機の無効設定
[値] FALSE: イベント取得待機します．
[値] TRUE: イベント取得待機しません．このとき、MC_MOVE_FUNCTION_RESULTのwStatusの値はbit7に1が立ちます(0x80が加算されます) [詳解]
DWORD | dwInposWidth
位置決め完了幅
[単位] pulse
[範囲] 0 - 4294967295 [詳解]
BYTE | bInposMode
long | lEncPulse
(予約) [詳解]
WORD | wIncPerMM
(予約) [詳解]
DWORD | dwPullPR
電子ギア設定時の分子
[範囲] 0 - 2147483647 [詳解]
DWORD | dwDisPR
電子ギア設定時の分母
[範囲] 0 - 2147483647 [詳解]
WORD | wPreviousDirection
(予約) [詳解]
double | fFLvelocity
FL速度
[単位] pps
[範囲] 0-2147483647 [詳解]
double | fMaxSLS
(予約) [詳解]
double | fMinSLS
(予約) [詳解]
double | fPosDeviation
(予約) [詳解]
double | fPosDevAlarm
(予約) [詳解]

詳解

[Struct] MC_AXIS_SETTING

フィールド詳解

◆ bDisableWaitMotionInt

BOOL bDisableWaitMotionInt

MC_WaitNextInterruptのイベント取得待機の無効設定
[値] FALSE: イベント取得待機します．
[値] TRUE: イベント取得待機しません．このとき、MC_MOVE_FUNCTION_RESULTのwStatusの値はbit7に1が立ちます(0x80が加算されます)

◆ dwInposWidth

DWORD dwInposWidth

位置決め完了幅
[単位] pulse
[範囲] 0 - 4294967295

◆ bInposMode

BYTE bInposMode

位置決め完了モード ( 0, 1, 2, 3 )
[説明] 位置決め完了モードを格納します．位置決め完了の確認方法は，下記の 2 つがあります． 方法１．ソフトウェアにより位置決めが完了した事を確認します．位置決め完了幅は，本構造体メンバの，dwInposWidth の値となります． 方法 2．インデックス 6041h の bit10(位置決め完了)，または同等の機能を有するインデックスと bit の値を確認します．TRUE の時，位置決め完了です． 方法 2 に関して，HLS-ECAT でサポートしているサーボドライバとインデックスと bit は，表 2.17-1 となります． [初期値] 0 [範囲] 0: 方法 2 をサポートしている場合，方法 2 を使用します．方法 2 をサポートしていない場合，方法 1 を使用します．方法１を使用する軸の位置決め完了幅の値は最大値となります．(dwInposWidth = 4294967295) 1: 方法 2 をサポートしている場合，方法 2 を使用します．方法 2 をサポートしていない場合，方法 1 を使用します． 2: 方法 1 を使用します．位置決め完了幅はdwInposWidth となります． 3: 方法 1 を使用します．位置決め完了幅の値は最大値となります．(dwInposWidth = 4294967295)

◆ lEncPulse

long lEncPulse

(予約)

◆ wIncPerMM

WORD wIncPerMM

(予約)

◆ dwPullPR

DWORD dwPullPR

電子ギア設定時の分子
[範囲] 0 - 2147483647

◆ dwDisPR

DWORD dwDisPR

電子ギア設定時の分母
[範囲] 0 - 2147483647

◆ wPreviousDirection

WORD wPreviousDirection

(予約)

◆ fFLvelocity

double fFLvelocity

FL速度
[単位] pps
[範囲] 0-2147483647

◆ fMaxSLS

double fMaxSLS

(予約)

◆ fMinSLS

double fMinSLS

(予約)

◆ fPosDeviation

double fPosDeviation

(予約)

◆ fPosDevAlarm

double fPosDevAlarm

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_REF 構造体

フィールド
MC_AXIS_REF 構造体

軸情報を格納する構造体 [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | bSlaveNo
スレーブのノード番号
[範囲] 0 - 255 [詳解]
WORD | wAxisNo
軸番号
[範囲] 0 - 65535 [詳解]

詳解

軸情報を格納する構造体

フィールド詳解

◆ bSlaveNo

BYTE bSlaveNo

スレーブのノード番号
[範囲] 0 - 255

◆ wAxisNo

WORD wAxisNo

軸番号
[範囲] 0 - 65535

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_AXIS_SETTING 構造体

フィールド
MC_AXIS_SETTING 構造体

[Out] MC_GetAxisSetting [詳解]

#include <hmecw0_struct.h>

フィールド

MC_AXIS_FACTOR AxisFactor
軸要素パラメータ [詳解]
MC_AXIS_MOVE AxisMove
軸動作パラメータ [詳解]
MC_AXIS_DRIVE AxisDrive
サーボIFパラメータ [詳解]
MC_AXIS_MACHINE AxisMachine
マシンIFパラメータ [詳解]

詳解

[Out] MC_GetAxisSetting

[In] MC_SetAxisSetting

フィールド詳解

◆ AxisFactor

MC_AXIS_FACTOR AxisFactor

軸要素パラメータ

◆ AxisMove

MC_AXIS_MOVE AxisMove

軸動作パラメータ

◆ AxisDrive

MC_AXIS_DRIVE AxisDrive

サーボIFパラメータ

◆ AxisMachine

MC_AXIS_MACHINE AxisMachine

マシンIFパラメータ

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_BUFFER_FUNC 構造体

フィールド
MC_BUFFER_FUNC 構造体

[Struct] MC_READ_BUFFER_OUT [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | bFuncID
バッファ待機中のAPI識別コード
[値]
0x66： MC_MoveRelative
0x65： MC_MoveAbsolute [詳解]
double | fPosition
目標位置(MC_MoveAbsolute)
[単位] pulse [詳解]
double | fDistance
移動量(MC_MoveRelative)
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
double | fVelocity
最高速度
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]

詳解

[Struct] MC_READ_BUFFER_OUT

[Out] MC_ReadFunctionResult

フィールド詳解

◆ bFuncID

BYTE bFuncID

バッファ待機中のAPI識別コード
[値]
0x66： MC_MoveRelative
0x65： MC_MoveAbsolute

◆ fPosition

double fPosition

目標位置(MC_MoveAbsolute)
[単位] pulse

◆ fDistance

double fDistance

移動量(MC_MoveRelative)
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ fVelocity

double fVelocity

最高速度
[単位] pps
[範囲] 0 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_ADD_AXIS 構造体

フィールド
MC_GROUP_ADD_AXIS 構造体

[In] MC_AddAxisToGroup [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE bySeqNo
軸追加先の配列番号
[範囲] 0 - 31． [詳解]

詳解

[In] MC_AddAxisToGroup

フィールド詳解

◆ bySeqNo

BYTE bySeqNo

軸追加先の配列番号
[範囲] 0 - 31．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_BUFFER_FUNC 構造体

フィールド
MC_GROUP_BUFFER_FUNC 構造体

[Struct] MC_GROUP_READ_BUFFER_OUT [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wBufferMode
動作モード
[値]
0:Aborting
1:Buffered
2:BlendingLow
3:BlendingPrevious
4:BlendingNext
5:BlendingHigh [詳解]
BYTE | bFuncID
バッファ待機中の関数の識別コード
[値]
0x24：MC_MoveLinearAbsolute
0x25：MC_MoveLinearRelative [詳解]
double | fPosition [32]
目標位置: MC_MoveLinearAbsolute
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
double | fDistance [32]
移動量: MC_MoveLinearRelative
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
double | fVelocity
速度
[単位] pps
[範囲] 1 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]

詳解

[Struct] MC_GROUP_READ_BUFFER_OUT

[Out] MC_GroupReadBuffer

フィールド詳解

◆ wBufferMode

WORD wBufferMode

動作モード
[値]
0:Aborting
1:Buffered
2:BlendingLow
3:BlendingPrevious
4:BlendingNext
5:BlendingHigh

◆ bFuncID

BYTE bFuncID

バッファ待機中の関数の識別コード
[値]
0x24：MC_MoveLinearAbsolute
0x25：MC_MoveLinearRelative

◆ fPosition

double fPosition[32]

目標位置: MC_MoveLinearAbsolute
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ fDistance

double fDistance[32]

移動量: MC_MoveLinearRelative
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ fVelocity

double fVelocity

速度
[単位] pps
[範囲] 1 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_HOME_IN 構造体

フィールド
MC_GROUP_HOME_IN 構造体

[In] MC_GroupHome [詳解]

#include <hmecw0_struct.h>

フィールド

double | fPosition [32]
原点復帰位置
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
double | fVelocity
原点復帰速度
[単位] pps
[範囲] 1 - 2147483647 [詳解]
double | fAcceleration
原点復帰加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
原点復帰減速度
[単位] pps^2
[範囲] 0-2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wBufferMode
(予約) [詳解]

詳解

[In] MC_GroupHome

フィールド詳解

◆ fPosition

double fPosition[32]

原点復帰位置
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ fVelocity

double fVelocity

原点復帰速度
[単位] pps
[範囲] 1 - 2147483647

◆ fAcceleration

double fAcceleration

原点復帰加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

原点復帰減速度
[単位] pps^2
[範囲] 0-2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_HOME_OUT 構造体

フィールド
MC_GROUP_HOME_OUT 構造体

[Out] MC_GroupHome [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_GroupHome

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_MOVE 構造体

フィールド
MC_GROUP_MOVE 構造体

[Struct] MC_GROUP_SETTING [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bDisableWaitMotionInt
イベント取得待機のキャンセル無効設定
FALSE: 無効(イベント取得待機します) TRUE: 有効(イベント取得待機しません) [詳解]
BYTE | byMasterSeqNo
ガントリ制御時のマスター軸
[範囲] 0 - 31 (ガントリ制御を行わない場合は常に0) [詳解]
BYTE | bySlaveSeqNo
ガントリ制御時のスレーブ軸
[範囲] 0 - 31 (ガントリ制御を行わない場合は常に0) [詳解]
BOOL | bDeviationStopEnable
ガントリ制御時の位置偏差エラー発生時の停止有効/無効
[値] FALSE:無効，TRUE：有効 [詳解]
BYTE | byDeviationStopMode
ガントリ制御時の位置偏差エラー発生時の停止方法
[値] 0:即時停止 [詳解]
double | fPosDeviation
ガントリ制御時の位置偏差の許容値
[単位] pulse
[範囲] 0 - 4294967295 (0: 無効) [詳解]
double | fDeviationDec
(予約) [詳解]
double | fDeviationJerk
(予約) [詳解]

詳解

[Struct] MC_GROUP_SETTING

フィールド詳解

◆ bDisableWaitMotionInt

BOOL bDisableWaitMotionInt

イベント取得待機のキャンセル無効設定
FALSE: 無効(イベント取得待機します) TRUE: 有効(イベント取得待機しません)

◆ byMasterSeqNo

BYTE byMasterSeqNo

ガントリ制御時のマスター軸
[範囲] 0 - 31 (ガントリ制御を行わない場合は常に0)

◆ bySlaveSeqNo

BYTE bySlaveSeqNo

ガントリ制御時のスレーブ軸
[範囲] 0 - 31 (ガントリ制御を行わない場合は常に0)

◆ bDeviationStopEnable

BOOL bDeviationStopEnable

ガントリ制御時の位置偏差エラー発生時の停止有効/無効
[値] FALSE:無効，TRUE：有効

◆ byDeviationStopMode

BYTE byDeviationStopMode

ガントリ制御時の位置偏差エラー発生時の停止方法
[値] 0:即時停止

◆ fPosDeviation

double fPosDeviation

ガントリ制御時の位置偏差の許容値
[単位] pulse
[範囲] 0 - 4294967295 (0: 無効)

◆ fDeviationDec

double fDeviationDec

(予約)

◆ fDeviationJerk

double fDeviationJerk

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_MOVE_FUNCTION_RESULT 構造体

フィールド
MC_GROUP_MOVE_FUNCTION_RESULT 構造体

[Out] MC_GroupReadFunctionResult [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wFunction
動作完了した関数コード
[値]
0x0031： MC_GroupReset
0x0032： MC_GroupHome
0x0033： MC_GroupStop
0x0034： MC_MoveLinearAbsolute
0x0035： MC_MoveLinearRelative
0x0036： MC_MoveLinearVelocity
0x0045： MC_MovePath [詳解]
WORD | wStatus
ステータス
[値]
[MC_GROUP_MOVE.bDisableWaitMotionInt = FALSE]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error
[MC_GROUP_MOVE.bDisableWaitMotionInt = TRUE]
0x81: Done
0x82: Busy
0x83: CommandAborted
0x84: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_GroupReadFunctionResult

フィールド詳解

◆ wFunction

WORD wFunction

動作完了した関数コード
[値]
0x0031： MC_GroupReset
0x0032： MC_GroupHome
0x0033： MC_GroupStop
0x0034： MC_MoveLinearAbsolute
0x0035： MC_MoveLinearRelative
0x0036： MC_MoveLinearVelocity
0x0045： MC_MovePath

◆ wStatus

WORD wStatus

ステータス
[値]
[MC_GROUP_MOVE.bDisableWaitMotionInt = FALSE]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error
[MC_GROUP_MOVE.bDisableWaitMotionInt = TRUE]
0x81: Done
0x82: Busy
0x83: CommandAborted
0x84: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_ACT_POS_IN 構造体

フィールド
MC_GROUP_READ_ACT_POS_IN 構造体

[In] MC_GroupReadActualPosition [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE byCoordSys
(予約) [詳解]

詳解

[In] MC_GroupReadActualPosition

フィールド詳解

◆ byCoordSys

BYTE byCoordSys

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_ACT_POS_OUT 構造体

フィールド
MC_GROUP_READ_ACT_POS_OUT 構造体

[In] MC_GroupReadActualPosition [詳解]

#include <hmecw0_struct.h>

フィールド

double fPosition [32]
軸グループに追加されている軸の現在位置[Pulse] [詳解]

詳解

[In] MC_GroupReadActualPosition

フィールド詳解

◆ fPosition

double fPosition[32]

軸グループに追加されている軸の現在位置[Pulse]

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_ACT_VEL_IN 構造体

フィールド
MC_GROUP_READ_ACT_VEL_IN 構造体

[In] MC_GroupReadActualVelocity [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE byCoordSys
(予約) [詳解]

詳解

[In] MC_GroupReadActualVelocity

フィールド詳解

◆ byCoordSys

BYTE byCoordSys

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_ACT_VEL_OUT 構造体

フィールド
MC_GROUP_READ_ACT_VEL_OUT 構造体

[Out] MC_GroupReadActualVelocity [詳解]

#include <hmecw0_struct.h>

フィールド

double | fPathVelocity
移動方向の現在速度
[単位] pps
[範囲] -2147483648 - 2147483647 [詳解]
double | fVelocity [32]
軸グループ内各軸の現在速度
[単位] pps
[範囲] -2147483648-2147483647 [詳解]

詳解

[Out] MC_GroupReadActualVelocity

フィールド詳解

◆ fPathVelocity

double fPathVelocity

移動方向の現在速度
[単位] pps
[範囲] -2147483648 - 2147483647

◆ fVelocity

double fVelocity[32]

軸グループ内各軸の現在速度
[単位] pps
[範囲] -2147483648-2147483647

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_BUFFER_OUT 構造体

フィールド
MC_GROUP_READ_BUFFER_OUT 構造体

[Out] MC_GroupReadBuffer [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | bBufferNum
バッファ待機中のAPI個数
[範囲] 0-1 [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]
MC_GROUP_BUFFER_FUNC | BufferFunction [4]
バッファ待機中の関数詳細 [詳解]

詳解

[Out] MC_GroupReadBuffer

フィールド詳解

◆ bBufferNum

BYTE bBufferNum

バッファ待機中のAPI個数
[範囲] 0-1

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

◆ BufferFunction

MC_GROUP_BUFFER_FUNC BufferFunction[4]

バッファ待機中の関数詳細

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_CONFIG_IN 構造体

フィールド
MC_GROUP_READ_CONFIG_IN 構造体

[In] MC_GroupReadConfiguration [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE bySeqNo
軸グループ内の読込む軸配列番号 [詳解]

詳解

[In] MC_GroupReadConfiguration

フィールド詳解

◆ bySeqNo

BYTE bySeqNo

軸グループ内の読込む軸配列番号

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_CONFIG_OUT 構造体

フィールド
MC_GROUP_READ_CONFIG_OUT 構造体

[Out] MC_GroupReadConfiguration [詳解]

#include <hmecw0_struct.h>

フィールド

MC_AXIS_REF stAxis
軸の情報 [詳解]

詳解

[Out] MC_GroupReadConfiguration

フィールド詳解

◆ stAxis

MC_AXIS_REF stAxis

軸の情報

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_ERROR 構造体

フィールド
MC_GROUP_READ_ERROR 構造体

[Out] MC_GroupReadError [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_GroupReadError

フィールド詳解

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_PATH_DATA_OUT 構造体

フィールド
MC_GROUP_READ_PATH_DATA_OUT 構造体

[Out] MC_GroupReadPathData [詳解]

#include <hmecw0_struct.h>

フィールド

DWORD | dwSize
パスデータ数
[範囲] 0-10000 [詳解]
DWORD | dwRun
実行中のパスデータ番号
[範囲] 0-10000 [詳解]
MC_PATH_DATA_REF PathRef
パスデータを格納する構造体 [詳解]

詳解

[Out] MC_GroupReadPathData

フィールド詳解

◆ dwSize

DWORD dwSize

パスデータ数
[範囲] 0-10000

◆ dwRun

DWORD dwRun

実行中のパスデータ番号
[範囲] 0-10000

◆ PathRef

MC_PATH_DATA_REF PathRef

パスデータを格納する構造体

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_READ_STATUS 構造体

フィールド
MC_GROUP_READ_STATUS 構造体

[Out] MC_GroupReadStatus [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wPLCOpenStatus
軸グループのステータス.
[値]
0x02： GroupMoving
0x04： GroupHoming
0x08： GroupErrorStop
0x10： GroupStandby
0x20： GroupStopping
0x40： GroupDisabled [詳解]
WORD | wMotionStatus
軸グループの動作状態．
[値]
bit1: 定速中
bit2: 加速中
bit3: 減速中 [詳解]

詳解

[Out] MC_GroupReadStatus

フィールド詳解

◆ wPLCOpenStatus

WORD wPLCOpenStatus

軸グループのステータス.
[値]
0x02： GroupMoving
0x04： GroupHoming
0x08： GroupErrorStop
0x10： GroupStandby
0x20： GroupStopping
0x40： GroupDisabled

◆ wMotionStatus

WORD wMotionStatus

軸グループの動作状態．
[値]
bit1: 定速中
bit2: 加速中
bit3: 減速中

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_REMOVE_AXIS 構造体

フィールド
MC_GROUP_REMOVE_AXIS 構造体

[In] MC_RemoveAxisFromGroup [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE bySeqNo
軸グループ内の削除する軸配列番号 [詳解]

詳解

[In] MC_RemoveAxisFromGroup

フィールド詳解

◆ bySeqNo

BYTE bySeqNo

軸グループ内の削除する軸配列番号

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_RESET_OUT 構造体

フィールド
MC_GROUP_RESET_OUT 構造体

[Out] MC_GroupReset [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_GroupReset

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_SET_OVERRIDE_IN 構造体

フィールド
MC_GROUP_SET_OVERRIDE_IN 構造体

[Out] MC_GroupReadPathData [詳解]

#include <hmecw0_struct.h>

フィールド

double | fVelFactor
速度の係数
[範囲] 0.0 - 1.0 [詳解]
double | fAccFactor
(予約) [詳解]
double | fJerkFactor
(予約) [詳解]

詳解

[Out] MC_GroupReadPathData

フィールド詳解

◆ fVelFactor

double fVelFactor

速度の係数
[範囲] 0.0 - 1.0

◆ fAccFactor

double fAccFactor

(予約)

◆ fJerkFactor

double fJerkFactor

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_SET_POSITION 構造体

フィールド
MC_GROUP_SET_POSITION 構造体

[In] MC_GroupSetPosition [詳解]

#include <hmecw0_struct.h>

フィールド

double | fPosition [32]
軸グループに追加されている軸の現在位置の設定値
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
BOOL | bPositionInp
(予約) [詳解]
BYTE | byCoordSys
(予約) [詳解]
WORD | wBufferMode
(予約) [詳解]

詳解

[In] MC_GroupSetPosition

フィールド詳解

◆ fPosition

double fPosition[32]

軸グループに追加されている軸の現在位置の設定値
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ bPositionInp

BOOL bPositionInp

(予約)

◆ byCoordSys

BYTE byCoordSys

(予約)

◆ wBufferMode

WORD wBufferMode

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_SETTING 構造体

フィールド
MC_GROUP_SETTING 構造体

[In] MC_SetGroupSetting [詳解]

#include <hmecw0_struct.h>

フィールド

MC_GROUP_MOVE GroupMove
軸グループの動作パラメータ [詳解]

詳解

[In] MC_SetGroupSetting

[Out] MC_GetGroupSetting

フィールド詳解

◆ GroupMove

MC_GROUP_MOVE GroupMove

軸グループの動作パラメータ

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_STOP_IN 構造体

フィールド
MC_GROUP_STOP_IN 構造体

[In] MC_GroupStop [詳解]

#include <hmecw0_struct.h>

フィールド

double | fDeceleration
原点復帰加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wBufferMode
動作モード
[値] 0: Aborting [詳解]

詳解

[In] MC_GroupStop

フィールド詳解

◆ fDeceleration

double fDeceleration

原点復帰加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

動作モード
[値] 0: Aborting

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_GROUP_STOP_OUT 構造体

フィールド
MC_GROUP_STOP_OUT 構造体

[Out] MC_GroupStop [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_GroupStop

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_HOME_IN 構造体

フィールド
MC_HOME_IN 構造体

[In] MC_Home [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bEncoder
エンコーダ
[値] FALSE: CiA402による原点復帰方式, TRUE: エンコーダによる原点復帰方式 [詳解]
BYTE | byHomingMethod
CiA402による原点復帰方法
[範囲] 0 - 65535 [詳解]
double | fSpeed1
原点近傍入力サーチ速度: CiA402による原点復帰
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fSpeed2
原点入力サーチ速度: CiA402による原点復帰
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fPosition
原点位置: エンコーダ
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
double | fVelocity
原点復帰速度: エンコーダ
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fAcceleration
原点復帰加速度: エンコーダ
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
原点復帰減速度: エンコーダ
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク: エンコーダ
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wHomePosiInpType
(予約) [詳解]
WORD | wHomePosiDir
(予約) [詳解]
WORD | wHomePosiInpDir
(予約) [詳解]
double | fHomeMaskDis
(予約) [詳解]
double | fHomePosiOffset
(予約) [詳解]
DWORD | dwHomePushWait
(予約) [詳解]
WORD | wBufferMode
(予約) [詳解]
BOOL | bSyncMotion
(予約) [詳解]

詳解

[In] MC_Home

フィールド詳解

◆ bEncoder

BOOL bEncoder

エンコーダ
[値] FALSE: CiA402による原点復帰方式, TRUE: エンコーダによる原点復帰方式

◆ byHomingMethod

BYTE byHomingMethod

CiA402による原点復帰方法
[範囲] 0 - 65535

◆ fSpeed1

double fSpeed1

原点近傍入力サーチ速度: CiA402による原点復帰
[単位] pps
[範囲] 0 - 2147483647

◆ fSpeed2

double fSpeed2

原点入力サーチ速度: CiA402による原点復帰
[単位] pps
[範囲] 0 - 2147483647

◆ fPosition

double fPosition

原点位置: エンコーダ
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ fVelocity

double fVelocity

原点復帰速度: エンコーダ
[単位] pps
[範囲] 0 - 2147483647

◆ fAcceleration

double fAcceleration

原点復帰加速度: エンコーダ
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

原点復帰減速度: エンコーダ
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク: エンコーダ
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wHomePosiInpType

WORD wHomePosiInpType

(予約)

◆ wHomePosiDir

WORD wHomePosiDir

(予約)

◆ wHomePosiInpDir

WORD wHomePosiInpDir

(予約)

◆ fHomeMaskDis

double fHomeMaskDis

(予約)

◆ fHomePosiOffset

double fHomePosiOffset

(予約)

◆ dwHomePushWait

DWORD dwHomePushWait

(予約)

◆ wBufferMode

WORD wBufferMode

(予約)

◆ bSyncMotion

BOOL bSyncMotion

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_HOME_OUT 構造体

フィールド
MC_HOME_OUT 構造体

[Out] MC_Home [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02: Busy
0x04: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_Home

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02: Busy
0x04: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_LATCH_COUNT_REF 構造体

フィールド
MC_LATCH_COUNT_REF 構造体

[In] MC_ReadLatchCountResult [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE byLatchCountRef
ラッチ位置を取得するプローブID
[値]
1: Probe1
2: Probe2
3: Probe1，Probe2 [詳解]

詳解

[In] MC_ReadLatchCountResult

フィールド詳解

◆ byLatchCountRef

BYTE byLatchCountRef

ラッチ位置を取得するプローブID
[値]
1: Probe1
2: Probe2
3: Probe1，Probe2

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_LATCH_COUNT_RESULT 構造体

フィールド
MC_LATCH_COUNT_RESULT 構造体

[Out] MC_ReadLatchCountResult [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | byLatchCountRef
ラッチ位置を取得するプローブID
[値]
1: Probe1
2: Probe2
3: Probe1，Probe2 [詳解]
BOOL | bProbe1Stored
Probe1のラッチ位置保存状態
[値] FALSE: 非保存 TRUE: 保存 [詳解]
WORD | wProbe1Status
Probe1のステータス
[範囲]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error [詳解]
WORD | wProbe1ErrorID
Probe1のエラーID
[範囲] 0-0xFFFF [詳解]
double | fProbe1RecPosition
Probe1のラッチ位置
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
BOOL | bProbe2Stored
Probe2のラッチ位置保存状態
[値] FALSE: 非保存 TRUE: 保存 [詳解]
WORD | wProbe2Status
Probe2のステータス
[値]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error [詳解]
WORD | wProbe2ErrorID
Probe2のエラーID
[範囲] 0-0xFFFF [詳解]
double | fProbe2RecPosition
Probe2のラッチ位置
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]

詳解

[Out] MC_ReadLatchCountResult

フィールド詳解

◆ byLatchCountRef

BYTE byLatchCountRef

ラッチ位置を取得するプローブID
[値]
1: Probe1
2: Probe2
3: Probe1，Probe2

◆ bProbe1Stored

BOOL bProbe1Stored

Probe1のラッチ位置保存状態
[値] FALSE: 非保存 TRUE: 保存

◆ wProbe1Status

WORD wProbe1Status

Probe1のステータス
[範囲]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error

◆ wProbe1ErrorID

WORD wProbe1ErrorID

Probe1のエラーID
[範囲] 0-0xFFFF

◆ fProbe1RecPosition

double fProbe1RecPosition

Probe1のラッチ位置
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ bProbe2Stored

BOOL bProbe2Stored

Probe2のラッチ位置保存状態
[値] FALSE: 非保存 TRUE: 保存

◆ wProbe2Status

WORD wProbe2Status

Probe2のステータス
[値]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error

◆ wProbe2ErrorID

WORD wProbe2ErrorID

Probe2のエラーID
[範囲] 0-0xFFFF

◆ fProbe2RecPosition

double fProbe2RecPosition

Probe2のラッチ位置
[単位] pulse
[範囲] -2147483647 - 2147483648

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOTION_STATE 構造体

フィールド
MC_MOTION_STATE 構造体

[Out] MC_ReadMotionState [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wMotionState
モーションステータス
bit1: 定速中
bit2: 加速中
bit3: 減速中
bit4: ＋方向動作中
bit5: ?方向動作中 [詳解]

詳解

[Out] MC_ReadMotionState

フィールド詳解

◆ wMotionState

WORD wMotionState

モーションステータス
bit1: 定速中
bit2: 加速中
bit3: 減速中
bit4: ＋方向動作中
bit5: ?方向動作中

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_ABSOLUTE_IN 構造体

フィールド
MC_MOVE_ABSOLUTE_IN 構造体

[In] MC_MoveAbsolute [詳解]

#include <hmecw0_struct.h>

フィールド

double | fPosition
目標位置
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
double | fVelocity
最高速度
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wDirection
(予約) [詳解]
WORD | wBufferMode
動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh [詳解]

詳解

[In] MC_MoveAbsolute

フィールド詳解

◆ fPosition

double fPosition

目標位置
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ fVelocity

double fVelocity

最高速度
[単位] pps
[範囲] 0 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wDirection

WORD wDirection

(予約)

◆ wBufferMode

WORD wBufferMode

動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_ABSOLUTE_OUT 構造体

フィールド
MC_MOVE_ABSOLUTE_OUT 構造体

[Out] MC_MoveAbsolute [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値] 0x02: Busy
0x04: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_MoveAbsolute

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値] 0x02: Busy
0x04: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_ADDITIVE_IN 構造体

フィールド
MC_MOVE_ADDITIVE_IN 構造体

[In] MC_MoveAdditive [詳解]

#include <hmecw0_struct.h>

フィールド

double | fDistance
移動距離
[単位] pulse
[範囲] -2147483647-2147483648 [詳解]
double | fVelocity
最高速度
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0-2,251,799,813,685,250 [詳解]
WORD | wBufferMode
動作モード
[値] 0: Aborting [詳解]

詳解

[In] MC_MoveAdditive

フィールド詳解

◆ fDistance

double fDistance

移動距離
[単位] pulse
[範囲] -2147483647-2147483648

◆ fVelocity

double fVelocity

最高速度
[単位] pps
[範囲] 0 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0-2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

動作モード
[値] 0: Aborting

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_ADDITIVE_OUT 構造体

フィールド
MC_MOVE_ADDITIVE_OUT 構造体

[Out] MC_MoveAdditive [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値] 0x02: Busy
0x04: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_MoveAdditive

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値] 0x02: Busy
0x04: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_FUNCTION_RESULT 構造体

フィールド
MC_MOVE_FUNCTION_RESULT 構造体

[Out] MC_ReadFunctionResult [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wFunction
完了したAPI
[値]
0x21： MC_Reset
0x22： MC_Home
0x23： MC_Stop
0x24： MC_MoveAbsolute
0x25： MC_MoveRelative
0x26： MC_MoveAdditive
0x27： MC_MoveVelocity [詳解]
WORD | wStatus
完了したAPIステータス
[値]
[MC_AXIS_MOVE.bDisableWaitMotionInt = FALSE]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error
[MC_AXIS_MOVE.bDisableWaitMotionInt = TRUE]
0x81: Done
0x82: Busy
0x83: CommandAborted
0x84: Error [詳解]
WORD | wErrorID
完了したAPIエラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_ReadFunctionResult

フィールド詳解

◆ wFunction

WORD wFunction

完了したAPI
[値]
0x21： MC_Reset
0x22： MC_Home
0x23： MC_Stop
0x24： MC_MoveAbsolute
0x25： MC_MoveRelative
0x26： MC_MoveAdditive
0x27： MC_MoveVelocity

◆ wStatus

WORD wStatus

完了したAPIステータス
[値]
[MC_AXIS_MOVE.bDisableWaitMotionInt = FALSE]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error
[MC_AXIS_MOVE.bDisableWaitMotionInt = TRUE]
0x81: Done
0x82: Busy
0x83: CommandAborted
0x84: Error

◆ wErrorID

WORD wErrorID

完了したAPIエラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_LINEAR_ABS_IN 構造体

フィールド
MC_MOVE_LINEAR_ABS_IN 構造体

[In] MC_MoveLinearAbsolute [詳解]

#include <hmecw0_struct.h>

フィールド

double | fPosition [32]
絶対位置
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
double | fVelocity
速度
[単位] pps
[範囲] 1 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wBufferMode
動作モード
[値]
0:Aborting
1:Buffered
2:BlendingLow
3:BlendingPrevious
4:BlendingNext
5:BlendingHigh [詳解]

詳解

[In] MC_MoveLinearAbsolute

フィールド詳解

◆ fPosition

double fPosition[32]

絶対位置
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ fVelocity

double fVelocity

速度
[単位] pps
[範囲] 1 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

動作モード
[値]
0:Aborting
1:Buffered
2:BlendingLow
3:BlendingPrevious
4:BlendingNext
5:BlendingHigh

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_LINEAR_ABS_OUT 構造体

フィールド
MC_MOVE_LINEAR_ABS_OUT 構造体

[Out] MC_MoveLinearAbsolute [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_MoveLinearAbsolute

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_LINEAR_REL_IN 構造体

フィールド
MC_MOVE_LINEAR_REL_IN 構造体

[In] MC_MoveLinearRelative [詳解]

#include <hmecw0_struct.h>

フィールド

double | fDistance [32]
相対位置
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
double | fVelocity
速度
[単位] pps
[範囲] 1 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wBufferMode
動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh [詳解]

詳解

[In] MC_MoveLinearRelative

フィールド詳解

◆ fDistance

double fDistance[32]

相対位置
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ fVelocity

double fVelocity

速度
[単位] pps
[範囲] 1 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_LINEAR_REL_OUT 構造体

フィールド
MC_MOVE_LINEAR_REL_OUT 構造体

[In] MC_MoveLinearRelative [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[In] MC_MoveLinearRelative

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_LINEAR_VEL_IN 構造体

フィールド
MC_MOVE_LINEAR_VEL_IN 構造体

[In] MC_MoveLinearVelocity [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bJogAxis [32]
連続動作を行う軸の有効設定
[値] False: 無効．True: 有効 [詳解]
double | fVelocity
速度
[単位] pps
[範囲] 1 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wDirection
回転方向
[範囲] 0:負方向, 1:正方向 [詳解]
WORD | wBufferMode
(予約) [詳解]
BYTE | byMode
速度の設定モード
[値]
1以外: 全軸で fVelocity の値を使用します。
1:各軸で fJogVelosity[32] の値を使用します。 [詳解]
BYTE | byBase
[byMode = 1時に設定]
加速度"fAcceleration",減速度"fDeceleration",ジャーク"fJerk"を適用する軸設定
[範囲] 0 - 31 [詳解]
double | fJogVelocity [32]
速度
[範囲] 0 - 2147483647 [詳解]

詳解

[In] MC_MoveLinearVelocity

フィールド詳解

◆ bJogAxis

BOOL bJogAxis[32]

連続動作を行う軸の有効設定
[値] False: 無効．True: 有効

◆ fVelocity

double fVelocity

速度
[単位] pps
[範囲] 1 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wDirection

WORD wDirection

回転方向
[範囲] 0:負方向, 1:正方向

◆ wBufferMode

WORD wBufferMode

(予約)

◆ byMode

BYTE byMode

速度の設定モード
[値]
1以外: 全軸で fVelocity の値を使用します。
1:各軸で fJogVelosity[32] の値を使用します。

◆ byBase

BYTE byBase

[byMode = 1時に設定]
加速度"fAcceleration",減速度"fDeceleration",ジャーク"fJerk"を適用する軸設定
[範囲] 0 - 31

◆ fJogVelocity

double fJogVelocity[32]

速度
[範囲] 0 - 2147483647

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_LINEAR_VEL_OUT 構造体

フィールド
MC_MOVE_LINEAR_VEL_OUT 構造体

[Out] MC_MoveLinearVelocity [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_MoveLinearVelocity

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_PATH_IN 構造体

フィールド
MC_MOVE_PATH_IN 構造体

[In] MC_MovePath [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | byInpMode
パスデータ生成モード
[値]
0: MC_PATH_DATA_REFで設定
1: txt,csvファイルで設定 [詳解]
DWORD | dwSize
パスデータ数
[範囲] 0 - 10000 [詳解]
BYTE | byCoordSystem
WORD | wBufferMode
(予約) [詳解]
BYTE | byTransitionMode
(予約) [詳解]
double | fVelFactor
(予約) [詳解]
double | fCornerDistance
(予約) [詳解]
double | fMaxCornerDeviation
(予約) [詳解]
double | fTransitionParam [1]
(予約) [詳解]
char * | pName
ファイルのパス (txt, csv, xml)
[例] pName = “C：\PathData.csv” [詳解]

詳解

[In] MC_MovePath

フィールド詳解

◆ byInpMode

BYTE byInpMode

パスデータ生成モード
[値]
0: MC_PATH_DATA_REFで設定
1: txt,csvファイルで設定

◆ dwSize

DWORD dwSize

パスデータ数
[範囲] 0 - 10000

◆ byCoordSystem

BYTE byCoordSystem

◆ wBufferMode

WORD wBufferMode

(予約)

◆ byTransitionMode

BYTE byTransitionMode

(予約)

◆ fVelFactor

double fVelFactor

(予約)

◆ fCornerDistance

double fCornerDistance

(予約)

◆ fMaxCornerDeviation

double fMaxCornerDeviation

(予約)

◆ fTransitionParam

double fTransitionParam[1]

(予約)

◆ pName

char* pName

ファイルのパス (txt, csv, xml)
[例] pName = “C：\PathData.csv”

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_PATH_OUT 構造体

フィールド
MC_MOVE_PATH_OUT 構造体

[Out] MC_MovePath [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
DWORD | dwSize
パスデータ数
[範囲] 0-10000 [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]
DWORD | dwErrLine
エラーが発生したパスデータ番号
[範囲] 0 - 10000 [詳解]

詳解

[Out] MC_MovePath

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ dwSize

DWORD dwSize

パスデータ数
[範囲] 0-10000

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

◆ dwErrLine

DWORD dwErrLine

エラーが発生したパスデータ番号
[範囲] 0 - 10000

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_RELATIVE_IN 構造体

フィールド
MC_MOVE_RELATIVE_IN 構造体

[In] MC_MoveRelative [詳解]

#include <hmecw0_struct.h>

フィールド

double | fDistance
移動距離
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
double | fVelocity
最高速度
[単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wBufferMode
動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh [詳解]

詳解

[In] MC_MoveRelative

フィールド詳解

◆ fDistance

double fDistance

移動距離
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ fVelocity

double fVelocity

最高速度
[単位] pps
[範囲] 0 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_RELATIVE_OUT 構造体

フィールド
MC_MOVE_RELATIVE_OUT 構造体

[Out] MC_MoveRelative [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値] 0x02: Busy
0x04: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_MoveRelative

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値] 0x02: Busy
0x04: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_VELOCITY_IN 構造体

フィールド
MC_MOVE_VELOCITY_IN 構造体

[In] MC_MoveVelocitiy [詳解]

#include <hmecw0_struct.h>

フィールド

double | fVelocity
最高速度
単位] pps
[範囲] 0 - 2147483647 [詳解]
double | fAcceleration
加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wDirection
回転方向
[値] 0: mcNegativeDirection(負方向) 1: mcPositiveDirection(正方向) [詳解]
WORD | wBufferMode
動作モード
[値] 0: Aborting，1: Buffered [詳解]

詳解

[In] MC_MoveVelocitiy

フィールド詳解

◆ fVelocity

double fVelocity

最高速度
単位] pps
[範囲] 0 - 2147483647

◆ fAcceleration

double fAcceleration

加速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wDirection

WORD wDirection

回転方向
[値] 0: mcNegativeDirection(負方向) 1: mcPositiveDirection(正方向)

◆ wBufferMode

WORD wBufferMode

動作モード
[値] 0: Aborting，1: Buffered

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_MOVE_VELOCITY_OUT 構造体

フィールド
MC_MOVE_VELOCITY_OUT 構造体

[Out] MC_MoveVelocitiy [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値] 0x02: Busy
0x04: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_MoveVelocitiy

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値] 0x02: Busy
0x04: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_PATH_DATA_REF 構造体

フィールド
MC_PATH_DATA_REF 構造体

[Struct] MC_GROUP_READ_PATH_DATA_OUT [詳解]

#include <hmecw0_struct.h>

フィールド

double | fPosition [32]
Position
[単位] pulse
[範囲] -2147483648 - 2147483647 [詳解]
double | fVelocity
Velocity
[単位] pps
[範囲] 1 - 2147483647 [詳解]
double | fAcceleration
Acceleration
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fDeceleration
Deceleration
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
Jerk
単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]
WORD | wBufferMode
動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh [詳解]
BYTE | byTransitionMode
(予約) [詳解]
BYTE | byMtnCmd
パスの動作設定
[値]
0： 相対位置決め動作
1： 絶対位置決め動作
2： 原点復帰による位置決め動作 [詳解]
double | fVelFactor
(予約) [詳解]
double | fCornerDistance
(予約) [詳解]
double | fMaxCornerDeviation
(予約) [詳解]

詳解

[Struct] MC_GROUP_READ_PATH_DATA_OUT

[In] MC_MovePath

フィールド詳解

◆ fPosition

double fPosition[32]

Position
[単位] pulse
[範囲] -2147483648 - 2147483647

◆ fVelocity

double fVelocity

Velocity
[単位] pps
[範囲] 1 - 2147483647

◆ fAcceleration

double fAcceleration

Acceleration
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fDeceleration

double fDeceleration

Deceleration
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

Jerk
単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

◆ wBufferMode

WORD wBufferMode

動作モード
[値]
0: Aborting
1: Buffered
2: BlendingLow
3: BlendingPrevious
4: BlendingNext
5: BlendingHigh

◆ byTransitionMode

BYTE byTransitionMode

(予約)

◆ byMtnCmd

BYTE byMtnCmd

パスの動作設定
[値]
0： 相対位置決め動作
1： 絶対位置決め動作
2： 原点復帰による位置決め動作

◆ fVelFactor

double fVelFactor

(予約)

◆ fCornerDistance

double fCornerDistance

(予約)

◆ fMaxCornerDeviation

double fMaxCornerDeviation

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_POWER_IN 構造体

フィールド
MC_POWER_IN 構造体

[Out] MC_GetAxisSetting, MC_SetAxisSetting [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bEnable
電源制御
[値] FALSE: サーボOFF，TRUE: サーボON． [詳解]
BOOL | bEnablePositive
正方向運転有効設定
[値] FALSE: 無効，TRUE: 有効 [詳解]
BOOL | bEnableNegative
負方向運転有効設定
[値] FALSE: 無効，TRUE: 有効 [詳解]

詳解

[Out] MC_GetAxisSetting, MC_SetAxisSetting

フィールド詳解

◆ bEnable

BOOL bEnable

電源制御
[値] FALSE: サーボOFF，TRUE: サーボON．

◆ bEnablePositive

BOOL bEnablePositive

正方向運転有効設定
[値] FALSE: 無効，TRUE: 有効

◆ bEnableNegative

BOOL bEnableNegative

負方向運転有効設定
[値] FALSE: 無効，TRUE: 有効

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_POWER_OUT 構造体

フィールド
MC_POWER_OUT 構造体

[Out] MC_GetAxisSetting, MC_SetAxisSetting [詳解]

#include <hmecw0_struct.h>

フィールド

BOOL | bStatus
サーボ状態
[値] FALSE: サーボOFF，TRUE: サーボON [詳解]
BOOL | bError
エラー
[値] FALSE: 正常，TRUE: エラー [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_GetAxisSetting, MC_SetAxisSetting

フィールド詳解

◆ bStatus

BOOL bStatus

サーボ状態
[値] FALSE: サーボOFF，TRUE: サーボON

◆ bError

BOOL bError

エラー
[値] FALSE: 正常，TRUE: エラー

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_PROBE_STATUS 構造体

フィールド
MC_PROBE_STATUS 構造体

[Out] MC_ReadProbeStatus [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | woProbe1Status
Probe1のステータス
[値]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error [詳解]
WORD | woProbe1ErrorID
Probe1のエラーID
[範囲] 0-0xFFFF [詳解]
WORD | woProbe2Status
Probe2のステータス
[値]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error [詳解]
WORD | woProbe2ErrorID
Probe2のエラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_ReadProbeStatus

フィールド詳解

◆ woProbe1Status

WORD woProbe1Status

Probe1のステータス
[値]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error

◆ woProbe1ErrorID

WORD woProbe1ErrorID

Probe1のエラーID
[範囲] 0-0xFFFF

◆ woProbe2Status

WORD woProbe2Status

Probe2のステータス
[値]
0x01: Done
0x02: Busy
0x03: CommandAborted
0x04: Error

◆ woProbe2ErrorID

WORD woProbe2ErrorID

Probe2のエラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_READ_BUFFER_OUT 構造体

フィールド
MC_READ_BUFFER_OUT 構造体

[Out] MC_ReadBuffer [詳解]

#include <hmecw0_struct.h>

フィールド

BYTE | bBufferNum
バッファ待機中の関数の個数
[範囲] 0 - 1 [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]
MC_BUFFER_FUNC | BufferFunction [4]
バッファ待機中の関数詳細． [詳解]

詳解

[Out] MC_ReadBuffer

フィールド詳解

◆ bBufferNum

BYTE bBufferNum

バッファ待機中の関数の個数
[範囲] 0 - 1

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

◆ BufferFunction

MC_BUFFER_FUNC BufferFunction[4]

バッファ待機中の関数詳細．

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_RESET_OUT 構造体

フィールド
MC_RESET_OUT 構造体

[Out] MC_Reset [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_Reset

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_SET_OVERRIDE_IN 構造体

フィールド
MC_SET_OVERRIDE_IN 構造体

[In] MC_SetOverride [詳解]

#include <hmecw0_struct.h>

フィールド

double | fVelFactor
速度の係数
[範囲] 0.0 - 1.0 [詳解]
double | fAccFactor
(予約) [詳解]
double | fJerkFactor
(予約) [詳解]

詳解

[In] MC_SetOverride

フィールド詳解

◆ fVelFactor

double fVelFactor

速度の係数
[範囲] 0.0 - 1.0

◆ fAccFactor

double fAccFactor

(予約)

◆ fJerkFactor

double fJerkFactor

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_STATUS 構造体

フィールド
MC_STATUS 構造体

[Out] MC_ReadStatus [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wStatus
状態遷移のステータス
[範囲]
0x00: 未定義
0x02: ErrorStop
0x04: Disabled
0x08: Stopping
0x10: Homing
0x20: StandStill
0x40: DiscreteMotion
0x80: ContinuousMotion
0x100: SynchronizedMotion [詳解]

詳解

[Out] MC_ReadStatus

フィールド詳解

◆ wStatus

WORD wStatus

状態遷移のステータス
[範囲]
0x00: 未定義
0x02: ErrorStop
0x04: Disabled
0x08: Stopping
0x10: Homing
0x20: StandStill
0x40: DiscreteMotion
0x80: ContinuousMotion
0x100: SynchronizedMotion

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_STOP_IN 構造体

フィールド
MC_STOP_IN 構造体

[In] MC_Stop [詳解]

#include <hmecw0_struct.h>

フィールド

double | fDeceleration
減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250 [詳解]
double | fJerk
ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250 [詳解]

詳解

[In] MC_Stop

フィールド詳解

◆ fDeceleration

double fDeceleration

減速度
[単位] pps^2
[範囲] 0 - 2,251,799,813,685,250

◆ fJerk

double fJerk

ジャーク
[単位] pps^3
[範囲] 0 - 2,251,799,813,685,250

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_STOP_OUT 構造体

フィールド
MC_STOP_OUT 構造体

[Out] MC_Stop [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値] 0x02: Busy
0x04: Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[Out] MC_Stop

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値] 0x02: Busy
0x04: Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_TOUCH_PROBE_IN 構造体

フィールド
MC_TOUCH_PROBE_IN 構造体

[In] MC_TouchProbe [詳解]

#include <hmecw0_struct.h>

フィールド

MC_TRIGGER_REF TriggerInput
タッチプローブ要素 [詳解]
BOOL | bWindowOnly
モニタリング範囲設定
[値] FALSE:無効，TRUE:有効 [詳解]
double | fFirstPosition
モニタリング範囲開始位置
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
double | fLastPosition
モニタリング範囲終了位置
[単位] pulse
[範囲] -2147483647 - 2147483648 [詳解]
WORD | wPositionSelect
(予約) [詳解]
WORD | wStopMotionSelect
(予約) [詳解]

詳解

[In] MC_TouchProbe

フィールド詳解

◆ TriggerInput

MC_TRIGGER_REF TriggerInput

タッチプローブ要素

◆ bWindowOnly

BOOL bWindowOnly

モニタリング範囲設定
[値] FALSE:無効，TRUE:有効

◆ fFirstPosition

double fFirstPosition

モニタリング範囲開始位置
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ fLastPosition

double fLastPosition

モニタリング範囲終了位置
[単位] pulse
[範囲] -2147483647 - 2147483648

◆ wPositionSelect

WORD wPositionSelect

(予約)

◆ wStopMotionSelect

WORD wStopMotionSelect

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_TOUCH_PROBE_OUT 構造体

フィールド
MC_TOUCH_PROBE_OUT 構造体

[In] MC_TouchProbe [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wStatus
ステータス
[値]
0x02:Busy
0x04:Error [詳解]
WORD | wErrorID
エラーID
[範囲] 0-0xFFFF [詳解]

詳解

[In] MC_TouchProbe

フィールド詳解

◆ wStatus

WORD wStatus

ステータス
[値]
0x02:Busy
0x04:Error

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: MC_TRIGGER_REF 構造体

フィールド
MC_TRIGGER_REF 構造体

[Struct] MC_TOUCH_PROBE_IN [詳解]

#include <hmecw0_struct.h>

フィールド

WORD | wProbeID
プローブID
[値] 1: プローブ 1，2: プローブ2 [詳解]
BOOL | bEdge
値を1に設定してください
[値] 1:立ち上がりエッジを使用 [詳解]
BYTE | byTriggerMode
(予約) [詳解]
BYTE | byInputSelect
トリガの選択
ご使用のサーボドライバをご確認下さい． [詳解]
BYTE | byEncoderID
(予約) [詳解]
BYTE | byTriggerVariable
(予約) [詳解]
BYTE | byProbeState
(予約) [詳解]

詳解

[Struct] MC_TOUCH_PROBE_IN

[In] MC_AbortTrigger

フィールド詳解

◆ wProbeID

WORD wProbeID

プローブID
[値] 1: プローブ 1，2: プローブ2

◆ bEdge

BOOL bEdge

値を1に設定してください
[値] 1:立ち上がりエッジを使用

◆ byTriggerMode

BYTE byTriggerMode

(予約)

◆ byInputSelect

BYTE byInputSelect

トリガの選択
ご使用のサーボドライバをご確認下さい．

◆ byEncoderID

BYTE byEncoderID

(予約)

◆ byTriggerVariable

BYTE byTriggerVariable

(予約)

◆ byProbeState

BYTE byProbeState

(予約)

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: READ_AXIS_INFO 構造体

フィールド
READ_AXIS_INFO 構造体

[Struct] MC_AXES_READ_INFO [詳解]

#include <hmecw0_struct.h>

フィールド

DWORD dwAxisInfo
軸情報
bit1: 原点入力信号 [値] 0: OFF, 1: ON
bit2: +ELS [値] 0: OFF, 1: ON
bit3: -ELS [値] 0:OFF, 1:ON
bit7: スレーブを駆動する準備が完了 [値] 0: 未完了, 1: 完了
bit8: サーボ [値] 0:OFF, 1:ON
bit9: 原点復帰完了(原点復帰方式がCiA402による方式の場合) [値] 0:未確定, 1:確定
Bit10: ワーニング発生状況 [値] 0:未発生, 1:ワーニング発生 [詳解]

詳解

[Struct] MC_AXES_READ_INFO

[Out] MC_GroupAxesReadInfo

フィールド詳解

◆ dwAxisInfo

DWORD dwAxisInfo

軸情報
bit1: 原点入力信号 [値] 0: OFF, 1: ON
bit2: +ELS [値] 0: OFF, 1: ON
bit3: -ELS [値] 0:OFF, 1:ON
bit7: スレーブを駆動する準備が完了 [値] 0: 未完了, 1: 完了
bit8: サーボ [値] 0:OFF, 1:ON
bit9: 原点復帰完了(原点復帰方式がCiA402による方式の場合) [値] 0:未確定, 1:確定
Bit10: ワーニング発生状況 [値] 0:未発生, 1:ワーニング発生

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: READ_ERROR 構造体

フィールド
READ_ERROR 構造体

[Struct] MC_AXES_READ_ERROR [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wErrorID
エラーID
[範囲] 0-0xFFFF. [詳解]

詳解

[Struct] MC_AXES_READ_ERROR

[Out] MC_GroupAxesReadError

フィールド詳解

◆ wErrorID

WORD wErrorID

エラーID
[範囲] 0-0xFFFF.

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: READ_MOTION_STATE 構造体

フィールド
READ_MOTION_STATE 構造体

[Struct] MC_AXES_READ_MOTION_STATE [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wMotionState
モーションステータス
[値]
bit1: 定速中
bit2: 加速中
bit3: 減速中
bit4: +方向動作中
bit5: -方向動作中 [詳解]

詳解

[Struct] MC_AXES_READ_MOTION_STATE

[Out] MC_GroupAxesReadMotionState

フィールド詳解

◆ wMotionState

WORD wMotionState

モーションステータス
[値]
bit1: 定速中
bit2: 加速中
bit3: 減速中
bit4: +方向動作中
bit5: -方向動作中

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: READ_STATUS 構造体

フィールド
READ_STATUS 構造体

[Struct] MC_AXES_READ_STATUS [詳解]

#include <hmecw0_struct.h>

フィールド

WORD wStatus
状態遷移ステータス
[値]
0x02: ErrorStop
0x04: Disabled
0x08: Stopping
0x10: Homing
0x20: StandStill
0x40: DiscreteMotion
0x80: ContinuousMotion
0x100: SynchronizedMotion [詳解]

詳解

[Struct] MC_AXES_READ_STATUS

[Out] MC_GroupAxesReadStatus

フィールド詳解

◆ wStatus

WORD wStatus

状態遷移ステータス
[値]
0x02: ErrorStop
0x04: Disabled
0x08: Stopping
0x10: Homing
0x20: StandStill
0x40: DiscreteMotion
0x80: ContinuousMotion
0x100: SynchronizedMotion

この構造体詳解は次のファイルから抽出されました:
  • hmecw0_struct.h


HLS-ECAT02WIN APIリファレンス: データ構造索引

データ構造索引
E | M | R
E
EC_DELAY_TIMER
EC_DIAGNOSIS_MESSAGE_FLAGS
EC_DIAGNOSIS_PARAMETER
EC_GET_DIAGNOSIS_MESSAGE_OUT
EC_GET_SLAVE_INFO_IN
EC_LOGPOS_STATUS
EC_MASTER_INFO
EC_SAVE_LOGPOS
EC_SLAVE_INFO
EC_START_LOGPOS
EC_VERSION
M
MC_ACTUAL_POSITION
MC_ACTUAL_VELOCITY
MC_AXES_GROUP_REF
MC_AXES_READ_ERROR
MC_AXES_READ_INFO
MC_AXES_READ_MOTION_STATE
MC_AXES_READ_STATUS
MC_AXIS_DRIVE
MC_AXIS_ERROR
MC_AXIS_FACTOR
MC_AXIS_INFO
MC_AXIS_MACHINE
MC_AXIS_MOVE
MC_AXIS_REF
MC_AXIS_SETTING
MC_BUFFER_FUNC
MC_GROUP_ADD_AXIS
MC_GROUP_BUFFER_FUNC
MC_GROUP_HOME_IN
MC_GROUP_HOME_OUT
MC_GROUP_MOVE
MC_GROUP_MOVE_FUNCTION_RESULT
MC_GROUP_READ_ACT_POS_IN
MC_GROUP_READ_ACT_POS_OUT
MC_GROUP_READ_ACT_VEL_IN
MC_GROUP_READ_ACT_VEL_OUT
MC_GROUP_READ_BUFFER_OUT
MC_GROUP_READ_CONFIG_IN
MC_GROUP_READ_CONFIG_OUT
MC_GROUP_READ_ERROR
MC_GROUP_READ_PATH_DATA_OUT
MC_GROUP_READ_STATUS
MC_GROUP_REMOVE_AXIS
MC_GROUP_RESET_OUT
MC_GROUP_SET_OVERRIDE_IN
MC_GROUP_SET_POSITION
MC_GROUP_SETTING
MC_GROUP_STOP_IN
MC_GROUP_STOP_OUT
MC_HOME_IN
MC_HOME_OUT
MC_LATCH_COUNT_REF
MC_LATCH_COUNT_RESULT
MC_MOTION_STATE
MC_MOVE_ABSOLUTE_IN
MC_MOVE_ABSOLUTE_OUT
MC_MOVE_ADDITIVE_IN
MC_MOVE_ADDITIVE_OUT
MC_MOVE_FUNCTION_RESULT
MC_MOVE_LINEAR_ABS_IN
MC_MOVE_LINEAR_ABS_OUT
MC_MOVE_LINEAR_REL_IN
MC_MOVE_LINEAR_REL_OUT
MC_MOVE_LINEAR_VEL_IN
MC_MOVE_LINEAR_VEL_OUT
MC_MOVE_PATH_IN
MC_MOVE_PATH_OUT
MC_MOVE_RELATIVE_IN
MC_MOVE_RELATIVE_OUT
MC_MOVE_VELOCITY_IN
MC_MOVE_VELOCITY_OUT
MC_PATH_DATA_REF
MC_POWER_IN
MC_POWER_OUT
MC_PROBE_STATUS
MC_READ_BUFFER_OUT
MC_RESET_OUT
MC_SET_OVERRIDE_IN
MC_STATUS
MC_STOP_IN
MC_STOP_OUT
MC_TOUCH_PROBE_IN
MC_TOUCH_PROBE_OUT
MC_TRIGGER_REF
R
READ_AXIS_INFO
READ_ERROR
READ_MOTION_STATE
READ_STATUS


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- a -

  • AxisDrive : MC_AXIS_SETTING
  • AxisError : MC_AXES_READ_ERROR
  • AxisFactor : MC_AXIS_SETTING
  • AxisInfo : MC_AXES_READ_INFO
  • AxisMachine : MC_AXIS_SETTING
  • AxisMove : MC_AXIS_SETTING


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- b -

  • bAxisNo : EC_SLAVE_INFO
  • bBasePrioriy : EC_MASTER_INFO
  • bBoolParameter : EC_DIAGNOSIS_PARAMETER
  • bBufferNum : MC_GROUP_READ_BUFFER_OUT , MC_READ_BUFFER_OUT
  • bByteArrayParameter : EC_DIAGNOSIS_PARAMETER
  • bDeviationStopEnable : MC_GROUP_MOVE
  • bDisableErrMes : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bDisableInfMes : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bDisableWaitMotionInt : MC_AXIS_MOVE , MC_GROUP_MOVE
  • bDisableWarnMes : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bEdge : MC_TRIGGER_REF
  • bElsInput : MC_AXIS_MACHINE
  • bEnable : MC_POWER_IN
  • bEnableEmergensy : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bEnableNegative : MC_POWER_IN
  • bEnablePositive : MC_POWER_IN
  • bEncoder : MC_HOME_IN
  • bError : MC_POWER_OUT
  • bFollowingError : MC_AXIS_DRIVE
  • bFuncID : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC
  • bInposEnable : MC_AXIS_DRIVE
  • bInposInput : MC_AXIS_DRIVE
  • bInposMode : MC_AXIS_MOVE
  • bJogAxis : MC_MOVE_LINEAR_VEL_IN
  • bModeSelect : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bNegaElsEnable : MC_AXIS_MACHINE
  • bParameterNum : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • bPosiElsEnable : MC_AXIS_MACHINE
  • bPositionInp : MC_GROUP_SET_POSITION
  • bProbe1Stored : MC_LATCH_COUNT_RESULT
  • bProbe2Stored : MC_LATCH_COUNT_RESULT
  • bSlaveNo : EC_SLAVE_INFO , MC_AXIS_REF
  • bStatus : MC_POWER_OUT
  • bSyncMotion : MC_HOME_IN
  • bType : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • BufferFunction : MC_GROUP_READ_BUFFER_OUT , MC_READ_BUFFER_OUT
  • bUnsigned8Parameter : EC_DIAGNOSIS_PARAMETER
  • bVersion : EC_VERSION
  • bWindowOnly : MC_TOUCH_PROBE_IN
  • byBase : MC_MOVE_LINEAR_VEL_IN
  • byCoordSys : MC_GROUP_READ_ACT_POS_IN , MC_GROUP_READ_ACT_VEL_IN , MC_GROUP_SET_POSITION
  • byCoordSystem : MC_MOVE_PATH_IN
  • byDeviationStopMode : MC_GROUP_MOVE
  • byEncoderID : MC_TRIGGER_REF
  • byFormat : EC_SAVE_LOGPOS
  • byGroupID : MC_AXES_GROUP_REF
  • byHomingMethod : MC_HOME_IN
  • byInpMode : MC_MOVE_PATH_IN
  • byInputSelect : MC_TRIGGER_REF
  • byLatchCountRef : MC_LATCH_COUNT_REF , MC_LATCH_COUNT_RESULT
  • byMasterSeqNo : MC_GROUP_MOVE
  • byMode : MC_MOVE_LINEAR_VEL_IN
  • byMtnCmd : MC_PATH_DATA_REF
  • byProbeState : MC_TRIGGER_REF
  • bySeqNo : MC_GROUP_ADD_AXIS , MC_GROUP_READ_CONFIG_IN , MC_GROUP_REMOVE_AXIS
  • bySlaveSeqNo : MC_GROUP_MOVE
  • bySyncAxis : MC_AXES_GROUP_REF
  • byTransitionMode : MC_MOVE_PATH_IN , MC_PATH_DATA_REF
  • byTriggerMode : MC_TRIGGER_REF
  • byTriggerVariable : MC_TRIGGER_REF


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- c -

  • cInt8Parameter : EC_DIAGNOSIS_PARAMETER
  • cInterfaceDriver : EC_MASTER_INFO
  • cMasterName : EC_MASTER_INFO
  • cRedundancyDriver : EC_MASTER_INFO
  • cStrParameter : EC_DIAGNOSIS_PARAMETER


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- d -

  • dwAutoIncAddr : EC_SLAVE_INFO
  • dwAxisInfo : MC_AXIS_INFO , READ_AXIS_INFO
  • dwCyclicTime : EC_MASTER_INFO
  • dwDCEnable : EC_SLAVE_INFO
  • dwDisPR : MC_AXIS_MOVE
  • dwErrLine : MC_MOVE_PATH_OUT
  • dwHomePushWait : MC_HOME_IN
  • dwInposWidth : MC_AXIS_MOVE
  • dwInstance : EC_GET_SLAVE_INFO_IN , EC_SLAVE_INFO
  • dwPdoInSize : EC_MASTER_INFO
  • dwPdoOutSize : EC_MASTER_INFO
  • dwPhysicalAddr : EC_SLAVE_INFO
  • dwProductCode : EC_GET_SLAVE_INFO_IN , EC_SLAVE_INFO
  • dwPullPR : MC_AXIS_MOVE
  • dwRevisionNo : EC_SLAVE_INFO
  • dwRun : MC_GROUP_READ_PATH_DATA_OUT
  • dwSerialNo : EC_SLAVE_INFO
  • dwSize : MC_GROUP_READ_PATH_DATA_OUT , MC_MOVE_PATH_IN , MC_MOVE_PATH_OUT
  • dwStatusBit : EC_SLAVE_INFO
  • dwTimeStampH : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • dwTimeStampL : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • dwUnsigned32Parameter : EC_DIAGNOSIS_PARAMETER
  • dwVendorID : EC_GET_SLAVE_INFO_IN , EC_SLAVE_INFO
  • dwViosInBaseOffset : EC_SLAVE_INFO
  • dwViosInSize : EC_SLAVE_INFO
  • dwViosOutBaseOffset : EC_SLAVE_INFO
  • dwViosOutSize : EC_SLAVE_INFO


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- f -

  • fAcceleration : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF
  • fAccFactor : MC_GROUP_SET_OVERRIDE_IN , MC_SET_OVERRIDE_IN
  • fActTime : EC_LOGPOS_STATUS
  • fCornerDistance : MC_MOVE_PATH_IN , MC_PATH_DATA_REF
  • fDeceleration : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_STOP_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF , MC_STOP_IN
  • fDeviationDec : MC_GROUP_MOVE
  • fDeviationJerk : MC_GROUP_MOVE
  • fDistance : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_RELATIVE_IN
  • fFirstPosition : MC_TOUCH_PROBE_IN
  • fFLvelocity : MC_AXIS_MOVE
  • fHomeMaskDis : MC_HOME_IN
  • fHomePosiOffset : MC_HOME_IN
  • fJerk : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_STOP_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF , MC_STOP_IN
  • fJerkFactor : MC_GROUP_SET_OVERRIDE_IN , MC_SET_OVERRIDE_IN
  • fJogVelocity : MC_MOVE_LINEAR_VEL_IN
  • fLastPosition : MC_TOUCH_PROBE_IN
  • fMaxCornerDeviation : MC_MOVE_PATH_IN , MC_PATH_DATA_REF
  • fMaxCount : MC_AXIS_FACTOR
  • fMaxSLS : MC_AXIS_MOVE
  • fMaxTime : EC_LOGPOS_STATUS
  • fMinCount : MC_AXIS_FACTOR
  • fMinSLS : MC_AXIS_MOVE
  • fPathVelocity : MC_GROUP_READ_ACT_VEL_OUT
  • fPosDevAlarm : MC_AXIS_MOVE
  • fPosDeviation : MC_AXIS_MOVE , MC_GROUP_MOVE
  • fPosition : MC_ACTUAL_POSITION , MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_READ_ACT_POS_OUT , MC_GROUP_SET_POSITION , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_LINEAR_ABS_IN , MC_PATH_DATA_REF
  • fProbe1RecPosition : MC_LATCH_COUNT_RESULT
  • fProbe2RecPosition : MC_LATCH_COUNT_RESULT
  • fSpeed1 : MC_HOME_IN
  • fSpeed2 : MC_HOME_IN
  • fTime : EC_START_LOGPOS
  • fTransitionParam : MC_MOVE_PATH_IN
  • fVelFactor : MC_GROUP_SET_OVERRIDE_IN , MC_MOVE_PATH_IN , MC_PATH_DATA_REF , MC_SET_OVERRIDE_IN
  • fVelocity : MC_ACTUAL_VELOCITY , MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_READ_ACT_VEL_OUT , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- g -

  • GroupMove : MC_GROUP_SETTING


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- h -

  • hMasterHandle : EC_MASTER_INFO


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- l -

  • lEncPulse : MC_AXIS_MOVE
  • lInt32Parameter : EC_DIAGNOSIS_PARAMETER
  • lMvAbsDelay : EC_DELAY_TIMER
  • lMvAddDelay : EC_DELAY_TIMER
  • lMvHmDelay : EC_DELAY_TIMER
  • lMvRelDelay : EC_DELAY_TIMER
  • lMvVelDelay : EC_DELAY_TIMER


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- m -

  • MotionState : MC_AXES_READ_MOTION_STATE


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- p -

  • Parameter : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • PathRef : MC_GROUP_READ_PATH_DATA_OUT
  • pName : EC_SAVE_LOGPOS , MC_MOVE_PATH_IN
  • pPath : EC_SAVE_LOGPOS


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- s -

  • sInt16Parameter : EC_DIAGNOSIS_PARAMETER
  • Status : MC_AXES_READ_STATUS
  • stAxis : MC_AXES_GROUP_REF , MC_GROUP_READ_CONFIG_OUT


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- t -

  • TriggerInput : MC_TOUCH_PROBE_IN


HLS-ECAT02WIN APIリファレンス: データフィールド

構造体・共用体の全フィールド一覧です。各フィールドが属する構造体・共用体へのリンクがあります。

- w -

  • wActuatorType : MC_AXIS_FACTOR
  • wAlias : EC_SLAVE_INFO
  • wAxisNo : MC_AXIS_REF
  • wAxisNum : EC_VERSION
  • wAxisType : MC_AXIS_FACTOR
  • wBufferMode : MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_SET_POSITION , MC_GROUP_STOP_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_PATH_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF
  • wCountMode : MC_AXIS_FACTOR
  • wDirection : MC_MOVE_ABSOLUTE_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_VELOCITY_IN
  • wElsStop : MC_AXIS_MACHINE
  • wEncType : MC_AXIS_FACTOR
  • wErrorID : MC_AXES_READ_ERROR , MC_AXIS_ERROR , MC_GROUP_HOME_OUT , MC_GROUP_MOVE_FUNCTION_RESULT , MC_GROUP_READ_BUFFER_OUT , MC_GROUP_READ_ERROR , MC_GROUP_RESET_OUT , MC_GROUP_STOP_OUT , MC_HOME_OUT , MC_MOVE_ABSOLUTE_OUT , MC_MOVE_ADDITIVE_OUT , MC_MOVE_FUNCTION_RESULT , MC_MOVE_LINEAR_ABS_OUT , MC_MOVE_LINEAR_REL_OUT , MC_MOVE_LINEAR_VEL_OUT , MC_MOVE_PATH_OUT , MC_MOVE_RELATIVE_OUT , MC_MOVE_VELOCITY_OUT , MC_POWER_OUT , MC_READ_BUFFER_OUT , MC_RESET_OUT , MC_STOP_OUT , MC_TOUCH_PROBE_OUT , READ_ERROR
  • wFlags : EC_DIAGNOSIS_PARAMETER
  • wFunction : MC_GROUP_MOVE_FUNCTION_RESULT , MC_MOVE_FUNCTION_RESULT
  • wHomePosiDir : MC_HOME_IN
  • wHomePosiInpDir : MC_HOME_IN
  • wHomePosiInpType : MC_HOME_IN
  • wIncPerMM : MC_AXIS_MOVE
  • wMotionState : MC_MOTION_STATE , READ_MOTION_STATE
  • wMotionStatus : MC_AXES_READ_MOTION_STATE , MC_AXES_READ_STATUS , MC_GROUP_READ_STATUS
  • wMotorType : MC_AXIS_FACTOR
  • woProbe1ErrorID : MC_PROBE_STATUS
  • woProbe1Status : MC_PROBE_STATUS
  • woProbe2ErrorID : MC_PROBE_STATUS
  • woProbe2Status : MC_PROBE_STATUS
  • wPLCOpenStatus : MC_AXES_READ_MOTION_STATE , MC_AXES_READ_STATUS , MC_GROUP_READ_STATUS
  • wPositionSelect : MC_TOUCH_PROBE_IN
  • wPreviousDirection : MC_AXIS_MOVE
  • wProbe1ErrorID : MC_LATCH_COUNT_RESULT
  • wProbe1Status : MC_LATCH_COUNT_RESULT
  • wProbe2ErrorID : MC_LATCH_COUNT_RESULT
  • wProbe2Status : MC_LATCH_COUNT_RESULT
  • wProbeID : MC_TRIGGER_REF
  • wSlaveCountOnline : EC_MASTER_INFO
  • wSlaveCountXml : EC_MASTER_INFO
  • wSlaveStatus : EC_SLAVE_INFO
  • wSlaveType : EC_SLAVE_INFO
  • wStatus : EC_LOGPOS_STATUS , MC_GROUP_HOME_OUT , MC_GROUP_MOVE_FUNCTION_RESULT , MC_GROUP_RESET_OUT , MC_GROUP_STOP_OUT , MC_HOME_OUT , MC_MOVE_ABSOLUTE_OUT , MC_MOVE_ADDITIVE_OUT , MC_MOVE_FUNCTION_RESULT , MC_MOVE_LINEAR_ABS_OUT , MC_MOVE_LINEAR_REL_OUT , MC_MOVE_LINEAR_VEL_OUT , MC_MOVE_PATH_OUT , MC_MOVE_RELATIVE_OUT , MC_MOVE_VELOCITY_OUT , MC_RESET_OUT , MC_STATUS , MC_STOP_OUT , MC_TOUCH_PROBE_OUT , READ_STATUS
  • wStopMotionSelect : MC_TOUCH_PROBE_IN
  • wTextID : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • wUnsigned16Parameter : EC_DIAGNOSIS_PARAMETER


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- a -

  • AxisDrive : MC_AXIS_SETTING
  • AxisError : MC_AXES_READ_ERROR
  • AxisFactor : MC_AXIS_SETTING
  • AxisInfo : MC_AXES_READ_INFO
  • AxisMachine : MC_AXIS_SETTING
  • AxisMove : MC_AXIS_SETTING


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- b -

  • bAxisNo : EC_SLAVE_INFO
  • bBasePrioriy : EC_MASTER_INFO
  • bBoolParameter : EC_DIAGNOSIS_PARAMETER
  • bBufferNum : MC_GROUP_READ_BUFFER_OUT , MC_READ_BUFFER_OUT
  • bByteArrayParameter : EC_DIAGNOSIS_PARAMETER
  • bDeviationStopEnable : MC_GROUP_MOVE
  • bDisableErrMes : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bDisableInfMes : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bDisableWaitMotionInt : MC_AXIS_MOVE , MC_GROUP_MOVE
  • bDisableWarnMes : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bEdge : MC_TRIGGER_REF
  • bElsInput : MC_AXIS_MACHINE
  • bEnable : MC_POWER_IN
  • bEnableEmergensy : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bEnableNegative : MC_POWER_IN
  • bEnablePositive : MC_POWER_IN
  • bEncoder : MC_HOME_IN
  • bError : MC_POWER_OUT
  • bFollowingError : MC_AXIS_DRIVE
  • bFuncID : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC
  • bInposEnable : MC_AXIS_DRIVE
  • bInposInput : MC_AXIS_DRIVE
  • bInposMode : MC_AXIS_MOVE
  • bJogAxis : MC_MOVE_LINEAR_VEL_IN
  • bModeSelect : EC_DIAGNOSIS_MESSAGE_FLAGS
  • bNegaElsEnable : MC_AXIS_MACHINE
  • bParameterNum : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • bPosiElsEnable : MC_AXIS_MACHINE
  • bPositionInp : MC_GROUP_SET_POSITION
  • bProbe1Stored : MC_LATCH_COUNT_RESULT
  • bProbe2Stored : MC_LATCH_COUNT_RESULT
  • bSlaveNo : EC_SLAVE_INFO , MC_AXIS_REF
  • bStatus : MC_POWER_OUT
  • bSyncMotion : MC_HOME_IN
  • bType : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • BufferFunction : MC_GROUP_READ_BUFFER_OUT , MC_READ_BUFFER_OUT
  • bUnsigned8Parameter : EC_DIAGNOSIS_PARAMETER
  • bVersion : EC_VERSION
  • bWindowOnly : MC_TOUCH_PROBE_IN
  • byBase : MC_MOVE_LINEAR_VEL_IN
  • byCoordSys : MC_GROUP_READ_ACT_POS_IN , MC_GROUP_READ_ACT_VEL_IN , MC_GROUP_SET_POSITION
  • byCoordSystem : MC_MOVE_PATH_IN
  • byDeviationStopMode : MC_GROUP_MOVE
  • byEncoderID : MC_TRIGGER_REF
  • byFormat : EC_SAVE_LOGPOS
  • byGroupID : MC_AXES_GROUP_REF
  • byHomingMethod : MC_HOME_IN
  • byInpMode : MC_MOVE_PATH_IN
  • byInputSelect : MC_TRIGGER_REF
  • byLatchCountRef : MC_LATCH_COUNT_REF , MC_LATCH_COUNT_RESULT
  • byMasterSeqNo : MC_GROUP_MOVE
  • byMode : MC_MOVE_LINEAR_VEL_IN
  • byMtnCmd : MC_PATH_DATA_REF
  • byProbeState : MC_TRIGGER_REF
  • bySeqNo : MC_GROUP_ADD_AXIS , MC_GROUP_READ_CONFIG_IN , MC_GROUP_REMOVE_AXIS
  • bySlaveSeqNo : MC_GROUP_MOVE
  • bySyncAxis : MC_AXES_GROUP_REF
  • byTransitionMode : MC_MOVE_PATH_IN , MC_PATH_DATA_REF
  • byTriggerMode : MC_TRIGGER_REF
  • byTriggerVariable : MC_TRIGGER_REF


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- c -

  • cInt8Parameter : EC_DIAGNOSIS_PARAMETER
  • cInterfaceDriver : EC_MASTER_INFO
  • cMasterName : EC_MASTER_INFO
  • cRedundancyDriver : EC_MASTER_INFO
  • cStrParameter : EC_DIAGNOSIS_PARAMETER


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- d -

  • dwAutoIncAddr : EC_SLAVE_INFO
  • dwAxisInfo : MC_AXIS_INFO , READ_AXIS_INFO
  • dwCyclicTime : EC_MASTER_INFO
  • dwDCEnable : EC_SLAVE_INFO
  • dwDisPR : MC_AXIS_MOVE
  • dwErrLine : MC_MOVE_PATH_OUT
  • dwHomePushWait : MC_HOME_IN
  • dwInposWidth : MC_AXIS_MOVE
  • dwInstance : EC_GET_SLAVE_INFO_IN , EC_SLAVE_INFO
  • dwPdoInSize : EC_MASTER_INFO
  • dwPdoOutSize : EC_MASTER_INFO
  • dwPhysicalAddr : EC_SLAVE_INFO
  • dwProductCode : EC_GET_SLAVE_INFO_IN , EC_SLAVE_INFO
  • dwPullPR : MC_AXIS_MOVE
  • dwRevisionNo : EC_SLAVE_INFO
  • dwRun : MC_GROUP_READ_PATH_DATA_OUT
  • dwSerialNo : EC_SLAVE_INFO
  • dwSize : MC_GROUP_READ_PATH_DATA_OUT , MC_MOVE_PATH_IN , MC_MOVE_PATH_OUT
  • dwStatusBit : EC_SLAVE_INFO
  • dwTimeStampH : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • dwTimeStampL : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • dwUnsigned32Parameter : EC_DIAGNOSIS_PARAMETER
  • dwVendorID : EC_GET_SLAVE_INFO_IN , EC_SLAVE_INFO
  • dwViosInBaseOffset : EC_SLAVE_INFO
  • dwViosInSize : EC_SLAVE_INFO
  • dwViosOutBaseOffset : EC_SLAVE_INFO
  • dwViosOutSize : EC_SLAVE_INFO


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- f -

  • fAcceleration : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF
  • fAccFactor : MC_GROUP_SET_OVERRIDE_IN , MC_SET_OVERRIDE_IN
  • fActTime : EC_LOGPOS_STATUS
  • fCornerDistance : MC_MOVE_PATH_IN , MC_PATH_DATA_REF
  • fDeceleration : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_STOP_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF , MC_STOP_IN
  • fDeviationDec : MC_GROUP_MOVE
  • fDeviationJerk : MC_GROUP_MOVE
  • fDistance : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_RELATIVE_IN
  • fFirstPosition : MC_TOUCH_PROBE_IN
  • fFLvelocity : MC_AXIS_MOVE
  • fHomeMaskDis : MC_HOME_IN
  • fHomePosiOffset : MC_HOME_IN
  • fJerk : MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_STOP_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF , MC_STOP_IN
  • fJerkFactor : MC_GROUP_SET_OVERRIDE_IN , MC_SET_OVERRIDE_IN
  • fJogVelocity : MC_MOVE_LINEAR_VEL_IN
  • fLastPosition : MC_TOUCH_PROBE_IN
  • fMaxCornerDeviation : MC_MOVE_PATH_IN , MC_PATH_DATA_REF
  • fMaxCount : MC_AXIS_FACTOR
  • fMaxSLS : MC_AXIS_MOVE
  • fMaxTime : EC_LOGPOS_STATUS
  • fMinCount : MC_AXIS_FACTOR
  • fMinSLS : MC_AXIS_MOVE
  • fPathVelocity : MC_GROUP_READ_ACT_VEL_OUT
  • fPosDevAlarm : MC_AXIS_MOVE
  • fPosDeviation : MC_AXIS_MOVE , MC_GROUP_MOVE
  • fPosition : MC_ACTUAL_POSITION , MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_READ_ACT_POS_OUT , MC_GROUP_SET_POSITION , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_LINEAR_ABS_IN , MC_PATH_DATA_REF
  • fProbe1RecPosition : MC_LATCH_COUNT_RESULT
  • fProbe2RecPosition : MC_LATCH_COUNT_RESULT
  • fSpeed1 : MC_HOME_IN
  • fSpeed2 : MC_HOME_IN
  • fTime : EC_START_LOGPOS
  • fTransitionParam : MC_MOVE_PATH_IN
  • fVelFactor : MC_GROUP_SET_OVERRIDE_IN , MC_MOVE_PATH_IN , MC_PATH_DATA_REF , MC_SET_OVERRIDE_IN
  • fVelocity : MC_ACTUAL_VELOCITY , MC_BUFFER_FUNC , MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_READ_ACT_VEL_OUT , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- g -

  • GroupMove : MC_GROUP_SETTING


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- h -

  • hMasterHandle : EC_MASTER_INFO


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- l -

  • lEncPulse : MC_AXIS_MOVE
  • lInt32Parameter : EC_DIAGNOSIS_PARAMETER
  • lMvAbsDelay : EC_DELAY_TIMER
  • lMvAddDelay : EC_DELAY_TIMER
  • lMvHmDelay : EC_DELAY_TIMER
  • lMvRelDelay : EC_DELAY_TIMER
  • lMvVelDelay : EC_DELAY_TIMER


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- m -

  • MotionState : MC_AXES_READ_MOTION_STATE


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- p -

  • Parameter : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • PathRef : MC_GROUP_READ_PATH_DATA_OUT
  • pName : EC_SAVE_LOGPOS , MC_MOVE_PATH_IN
  • pPath : EC_SAVE_LOGPOS


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- s -

  • sInt16Parameter : EC_DIAGNOSIS_PARAMETER
  • Status : MC_AXES_READ_STATUS
  • stAxis : MC_AXES_GROUP_REF , MC_GROUP_READ_CONFIG_OUT


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- t -

  • TriggerInput : MC_TOUCH_PROBE_IN


HLS-ECAT02WIN APIリファレンス: データフィールド - 変数

- w -

  • wActuatorType : MC_AXIS_FACTOR
  • wAlias : EC_SLAVE_INFO
  • wAxisNo : MC_AXIS_REF
  • wAxisNum : EC_VERSION
  • wAxisType : MC_AXIS_FACTOR
  • wBufferMode : MC_GROUP_BUFFER_FUNC , MC_GROUP_HOME_IN , MC_GROUP_SET_POSITION , MC_GROUP_STOP_IN , MC_HOME_IN , MC_MOVE_ABSOLUTE_IN , MC_MOVE_ADDITIVE_IN , MC_MOVE_LINEAR_ABS_IN , MC_MOVE_LINEAR_REL_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_PATH_IN , MC_MOVE_RELATIVE_IN , MC_MOVE_VELOCITY_IN , MC_PATH_DATA_REF
  • wCountMode : MC_AXIS_FACTOR
  • wDirection : MC_MOVE_ABSOLUTE_IN , MC_MOVE_LINEAR_VEL_IN , MC_MOVE_VELOCITY_IN
  • wElsStop : MC_AXIS_MACHINE
  • wEncType : MC_AXIS_FACTOR
  • wErrorID : MC_AXES_READ_ERROR , MC_AXIS_ERROR , MC_GROUP_HOME_OUT , MC_GROUP_MOVE_FUNCTION_RESULT , MC_GROUP_READ_BUFFER_OUT , MC_GROUP_READ_ERROR , MC_GROUP_RESET_OUT , MC_GROUP_STOP_OUT , MC_HOME_OUT , MC_MOVE_ABSOLUTE_OUT , MC_MOVE_ADDITIVE_OUT , MC_MOVE_FUNCTION_RESULT , MC_MOVE_LINEAR_ABS_OUT , MC_MOVE_LINEAR_REL_OUT , MC_MOVE_LINEAR_VEL_OUT , MC_MOVE_PATH_OUT , MC_MOVE_RELATIVE_OUT , MC_MOVE_VELOCITY_OUT , MC_POWER_OUT , MC_READ_BUFFER_OUT , MC_RESET_OUT , MC_STOP_OUT , MC_TOUCH_PROBE_OUT , READ_ERROR
  • wFlags : EC_DIAGNOSIS_PARAMETER
  • wFunction : MC_GROUP_MOVE_FUNCTION_RESULT , MC_MOVE_FUNCTION_RESULT
  • wHomePosiDir : MC_HOME_IN
  • wHomePosiInpDir : MC_HOME_IN
  • wHomePosiInpType : MC_HOME_IN
  • wIncPerMM : MC_AXIS_MOVE
  • wMotionState : MC_MOTION_STATE , READ_MOTION_STATE
  • wMotionStatus : MC_AXES_READ_MOTION_STATE , MC_AXES_READ_STATUS , MC_GROUP_READ_STATUS
  • wMotorType : MC_AXIS_FACTOR
  • woProbe1ErrorID : MC_PROBE_STATUS
  • woProbe1Status : MC_PROBE_STATUS
  • woProbe2ErrorID : MC_PROBE_STATUS
  • woProbe2Status : MC_PROBE_STATUS
  • wPLCOpenStatus : MC_AXES_READ_MOTION_STATE , MC_AXES_READ_STATUS , MC_GROUP_READ_STATUS
  • wPositionSelect : MC_TOUCH_PROBE_IN
  • wPreviousDirection : MC_AXIS_MOVE
  • wProbe1ErrorID : MC_LATCH_COUNT_RESULT
  • wProbe1Status : MC_LATCH_COUNT_RESULT
  • wProbe2ErrorID : MC_LATCH_COUNT_RESULT
  • wProbe2Status : MC_LATCH_COUNT_RESULT
  • wProbeID : MC_TRIGGER_REF
  • wSlaveCountOnline : EC_MASTER_INFO
  • wSlaveCountXml : EC_MASTER_INFO
  • wSlaveStatus : EC_SLAVE_INFO
  • wSlaveType : EC_SLAVE_INFO
  • wStatus : EC_LOGPOS_STATUS , MC_GROUP_HOME_OUT , MC_GROUP_MOVE_FUNCTION_RESULT , MC_GROUP_RESET_OUT , MC_GROUP_STOP_OUT , MC_HOME_OUT , MC_MOVE_ABSOLUTE_OUT , MC_MOVE_ADDITIVE_OUT , MC_MOVE_FUNCTION_RESULT , MC_MOVE_LINEAR_ABS_OUT , MC_MOVE_LINEAR_REL_OUT , MC_MOVE_LINEAR_VEL_OUT , MC_MOVE_PATH_OUT , MC_MOVE_RELATIVE_OUT , MC_MOVE_VELOCITY_OUT , MC_RESET_OUT , MC_STATUS , MC_STOP_OUT , MC_TOUCH_PROBE_OUT , READ_STATUS
  • wStopMotionSelect : MC_TOUCH_PROBE_IN
  • wTextID : EC_GET_DIAGNOSIS_MESSAGE_OUT
  • wUnsigned16Parameter : EC_DIAGNOSIS_PARAMETER


HLS-ECAT02WIN APIリファレンス: ファイル一覧

ファイル一覧
ファイル一覧です。
hmecw0_func.h
hmecw0_macro.h
hmecw0_struct.h
mainpage.h


HLS-ECAT02WIN APIリファレンス: mainpage.h ファイル

mainpage.h ファイル


HLS-ECAT02WIN APIリファレンス: mainpage.h ソースファイル

mainpage.h
[詳解]
1


HLS-ECAT02WIN APIリファレンス: 大域各種

関数・変数・マクロ・列挙・型定義一覧です。各々詳解があればそこへリンクしています。

- e -

  • EC_ClearLogPositionMemory() : hmecw0_func.h
  • EC_CloseMaster() : hmecw0_func.h
  • EC_GetDiagnosisMessage() : hmecw0_func.h
  • EC_GetDiagnosisMessageFlags() : hmecw0_func.h
  • EC_GetMasterInfo() : hmecw0_func.h
  • EC_GetSlaveInfo() : hmecw0_func.h
  • EC_OpenMaster() : hmecw0_func.h
  • EC_ReadLogPositionStatus() : hmecw0_func.h
  • EC_ReadSDO() : hmecw0_func.h
  • EC_ReadVersion() : hmecw0_func.h
  • EC_ResetDiagnosisMessage() : hmecw0_func.h
  • EC_SaveLogPosition() : hmecw0_func.h
  • EC_SetDiagnosisMessageFlags() : hmecw0_func.h
  • EC_StartLogPosition() : hmecw0_func.h
  • EC_StopLogPosition() : hmecw0_func.h
  • EC_WriteSDO() : hmecw0_func.h


HLS-ECAT02WIN APIリファレンス: 大域各種

関数・変数・マクロ・列挙・型定義一覧です。各々詳解があればそこへリンクしています。

- i -

  • IO_Groupinp() : hmecw0_func.h
  • IO_Groupinpdw() : hmecw0_func.h
  • IO_Groupinpw() : hmecw0_func.h
  • IO_Groupoutp() : hmecw0_func.h
  • IO_Groupoutpdw() : hmecw0_func.h
  • IO_Groupoutpw() : hmecw0_func.h
  • IO_inp() : hmecw0_func.h
  • IO_inpdw() : hmecw0_func.h
  • IO_inpw() : hmecw0_func.h
  • IO_outp() : hmecw0_func.h
  • IO_outpdw() : hmecw0_func.h
  • IO_outpw() : hmecw0_func.h


HLS-ECAT02WIN APIリファレンス: 大域各種

関数・変数・マクロ・列挙・型定義一覧です。各々詳解があればそこへリンクしています。

- m -

  • MC_AbortTrigger() : hmecw0_func.h
  • MC_AddAxisToGroup() : hmecw0_func.h
  • MC_CancelWaitInterrupt() : hmecw0_func.h
  • MC_CancelWaitLatchCountInterrupt() : hmecw0_func.h
  • MC_DeleteBuffer() : hmecw0_func.h
  • MC_GetAxisSetting() : hmecw0_func.h
  • MC_GetGroupIntSignalInfo() : hmecw0_func.h
  • MC_GetGroupSetting() : hmecw0_func.h
  • MC_GetIntSignalInfo() : hmecw0_func.h
  • MC_GetLatchCountIntSignalInfo() : hmecw0_func.h
  • MC_GroupAxesReadError() : hmecw0_func.h
  • MC_GroupAxesReadInfo() : hmecw0_func.h
  • MC_GroupAxesReadMotionState() : hmecw0_func.h
  • MC_GroupAxesReadStatus() : hmecw0_func.h
  • MC_GroupCancelWaitInterrupt() : hmecw0_func.h
  • MC_GroupDeleteBuffer() : hmecw0_func.h
  • MC_GroupDisable() : hmecw0_func.h
  • MC_GroupEnable() : hmecw0_func.h
  • MC_GroupHome() : hmecw0_func.h
  • MC_GroupReadActualPosition() : hmecw0_func.h
  • MC_GroupReadActualVelocity() : hmecw0_func.h
  • MC_GroupReadBuffer() : hmecw0_func.h
  • MC_GroupReadConfiguration() : hmecw0_func.h
  • MC_GroupReadError() : hmecw0_func.h
  • MC_GroupReadFunctionResult() : hmecw0_func.h
  • MC_GroupReadPathData() : hmecw0_func.h
  • MC_GroupReadStatus() : hmecw0_func.h
  • MC_GroupReset() : hmecw0_func.h
  • MC_GroupResetMotionSts() : hmecw0_func.h
  • MC_GroupSetOverride() : hmecw0_func.h
  • MC_GroupSetPosition() : hmecw0_func.h
  • MC_GroupStop() : hmecw0_func.h
  • MC_GroupWaitNextInterrupt() : hmecw0_func.h
  • MC_Home() : hmecw0_func.h
  • MC_MoveAbsolute() : hmecw0_func.h
  • MC_MoveAdditive() : hmecw0_func.h
  • MC_MoveLinearAbsolute() : hmecw0_func.h
  • MC_MoveLinearRelative() : hmecw0_func.h
  • MC_MoveLinearVelocity() : hmecw0_func.h
  • MC_MovePath() : hmecw0_func.h
  • MC_MoveRelative() : hmecw0_func.h
  • MC_MoveVelocity() : hmecw0_func.h
  • MC_Power() : hmecw0_func.h
  • MC_ReadActualPosition() : hmecw0_func.h
  • MC_ReadActualVelocity() : hmecw0_func.h
  • MC_ReadAxisError() : hmecw0_func.h
  • MC_ReadAxisInfo() : hmecw0_func.h
  • MC_ReadBuffer() : hmecw0_func.h
  • MC_ReadDelayTimer() : hmecw0_func.h
  • MC_ReadFunctionResult() : hmecw0_func.h
  • MC_ReadLatchCountResult() : hmecw0_func.h
  • MC_ReadMotionState() : hmecw0_func.h
  • MC_ReadProbeStatus() : hmecw0_func.h
  • MC_ReadStatus() : hmecw0_func.h
  • MC_RemoveAxisFromGroup() : hmecw0_func.h
  • MC_Reset() : hmecw0_func.h
  • MC_ResetAxisSetting() : hmecw0_func.h
  • MC_ResetGroupSetting() : hmecw0_func.h
  • MC_ResetLatchSts() : hmecw0_func.h
  • MC_ResetMotionSts() : hmecw0_func.h
  • MC_SetAxisSetting() : hmecw0_func.h
  • MC_SetDelayTimer() : hmecw0_func.h
  • MC_SetGroupIntSignalInfo() : hmecw0_func.h
  • MC_SetGroupSetting() : hmecw0_func.h
  • MC_SetIntSignalInfo() : hmecw0_func.h
  • MC_SetLatchCountIntSignalInfo() : hmecw0_func.h
  • MC_SetOverride() : hmecw0_func.h
  • MC_SetPosition() : hmecw0_func.h
  • MC_Stop() : hmecw0_func.h
  • MC_TouchProbe() : hmecw0_func.h
  • MC_UngroupAllAxes() : hmecw0_func.h
  • MC_WaitNextInterrupt() : hmecw0_func.h
  • MC_WaitNextLatchCountInterrupt() : hmecw0_func.h


HLS-ECAT02WIN APIリファレンス: 大域各種

関数・変数・マクロ・列挙・型定義一覧です。各々詳解があればそこへリンクしています。

- r -

  • RESULT_FUNCTION_ABSOLUTE : hmecw0_macro.h
  • RESULT_FUNCTION_ADDITIVE : hmecw0_macro.h
  • RESULT_FUNCTION_GROUP_HOME : hmecw0_macro.h
  • RESULT_FUNCTION_GROUP_RESET : hmecw0_macro.h
  • RESULT_FUNCTION_GROUP_STOP : hmecw0_macro.h
  • RESULT_FUNCTION_HOME : hmecw0_macro.h
  • RESULT_FUNCTION_LINEAR_ABSOLUTE : hmecw0_macro.h
  • RESULT_FUNCTION_LINEAR_RELATIVE : hmecw0_macro.h
  • RESULT_FUNCTION_LINEAR_VELOCITY : hmecw0_macro.h
  • RESULT_FUNCTION_MOVE_PATH : hmecw0_macro.h
  • RESULT_FUNCTION_RELATIVE : hmecw0_macro.h
  • RESULT_FUNCTION_RESET : hmecw0_macro.h
  • RESULT_FUNCTION_STOP : hmecw0_macro.h
  • RESULT_FUNCTION_VELOCITY : hmecw0_macro.h
  • RESULT_STATUS_ABORTED : hmecw0_macro.h
  • RESULT_STATUS_ABORTED_WAIT : hmecw0_macro.h
  • RESULT_STATUS_BUSY : hmecw0_macro.h
  • RESULT_STATUS_BUSY_WAIT : hmecw0_macro.h
  • RESULT_STATUS_DONE : hmecw0_macro.h
  • RESULT_STATUS_DONE_WAIT : hmecw0_macro.h
  • RESULT_STATUS_ERROR : hmecw0_macro.h
  • RESULT_STATUS_ERROR_WAIT : hmecw0_macro.h
  • RET_ABORT_TRIG_RUNNING_ERR : hmecw0_macro.h
  • RET_ACTIVE_OTHER_FUNCTION : hmecw0_macro.h
  • RET_ALAM : hmecw0_macro.h
  • RET_AXIS_ERR : hmecw0_macro.h
  • RET_AXIS_REG_ERR : hmecw0_macro.h
  • RET_AXIS_REGISTERED : hmecw0_macro.h
  • RET_BUFFER_FULL : hmecw0_macro.h
  • RET_BUFFER_MODE_INVALID : hmecw0_macro.h
  • RET_DIAGNOSIS_MESSAGE_ERR : hmecw0_macro.h
  • RET_EHAPI_ALIAS_CONFLICT : hmecw0_macro.h
  • RET_EHAPI_CATALOG : hmecw0_macro.h
  • RET_EHAPI_CATEGORY : hmecw0_macro.h
  • RET_EHAPI_CHANNEL : hmecw0_macro.h
  • RET_EHAPI_CLOSE : hmecw0_macro.h
  • RET_EHAPI_CLOSED : hmecw0_macro.h
  • RET_EHAPI_CMDERR : hmecw0_macro.h
  • RET_EHAPI_CONFLICT : hmecw0_macro.h
  • RET_EHAPI_CREATE_EVENT : hmecw0_macro.h
  • RET_EHAPI_EDITION : hmecw0_macro.h
  • RET_EHAPI_ENIFILE : hmecw0_macro.h
  • RET_EHAPI_EXIST : hmecw0_macro.h
  • RET_EHAPI_FIND_SLAVE : hmecw0_macro.h
  • RET_EHAPI_INDEX : hmecw0_macro.h
  • RET_EHAPI_INVALID_EVENT : hmecw0_macro.h
  • RET_EHAPI_INVALID_LOCATION : hmecw0_macro.h
  • RET_EHAPI_IS_DEAD : hmecw0_macro.h
  • RET_EHAPI_LENGTH : hmecw0_macro.h
  • RET_EHAPI_LICENSE : hmecw0_macro.h
  • RET_EHAPI_LIMIT : hmecw0_macro.h
  • RET_EHAPI_MAX_OPEN : hmecw0_macro.h
  • RET_EHAPI_MAX_QUE : hmecw0_macro.h
  • RET_EHAPI_MEMORY : hmecw0_macro.h
  • RET_EHAPI_NIC_DRIVER : hmecw0_macro.h
  • RET_EHAPI_NO_RESPONSE : hmecw0_macro.h
  • RET_EHAPI_NOITEM : hmecw0_macro.h
  • RET_EHAPI_NOT_FOUND : hmecw0_macro.h
  • RET_EHAPI_NOT_HOTCONNECT : hmecw0_macro.h
  • RET_EHAPI_NOT_READY : hmecw0_macro.h
  • RET_EHAPI_NOT_REGISTERED : hmecw0_macro.h
  • RET_EHAPI_OBJECT : hmecw0_macro.h
  • RET_EHAPI_OFFLINE : hmecw0_macro.h
  • RET_EHAPI_OPEN : hmecw0_macro.h
  • RET_EHAPI_OPENED : hmecw0_macro.h
  • RET_EHAPI_PARAM : hmecw0_macro.h
  • RET_EHAPI_READ_EEPROM : hmecw0_macro.h
  • RET_EHAPI_READ_REGISTER : hmecw0_macro.h
  • RET_EHAPI_READONLY : hmecw0_macro.h
  • RET_EHAPI_RECV : hmecw0_macro.h
  • RET_EHAPI_REF_CATALOG : hmecw0_macro.h
  • RET_EHAPI_REG_EVENT : hmecw0_macro.h
  • RET_EHAPI_REQ_ERROR : hmecw0_macro.h
  • RET_EHAPI_RT_MEM : hmecw0_macro.h
  • RET_EHAPI_RT_VMEM : hmecw0_macro.h
  • RET_EHAPI_SEND : hmecw0_macro.h
  • RET_EHAPI_SIZE : hmecw0_macro.h
  • RET_EHAPI_SLAVE_COUNT : hmecw0_macro.h
  • RET_EHAPI_SLAVE_IS_ZERO : hmecw0_macro.h
  • RET_EHAPI_STARTARG_ABNORMAL : hmecw0_macro.h
  • RET_EHAPI_STARTARG_HIGHER : hmecw0_macro.h
  • RET_EHAPI_STARTARG_LOWER : hmecw0_macro.h
  • RET_EHAPI_STATE_I : hmecw0_macro.h
  • RET_EHAPI_STATE_O : hmecw0_macro.h
  • RET_EHAPI_STATE_P : hmecw0_macro.h
  • RET_EHAPI_STATE_S : hmecw0_macro.h
  • RET_EHAPI_STATE_UNKNOWN : hmecw0_macro.h
  • RET_EHAPI_STOPNODE : hmecw0_macro.h
  • RET_EHAPI_SUBINDEX : hmecw0_macro.h
  • RET_EHAPI_SYSERR : hmecw0_macro.h
  • RET_EHAPI_TIMEOUT : hmecw0_macro.h
  • RET_EHAPI_TXBUFF : hmecw0_macro.h
  • RET_EHAPI_TXDATA : hmecw0_macro.h
  • RET_EHAPI_WAIT_CANCEL : hmecw0_macro.h
  • RET_EHAPI_WAIT_EVENT : hmecw0_macro.h
  • RET_EHAPI_WORKING : hmecw0_macro.h
  • RET_EHAPI_WRITE_EEPROM : hmecw0_macro.h
  • RET_EHAPI_WRITE_REGISTER : hmecw0_macro.h
  • RET_EHAPI_WRITEONLY : hmecw0_macro.h
  • RET_ER_INVALID_BUFFER_MODE : hmecw0_macro.h
  • RET_FAILED_FILE_OPEN : hmecw0_macro.h
  • RET_FAILED_FILE_PROC : hmecw0_macro.h
  • RET_FOLLOWING_ERR : hmecw0_macro.h
  • RET_FUNC_ABORT_TRIG_ERR : hmecw0_macro.h
  • RET_FUNC_TOUCH_PRB_ERR : hmecw0_macro.h
  • RET_GROUP_ILL_PRM : hmecw0_macro.h
  • RET_GROUP_NO_AXIS : hmecw0_macro.h
  • RET_GRP_ADD_AXIS_FAILED : hmecw0_macro.h
  • RET_GRP_ARRAY0_ALAM : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_DIRECTION : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_FOLLOWING : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_NOT : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_PLCOPEN_STATE : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_POT : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_PRM : hmecw0_macro.h
  • RET_GRP_ARRAY0_RATIO_ERR : hmecw0_macro.h
  • RET_GRP_AXIS_EXIST : hmecw0_macro.h
  • RET_GRP_AXIS_ILL_CONDITION : hmecw0_macro.h
  • RET_GRP_AXIS_ILL_PRM : hmecw0_macro.h
  • RET_GRP_AXIS_NOT_EXIST : hmecw0_macro.h
  • RET_GRP_EXIST : hmecw0_macro.h
  • RET_GRP_FULL : hmecw0_macro.h
  • RET_GRP_ILL_DIRECTION : hmecw0_macro.h
  • RET_GRP_ILL_FOLLOWING : hmecw0_macro.h
  • RET_GRP_ILL_PLCOPEN_STATE : hmecw0_macro.h
  • RET_GRP_MVPATH_EXECUTED_ERR : hmecw0_macro.h
  • RET_GRP_OTHER_AXIS_EXIST : hmecw0_macro.h
  • RET_GRP_PATH_ACCELERATION_ERR : hmecw0_macro.h
  • RET_GRP_PATH_BUFFER_MODE_ERR : hmecw0_macro.h
  • RET_GRP_PATH_DECELERATION_ERR : hmecw0_macro.h
  • RET_GRP_PATH_FILE_ERR : hmecw0_macro.h
  • RET_GRP_PATH_JERK_ERR : hmecw0_macro.h
  • RET_GRP_PATH_MOTION_CMD_ERR : hmecw0_macro.h
  • RET_GRP_PATH_POSITION_ERR : hmecw0_macro.h
  • RET_GRP_PATH_VELOCITY_ERR : hmecw0_macro.h
  • RET_GRP_RESET_FAILED : hmecw0_macro.h
  • RET_GRP_SLV_ILL_CONDITION : hmecw0_macro.h
  • RET_HOMING_ERR : hmecw0_macro.h
  • RET_HOMING_MODE_ERR : hmecw0_macro.h
  • RET_ILL_AXIS : hmecw0_macro.h
  • RET_ILL_GR : hmecw0_macro.h
  • RET_ILL_LINE : hmecw0_macro.h
  • RET_ILL_NOT : hmecw0_macro.h
  • RET_ILL_PARAMETER : hmecw0_macro.h
  • RET_ILL_PATH_DATA_SIZE : hmecw0_macro.h
  • RET_ILL_POT : hmecw0_macro.h
  • RET_ILL_SLAVE : hmecw0_macro.h
  • RET_INACTIVE_INTIME : hmecw0_macro.h
  • RET_INACTIVE_WIN_DLL : hmecw0_macro.h
  • RET_INVALID_DIRECTION : hmecw0_macro.h
  • RET_INVALID_OPERATION_MODE : hmecw0_macro.h
  • RET_INVALID_PLCOPEN_STATE : hmecw0_macro.h
  • RET_INVALID_VARIABLE : hmecw0_macro.h
  • RET_LAST_ERR : hmecw0_macro.h
  • RET_MAX_CONTROL_AXIS : hmecw0_macro.h
  • RET_MK_MEM_ERR : hmecw0_macro.h
  • RET_NS_SERVO : hmecw0_macro.h
  • RET_OTHER_ERR : hmecw0_macro.h
  • RET_OUT_OF_INTIME_MEM : hmecw0_macro.h
  • RET_PATH_DATA_MAX : hmecw0_macro.h
  • RET_PDO_OBJECT_NOT_EXIST : hmecw0_macro.h
  • RET_POWER_FAIL : hmecw0_macro.h
  • RET_PRB_FUNC_PDO_PRM_ERR : hmecw0_macro.h
  • RET_PRB_ID_DUP_ERR : hmecw0_macro.h
  • RET_PRB_NOT_ACTIVE : hmecw0_macro.h
  • RET_RATIO_ERR : hmecw0_macro.h
  • RET_READ_SDO_ERR : hmecw0_macro.h
  • RET_RESET_FAIL : hmecw0_macro.h
  • RET_RSI_HANDLER_ERR : hmecw0_macro.h
  • RET_S_ECATSTATE_ERR : hmecw0_macro.h
  • RET_S_OFFLINE : hmecw0_macro.h
  • RET_SET_OVERRIDE_FAIL : hmecw0_macro.h
  • RET_SLV_REG_ERR : hmecw0_macro.h
  • RET_SOFTWARE_NOT_SUPPORT : hmecw0_macro.h
  • RET_SUCCESS : hmecw0_macro.h
  • RET_TCH_PRB_PRM_ERR : hmecw0_macro.h
  • RET_TRG_PRM_ERR : hmecw0_macro.h
  • RET_WAITING_CANCELED : hmecw0_macro.h
  • RET_WAITING_NOT_EXIST : hmecw0_macro.h
  • RET_WRITE_SDO_ERR : hmecw0_macro.h


HLS-ECAT02WIN APIリファレンス: 大域各種

- e -

  • EC_ClearLogPositionMemory() : hmecw0_func.h
  • EC_CloseMaster() : hmecw0_func.h
  • EC_GetDiagnosisMessage() : hmecw0_func.h
  • EC_GetDiagnosisMessageFlags() : hmecw0_func.h
  • EC_GetMasterInfo() : hmecw0_func.h
  • EC_GetSlaveInfo() : hmecw0_func.h
  • EC_OpenMaster() : hmecw0_func.h
  • EC_ReadLogPositionStatus() : hmecw0_func.h
  • EC_ReadSDO() : hmecw0_func.h
  • EC_ReadVersion() : hmecw0_func.h
  • EC_ResetDiagnosisMessage() : hmecw0_func.h
  • EC_SaveLogPosition() : hmecw0_func.h
  • EC_SetDiagnosisMessageFlags() : hmecw0_func.h
  • EC_StartLogPosition() : hmecw0_func.h
  • EC_StopLogPosition() : hmecw0_func.h
  • EC_WriteSDO() : hmecw0_func.h

- i -

  • IO_Groupinp() : hmecw0_func.h
  • IO_Groupinpdw() : hmecw0_func.h
  • IO_Groupinpw() : hmecw0_func.h
  • IO_Groupoutp() : hmecw0_func.h
  • IO_Groupoutpdw() : hmecw0_func.h
  • IO_Groupoutpw() : hmecw0_func.h
  • IO_inp() : hmecw0_func.h
  • IO_inpdw() : hmecw0_func.h
  • IO_inpw() : hmecw0_func.h
  • IO_outp() : hmecw0_func.h
  • IO_outpdw() : hmecw0_func.h
  • IO_outpw() : hmecw0_func.h

- m -

  • MC_AbortTrigger() : hmecw0_func.h
  • MC_AddAxisToGroup() : hmecw0_func.h
  • MC_CancelWaitInterrupt() : hmecw0_func.h
  • MC_CancelWaitLatchCountInterrupt() : hmecw0_func.h
  • MC_DeleteBuffer() : hmecw0_func.h
  • MC_GetAxisSetting() : hmecw0_func.h
  • MC_GetGroupIntSignalInfo() : hmecw0_func.h
  • MC_GetGroupSetting() : hmecw0_func.h
  • MC_GetIntSignalInfo() : hmecw0_func.h
  • MC_GetLatchCountIntSignalInfo() : hmecw0_func.h
  • MC_GroupAxesReadError() : hmecw0_func.h
  • MC_GroupAxesReadInfo() : hmecw0_func.h
  • MC_GroupAxesReadMotionState() : hmecw0_func.h
  • MC_GroupAxesReadStatus() : hmecw0_func.h
  • MC_GroupCancelWaitInterrupt() : hmecw0_func.h
  • MC_GroupDeleteBuffer() : hmecw0_func.h
  • MC_GroupDisable() : hmecw0_func.h
  • MC_GroupEnable() : hmecw0_func.h
  • MC_GroupHome() : hmecw0_func.h
  • MC_GroupReadActualPosition() : hmecw0_func.h
  • MC_GroupReadActualVelocity() : hmecw0_func.h
  • MC_GroupReadBuffer() : hmecw0_func.h
  • MC_GroupReadConfiguration() : hmecw0_func.h
  • MC_GroupReadError() : hmecw0_func.h
  • MC_GroupReadFunctionResult() : hmecw0_func.h
  • MC_GroupReadPathData() : hmecw0_func.h
  • MC_GroupReadStatus() : hmecw0_func.h
  • MC_GroupReset() : hmecw0_func.h
  • MC_GroupResetMotionSts() : hmecw0_func.h
  • MC_GroupSetOverride() : hmecw0_func.h
  • MC_GroupSetPosition() : hmecw0_func.h
  • MC_GroupStop() : hmecw0_func.h
  • MC_GroupWaitNextInterrupt() : hmecw0_func.h
  • MC_Home() : hmecw0_func.h
  • MC_MoveAbsolute() : hmecw0_func.h
  • MC_MoveAdditive() : hmecw0_func.h
  • MC_MoveLinearAbsolute() : hmecw0_func.h
  • MC_MoveLinearRelative() : hmecw0_func.h
  • MC_MoveLinearVelocity() : hmecw0_func.h
  • MC_MovePath() : hmecw0_func.h
  • MC_MoveRelative() : hmecw0_func.h
  • MC_MoveVelocity() : hmecw0_func.h
  • MC_Power() : hmecw0_func.h
  • MC_ReadActualPosition() : hmecw0_func.h
  • MC_ReadActualVelocity() : hmecw0_func.h
  • MC_ReadAxisError() : hmecw0_func.h
  • MC_ReadAxisInfo() : hmecw0_func.h
  • MC_ReadBuffer() : hmecw0_func.h
  • MC_ReadDelayTimer() : hmecw0_func.h
  • MC_ReadFunctionResult() : hmecw0_func.h
  • MC_ReadLatchCountResult() : hmecw0_func.h
  • MC_ReadMotionState() : hmecw0_func.h
  • MC_ReadProbeStatus() : hmecw0_func.h
  • MC_ReadStatus() : hmecw0_func.h
  • MC_RemoveAxisFromGroup() : hmecw0_func.h
  • MC_Reset() : hmecw0_func.h
  • MC_ResetAxisSetting() : hmecw0_func.h
  • MC_ResetGroupSetting() : hmecw0_func.h
  • MC_ResetLatchSts() : hmecw0_func.h
  • MC_ResetMotionSts() : hmecw0_func.h
  • MC_SetAxisSetting() : hmecw0_func.h
  • MC_SetDelayTimer() : hmecw0_func.h
  • MC_SetGroupIntSignalInfo() : hmecw0_func.h
  • MC_SetGroupSetting() : hmecw0_func.h
  • MC_SetIntSignalInfo() : hmecw0_func.h
  • MC_SetLatchCountIntSignalInfo() : hmecw0_func.h
  • MC_SetOverride() : hmecw0_func.h
  • MC_SetPosition() : hmecw0_func.h
  • MC_Stop() : hmecw0_func.h
  • MC_TouchProbe() : hmecw0_func.h
  • MC_UngroupAllAxes() : hmecw0_func.h
  • MC_WaitNextInterrupt() : hmecw0_func.h
  • MC_WaitNextLatchCountInterrupt() : hmecw0_func.h


HLS-ECAT02WIN APIリファレンス: 大域各種

- r -

  • RESULT_FUNCTION_ABSOLUTE : hmecw0_macro.h
  • RESULT_FUNCTION_ADDITIVE : hmecw0_macro.h
  • RESULT_FUNCTION_GROUP_HOME : hmecw0_macro.h
  • RESULT_FUNCTION_GROUP_RESET : hmecw0_macro.h
  • RESULT_FUNCTION_GROUP_STOP : hmecw0_macro.h
  • RESULT_FUNCTION_HOME : hmecw0_macro.h
  • RESULT_FUNCTION_LINEAR_ABSOLUTE : hmecw0_macro.h
  • RESULT_FUNCTION_LINEAR_RELATIVE : hmecw0_macro.h
  • RESULT_FUNCTION_LINEAR_VELOCITY : hmecw0_macro.h
  • RESULT_FUNCTION_MOVE_PATH : hmecw0_macro.h
  • RESULT_FUNCTION_RELATIVE : hmecw0_macro.h
  • RESULT_FUNCTION_RESET : hmecw0_macro.h
  • RESULT_FUNCTION_STOP : hmecw0_macro.h
  • RESULT_FUNCTION_VELOCITY : hmecw0_macro.h
  • RESULT_STATUS_ABORTED : hmecw0_macro.h
  • RESULT_STATUS_ABORTED_WAIT : hmecw0_macro.h
  • RESULT_STATUS_BUSY : hmecw0_macro.h
  • RESULT_STATUS_BUSY_WAIT : hmecw0_macro.h
  • RESULT_STATUS_DONE : hmecw0_macro.h
  • RESULT_STATUS_DONE_WAIT : hmecw0_macro.h
  • RESULT_STATUS_ERROR : hmecw0_macro.h
  • RESULT_STATUS_ERROR_WAIT : hmecw0_macro.h
  • RET_ABORT_TRIG_RUNNING_ERR : hmecw0_macro.h
  • RET_ACTIVE_OTHER_FUNCTION : hmecw0_macro.h
  • RET_ALAM : hmecw0_macro.h
  • RET_AXIS_ERR : hmecw0_macro.h
  • RET_AXIS_REG_ERR : hmecw0_macro.h
  • RET_AXIS_REGISTERED : hmecw0_macro.h
  • RET_BUFFER_FULL : hmecw0_macro.h
  • RET_BUFFER_MODE_INVALID : hmecw0_macro.h
  • RET_DIAGNOSIS_MESSAGE_ERR : hmecw0_macro.h
  • RET_EHAPI_ALIAS_CONFLICT : hmecw0_macro.h
  • RET_EHAPI_CATALOG : hmecw0_macro.h
  • RET_EHAPI_CATEGORY : hmecw0_macro.h
  • RET_EHAPI_CHANNEL : hmecw0_macro.h
  • RET_EHAPI_CLOSE : hmecw0_macro.h
  • RET_EHAPI_CLOSED : hmecw0_macro.h
  • RET_EHAPI_CMDERR : hmecw0_macro.h
  • RET_EHAPI_CONFLICT : hmecw0_macro.h
  • RET_EHAPI_CREATE_EVENT : hmecw0_macro.h
  • RET_EHAPI_EDITION : hmecw0_macro.h
  • RET_EHAPI_ENIFILE : hmecw0_macro.h
  • RET_EHAPI_EXIST : hmecw0_macro.h
  • RET_EHAPI_FIND_SLAVE : hmecw0_macro.h
  • RET_EHAPI_INDEX : hmecw0_macro.h
  • RET_EHAPI_INVALID_EVENT : hmecw0_macro.h
  • RET_EHAPI_INVALID_LOCATION : hmecw0_macro.h
  • RET_EHAPI_IS_DEAD : hmecw0_macro.h
  • RET_EHAPI_LENGTH : hmecw0_macro.h
  • RET_EHAPI_LICENSE : hmecw0_macro.h
  • RET_EHAPI_LIMIT : hmecw0_macro.h
  • RET_EHAPI_MAX_OPEN : hmecw0_macro.h
  • RET_EHAPI_MAX_QUE : hmecw0_macro.h
  • RET_EHAPI_MEMORY : hmecw0_macro.h
  • RET_EHAPI_NIC_DRIVER : hmecw0_macro.h
  • RET_EHAPI_NO_RESPONSE : hmecw0_macro.h
  • RET_EHAPI_NOITEM : hmecw0_macro.h
  • RET_EHAPI_NOT_FOUND : hmecw0_macro.h
  • RET_EHAPI_NOT_HOTCONNECT : hmecw0_macro.h
  • RET_EHAPI_NOT_READY : hmecw0_macro.h
  • RET_EHAPI_NOT_REGISTERED : hmecw0_macro.h
  • RET_EHAPI_OBJECT : hmecw0_macro.h
  • RET_EHAPI_OFFLINE : hmecw0_macro.h
  • RET_EHAPI_OPEN : hmecw0_macro.h
  • RET_EHAPI_OPENED : hmecw0_macro.h
  • RET_EHAPI_PARAM : hmecw0_macro.h
  • RET_EHAPI_READ_EEPROM : hmecw0_macro.h
  • RET_EHAPI_READ_REGISTER : hmecw0_macro.h
  • RET_EHAPI_READONLY : hmecw0_macro.h
  • RET_EHAPI_RECV : hmecw0_macro.h
  • RET_EHAPI_REF_CATALOG : hmecw0_macro.h
  • RET_EHAPI_REG_EVENT : hmecw0_macro.h
  • RET_EHAPI_REQ_ERROR : hmecw0_macro.h
  • RET_EHAPI_RT_MEM : hmecw0_macro.h
  • RET_EHAPI_RT_VMEM : hmecw0_macro.h
  • RET_EHAPI_SEND : hmecw0_macro.h
  • RET_EHAPI_SIZE : hmecw0_macro.h
  • RET_EHAPI_SLAVE_COUNT : hmecw0_macro.h
  • RET_EHAPI_SLAVE_IS_ZERO : hmecw0_macro.h
  • RET_EHAPI_STARTARG_ABNORMAL : hmecw0_macro.h
  • RET_EHAPI_STARTARG_HIGHER : hmecw0_macro.h
  • RET_EHAPI_STARTARG_LOWER : hmecw0_macro.h
  • RET_EHAPI_STATE_I : hmecw0_macro.h
  • RET_EHAPI_STATE_O : hmecw0_macro.h
  • RET_EHAPI_STATE_P : hmecw0_macro.h
  • RET_EHAPI_STATE_S : hmecw0_macro.h
  • RET_EHAPI_STATE_UNKNOWN : hmecw0_macro.h
  • RET_EHAPI_STOPNODE : hmecw0_macro.h
  • RET_EHAPI_SUBINDEX : hmecw0_macro.h
  • RET_EHAPI_SYSERR : hmecw0_macro.h
  • RET_EHAPI_TIMEOUT : hmecw0_macro.h
  • RET_EHAPI_TXBUFF : hmecw0_macro.h
  • RET_EHAPI_TXDATA : hmecw0_macro.h
  • RET_EHAPI_WAIT_CANCEL : hmecw0_macro.h
  • RET_EHAPI_WAIT_EVENT : hmecw0_macro.h
  • RET_EHAPI_WORKING : hmecw0_macro.h
  • RET_EHAPI_WRITE_EEPROM : hmecw0_macro.h
  • RET_EHAPI_WRITE_REGISTER : hmecw0_macro.h
  • RET_EHAPI_WRITEONLY : hmecw0_macro.h
  • RET_ER_INVALID_BUFFER_MODE : hmecw0_macro.h
  • RET_FAILED_FILE_OPEN : hmecw0_macro.h
  • RET_FAILED_FILE_PROC : hmecw0_macro.h
  • RET_FOLLOWING_ERR : hmecw0_macro.h
  • RET_FUNC_ABORT_TRIG_ERR : hmecw0_macro.h
  • RET_FUNC_TOUCH_PRB_ERR : hmecw0_macro.h
  • RET_GROUP_ILL_PRM : hmecw0_macro.h
  • RET_GROUP_NO_AXIS : hmecw0_macro.h
  • RET_GRP_ADD_AXIS_FAILED : hmecw0_macro.h
  • RET_GRP_ARRAY0_ALAM : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_DIRECTION : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_FOLLOWING : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_NOT : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_PLCOPEN_STATE : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_POT : hmecw0_macro.h
  • RET_GRP_ARRAY0_ILL_PRM : hmecw0_macro.h
  • RET_GRP_ARRAY0_RATIO_ERR : hmecw0_macro.h
  • RET_GRP_AXIS_EXIST : hmecw0_macro.h
  • RET_GRP_AXIS_ILL_CONDITION : hmecw0_macro.h
  • RET_GRP_AXIS_ILL_PRM : hmecw0_macro.h
  • RET_GRP_AXIS_NOT_EXIST : hmecw0_macro.h
  • RET_GRP_EXIST : hmecw0_macro.h
  • RET_GRP_FULL : hmecw0_macro.h
  • RET_GRP_ILL_DIRECTION : hmecw0_macro.h
  • RET_GRP_ILL_FOLLOWING : hmecw0_macro.h
  • RET_GRP_ILL_PLCOPEN_STATE : hmecw0_macro.h
  • RET_GRP_MVPATH_EXECUTED_ERR : hmecw0_macro.h
  • RET_GRP_OTHER_AXIS_EXIST : hmecw0_macro.h
  • RET_GRP_PATH_ACCELERATION_ERR : hmecw0_macro.h
  • RET_GRP_PATH_BUFFER_MODE_ERR : hmecw0_macro.h
  • RET_GRP_PATH_DECELERATION_ERR : hmecw0_macro.h
  • RET_GRP_PATH_FILE_ERR : hmecw0_macro.h
  • RET_GRP_PATH_JERK_ERR : hmecw0_macro.h
  • RET_GRP_PATH_MOTION_CMD_ERR : hmecw0_macro.h
  • RET_GRP_PATH_POSITION_ERR : hmecw0_macro.h
  • RET_GRP_PATH_VELOCITY_ERR : hmecw0_macro.h
  • RET_GRP_RESET_FAILED : hmecw0_macro.h
  • RET_GRP_SLV_ILL_CONDITION : hmecw0_macro.h
  • RET_HOMING_ERR : hmecw0_macro.h
  • RET_HOMING_MODE_ERR : hmecw0_macro.h
  • RET_ILL_AXIS : hmecw0_macro.h
  • RET_ILL_GR : hmecw0_macro.h
  • RET_ILL_LINE : hmecw0_macro.h
  • RET_ILL_NOT : hmecw0_macro.h
  • RET_ILL_PARAMETER : hmecw0_macro.h
  • RET_ILL_PATH_DATA_SIZE : hmecw0_macro.h
  • RET_ILL_POT : hmecw0_macro.h
  • RET_ILL_SLAVE : hmecw0_macro.h
  • RET_INACTIVE_INTIME : hmecw0_macro.h
  • RET_INACTIVE_WIN_DLL : hmecw0_macro.h
  • RET_INVALID_DIRECTION : hmecw0_macro.h
  • RET_INVALID_OPERATION_MODE : hmecw0_macro.h
  • RET_INVALID_PLCOPEN_STATE : hmecw0_macro.h
  • RET_INVALID_VARIABLE : hmecw0_macro.h
  • RET_LAST_ERR : hmecw0_macro.h
  • RET_MAX_CONTROL_AXIS : hmecw0_macro.h
  • RET_MK_MEM_ERR : hmecw0_macro.h
  • RET_NS_SERVO : hmecw0_macro.h
  • RET_OTHER_ERR : hmecw0_macro.h
  • RET_OUT_OF_INTIME_MEM : hmecw0_macro.h
  • RET_PATH_DATA_MAX : hmecw0_macro.h
  • RET_PDO_OBJECT_NOT_EXIST : hmecw0_macro.h
  • RET_POWER_FAIL : hmecw0_macro.h
  • RET_PRB_FUNC_PDO_PRM_ERR : hmecw0_macro.h
  • RET_PRB_ID_DUP_ERR : hmecw0_macro.h
  • RET_PRB_NOT_ACTIVE : hmecw0_macro.h
  • RET_RATIO_ERR : hmecw0_macro.h
  • RET_READ_SDO_ERR : hmecw0_macro.h
  • RET_RESET_FAIL : hmecw0_macro.h
  • RET_RSI_HANDLER_ERR : hmecw0_macro.h
  • RET_S_ECATSTATE_ERR : hmecw0_macro.h
  • RET_S_OFFLINE : hmecw0_macro.h
  • RET_SET_OVERRIDE_FAIL : hmecw0_macro.h
  • RET_SLV_REG_ERR : hmecw0_macro.h
  • RET_SOFTWARE_NOT_SUPPORT : hmecw0_macro.h
  • RET_SUCCESS : hmecw0_macro.h
  • RET_TCH_PRB_PRM_ERR : hmecw0_macro.h
  • RET_TRG_PRM_ERR : hmecw0_macro.h
  • RET_WAITING_CANCELED : hmecw0_macro.h
  • RET_WAITING_NOT_EXIST : hmecw0_macro.h
  • RET_WRITE_SDO_ERR : hmecw0_macro.h